16:08:28 <geppetto> #startmeeting fpc
16:08:28 <geppetto> #meetingname fpc
16:08:28 <zodbot> Meeting started Thu Jul 8 16:08:28 2021 UTC.
16:08:28 <zodbot> This meeting is logged and archived in a public location.
16:08:28 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:08:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:08:28 <zodbot> The meeting name has been set to 'fpc'
16:08:28 <zodbot> The meeting name has been set to 'fpc'
16:08:28 <geppetto> #topic Roll Call
16:08:34 * limburgher here
16:08:39 <geppetto> #chair Eighth_Doctor
16:08:39 <zodbot> Current chairs: Eighth_Doctor geppetto
16:08:39 <decathorpe> .hello2
16:08:40 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
16:08:43 <geppetto> #chair carlwgeorge
16:08:43 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto
16:08:44 <mhroncok> .hello churchyard
16:08:45 <geppetto> #chair decathorpe
16:08:45 <zodbot> Current chairs: Eighth_Doctor carlwgeorge decathorpe geppetto
16:08:45 <Eighth_Doctor> .hello ngompa
16:08:46 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
16:08:47 <geppetto> #chair mhroncok
16:08:47 <zodbot> Current chairs: Eighth_Doctor carlwgeorge decathorpe geppetto mhroncok
16:08:49 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:08:59 <geppetto> #chair limburgher
16:08:59 <zodbot> Current chairs: Eighth_Doctor carlwgeorge decathorpe geppetto limburgher mhroncok
16:09:18 * carlwgeorge waves
16:12:38 <geppetto> Well my mail doesn't seem to be going to the packaging mailing list anymore … no idea why
16:12:45 <Eighth_Doctor> :(
16:13:29 <mhroncok> geppetto: but it goes to devel
16:13:32 <mhroncok> :/
16:14:05 <geppetto> yeh
16:14:28 <geppetto> just much more annoying to find the schedule in the devel … so give me a couple of minutes
16:14:49 <mhroncok> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/ZUEQMBY4TW62FXNZXGJXHNEF2RICYCOC/
16:15:00 <mhroncok> geppetto: ^
16:15:53 <geppetto> Thanks … just found it
16:16:27 <geppetto> searching for "schedule fpc" gives me hits from 2017, which is …
16:16:35 <geppetto> anyway...
16:16:40 <geppetto> #topic Schedule
16:16:49 <geppetto> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/ZUEQMBY4TW62FXNZXGJXHNEF2RICYCOC/
16:17:16 <geppetto> We have a couple of updates on some PRs
16:17:52 <geppetto> #topic #pr-1071 Overhaul the RPATH section of the guidelines.
16:18:04 <geppetto> #link https://pagure.io/packaging-committee/pull-request/1071
16:18:59 <geppetto> I think we talked about this briefly last week.
16:19:13 <mhroncok> yes, we did
16:19:22 <mhroncok> I've also posted soem of my comment to the PR
16:19:28 <mhroncok> but cstratak is on vacation this week
16:19:59 <geppetto> I know tibbs had problems with the binary/object change … because binary is defined the way object is in elf.
16:20:08 <geppetto> in our policy
16:20:38 <decathorpe> well that's a minor thing we could change after merging the PR, no?
16:21:23 <geppetto> I mean it all looks minor, but maybe I'm missing something due to the long lines?
16:21:56 <geppetto> If someone wants to tweak it now to get it passed though … I have no problems with that :).
16:24:21 <mhroncok> I'd give cstratak a fair chance to respond
16:25:07 <mhroncok> OTOH it would be easier to see the concerns in the pr as comments
16:26:39 * geppetto nods … should at least get a summary that we've discussed it today
16:26:56 <geppetto> #info Object vs. Binary change seems bad.
16:27:04 <geppetto> #topic #pr-1072 Python Packaging Guidelines overhaul
16:27:10 <geppetto> https://pagure.io/packaging-committee/pull-request/1072
16:28:04 <geppetto> And as mhroncok comment says, there's a nice summary at: https://hackmd.io/@python-maint/rJmQQc4DP
16:29:17 <geppetto> As I think I said before I'm not super happy about the pypi naming thing … but I'm fine to +1 it anyway
16:29:55 <geppetto> I kind of assume mhroncok is +1 ;)
16:30:06 <limburgher> I would hope so.
16:30:32 <geppetto> Eighth_Doctor: carlwgeorge decathorpe limburgher: So that leaves ya'll
16:30:46 <mhroncok> yes, mhroncok is +1 in principle, waiting for the %py3_check_import update to land before merging
16:30:46 <carlwgeorge> i don't think i understand the aversion to the pypi parity part, i think the placement of must/should in it works well
16:30:58 <limburgher> I'm +1.
16:31:07 <Eighth_Doctor> I'm -1 to the pypi part, but the rest of it is fine
16:31:21 <Eighth_Doctor> but Python team said they'll take on that burden
16:31:26 <decathorpe> I'm +1 as well
16:31:28 <Eighth_Doctor> so with that proviso, I'm +1
16:31:39 <carlwgeorge> i'm +1 in general but would like to know more about Eighth_Doctor's concerns
16:31:44 <Eighth_Doctor> as long as packagers aren't burdened with the inanity of dealing with pypi bureaucracy, I'm fine
16:32:21 <Eighth_Doctor> carlwgeorge: packagers have to go out of their way to rationalize packages in Fedora with PyPI in the event they're not registered
16:32:43 <Eighth_Doctor> but Petr and Miro have agreed to have the Python team at Red Hat deal with that
16:32:53 <carlwgeorge> as i understood it most fedora names are already registered or blocked in pypi
16:32:56 <Eighth_Doctor> so as long as it remains largely invisible to packagers, I'm fine with it
16:33:25 <carlwgeorge> so it would be a matter of the fedora packager and the upstream just raising their hand to say "yes assign this blocked one to me"
16:33:29 <mhroncok> Eighth_Doctor: well, when caught during package review, somebody needs to let us know that they need us to deal with it
16:33:41 <mhroncok> Eighth_Doctor: it won't be dealt by us magically
16:33:41 <Eighth_Doctor> sure
16:33:47 <Eighth_Doctor> lol
16:33:54 <Eighth_Doctor> I did suggest we should have some automation for it
16:33:59 <mhroncok> :)
16:34:11 <Eighth_Doctor> Petr was the one who said we don't need it :P
16:34:13 <mhroncok> we can check existing packages pro-actively
16:34:34 <carlwgeorge> mhroncok: how do you square the must with the packages that already violate it, e.g. python-mimeparse
16:34:35 <mhroncok> not sure we can check proposed packages
16:35:05 <mhroncok> carlwgeorge: packages that existed wehn we started working on this were blocked on pypi
16:35:23 <decathorpe> well, Packaging Guidelines are already never applied retroactively to existing packages
16:35:26 <mhroncok> carlwgeorge: to avoid trolls seeing this and registering random different stuff
16:35:27 <carlwgeorge> i don't mean packages that didn't exist on pypi
16:35:43 <limburgher> <cough>merge reviews<cough>
16:35:44 * mhroncok looks at python-mimeparse
16:36:02 <carlwgeorge> in my example, mimeparse is a dead upstream, and python-mimeparse (pypi name) is now used as the package source
16:36:37 <mhroncok> carlwgeorge: what's wrong with python-mimeparse?
16:37:01 <carlwgeorge> `pip install mimeparse` doesn't install the same package as `dnf install python3-mimeparse`
16:37:03 <mhroncok> carlwgeorge: and the package provides... python3.10dist(python-mimeparse)
16:37:16 <mhroncok> carlwgeorge: pip install python-mimeparse installs the same package
16:37:39 <carlwgeorge> ah ok, i misunderstood that part
16:38:03 <carlwgeorge> i was conflating projectname with the second half of the rpm package name
16:38:25 <mhroncok> as decathorpe said last week, we wish there were not 4 different names of Python packages :(
16:38:44 <decathorpe> yeah it gets confusing :)
16:39:05 <limburgher> I love when they include py-, and you get python-py-foo-forgodsake
16:39:09 <mhroncok> carlwgeorge: this particular problem might be solved by demanding to package it as python-python-mimeparse but since that is rtaher silly, we have decided not to ask for that
16:39:33 <carlwgeorge> some extra clarity about what `PROJECTNAME` is in that section would be nice, but i understand now and am confirming my +1
16:39:34 <mhroncok> limburgher: I maintain python-u-msgpack-python
16:39:45 <limburgher> We could allow dropping extra python- or py-s.
16:39:54 <limburgher> mhroncok: icky
16:40:04 <mhroncok> carlwgeorge: we can probably make all the instances of PROJECTNAME link to that part of the guidelines if it helps
16:40:14 <carlwgeorge> sure
16:40:24 <mhroncok> limburgher: we ask not to repeat leading python-
16:40:27 <decathorpe> the golang tooling already does stuff like that, and it creates weird package names in some cases ... and could even lead to conflicts
16:40:40 <mhroncok> limburgher: I don't want to add more cases like py- or -python, or it gets even more messy
16:40:48 <geppetto> #action Python Packaging Guidelines overhaul (+1:6, 0:0, -1:0)
16:40:48 <limburgher> mhroncok: fair.
16:40:59 <geppetto> A part of me wants to see python-python-python-python-foo
16:41:20 <mhroncok> thanks. please don't merge yet, Petr will cleanup the commits and add the %py3_check_import info
16:41:22 <limburgher> python-py-pypi-foo-sdk-py
16:42:03 <mhroncok> geppetto: I have on my (never-)todo list to release an upstream package with such name and package it in Fedora just for the sake of it :D
16:42:32 <geppetto> mhroncok: 👍
16:44:00 <mhroncok> speaking of %py3_check_import, I've also just added it to the current Python guidelines in https://pagure.io/packaging-committee/pull-request/1081
16:46:54 <geppetto> #info Don't merge until Petr cleans the commits and adds %py3_check_import info
16:47:17 <mhroncok> geppetto: thanks
16:47:35 <geppetto> no problem … 1081 looks fine to me too
16:48:04 <geppetto> Not sure we even need to vote on it
16:48:49 <mhroncok> geppetto: probably no, I'd just appreciate a language check by a native speaker
16:50:09 * geppetto nods
16:50:15 <geppetto> #topic Open floor
16:50:26 <geppetto> Anything else anyone wants to talk about?
16:50:35 <carlwgeorge> mhroncok: the language looks good to me, other than the phrase smoke test
16:50:50 <carlwgeorge> i know what that means but i'm not sure it's a universal phrase
16:51:03 <mhroncok> carlwgeorge: understood, any other suggestions?
16:51:26 <Eighth_Doctor> mhroncok: btw, the silliness of python-python-py-foo is a thing I see on openSUSE :P
16:51:32 <mhroncok> carlwgeorge: or just remove the word "smoke"?
16:51:53 <mhroncok> Eighth_Doctor: well et least the names are somewhat consistent then :D
16:52:23 <Eighth_Doctor> python-foo-python3-py was a thing too
16:52:29 <mhroncok> oh
16:52:56 <Eighth_Doctor> the rule in openSUSE is python-<UpstreamName>
16:53:02 <mhroncok> I think we had (have?) a pygobject component with python3-gobject subpackage
16:53:02 <Eighth_Doctor> case-preserved
16:53:24 <Eighth_Doctor> so, for example, there's python-python3-python-openid because of this
16:53:29 <limburgher> mhroncok: I'm American but it'll have to do. Looks ok, but yeah, drop smoke.
16:53:31 <geppetto> lol
16:53:41 <Eighth_Doctor> or python-python3-openid-python, I forget which
16:53:41 <mhroncok> :)
16:53:46 * mhroncok drops smoke
16:53:49 <mhroncok> on the water
16:54:02 <Eighth_Doctor> and then it produces a python3-python3-openid-python and python2-python3-openid-python package
16:54:05 <limburgher> thank you ever so much for the earworm
16:54:31 <mhroncok> dropped, amended
16:54:45 <mhroncok> limburgher: your are welcome :)
16:55:10 <carlwgeorge> i stepped away briefly, but yes dropping the word smoke is sufficient, thanks
16:55:46 <Eighth_Doctor> the smoke test is just the check import test, right?
16:55:59 <mhroncok> Eighth_Doctor: yes
16:56:17 <Eighth_Doctor> so python_import_test?
16:56:19 <mhroncok> ...to test public Python modules are importable...
16:56:20 <Eighth_Doctor> or somesuch?
16:56:39 <mhroncok> Eighth_Doctor: well, that would ned to be python3, and we don't have python3_ prefixed macros that do stuff
16:56:50 <mhroncok> we only have python3_ prefixed macros that expand to values
16:57:18 <mhroncok> Eighth_Doctor: I've asked for better name suggestions on the mailing lists week+ ago, before this was merged to rawhide
16:57:30 * Eighth_Doctor shrugs
16:57:32 <mhroncok> now I already aksed people to use it on rawhide... so I'd rather not chnage it
16:57:38 <Eighth_Doctor> fair
16:57:51 <Eighth_Doctor> I'm fine with whatever as long as it's not stupid and is prefixed with python_
16:58:00 <Eighth_Doctor> and that there's a version where overriding the interpreter works
16:58:17 <mhroncok> Eighth_Doctor: it uses %__python3
16:58:50 <Eighth_Doctor> one day I gotta sit down and figure out multi-python cases
16:59:11 * mhroncok is not keen on %py3_ prefixed macros either, but well, that's what we have
17:00:30 * geppetto nods
17:00:38 <geppetto> And on that note I'll close
17:00:38 <Eighth_Doctor> we'll fix it someday
17:00:42 <geppetto> See you next week
17:00:43 <Eighth_Doctor> if for nothing else, because it's annoying
17:00:48 <Eighth_Doctor> bye :)
17:00:56 <geppetto> #endmeeting