16:00:24 <geppetto> #startmeeting fpc
16:00:24 <zodbot> Meeting started Thu Aug 26 16:00:24 2021 UTC.
16:00:24 <zodbot> This meeting is logged and archived in a public location.
16:00:24 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:24 <zodbot> The meeting name has been set to 'fpc'
16:00:24 <geppetto> #meetingname fpc
16:00:24 <geppetto> #topic Roll Call
16:00:24 <zodbot> The meeting name has been set to 'fpc'
16:01:06 * limburgher here
16:01:15 <carlwgeorge> .hi
16:01:16 <zodbot> carlwgeorge: carlwgeorge 'Carl George' <carl@redhat.com>
16:01:25 <geppetto> #chair limburgher
16:01:25 <zodbot> Current chairs: geppetto limburgher
16:01:28 <geppetto> #chair carlwgeorge
16:01:28 <zodbot> Current chairs: carlwgeorge geppetto limburgher
16:11:15 <decathorpe> hey, sorry for being late
16:11:22 <tibbs> Hey, folks.
16:11:36 <geppetto> #chair decathorpe
16:11:36 <zodbot> Current chairs: carlwgeorge decathorpe geppetto limburgher
16:11:40 <geppetto> #chair tibbs
16:11:40 <zodbot> Current chairs: carlwgeorge decathorpe geppetto limburgher tibbs
16:11:43 <geppetto> Hy
16:13:09 <tibbs> I've gone from a funeral out of the country to quarantine to the first week of the semester without any air conditioning in my office. In Houston. In August.
16:14:02 <geppetto> #topic Schedule
16:14:04 <decathorpe> that doesn't sound too pleasant :(
16:14:06 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/TP6VT5D7O6BD4SBE3EC6YVH42GINLHWS/
16:14:19 <geppetto> tibbs: Is that legal?
16:14:57 <limburgher> Ouch. :(
16:15:21 <limburgher> geppetto: It's Texas. So....probably.
16:16:02 <geppetto> limburgher: true
16:16:08 <tibbs> I'm not sticking around for too long today.
16:16:21 <decathorpe> people seem to want us to merge 1066
16:16:35 <limburgher> Battle of Hastings!
16:16:40 <geppetto> So mhroncok asked if we could look at the 1066 PR first
16:16:53 <geppetto> #topic #pr-1066 Update compiler guidelines for compiler policy change
16:16:53 <geppetto> https://pagure.io/packaging-committee/pull-request/1066
16:19:05 <decathorpe> I at least have already approved this with FESCo so it's fine with me
16:19:34 * geppetto nods … it seems fairly simple
16:20:01 <carlwgeorge> yup, it seems reasonable
16:20:11 <geppetto> And others have already signed off on the main point of having a free for all on what compiler you want to use
16:20:16 <geppetto> So … +1
16:20:46 <limburgher> +1 here too.
16:21:20 * limburgher mulls writing an ELF output plugin for texlive
16:22:28 <carlwgeorge> considering that it says a valid technical reason is needed, should we put it in the guidelines that the spec file should include a descriptive comment about why a package doesn't use gcc?
16:23:35 <geppetto> I'm fine with adding a "you should add a comment about why you aren't using gcc"
16:23:54 <decathorpe> I think that was part of the original proposal and somehow got lost in the process.
16:24:20 <carlwgeorge> similar to how we require a comment for each patch to indicate the upstream status (or if it's inappropriate for upstream)
16:24:24 <decathorpe> (i.e. the tracking bug requirement was dropped and the explanatory comment requirement got lost too?)
16:24:32 <limburgher> 99% of the time it'll be "upstream said so"
16:24:33 <carlwgeorge> i can comment that in the issue
16:25:23 <carlwgeorge> i just fear that without the need to comment it people will just switch because they feel like it, without thinking through the valid technical reason part
16:25:55 <carlwgeorge> i don't see "upstream said so" as a valid reason example
16:26:17 <limburgher> Right. 'upstream said so because <foo>" would be.
16:26:45 <carlwgeorge> exactly, and that's what i'd like to see in a comment when i come across a spec file using clang
16:27:03 <carlwgeorge> so i'm +1 pending that small adjustment, and i'll comment on the issue to ask for it
16:27:15 <geppetto> carlwgeorge: isn't not in the bullet list, but just above one of the reasons given is "upstream doesn't support building with gcc"
16:28:02 <carlwgeorge> maybe we should avoid the word support entirely
16:28:18 <limburgher> recommend?
16:28:30 <geppetto> I mean, I'm not against that … but I also don't want to go against what FESCo said.
16:29:11 <carlwgeorge> it's probably fine, the point of this isn't to enumerate all valid reasons
16:29:17 <geppetto> Maybe add "upstream recommends/prefers building with clang"
16:29:21 * geppetto nods
16:29:44 <geppetto> I'm kind of hoping most people will just shrug and keep using gcc
16:29:50 <carlwgeorge> personally i don't think a simple upstream preference is sufficient, but i'm ok leaving that up to each packager
16:30:17 <carlwgeorge> like limburgher said, "upstream prefers clang because ___"
16:30:43 <geppetto> So … I'm at +4 now, with not vote from decathorpe or tibbs
16:30:58 <tibbs> I think this is fine.
16:31:02 <tibbs> +!
16:31:04 <tibbs> +1
16:32:10 <geppetto> #info Minor change: Add the requirement of a comment explaining the reasoning for switching from the default.
16:32:27 <geppetto> decathorpe: want to vote?
16:33:34 <decathorpe> I already said; fine with me
16:33:52 <geppetto> #action #pr-1066 Update compiler guidelines for compiler policy change (+1:6, 0:0, -1:0)
16:33:53 <decathorpe> so +1 if I need to make that very very explicit ;)
16:34:01 <geppetto> It always helps :)
16:34:21 <carlwgeorge> is the term "SHOULD requirement" accurate?
16:34:27 <carlwgeorge> or is there a better way to say that
16:35:03 <geppetto> So given tibbs needs to leave soon … are there any other tickets/PRs we should look at today?
16:35:22 <geppetto> carlwgeorge: I said should to be nice … I'm not against making it a must
16:35:47 <carlwgeorge> well i'm aiming for consistency with that upstream patch status comment thing, and that's also a should
16:36:09 <geppetto> Again, main thing is I don't want to step on what FESCo has said … so if they said you can just do it, I didn't want to add hard reqs.
16:36:19 * geppetto nods
16:36:22 <carlwgeorge> (but for what it's worth i'd be ok making both of those musts)
16:36:51 <carlwgeorge> eh, should requirement is close enough
16:37:02 <carlwgeorge> comment added
16:38:32 <geppetto> #topic Open Floor
16:38:39 <geppetto> Ok, so … anything?
16:43:09 <geppetto> #endmeeting