18:30:27 <bcotton> #startmeeting docs
18:30:27 <zodbot> Meeting started Wed Mar  2 18:30:27 2022 UTC.
18:30:27 <zodbot> This meeting is logged and archived in a public location.
18:30:27 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:30:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:30:27 <zodbot> The meeting name has been set to 'docs'
18:30:31 <bcotton> #topic Roll call
18:30:47 <bcotton> Hellooooooooo. Who is here for Docs-ery today?
18:30:47 <pboy> .hello2
18:30:48 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:30:50 <mroche> .hello mroche
18:30:51 <zodbot> mroche: mroche 'Michael Rochefort' <mike@michaelrochefort.com>
18:30:54 <darknao> .hi
18:30:55 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
18:31:04 <pbokoc> Hi there
18:31:17 <bcotton> #chair pboy mroche darknao pbokoc py0xc3
18:31:17 <zodbot> Current chairs: bcotton darknao mroche pbokoc pboy py0xc3
18:31:20 <py0xc3[m]> hi all
18:32:23 <shaunm[m]> .hello shaunm
18:32:24 <zodbot> shaunm[m]: shaunm 'Shaun McCance' <shaunm@gnome.org>
18:32:35 <py0xc3[m]> .hello py0xc3
18:32:36 <zodbot> py0xc3[m]: py0xc3 'Christopher Klooz' <py0xc3@my.mail.de>
18:33:19 <HankuLee[m]> Hi everyone
18:33:54 <bcotton> welcome, everyone. let's get started!
18:34:00 <copperi[m]> hello
18:34:00 <bcotton> #topic Agenda... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/f3c2b55589f4a482858e0be2a035b43363fa744d)
18:34:12 <bcotton> #topic Announcements
18:34:12 <bcotton> #info F36 Beta target is the early target date of 2022-03-15
18:34:12 <bcotton> #info We're using the docs-fp-o repo to track meta-work
18:34:12 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issues
18:34:15 <bcotton> any other announcements?
18:35:33 <bcotton> i'll take that as a "no" :-)
18:35:34 <bcotton> #topic Previous action items
18:35:34 <bcotton> #info pbokoc was to cherry-pick antora 3.0 changes in relnotes/install guide/sysadmin guide
18:36:23 <pbokoc> yeah, I did that for relnotes. (Except for branches f27 and f26 because I ran into something I want to check first.)
18:36:27 <bcotton> pbokoc: any update?
18:36:31 <bcotton> ah, you got me!
18:36:36 <pbokoc> install guide and sysadmin guide will be done later today
18:36:50 <bcotton> awesome
18:37:18 <bcotton> #info Relnotes (except f26/27) are done. Install & Sysadmin Guides will be done later today
18:37:24 <pbokoc> btw, darknao I wanted to ask, what exactly happens when a repo doesn't have these changes yet? We should probably do the same thing for all repos we publish, but I'm wondering how it works right now
18:37:35 <bcotton> i'll still #action in just in case
18:37:44 <pbokoc> bcotton, sure :)
18:38:00 <bcotton> #action pbokoc to cherry-pick antora 3.0 changes for Install Guide and Sysadmin Guide
18:38:47 <pbokoc> also I've been updating build/preview scripts on older branches at the same time while I'm at it. Just in case someone needs to do something with them in the future
18:39:24 <bcotton> #info pbokoc has been updating the build/preview scripts on older branches in case they're needed in the future
18:39:27 <bcotton> pbokoc++
18:39:27 <zodbot> bcotton: Karma for pbokoc changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:39:28 <darknao> pbokoc: those changes are only needed for local build, so it doesn't impact the global doc build if not applied
18:39:49 <pbokoc> ...right, I'm dumb :)) ok then
18:39:55 <bcotton> #info bcotton was to post ideas for decision-making to a Discussion thread
18:39:56 <bcotton> #info This is done: https://discussion.fedoraproject.org/t/how-do-we-make-decisions/37218/11
18:39:56 <bcotton> #info There's been good discussion, but it would be nice to have more input
18:40:37 <bcotton> in particular, there are some widely differing opinions on this, so it would be good if we could start converging on a consensus
18:41:19 <bcotton> so if you have opinions, please add them to the Discussion thread
18:41:27 <bcotton> anything else on previous action items?
18:43:35 <bcotton> #topic Content plan
18:43:36 <bcotton> #link https://discussion.fedoraproject.org/t/proposal-of-an-umbrella-plan-for-content/37161/
18:43:42 <bcotton> So pboy started a great discussion about content, and he rightly points out that we can't over-focus on process
18:44:56 <bcotton> relatedly, mroche mentioned discussing CentOS wiki content and the future plans for that
18:45:16 <bcotton> anyone want to raise their hand to speak on either of those?
18:46:25 <pboy> a remark about "curated set of links". I think, there would be still a lot to do for us as docs group.
18:46:40 <pboy> May be, in the end as much as currently.
18:47:01 <bcotton> i'm not sure what you mean. can you expand on that?
18:47:32 <pboy> bcotton your wrote "making our guides basically be a curated set of links to Quick Docs and similar would be a good goal"
18:47:56 <pboy> I think, we will have much more to do as just maintain links. :-)
18:48:08 <bcotton> right
18:48:09 <bcotton> sorry I was unclear
18:48:51 <bcotton> what I meant was that, for example, what we call the "Installation Guide" would be a series of links to Quick Docs (or similar), not full content on its own
18:49:27 <bcotton> basically saying "we'd decompose contents and link to the appropriate small pieces instead of writing a book"
18:49:43 <pboy> Yes, just that "Installation Guide" would be  a series of links the the editions installation guides.
18:50:07 <pboy> It's a kind of delegation of responsibility
18:50:14 <bcotton> just the opposite :-)
18:51:18 <bcotton> the Workstation Install Guide would be a set of links to the relevant parts of the task-specific docs. the Server Install guide would also be a set of links. Some of the links would be to the same content. Some would be to different content
18:51:55 <bcotton> Like if you have two shell scripts, they might both use `grep` in places, and one uses `awk` to do something and another uses `sed` to do something else.
18:52:00 <bcotton> does that analogy make sense?
18:52:32 <copperi[m]> Yes
18:53:24 <copperi[m]> Many current docs pages are built out of smaller pages as well.
18:53:25 <pboy> bcotton yes, that is the general idea of my wording "reference guide"
18:54:40 <bcotton> great!
18:55:41 <bcotton> shaun, were you trying to say something?
18:56:10 <shaunm[m]> nope
18:56:42 <bcotton> okay, cool
18:56:53 <bcotton> would you like to say something about CentOS wiki content? ;-)
18:57:36 <shaunm[m]> um, it's a mess :)
18:57:55 <shaunm[m]> it needs a very thorough audit
18:58:42 <pboy> I think, we issue, again, is not the content, but a plan what to achieve.
18:59:45 <mroche> Looking at possibilities I'm seeing four potential zones of CentOS docs: a) Actual distro docs (rhel docs), b) Contributor docs, c) Community guides/docs (port some wiki content), and d) SIG docs.
18:59:54 <pboy> What would be the overall idea about CentOS doc? It very near to RHEL, what could be the difference to their docs?
19:00:32 <shaunm[m]> what mroche says
19:00:59 <shaunm[m]> the majority of the usage docs will just come from rhel. that's already in progress
19:01:41 <shaunm[m]> but we need contributor docs, which can possibly just be shared with fedora. and SIGs are their own thing.
19:02:28 <pboy> What is the difference between contributor docs and community guides ?
19:03:01 <shaunm[m]> that leaves random assortments of howtos written by the community, which is where the wiki sits right now. some of that could possibly be incorporated into the shared rhel docs, but the contribution pathway for that is tricky. sometimes people just like to write a standalone howto.
19:03:32 <mroche> Contributor docs is about getting involved in Stream, so actual development. In my head Community docs would be porting topics from the Wiki, such as FAQs, tips+tricks, guides, etc.
19:03:57 <pbokoc> yeah, community guides could be something like Quick Docs in Fedora
19:03:58 <pboy> AH, OK
19:04:33 <shaunm[m]> there's also some real potential to engage rhel downstreams in community docs
19:05:10 <pboy> I could think of something like "setting upa mails service" and write one variant for Stream, another for Fedora.
19:05:49 <pboy> The differ in version and capability of software like postfix, but share a lot of issues like mailbox domain setup.
19:07:12 <shaunm[m]> right, and a lot of these programs don't change very quickly
19:07:13 <pboy> shaunm[m] engage rhel downstreams could be very helpful
19:08:54 <pboy> Fedora Server could benefit from the RHEL doku on Ansible.
19:09:14 <bcotton> i guess my question is how should we narrow the scope such that it's achievable
19:10:14 <bcotton> the amount of work we could do is so much larger than we could reasonably accomplish in the next...6 months, let's say
19:10:32 <bcotton> and i think it would be good for momentum and morale to be able to point to things that are Done than to have a thousand things in progress
19:11:53 <pboy> There is a great need for guidance to find typical tasks, like mail, but also setup of a home server or SME for something other than Debian / Ubuntu.
19:12:23 <pboy> That could be a task we can combine CentOS & Fedora
19:12:29 <mroche> From the CentOS side of things, I think a focus on filling out the Contributor's Guide would be worthwhile. It'll end up being (or should be) the main point people look to for getting involved. And of course ensuring the RHEL docs make the migration over.
19:12:56 <mroche> s/involved/involved in Stream/
19:13:53 <pboy> In the Contributors Guide, there will be little overlap and little synergistic effect.
19:14:17 <pboy> Unlike with the Community Guide
19:15:25 <pbokoc> there's also little overlap in potential contributors, I think, so it wouldn't be a huge problem
19:15:53 <pbokoc> (by contributors I mean people willing and able to write those docs)
19:16:17 <HankuLee[m]> <bcotton> "i guess my question is how..." <- Overall, timed with website revamp, how about making a shortlist for structuring/repurposing existing user documentation, say, new & simple categorization? There should be more sort of editor/QA style of accountability.
19:16:43 <bcotton> Hanku Lee: i'm not sure what you mean
19:18:21 <HankuLee[m]> bcotton: I'm referring to the discussion thread https://discussion.fedoraproject.org/t/proposal-of-an-umbrella-plan-for-content/37161?u=hankuoffroad
19:18:47 <pboy> Looking at the clock: just as a reminder, we should still spend time discussing how we want to proceed in concrete terms. What follows from our discussion?
19:19:12 <pboy> Sorry for interjection
19:19:22 <HankuLee[m]> I'll elaborate in the discussion board. I'm new.
19:19:23 <bcotton> no, that's a good reminder
19:20:34 <bcotton> let's continue the discussion on...Discussion, with a goal of identifying a few concrete things to work on by the next meeting. how does that sound?
19:21:18 <bcotton> I'm sort of inclined to say "everyone pick a piece that's interesting to you and work on it" but that's a little too disorganized :-) (and it loses the collaborative effort that would help us get going)
19:22:10 <pboy> And bevor someone can pick, we should have something to pick from, i.d. a general plan. :.)
19:23:04 <bcotton> yeah. what you proposed is definitely at least a framework
19:23:42 <pboy> But a first consideration would be, do we want to pursue something like the umbrella plan, and if so, what would be the next step?
19:24:01 <pboy> and if not, what is than the next step
19:24:18 <mroche> Not to add another question to the mix, bu should CentOS and Fedora docs be handled separately in such discussions?
19:25:06 <bcotton> pboy: i'd say there's a general consensus in favor of your plan, but the input has been limited so far
19:25:15 <pboy> mroche not necessarily. We shóuld look for overlapping areas ans sysnergy options
19:25:33 <pboy> (sorry, my typos)
19:26:32 <pboy> so the next step might be, to collect additional ideas. And may be to detail some parts?
19:26:39 <bcotton> +1
19:27:50 <pboy> And regarding Feora-CentOS cooperation, we could try to further collect ideas about sharable content?
19:28:39 <pboy> (provided there are at least some people interested in that. I would be one)
19:29:14 <mroche> If people wanted to have a docsfest combing through the CentOS Wiki, I'd be open to that
19:29:40 <bcotton> #info Next steps: Collect additional ideas and detail parts of the umbrella plan, with an emphasis on overlapping areas between Fedora/CentOS where possible
19:30:00 <bcotton> mroche: i think that'd be a good thing to schedule. want to own that?
19:30:18 <pboy> mroche +1
19:30:31 <mroche> I don't have a Wiki account myself, not sure if there's still openings to that process. shaunm might know more?
19:30:50 <mroche> Is the sitemap public?
19:31:13 <mroche> There must be more than: https://wiki.centos.org/FrontPage?action=LocalSiteMap
19:31:38 <shaunm[m]> you have to be given explicit edit permissions to the centos wiki, unfortunately
19:32:01 <bcotton> we're at the end of the hour, so let's continue this discussion elsewhere
19:32:09 <pboy> Thats a good idea for a wiki. :-)
19:32:11 <bcotton> or save it for next time
19:32:30 <bcotton> #topic Next week's meeting
19:32:48 <bcotton> #info bcotton will be on jury duty Wednesday. Volunteers to chair the next meeting?
19:33:22 <pboy> One idea for next meeting was to care about our backlog
19:34:15 <pboy> What about shaunm as chair?
19:34:54 <bcotton> or darknao since they suggested the backlog grooming :-)
19:34:57 <darknao> maybe we can only take something like 20 minutes every meeting for the backlog
19:35:51 <bcotton> okay, well we're at 5 minutes past so i guess we'll figure out next week's chair later :-)
19:36:02 <pboy> darknao that's generally a good idea. it is continuity. But for the first session 60 min may be good.
19:36:03 <bcotton> #help volunteer needed to chair next week's meeting
19:36:07 <bcotton> thanks for coming, everyone!
19:36:15 <bcotton> #endmeeting