18:31:49 <bcotton> #startmeeting docs
18:31:49 <zodbot> Meeting started Wed Apr 13 18:31:49 2022 UTC.
18:31:49 <zodbot> This meeting is logged and archived in a public location.
18:31:49 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:31:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:31:49 <zodbot> The meeting name has been set to 'docs'
18:31:57 <bcotton> #topic Roll call
18:32:02 <bcotton> who's here today?
18:32:03 <shaunm[m]> .hello shaunm
18:32:04 <zodbot> shaunm[m]: shaunm 'Shaun McCance' <shaunm@gnome.org>
18:32:04 <pboy> .hello2
18:32:07 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:32:14 <darknao> .hi
18:32:15 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
18:33:32 <bcotton> #chair shaunm pboy darknao
18:33:32 <zodbot> Current chairs: bcotton darknao pboy shaunm
18:35:27 <bcotton> okay, let's start!
18:35:41 <bcotton> #topic Agenda
18:35:48 <bcotton> #info Announcements... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/94254ed65a5fc911eb7df72804ce830c7228dc43)
18:35:57 <bcotton> #topic Announcements
18:35:57 <bcotton> #info F36 Final release is targeted for 26 April
18:36:13 <bcotton> note that this is target date #1 now, not the early target date of 19 April
18:36:23 <bcotton> #info We're receiving applicants for our Outreachy proposal. Please welcome them and help them get settled in
18:36:23 <bcotton> #info We're using the docs-fp-o repo to track meta-work
18:36:23 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issues
18:36:31 <bcotton> any other announcements?
18:37:14 <bcotton> #topic Previous action items
18:37:14 <bcotton> #info bcotton to retire the Telegram group
18:37:15 <bcotton> #info this is done!
18:37:23 <bcotton> #info bcotton and darknao to write a post about the /latest/ URL for the Community Blog
18:37:23 <bcotton> this one is on my list still
18:37:33 <bcotton> it's low-priority, but i don't want to forget about it
18:37:43 <bcotton> #info pbokoc to write a “how to do release notes” guide that he’ll post in the forum
18:38:04 <bcotton> has anyone heard from pbokoc lately?
18:38:43 <pboy> He is listed as online
18:39:27 <pbokoc> Oh yeah sorry, I keep forgetting. I'll do that now.
18:40:23 <bcotton> pbokoc++
18:40:28 <bcotton> #info he'll do it now :-)
18:40:44 <bcotton> okay, on to
18:40:50 <bcotton> #topic GitLab followup
18:40:50 <bcotton> #info darknao to start discussion of GitLab migration plan for follow-up next week
18:40:50 <bcotton> #link https://discussion.fedoraproject.org/t/gitlab-migration-plan/38092
18:42:42 <darknao> so the contributors-guide has been migrated already
18:42:52 <darknao> and docs.stg is using the new repo
18:43:06 <bcotton> #info contributors-guide is migrated to gitlab, docs.stg is using the new location
18:43:40 <darknao> I don't see anything not working, so I'll probably do the same on prod later today or tomorrow
18:45:25 <bcotton> great. anything else on this topic?
18:45:31 <darknao> I also moved the docs-bundle-ui, and it's deployed on stg too
18:47:28 <darknao> speaking of the ui-bundle, can we all agree on deploying the search feature on prod anytime soon?
18:47:59 <bcotton> i think the general consensus was that we should go ahead with it. any objections?
18:48:00 <pboy> yes please!
18:48:08 <darknao> +1
18:48:27 <bcotton> #agreed the search feature is ready for prod
18:48:33 <bcotton> #action darknao to deploy search to prod
18:48:35 <dustymabe> oooh -- search feature!
18:48:57 <pboy> yes, we meet modern times now :-)
18:49:46 <darknao> ok will do that in the next days
18:50:07 <bcotton> great
18:50:12 <darknao> nothing else from me regarding gitlab migration
18:50:20 <pboy> darknao +1
18:50:44 <darknao> oh actually, there is one last thing
18:50:59 <pboy> :-) learnt at apple?
18:51:19 <bcotton> Or Columbo :-)
18:51:47 <darknao> i already posted about this, but I've implemented a CI on the ui-bundle repo, so the bundle archive is automatically build at each commit
18:52:09 <darknao> which allow us to get a "stable" url with always the latest version
18:52:23 <pbokoc> awesome
18:52:34 <darknao> so we should update the doc template repository to use that one instead
18:53:00 <bcotton> and we don't need to get asamalik to upload a new zip file every time it changes :-D
18:53:11 <darknao> that too :)
18:53:37 <bcotton> i was thinking it'd be nice to let folks know somehow...but i'm not sure there's a great way to do that apart from submitting a PR to every repo listed in site.yml
18:53:54 <bcotton> obviously on the server it'd be fine, but people might want it for local previews, too
18:55:16 <pboy> Do we have to do something special to get it? E.G. server that is on a non-doc repo?
18:56:04 <bcotton> update the site.yml in your repo and you'll get it on local builds. the prod/stg builds will get it automatically as part of the regular build process
18:56:51 <pboy> So our server repo will get it automatically?
18:57:04 <bcotton> the repo won't. the rendered version will
18:57:21 <pboy> OK. thanks. I'll try to get it. :-)
18:57:49 <darknao> each repo will need to update their own site.yml, just like we did for antora 3.0 migration not so long ago
18:58:23 <pboy> Hm, I remember we got antora 3.0 automatically. I didn't update anything.
18:58:55 <pboy> Or at least I don't remember
18:59:26 <darknao> (and not all docs repo got that update btw)
19:00:14 <darknao> pboy: https://pagure.io/fedora-server/c/295efb4eb504673ef19a5f6467f73a1ee5a07082
19:00:20 <pboy> is the new version anywhere on pagure or only gitlab?
19:01:07 <pboy> Hm, I'll look at that. (I mean the pagure commit)
19:01:22 <darknao> the new ui-bundle? the latest version is only on gitlab
19:01:41 <pboy> OK. time get my gitlab account up and running.
19:02:45 <bcotton> alrighty, on to the next topic
19:02:46 <bcotton> #topic Visibility on website
19:02:46 <bcotton> #link https://discussion.fedoraproject.org/t/we-urgently-need-better-visibility-of-docs-specifically-on-getfedora-fedora-36/37951
19:04:15 <pboy> As I said, IoT has the improvement  already, how do we get it for server and docs landing page as well?
19:04:58 <bcotton> "someone" can submit pull requests to https://pagure.io/fedora-web/websites with the changes
19:05:51 <pboy> Well, who has the technical knowwledge to build the PR?
19:06:41 <pboy> But beforehand, do we agree, that we want the improvement in visability?
19:07:26 <bcotton> i think visibility is good
19:07:38 <darknao> +1 for visibility
19:08:02 <bcotton> i've done some websites work, so i have the technical knowledge in theory, although mostly i manage to do just enough to not break things :-)
19:08:36 <bcotton> if you're familiar with python and html, changes like we're discussing aren't particularly hard to figure out, once you look around the repo a bit
19:08:59 <AnushkaJain[m]> Hi everyone! I'm Anushka, an Outreachy applicant
19:08:59 <AnushkaJain[m]> Sorry, I got disconnected because I thought we're not invited to the meet- and went for a game of badminton 😅
19:09:20 <bcotton> welcome, Anushka Jain
19:09:43 <darknao> I can probably help with the website changes, I just need to figure out what exactly needs to be done
19:09:59 <pboy> Same to me, but I've no idea at all how the pages are build and how to fit something in.
19:10:26 <AnushkaJain[m]> Thankyou! Ben Cotton (he/him): just half an hour ago I had a chat with the design team about the website redesign:)
19:10:48 <AdvikaSingh[m]> Hi everyone! I am Advika, I am an Outreachy applicant and a UI/UX designer. I would love to help in the design problems!
19:10:54 <pboy> darknao: At the IoT getfedora page you see an additional "sub-footer". with links to IoT documentation, mailing list, etc.
19:11:19 <bcotton> pboy: if you want to file issues in that repo, darknao and/or i can work on them if someone else from the websites team don't get to it first
19:11:27 <darknao> Yeah I just saw that, maybe we can do the same for the other editions
19:12:01 <pboy> Yes, maybe AnushkaJain[m] can help, too?
19:12:03 <bcotton> welcome, Advika Singh
19:12:35 <AdvikaSingh[m]> Thank you Ben Cotton (he/him)
19:12:38 <pboy> or Advika Singh?
19:12:50 <bcotton> okay, so how about this
19:12:53 <AdvikaSingh[m]> pboy: Would love to help!
19:13:20 <bcotton> #action pboy to open issues against fedora-web/websites for docs visibility and put the links in the thread so Docs contributors can help implement
19:13:27 <bcotton> that sound good?
19:13:33 <AnushkaJain[m]> Yep
19:13:54 <darknao> sound great
19:13:54 <bcotton> this way, it's documented what needs to be done and assignees can be tracked
19:13:55 <AdvikaSingh[m]> bcotton: Sounds great!
19:14:01 <pboy> Well, I can oben an issue, yes. But not create a pull request.
19:14:16 <subtle-influence> Hi, I am Oluwaseun an outreachy applicant... I'd be happy to help too
19:14:17 <darknao> we can even tag it as easyfix
19:14:55 <pboy> OK. I'll start with that later or tomorrow (it's late evening hier in Europe)
19:15:08 <darknao> pboy: someone from the website team might be able to handle the pr work
19:15:20 <pboy> Let's hope so.
19:15:54 <AnushkaJain[m]> I think, after discussion with Mo, they've a new interface and a new header for the website, which aims at increasing visibility ( of fedora products, as well as contributions) should we take that into consideration as well
19:15:54 <darknao> (I was referring to me :p)
19:15:59 <bcotton> excellent
19:16:32 <AnushkaJain[m]> s/contributions/how to contribute/
19:16:34 <bcotton> anything else on the visibility topic?
19:16:42 <pboy> The server link and teh docs page linkt, anissue each or for both at the same time?
19:16:53 <pboy> Oh, my keyboard
19:17:10 <bcotton> pboy: i'd say one each, for clarity
19:17:23 <pboy> Thanks, Ill do
19:17:50 <bcotton> and for workstation, we might just refer to `/latest` for now until there are Workstation-specific docs
19:18:06 <pboy> OK, but latest what?
19:18:13 <pboy> the installation guide?
19:18:46 <pboy> or the lease page?
19:18:47 <bcotton> pboy: https://docs.fedoraproject.org/en-US/fedora/latest/
19:19:14 <pboy> OK, that's the release page.
19:19:38 <bcotton> seems slightly better than dropping them on the docs front page :-)
19:19:48 <pboy> Indeed, yes
19:20:08 <bcotton> alrighty...
19:20:11 <bcotton> #topic Open floor
19:20:31 <bcotton> anything else for today's meeting or shall we adjourn to our usual channels?
19:20:45 <pboy> nothing from me at the moment
19:21:57 <darknao> welcome again to all outreachy applicants o/
19:22:07 <bcotton> 🎉
19:22:11 <AnushkaJain[m]> Thank you so much!
19:22:13 <pboy> me too!
19:22:23 <AnushkaJain[m]> Ben Cotton (he/him):  I have a question
19:22:23 <subtle-influence> Thank you!
19:22:30 <AdvikaSingh[m]> Thank you , I hope to be of great help !
19:22:32 <bcotton> Anushka Jain: go ahead
19:22:36 <pboy> it was unfortunately a bit short
19:23:01 <pboy> not your help! but hte welcome!
19:23:38 <AnushkaJain[m]> Since the design team is working on a revamp, should we think about the docs website as a part of the revamp( which would absolutely fit better) or we can think of docs as a separate entity?
19:24:11 <AnushkaJain[m]> * of docs website as a, * separate entity? Following the same design system i.e.
19:24:26 <bcotton> imo it's a separate entity, but ideally most visitors would come via the revamped website
19:25:01 <AnushkaJain[m]> It's a little confusing to me, since pboy is also referring to the current getfedora website only.
19:25:26 <pboy> I'm pragmatically referring the the pages as they are now.
19:25:35 <bcotton> yeah, that's about improving what exists now, not what will exist in the undetermined future
19:25:40 <pboy> Without any structurell idea.
19:25:46 <AnushkaJain[m]> Okkkk!
19:26:02 <AnushkaJain[m]> I can ask this to Mo also once?
19:26:43 <pboy> I think, the revamp project is a huge work and will time longer the less time
19:26:55 <pboy> So we need interim solutions.
19:27:02 <AnushkaJain[m]> Even though a change in the current website would be of help to the users as well- I see you're talking about spontaneous changes
19:27:26 <pboy> I'm, yes
19:27:48 <AnushkaJain[m]> Got it! You'd need some design mockups for that?
19:27:55 <AnushkaJain[m]> I could help there
19:28:38 <pboy> For the modifications we just discussed, let's see, what the outcome of the issue is.
19:28:56 <AnushkaJain[m]> Sure.
19:29:32 <AdvikaSingh[m]> pboy: By interim solutions, you mean minor design changes that could increase feasibility and usability?
19:29:35 <pboy> But we may want do do some more modifications, and then a mockup would be nice. But that depends on some ongoing content work.
19:30:04 <pboy> AdvikaSingh[m]: yes!
19:31:44 <AdvikaSingh[m]> pboy: That seems interesting work, would love to contribute to that.
19:32:15 <pboy> Thanks, I would appreciate (and I think all of us).
19:34:04 <AnushkaJain[m]> Got it, I've no more questions!
19:36:42 <bcotton> OK, thanks everyone!
19:37:13 <bcotton> #endmeeting