18:30:54 <bcotton> #startmeeting docs
18:30:54 <zodbot> Meeting started Wed Jun  1 18:30:54 2022 UTC.
18:30:54 <zodbot> This meeting is logged and archived in a public location.
18:30:54 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:30:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:30:54 <zodbot> The meeting name has been set to 'docs'
18:31:13 <bcotton> #topic Roll call
18:31:17 <pboy> .hi
18:31:18 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:31:29 <darknao> .hi
18:31:30 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
18:31:33 <py0xc3[m]> .hello py0xc3
18:31:34 <zodbot> py0xc3[m]: py0xc3 'Christopher Klooz' <py0xc3@my.mail.de>
18:32:22 <MateusRodCosta[m> Er... I'm new here, what should I do?
18:32:38 <bcotton> #chair pboy darknao
18:32:38 <zodbot> Current chairs: bcotton darknao pboy
18:32:43 <bcotton> welcome, MateusRodCosta !
18:33:06 <pboy> Welcome too, we had a short discussion
18:33:33 <bcotton> you can add yourself to the log with `.hello <YOUR_FEDORA_ID>` (but also just speaking notes that you're here)
18:33:44 <MateusRodCosta[m> .hello mateusrodcosta
18:33:48 <zodbot> MateusRodCosta[m: mateusrodcosta 'Mateus Rodrigues Costa' <mateusrodcosta@gmail.com>
18:34:21 <darknao> welcome MateusRodCosta[m o/
18:34:35 <py0xc3[m]> Welcome Mateus
18:34:58 <bcotton> #topic Agenda
18:35:09 <bcotton> #info Announcements
18:35:09 <bcotton> #info Review action items
18:35:10 <bcotton> #info Content plan office hours
18:35:19 <bcotton> #info GitLab followup
18:35:19 <bcotton> #info Revitalization status
18:35:19 <bcotton> #info Open floor
18:35:30 <bcotton> #topic Announcements
18:35:39 <bcotton> #help Some release notes still need written: https://discussion.fedoraproject.org/t/how-to-write-fedora-release-notes/38311
18:35:45 <bcotton> #info We're using the docs-fp-o repo to track meta-work
18:35:45 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issues
18:35:55 <bcotton> #info The Write the Docs Prague CfP is open (conference will be held online this year)
18:35:55 <bcotton> #link https://www.writethedocs.org/conf/prague/2022/cfp/
18:36:04 <bcotton> #topic Previous action items
18:36:21 <bcotton> #info pbokoc to finally add a relnotes guide to the contributor docs
18:36:41 <bcotton> #action pbokoc to finally add a relnotes guide to the contributor docs
18:37:00 <bcotton> #info bcotton to propose new text for the Mindshare box on the docs home page
18:37:00 <bcotton> #link https://pagure.io/mindshare/issue/341
18:37:01 <bcotton> this is in Mindshare's hands now
18:37:07 <bcotton> #info bcotton to share office hours post on cloud, devel, desktop, iot, kde, mindshare, server mailing lists
18:37:13 <bcotton> #action bcotton to share office hours post on cloud, devel, desktop, iot, kde, mindshare, server mailing lists
18:37:19 <bcotton> i haven't done this yet, but soon!
18:37:40 <bcotton> #topic Content plan office hours
18:38:01 <bcotton> #link https://communityblog.fedoraproject.org/fedora-docs-is-about-to-change-significantly-check-it-out-still-in-statu-nascendi/
18:38:26 <bcotton> apart from my #action to share the link with the appropriate teams, is there anything to note on this topic this week?
18:38:42 <pboy> I don#t think so.
18:39:03 <pboy> I hope we are all present on thuesday?
18:39:27 <pboy> bcotton will you chair the meeting?
18:39:57 <bcotton> i can do that
18:40:02 <pboy> thanks
18:40:58 <bcotton> #topic GitLab migration
18:41:02 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/boards/GitLab%20migration
18:41:09 <bcotton> so there were a couple of items related to this that got a mention on Discussion
18:41:49 <bcotton> darknao, can you expand on these?
18:42:05 <darknao> yes
18:42:21 <darknao> so the first one is about how we are going to handle permissions: https://discussion.fedoraproject.org/t/fedora-docs-gitlab-permissions/39545
18:42:56 <darknao> for now, access are granted manually
18:43:36 <darknao> but we can link gitlab to FAS group for a better (more centralized) permission managment
18:43:42 <bcotton> #link https://discussion.fedoraproject.org/t/fedora-docs-gitlab-permissions/39545
18:44:03 <bcotton> #info We currently grant access manually, but we can link GitLab to Fedora Accounts for centralized permission management
18:44:19 <bcotton> are there downsides to linking to FAS? because that seems like the way to go
18:44:31 <pboy> I would prefer linking the FAS group, but I don't know if that is technicaly favourable.
18:44:34 <darknao> but if we are doing that, I think we can't assign permission manually anymore to individual repository
18:45:01 <pboy> darknao that's not good, I guess
18:45:15 <pboy> we should be able to do that.
18:45:55 <darknao> which means, for repository not completely maintained by us (like the flatpak or packaging guideline) that may cause some issues
18:45:55 <bcotton> so all of the repos in the docs group would have the some ACLs?
18:47:08 <darknao> ACLs are assigned on the Fedora Docs group, and all repositories inherit from it
18:48:01 <bcotton> arguably, that's good. permissions on repos are currently all over the place, which is confusing. if we're not the ones maintaining a repo, it shouldn't be in the Fedora Docs group
18:48:18 <pboy> Is there a way to "subgroups" ? e.g. core, external, ....
18:48:19 <darknao> but maybe we can do both, like using SAML groups (FAS) on Fedora Docs group itself, and still be able to grant access to individual repositories behind it
18:50:34 <bcotton> can i #action you to find out if that's possible?
18:50:43 <darknao> yes
18:51:15 <bcotton> #action darknao to find out if we can use SAML groups on Fedora Docs GitLab group and still grant additional access to individual repositories
18:51:56 <bcotton> anything else on permissions before we move to the second GitLab item?
18:51:57 <darknao> I already ask that on the discussion thread, will see if ryanlerch  know the answer
18:52:08 <bcotton> great
18:52:31 <darknao> assuming this is not possible, what will be our position on this?
18:53:13 <darknao> does that mean we only allow docs repository maintained by us in this group ?
18:53:20 <pboy> Then we should start with a strict pull request model
18:53:25 <bcotton> that's the route i'd go
18:53:41 <bcotton> repos not maintained by the docs team should be in a different group, imo
18:53:48 <pboy> darknao  I think so. at least at the beginning.
18:54:37 <darknao> ok, so I will hold on the migration of both flatpak and packaging guideline repositories for now
18:55:09 <darknao> and maybe the l10n one too, since we are not the one maintaining it either
18:55:12 <bcotton> sounds good. thanks, darknao!
18:55:38 <bcotton> #agreed Repos not maintained by the Docs team shouldn't be in the Fedora Docs group on GitLab
18:56:10 <darknao> ok so second topic, pboy already did a nice transition to it, since it's about pull request model
18:56:10 <bcotton> #info We will hold off on migrating the flatpak, Packaging Guidelines, and l10n repos until we know if we can grant additional repo permissions
18:56:43 <darknao> more precisely, on how protected branches work on gitlab
18:57:12 <darknao> by default on gitlab, the `main` branch is protected
18:57:54 <darknao> meaning only users with `mainteners`  role can push commit or merge PR
18:58:32 <darknao> basically, everyone must use pull request workflow to push some code (or any content)
18:59:23 <darknao> question is: do we want to enforce this (the default) or should we relax it a bit, so at least team members can push directly
18:59:47 <pboy> From a non-technical view: If a take responsibility for e.f repo Anaconda guide, I would like to be able to commit directly, and commit PRs
19:00:17 <pboy> And it would be nice to have a team, that can do it that way.
19:00:26 <darknao> personal opinion: I think we are not enough in the team right now to enforce this policy and add the need to review every single change
19:00:43 <bcotton> i like the idea of relaxing. i think we should do PRs for significant changes, but it'd be annoying to require it for trivial changes, typo fixes, etc
19:00:50 <pboy> darknao +1
19:01:08 <pboy> We need somethink like QA
19:01:30 <darknao> if you have access to the docs group, I guess we trust you enough to push commit, just like it is on Pagure
19:01:59 <MateusRodCosta[m> IMHO, if I were to contribute writing docs, I would prefer my contributions to be reviewed first until I got tthe hang of the process and writing style
19:02:16 <darknao> for external users, in other hand, we keep the MR workflow, of course
19:02:45 <py0xc3[m]> MateusRodCosta: even if you are allowed to directly push, you can still do a pull request if you are not sure about the content :)
19:02:47 <darknao> by external users, I mean users that are not in the Fedora Account Docs group
19:03:10 <MateusRodCosta[m> Ok, got it!
19:03:22 <darknao> we can also add a number of required approval to merge MR
19:03:43 <pboy> I should not make it too complicated.
19:03:51 <pboy> I -> We
19:04:08 <bcotton> agreed. i think if someone with commit access approves the MR, we should merge it
19:04:25 <pboy> What is a MR?
19:04:27 <bcotton> i'd love for us to have enough people actively contributing to require 2 approvals, but we're definitely not there yet
19:04:34 <darknao> MR = PR (Merge Request)
19:04:40 <pboy> thanks
19:04:54 <darknao> Gitlab uses MR, where Github uses PR
19:05:10 <darknao> so 1 approval required then?
19:05:14 <pboy> bcotton: in the long run yes
19:05:35 <pboy> darknao We should begin that way.
19:06:08 <darknao> we can revisit it at later time if that doesn't work well an
19:06:12 <darknao> anyway*
19:06:22 <pboy> indeed
19:07:02 <darknao> I don't know if we have the time, but I have a third topic that cross my mind just now
19:07:15 <bcotton> go for it
19:07:22 <darknao> alright
19:07:25 <darknao> CI !
19:07:53 <darknao> Once upon a time, there was a project to implement CI in docs
19:08:46 <darknao> the goal was to build the whole documentation website somewhere, and make it available in each PR made all around for every single documentation repositories
19:09:52 <darknao> that was never implemented, mainly because you'll need to monitor each repository for PR, using fedora-messaging for instance, and that can become very complicated
19:10:21 <darknao> But now, we have gitlab-ci to the rescue
19:11:23 <darknao> We can easily implement that for every repository we manage, but that will most likely only build the doc component alone instead of the whole website
19:12:08 <darknao> question is: Do we really need to build the whole website for that, or can we just limit ourselves to the component we are currently testing?
19:12:38 <bcotton> if it's just the component, that's still better than we have now
19:12:45 <pboy> Question: Does it mean that I have the complete doc site locally available? Or do I got it totally wrong?
19:13:12 <bcotton> and it will catch maybe 80% of issues? thinks like cross-module includes and xrefs won't be right, but most things will
19:13:29 <darknao> pboy: basically, the CI system will run the build.sh script and make the result available for previewing in your PR
19:13:42 <pboy> OK
19:14:04 <darknao> that is for the base job, we can then add whatever check we want to that
19:14:54 <darknao> like, checking links or syntax...
19:15:38 <pboy> sounds interesting. Something like a private stg
19:16:01 <darknao> if a component does a lot of cross link to another component, we can add it to the site.yml
19:16:25 <darknao> and include it in the CI build
19:16:36 <darknao> pboy: yes, exactly
19:16:58 <pboy> would be great, practically
19:18:07 <darknao> alright so I can configure all the repositories already in gitlab with that in mind
19:18:25 <bcotton> agreed
19:18:26 <bcotton> we can start with a simple build on the repos we manage and build out additional checks (and docs for others who want to use CI) over time
19:19:21 <darknao> yep sounds good
19:19:29 <darknao> you can action me on that
19:20:18 <bcotton> #action darknao to configure the docs repos in GitLab with CI to run builds on MRs (we can add additional checks later)
19:20:27 <bcotton> anything else on GitLab?
19:20:55 <darknao> I think that's it for me
19:21:11 <darknao> oh actually one last thing
19:21:22 <darknao> what about the docs-fp-o repository?
19:21:54 <darknao> can we migrate it now, or do you want to leave it for a bit?
19:22:03 <pboy> may be we migrate that last?
19:22:18 <bcotton> yeah, i thought we were going to leave that for last
19:23:08 <darknao> well, there is not much left to migrate
19:23:25 <darknao> the last one is quick-docs
19:23:55 <pboy> I see, I must hurry with my account
19:23:56 <darknao> and all others are maintained by other team, so we may end up not migrate these in the end
19:24:39 <bcotton> did we do release notes?
19:25:04 <darknao> I don't think there was a ticket for that one
19:25:35 <bcotton> whoops
19:25:39 <bcotton> looks like there wasn't
19:25:53 <bcotton> that one's a little more complicated since we don't actually want to declare bankruptcy there
19:26:27 <bcotton> #action bcotton to start discussion of how to handle the Release Notes repo move
19:27:25 <bcotton> okay, we're near the end of the hour. anything else that needs to be discussed this week?
19:28:00 <pboy> don't think so
19:28:07 <pboy> not in 2 mins
19:28:14 <MateusRodCosta[m> Hi, where and how I should I start contributing?
19:28:26 <darknao> last one, we should close this ticket: https://pagure.io/fedora-docs/docs-fp-o/issue/189
19:28:37 <darknao> I mean, do the changes, then close
19:29:00 <darknao> I can handle the fedora-docs group on Pagure, but I don't have access to the Fedora Account one
19:29:11 <bcotton> okay, i can do that
19:29:12 <pboy> Could we wait until we have time for the topic we miss today?
19:29:14 <bcotton> #action bcotton to make the group changes in https://pagure.io/fedora-docs/docs-fp-o/issue/189 and close the issue
19:29:31 <bcotton> the revitalizaiton status?
19:29:37 <pboy> yes
19:29:51 <bcotton> makes sense
19:29:57 <bcotton> #undo
19:29:57 <zodbot> Removing item from minutes: ACTION by bcotton at 19:29:14 : bcotton to make the group changes in https://pagure.io/fedora-docs/docs-fp-o/issue/189 and close the issue
19:30:08 <bcotton> i'll put that at the top of the list for next week since we've missed it the last few times
19:30:28 <pboy> MateusRodCosta[m>
19:30:50 <pboy> MateusRodCosta[m can we discuss your contribution on mailing list?
19:30:59 <pboy> contribution options
19:31:08 <MateusRodCosta[m> pboy: Mailing list or Discussion?
19:31:32 <pboy> discussion, we have no mailing list anymore. :-(
19:31:43 <MateusRodCosta[m> Ok, sure
19:31:47 <bcotton> okay, thanks everyone!
19:31:49 <bcotton> #endmeeting