14:00:45 <bcotton> #startmeeting Prioritized bugs and issues
14:00:45 <zodbot> Meeting started Wed Jun 15 14:00:45 2022 UTC.
14:00:45 <zodbot> This meeting is logged and archived in a public location.
14:00:45 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
14:00:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:45 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
14:00:50 <bcotton> #meetingname Fedora Prioritized bugs and issues
14:00:50 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
14:01:02 <bcotton> #topic Purpose of this meeting
14:01:02 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
14:01:02 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
14:01:02 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
14:01:06 <bcotton> #topic Roll Call
14:01:12 <bcotton> who's here to prioritize some bugs?
14:01:24 <mattdm> I am here to chew gum
14:01:28 <mattdm> and prioritized bugs
14:01:32 <mattdm> and I am all out of one of those things
14:01:35 <mattdm> but I forget which
14:01:39 <bcotton> :-)
14:02:52 <bcotton> i think the other regulars have all indicated that they can't make it today, so let's get started
14:02:58 <bcotton> #topic Common Bugs review
14:02:58 <mattdm> ok
14:02:58 <bcotton> #info Let's start with a check of the Common Bugs pages for supported releases and see if any should be nominated as Prioritized Bugs
14:02:58 <bcotton> #link https://ask.fedoraproject.org/c/common-issues/141/none/l/latest?order=votes
14:04:03 <mattdm> I don't see anything, but I'm excited to test the workarounds for video acceleration in firefox
14:04:04 <bcotton> most of these look like they haven't been commented on in a while, so probably not good candidates
14:04:11 <mattdm> that might make hopin not burn up my computer
14:05:59 <bcotton> where would be the fun in that?
14:06:16 <bcotton> #topic Nominated bugs
14:06:16 <bcotton> #info 2 nominated bugs
14:06:16 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
14:06:29 <bcotton> #topic Connecting/disconnecting an external monitor or VM resizing switches GNOME to the login screen
14:06:29 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2071394
14:07:01 <bcotton> #info This bug was previously nominated but closed before we could evaluate it. It has since been reopened
14:07:50 <mattdm> Let me look at rawhide real quick...
14:09:21 <mattdm> Hmmm, yeah, looks like f36 is ahead of rawhide by two fixes.
14:09:24 <bcotton> looks like rawhide doesn't have the fix
14:09:29 <mattdm> yeah exactly
14:10:30 <mattdm> I wonder if the expectation is "fix on branch + upstream, it'll get into rawhide eventually"?
14:10:56 <bcotton> i'm not particularly sold on this as a prioritized bug considering how little the BZ and Ask post seemed to draw
14:11:30 <mattdm> I do want to make sure the fix isn't lost....
14:11:44 <bcotton> FWIW the upstream bug report is still open
14:11:53 <bcotton> bug the fix is merged upstream
14:12:16 <bcotton> #info Our local fix that works for F36 is merged upstream
14:12:16 <bcotton> #link https://gitlab.gnome.org/GNOME/gdm/-/merge_requests/175
14:13:44 <mattdm> That should resolve it. It would be nice to have these things fixed in rawhide too ... it's kind of a packager workflow thing though
14:13:51 <bcotton> yeah
14:14:11 <bcotton> i guess we can accept this as a prioritized bug just to make sure the update is put into rawhide
14:14:21 <mattdm> Yeah I'll buy that.
14:14:23 <bcotton> but when gnome 43 is released, that should fix it anyway
14:14:28 <mattdm> For, like, 3¢
14:14:32 <mattdm> exactly, yeah.
14:14:49 <mattdm> I might take my 3¢ back.
14:15:14 <mattdm> Reject as prioritize bug because there's no real action to take -- we are confident that the fix will land for f37
14:15:25 <mattdm> And rawhide is important but it isn't the job of this process to keep rawhide working
14:15:36 <bcotton> works for me
14:15:58 <bcotton> proposed #agreed 2071394 is rejected as a prioritized bug. The fix is committed upstream and we are confident this will land before the F37 release.
14:16:13 <bcotton> and it's an annoying bug, not a breaks-usability bug
14:16:44 <bcotton> i'd be more likely to accept it if it make rawhide harder to use (but even then, rawhide isn't super important for this process, as you said)
14:16:44 <mattdm> Policies for rawhide are a fesco issue and I don't think the guidance is definitive here
14:17:44 <mattdm> ok next :)
14:17:57 <bcotton> #agreed 2071394 is rejected as a prioritized bug. The fix is committed upstream and we are confident this will land before the F37 release.
14:18:15 <bcotton> #topic Get rid of multiple source path definitions
14:18:16 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2079833
14:20:57 <bcotton> so even though this one also affects rawhide, it seems more prioritize-y than the previous
14:21:47 <bcotton> seems like the answer (for now at least) is to update the cmake package in rawhide. there may be a time bomb waiting for us after that, but it's at least a start
14:22:47 <mattdm> Huh. Seems like maybe this should be reverted and made a system-wide change
14:24:15 <mattdm> Since I was just looking at the rawhide policy, dropping that here...
14:24:21 <bcotton> i don't love the idea of reverting it just because we don't have particularly good methods for that
14:24:21 <mattdm> #link https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#_rawhide
14:25:21 <bcotton> but at least "update with the bugfix and then submit a change proposal" is a good approach
14:25:23 <mattdm> Particularly: [maintainers MUST] not push any known broken builds (breaks the default buildroot package set, etc.). This causes additional work for other maintainers trying to integrate their changes.
14:26:27 <bcotton> so how about this...
14:26:55 <mattdm> oh yeah I see further in the bug that cmake reverted the change
14:27:34 <bcotton> proposed #agreed 2079833 is accepted as a prioritized bug due to the impact on package maintainers. The cmake maintainers should update with the upstream package and submit a System-Wide Change proposal for this and future updates
14:27:48 <mattdm> hold on, amend
14:27:57 <bcotton> and then if it's not addressed, we can refer it to FESCo for action on the updates policy
14:29:30 <mattdm> proposed #agreed 2079833 is accepted as a prioritized bug due to the impact on package maintainers. The cmake maintainers should update with the upstream package and submit a System-Wide Change proposal for any future release where Cmake might re-implement this change or any similar change that might require coordination with other packagers (as outlined in the Rawhide updates policy)
14:29:46 <mattdm> except be consistent with capitalizing or not cmake
14:29:54 <bcotton> not sure that fits on one line, but good enough for me
14:30:04 <mattdm> How long is a line? :)
14:30:14 <bcotton> no idea
14:31:08 <bcotton> #agreed 2079833 is accepted as a prioritized bug due to the impact on package maintainers. cmake maintainers should update with the upstream package and submit a System-Wide Change proposal for future releases where upstream re-implements this or similar change that require coordination with other packagers (as outlined in the Rawhide updates policy)
14:31:30 <bcotton> i edited it down a bit. if it doesn't fit entirely, it'll still be recorded in the bz so that's what really matters
14:32:02 <mattdm> is it meetbot line length we are concerned with?
14:32:08 <bcotton> yessir
14:33:06 <mattdm> ah.
14:34:15 <mattdm> #info 123456789A123456789B123456789C123456789D123456789E123456789F123456789G123456789H123456789I123456789J123456789K123456789L123456789M123456789N123456789O123456789P123456789Q123456789R123456789S123456789T123456789U123456789V123456789W123456789X123456789Y123456789Z
14:34:30 <mattdm> maybe that's not long enough
14:34:40 <bcotton> we can play with it later
14:34:43 <mattdm> finnnneee
14:34:45 <bcotton> #topic Accepted bugs
14:34:45 <bcotton> #info 1 accepted bugs
14:34:45 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
14:35:27 <mattdm> I wish computers didn't have to boot
14:35:31 <mattdm> SOOOO complicated
14:36:50 <bcotton> so it looks like this has been reviewed and is waiting to be signed
14:37:14 <bcotton> so nothing for us to do at the moment, but progress is happening and we don't need to push on anything
14:38:46 <mattdm> So https://bugzilla.redhat.com/show_bug.cgi?id=1955416#c75 is still the latest update?
14:39:05 <mattdm> I understand this being frustrating for people because "progress is happening" isn't apparent
14:39:32 <bcotton> it is
14:39:50 <bcotton> there's a little more activity in the GH issue
14:40:00 <bcotton> but it's all basically the same
14:42:27 <bcotton> basically, we're waiting for Microsoft to send the signed shim at this point
14:42:41 <bcotton> https://github.com/rhboot/shim-review/issues/241#issuecomment-1155316235
14:44:32 <mattdm> Maybe worth putting that in the bug for people who just scroll to the bottom
14:45:31 <bcotton> #action bcotton to update the BZ with the latest update from the GH issue
14:45:45 <mattdm> thank you ben!
14:45:50 <pjones> it'll be this afternoon
14:46:00 <mattdm> Also I like that Peter Jones' system name is apparently `random`.
14:46:04 <bcotton> pjones: awesome, thanks
14:46:14 <mattdm> This fits nicely with the default hostname discussion on devel list
14:46:17 <pjones> mattdm: my not-test-machines are all hitchhikers characters
14:46:20 <mattdm> pjones++
14:46:20 <zodbot> mattdm: Karma for pjones changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:46:33 <mattdm> pjones: awesome. that's a good scheme.
14:47:17 <bcotton> mine are notable places i've gone storm chasing
14:47:24 <pjones> bcotton: that's perfect for you
14:47:29 <bcotton> pjones: should i just hold off on updating the BZ then?
14:47:46 <pjones> bcotton: gimme an hour?
14:48:11 <bcotton> sounds good :-)
14:48:21 <bcotton> anything else on this bug?
14:48:38 <bcotton> (that i realize i never actually topic'ed and now i'm going to go to program manager hell)
14:49:08 <mattdm> OH NO
14:49:56 <mattdm> #help future matrix-based zodbot should allow "insert" into timeline at arbitrary points in the history
14:50:33 <bcotton> #topic Next meeting
14:50:34 <bcotton> #info We will meet again on 29 June at 1400 UTC in #fedora-meeting-1
14:50:58 <bcotton> that's all i have for today. anything else?
14:51:43 <mattdm> That is all. Good job team!
14:51:47 <mattdm> bcotton++
14:51:47 <zodbot> mattdm: Karma for bcotton changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:52:02 <bcotton> #endmeeting