15:30:12 <nirik> #startmeeting Fedora Mobility SIG
15:30:12 <zodbot> Meeting started Mon Sep 12 15:30:12 2022 UTC.
15:30:12 <zodbot> This meeting is logged and archived in a public location.
15:30:12 <zodbot> The chair is nirik. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:30:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:30:12 <zodbot> The meeting name has been set to 'fedora_mobility_sig'
15:30:12 <nirik> #meeting_name fedora_mobility_sig
15:30:12 <nirik> #chair torbuntu pbrobinson _Yoda_
15:30:12 <nirik> #topic init process
15:30:12 <zodbot> Current chairs: _Yoda_ nirik pbrobinson torbuntu
15:30:22 <nirik> hey folks. anyone around for a mobililty sig meeting?
15:30:40 <_Yoda_> o/
15:32:28 <nirik> morning _Yoda_
15:32:50 <nirik> might be a short one. ;)
15:32:54 <_Yoda_> Yo, looks like this will bee a short meeting
15:33:04 <_Yoda_> :)
15:33:34 <nirik> #topic General topics/Status
15:33:40 <nirik> anything to note?
15:34:08 <nirik> torsh[m] said earlier: "I'll likely miss the meeting, but as far as updates nothing form me outside of mobile package updates and testing Phosh on Pinebook Pro which is neat. (requires setting the chassis with hostnamectl to laptop to be in non-mobile mode)"
15:34:32 <_Yoda_> not really. Trying to get camera working on PPP - but kernel is fighting back :)
15:35:16 <nirik> The ppp DT finally landed upstream: https://lore.kernel.org/all/166231195330.2423948.5394487959576836993.b4-ty@sntech.de/
15:35:42 <_Yoda_> yes, but it is only the basics. Its a start however
15:35:58 <nirik> yep.
15:36:26 <nirik> #info initial bare dt merged upstream for pinephone pro
15:36:56 <nirik> I'll send out a thing on picking another time for this meeting... I often get doublebooked or otherwise busy and I think others have had trouble with this time too.
15:36:59 <torsh[m]> What is al supported in this initial dt?
15:37:03 <torsh[m]> s/al/all/
15:37:20 <nirik> "Tested to work: booting from eMMC/SD, output over UART."
15:37:35 <_Yoda_> mostly just that it can boot
15:37:54 <torsh[m]> Nice :)
15:39:00 <nirik> has anyone tested the gnome mobile support stuff? it looked pretty interesting in demos, but not sure if it's landed anywhere yet?
15:39:23 <torsh[m]> Haven't had the chance to build it myself.
15:39:39 <_Yoda_> me neither
15:39:51 <nirik> ok, just wondering. :)
15:39:57 <nirik> #topic Open Floor
15:40:06 <nirik> anything anyone wants to bring up?
15:41:09 <_Yoda_> not really
15:41:38 <torsh[m]> Oh! Charging the keyboard
15:41:46 <torsh[m]> I've noticed it requires the phone to be turned off to actually charge
15:41:57 <torsh[m]> It was in the documentation, but I only recently relearned that.
15:41:57 <_Yoda_> mine doesn't work at all :-/
15:42:00 <torsh[m]> (pine64 wiki)
15:42:57 <nirik> I've not messed with mine recently... I know megi was working on some in kernel charging thing
15:43:13 <torsh[m]> Was that in his 5.19 build?
15:43:35 <nirik> not sure
15:44:35 <torsh[m]> oh, I also have the phosh-mobile-settings application in copr https://copr.fedorainfracloud.org/coprs/torbuntu/mobile-testing/package/phosh-mobile-settings/
15:44:45 <torsh[m]> if anyone else wants to test it (for enabling new phosh widgets on lockscreen)
15:45:03 <nirik> nice
15:46:53 <torsh[m]> Not probably too related but I'm still trying to get phosh working on my pi3b using the 7 inch display
15:47:02 <torsh[m]> but latest fedora images (37+) don't seem to boot there heh.
15:47:41 <nirik> odd.
15:48:08 <torsh[m]> (I've never been able to get the display to actually work with wayland/wlroots anyway though)
15:48:36 <torsh[m]> When using hdmi it gets to the gdm login, but it never succeeds in logging in. Haven't figured out why yet. (that part isn't mobility related)
15:49:18 <nirik> I would think if it lights up the display it would work... but clearly not. ;)
15:50:41 <nirik> ok, if nothing else, lets close out and meet again... at some new point. :)
15:51:33 <torsh[m]> 👋 sounds good. Thanks!
15:51:35 <_Yoda_> what about the change ?
15:52:37 <_Yoda_> is it ready ?
15:53:09 <nirik> yeah, I haven't done anything with it... should I submit it for f38? f39? or keep holing it until we see more?
15:54:24 <_Yoda_> wouldn't F38 be ok ? Then we have until april to get it polished
15:54:34 <camorris> I've got a quick question if anyone has some time. Has anyone managed to get signal working on their fedora pinephone ?
15:55:05 <camorris> I raised a bug for axolotl but so far all my attempts have failed https://github.com/nanu-c/axolotl/issues/873
15:55:33 <nirik> _Yoda_: we could. We still would need to write kickstart/osbuild and compose stuff for the image to be added... but sure. I could put it in for f38...
15:55:51 <nirik> camorris: I had it working at one point I think... via the flatpak.
15:56:23 <_Yoda_> if you think it is better to wait for F39, that is ok with me....
15:56:41 <nirik> might have more things we can use the image on is the main thing...
15:56:59 <_Yoda_> I just like us to get Fedora to build nightlies for us asap
15:58:32 <camorris> nirik, good to know. I'll probably mess again with this soon and let you know
15:59:37 <nirik> _Yoda_: ok. I can put in for f38...
16:03:32 <_Yoda_> but maybe we should get the osbuild/kickstart stuff written and tested first ?
16:04:17 <nirik> we could, but also the change needs announced/discussed/approved... so we have some time there too.
16:04:59 <_Yoda_> Might also make it easier for me to build the images - because the current way is highly unstable, and brings my server down very often :-|
16:05:26 <nirik> ok. I can put it in soon... and we can work on the kickstarts in the mean time.
16:06:29 <nirik> #action nirik to put f38 change in
16:06:37 <nirik> #action everyone to work on kickstart
16:06:45 <_Yoda_> I guess I can testbuild it on my quartz64, when we have the right kickstarts
16:07:00 <nirik> ok, thanks for coming everyone. Lets continue over in #fedora-mobility.
16:07:20 <nirik> sounds good.
16:07:23 <nirik> #endmeeting