16:00:14 <geppetto> #startmeeting fpc
16:00:14 <zodbot> Meeting started Thu Apr 6 16:00:14 2023 UTC.
16:00:14 <zodbot> This meeting is logged and archived in a public location.
16:00:14 <zodbot> The chair is geppetto. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:14 <zodbot> The meeting name has been set to 'fpc'
16:00:14 <geppetto> #meetingname fpc
16:00:14 <zodbot> The meeting name has been set to 'fpc'
16:00:14 <geppetto> #topic Roll Call
16:00:35 <Eighth_Doctor> .hello ngompa
16:00:36 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:00:43 <GwynCieslasheher> .hello2 limb
16:00:44 <zodbot> GwynCieslasheher: Sorry, but user 'GwynCieslasheher' does not exist
16:00:55 <geppetto> #chair Eighth_Doctor
16:00:55 <zodbot> Current chairs: Eighth_Doctor geppetto
16:00:59 <geppetto> #chair GwynCieslasheher
16:00:59 <zodbot> Current chairs: Eighth_Doctor GwynCieslasheher geppetto
16:01:11 <GwynCieslasheher> I keep having the same dream...
16:01:55 <carlwgeorge> .hi
16:01:56 <zodbot> carlwgeorge: carlwgeorge 'Carl George' <carl@redhat.com>
16:01:57 <geppetto> How dystopian is it?
16:02:00 <geppetto> #chair carlwgeorge
16:02:00 <zodbot> Current chairs: Eighth_Doctor GwynCieslasheher carlwgeorge geppetto
16:02:12 <GwynCieslasheher> About a 14.
16:02:26 <GwynCieslasheher> Then I wake up and it's only 35.
16:02:26 <Eighth_Doctor> #chair limb
16:02:26 <zodbot> Current chairs: Eighth_Doctor GwynCieslasheher carlwgeorge geppetto limb
16:02:27 <Eighth_Doctor> #unchair GwynCieslasheher
16:02:27 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto limb
16:02:47 <Eighth_Doctor> #unchair limb
16:02:47 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto
16:03:48 <Eighth_Doctor> #chair limburgher
16:03:48 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto limburgher
16:04:07 <carlwgeorge> what's going on with this chair fight lol
16:04:18 <Eighth_Doctor> #chair Gwyn Ciesla (she/her)
16:04:18 <zodbot> Current chairs: (she/her) Ciesla Eighth_Doctor Gwyn carlwgeorge geppetto limburgher
16:04:34 <geppetto> zodbot fail
16:04:34 <zodbot> Fail. EPIC Fail. Total, Abject, Miserable failure.
16:04:41 <Eighth_Doctor> #unchair Gwyn Ciesla (she/her)
16:04:41 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto limburgher
16:04:43 <Eighth_Doctor> blech, I give up
16:04:57 <GwynCieslasheher> I can just stand.
16:05:10 <Eighth_Doctor> I got it to do the right thing before once
16:08:47 <Eighth_Doctor> #chair GwynCieslasheher
16:08:47 <zodbot> Current chairs: Eighth_Doctor GwynCieslasheher carlwgeorge geppetto limburgher
16:09:03 <Eighth_Doctor> status quo ante
16:09:32 <geppetto> #topic Schedule
16:09:34 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/YHG2LKF6A2HH4NUZYGTU4ZELBFQYB4CM/
16:09:39 <geppetto> #topic Open Floor
16:10:09 <geppetto> Everything is old, I'm trying to move things off the schedule that aren't moving. Moved the SELinux thing to needinfo this week.
16:10:21 <geppetto> Anyone have anything to talk about?
16:10:28 <tibbs> Hey.
16:10:32 <geppetto> #chair tibbs
16:10:32 <zodbot> Current chairs: Eighth_Doctor GwynCieslasheher carlwgeorge geppetto limburgher tibbs
16:10:36 <GwynCieslasheher> I seem to recall a couple of asks but don't recall.
16:10:46 <Eighth_Doctor> we should just ban %configure in prep and be done with it
16:10:59 <jerryjames> Could you look at an OCaml Guidelines update? https://pagure.io/packaging-committee/issue/1266
16:12:37 <geppetto> Yeh, Panu mentioned %conf section and I think that stopped us just banning it because maybe it woud have an obvious section to move to then
16:12:55 <geppetto> I'm fine with just banning it and we can revisit when %conf section appears.
16:12:57 <tibbs> We should probably just merge the ocaml thing but I simply haven't had a chance to review it all.
16:13:17 <tibbs> %conf does exist, but doesn't work in F36 (or EPEL, of course).
16:13:32 <geppetto> Any objections to just banning %configure in %prep?
16:13:40 <tibbs> Not from me.
16:13:45 <carlwgeorge> nope, seems like a good idea to me
16:14:04 <tibbs> Sadly I jut went off into the weeds trying to make an "autoconf" section to go with the other build systems.
16:15:18 <Eighth_Doctor> for now, we can say it goes in %build like we do for other build systems
16:15:19 <tibbs> I think it does deserve its own page but doing that gets into other thorny questions (like "should you run autoreconf") and that shouldn't get in the way of making this pretty obvious change.
16:15:45 <GwynCieslasheher> NO, sounds good.
16:16:25 <geppetto> #action #1159 Ban use of %configure in %prep (passed)
16:17:15 <geppetto> #topic #1265 Update OCaml Guidelines
16:17:25 <geppetto> PR: https://pagure.io/packaging-committee/pull-request/1265#
16:17:44 <geppetto> Seems ok, from what I can see/understand … but I don't know much about OCaml
16:18:42 <tibbs> I don't have enough ocaml experience to ta;lk about the details, but I'm happy to see the modernization of the examples. (Still had BuildRoot....).
16:19:24 <jerryjames> The changes update the guidelines to reflect current practice. There are several obsolete recommendations in the current version.
16:19:37 <tibbs> I say just rebase and merge it.
16:19:42 <carlwgeorge> the pr seems to do some needed reformatting for line lengths, which is good but makes the pr harder to review. would be better as a separate pr.
16:20:43 <Eighth_Doctor> there are some style nits that are worth pointing out (e.g. strings being echoed to files should be quoted in specs, etc.), but otherwise it looks fine to me
16:20:57 <tibbs> I wouldn't hold anyone to that, really. It's our fault for not switching everything to semantic breaks already and if anyone's going to do that for us then I don't care if it makes it slightly more difficult to review.
16:21:19 <carlwgeorge> fair enough
16:21:31 <Eighth_Doctor> undefining package notes being in examples sucks balls though
16:22:03 <jerryjames> It does, but all current OCaml packages do that because we still haven't figured out how to make package notes coexist with OCaml peacefully.
16:22:05 <Eighth_Doctor> if language ecosystems are doing that by default, then we should really be talking to the maintainers of the package notes stuff to fix it or properly automatically disable it
16:22:29 <Eighth_Doctor> the onus isn't just on the ocaml folks, it's on the people that created package notes in the first place
16:22:40 <tibbs> I recall that there was discussion about it but the package notes thing went in anyway.
16:22:58 <Eighth_Doctor> this just reminds me that I still need to write D language guidelines to tell people to stop using ldc
16:24:22 <geppetto> Ok, should I just merge the PR then?
16:24:29 <tibbs> I just rebased it.
16:24:40 <geppetto> Ok, feel free to click the button too :)
16:24:50 <tibbs> Merged.
16:24:59 <jerryjames> Thank you
16:25:29 <geppetto> #topic Ooen Floor
16:25:38 <tibbs> Eighth_Doctor: Any other nits besides quoting arguments to echo in that PR?
16:26:27 <Eighth_Doctor> nah, the only other thing was the undefine stuff
16:26:47 <Eighth_Doctor> that needs to be called out and driven to be fixed in some meaningful way
16:28:08 <tibbs> On, %undefine _package_note_flags ? I wish that the package notes thing had been slowed down just a bit so that it didn't break entire language families.
16:28:46 <tibbs> But it got pushed through, and that is simply what they expect those languages to do.
16:28:46 <Eighth_Doctor> yeah
16:29:03 <Eighth_Doctor> if that's the case, we should have language stack macros just automatically handle this for us
16:29:26 <Eighth_Doctor> we should not be having undefines in our templates or examples unless it's a specific exception, not as a default matter of course
16:30:05 <tibbs> I'm not sure where you could hang it, unless you add something random like %ocaml_init to hide it.
16:30:38 <Eighth_Doctor> for example, the KDE packaging macros force out of tree builds on EPEL 8 by undefining it through the %cmake_kf5 macro
16:30:52 <Eighth_Doctor> if there's a primary macro that's invoked, then it can be undefined inside of it
16:31:13 <Eighth_Doctor> err, undefining the in-source build default in RHEL 8
16:31:55 <Eighth_Doctor> https://src.fedoraproject.org/rpms/kf5/blob/epel8/f/macros.kf5#_19
16:32:04 <tibbs> Right but that's kind of directly related to the action of %cmake_kf5. I'm not sure what equivalent macro would exist for ocaml.
16:33:07 <Eighth_Doctor> that might be worth passing back to jerryjames and rwmjones to figure out
16:33:32 <Eighth_Doctor> I'd also like to see the debug_package disabler go away too, especially since it's conditioned on an %Ifnarch now
16:33:40 <jerryjames> I have an idea how to make package notes work with OCaml, but haven't gotten a round tuit yet. Will try to do that soon.
16:33:58 <Eighth_Doctor> cool
16:34:06 <geppetto> jerryjames++
16:34:06 <zodbot> geppetto: Karma for jjames changed to 1 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:34:14 <Eighth_Doctor> jerryjames++
16:34:14 <zodbot> Eighth_Doctor: Karma for jjames changed to 2 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:34:26 <tibbs> Maybe both the package notes and debug package disabling could be hidden in some kind of %ocaml_setup or %ocaml_init macro, if there really is no better place to put them.
16:34:28 <Eighth_Doctor> the key here is that I don't want exceptional stuff to be the norm
16:35:04 <jerryjames> Good point. I'll try to work up such a macro.
16:35:06 <tibbs> I agree, but when someone forces the situation, you don't have all that much choice. How you hide the unpleasant stuff is just semantics.
16:35:17 <Eighth_Doctor> yup
16:35:27 <Eighth_Doctor> it's more about presentation and preventing confusion
16:36:33 <tibbs> It's all just detail that the packager shouldn't have to worry about.
16:37:15 <tibbs> We have worked really hard to get rid of most of that.
16:37:26 <Eighth_Doctor> yup
16:37:39 <Eighth_Doctor> and the less crap like this, the easier it becomes to template/automate packaging
16:38:04 * Eighth_Doctor still remembers when debuginfo packages had to be manually defined
16:38:08 <geppetto> Ok, anything else to talk about … or should I close at :40 past, and give ya'll 20 minutes back?
16:38:18 <tibbs> I'm done.
16:39:38 <Eighth_Doctor> I'm good, I don't think any dotnet people are around for the next one
16:40:01 <Eighth_Doctor> so we can end now if you like
16:40:07 <geppetto> gg
16:40:10 <geppetto> #endmeeting