20:07:35 <cwickert> #startmeeting Spins SIG meeting
20:07:35 <zodbot> Meeting started Mon Mar 21 20:07:35 2011 UTC.  The chair is cwickert. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:07:47 <cwickert> #chair nirik brunowolff
20:07:47 <zodbot> Current chairs: brunowolff cwickert nirik
20:08:04 <cwickert> #topic F15 spins
20:08:24 <cwickert> #info no new spins were marked ready for SIG, so there is nothing to discuss today
20:08:47 <cwickert> #info we haven't heared back on spins that are going to be dropped either
20:09:13 <cwickert> #info brunowolff has updated the spins release list to include the ks only versions of Desktop and KDE spins
20:09:28 <cwickert> # link https://fedoraproject.org/wiki/Releases/15/Spins
20:09:33 <cwickert> #link https://fedoraproject.org/wiki/Releases/15/Spins
20:09:47 <cwickert> #topic Biarch spin
20:10:29 <cwickert> #info nothing new from the biarch spin and the spin owner jkratochvi is not around today, so we need to delay this topic once again
20:10:49 <cwickert> #topic Open floor
20:10:56 <nirik> ok, one thing I had:
20:11:07 <nirik> I am working toward doing the nightly composes in koji.
20:11:29 <nirik> This has a number of advantages, and a few disadvantages.
20:11:52 <nirik> Here's a mock up of them from yesterday:
20:11:54 <nirik> http://www.scrye.com/~kevin/fedora/2011-03-20-nightly-spins.html
20:12:07 <nirik> it's a simple page, but hopefully it will provide the links/info people need to get to the builds.
20:12:11 <nirik> advantages of this:
20:12:24 <nirik> * finishes in 30min instead of all day like the single threaded compose machine.
20:12:43 <nirik> * Keeps 2 weeks (scratch build timelimit) of builds around, so you can go back and look at old ones.
20:13:03 <nirik> * means we can not have to deal with the compose machine hanging on things or having issues.
20:13:08 <nirik> Disadvantages:
20:13:23 <nirik> * The size isn't obvious, you have to click down into the build to get the size.
20:13:38 <nirik> * we can't add custom builds or things from testing.
20:14:02 <nirik> So, just thought I would let everyone know and provide feedback if they wanted. ;)
20:14:31 <brunowolff> It's odd that the alternate KDE spin is there, but the alternate Desktop spin isn't.
20:14:48 <cwickert> nirik: thanks a lot for your work
20:14:48 <brunowolff> I would have expected both or neither.
20:14:51 <nirik> they didn't ask me to ever compose it.
20:15:02 <nirik> that was last cycle and they dropped the idea.
20:15:36 <brunowolff> OK, maybe we'll end up dropping that KS file if we ever hear back from spin owners.
20:15:50 <nirik> yeah, I think we could... but yeah.
20:16:01 * nirik has to step away for a bit... thats all I had.
20:16:08 <brunowolff> I talked to QA about the QA Test Day spin ks file and they are using it. It should get some updates
20:16:33 <brunowolff> though. As it refers to some stuff that is gone and the desktop icons won't work with gnome3.
20:16:55 <brunowolff> It works as is, so no real hurry.
20:17:25 <cwickert> brunowolff: what is the 'alternate' desktop spin?
20:17:44 <brunowolff> KDE and Desktop each have two ks files.
20:17:56 <cwickert> targeting different size?
20:18:12 <brunowolff> As far as I know both are going to use the CD size ones for the ISOs at release.
20:18:20 <brunowolff> Yes, different sizes.
20:18:29 <cwickert> huh?
20:19:03 <brunowolff> Desktop has a 700MiB and a 1GB version of their spin.
20:19:12 <cwickert> ok, that was my question
20:19:18 <brunowolff> KDE has a 700 MiB and a 2GB version of their spin.
20:19:33 <cwickert> which ones do the want to be composed?
20:19:46 <cwickert> nirik: what was your approach to find out which spins to do?
20:19:53 <cwickert> did you just mail people?
20:20:03 <brunowolff> Desktop used 700 MiB for last release and we haven't heard anything to change that.
20:20:09 <nirik> cwickert: yeah, basically just did the ones we did before + any that people asked me to.
20:20:22 <nirik> but I can adjust to do just approved ones if you want.
20:20:25 <nirik> or whatever we decide.
20:20:40 <brunowolff> Kevin Koffler commented in email that KDE also is going to use the 700MiB for the release ISO.
20:20:52 <cwickert> nirik: ok, so people approached you. that is much better than having to ask each and every potential spin maintainer
20:21:11 <nirik> yeah
20:21:19 <brunowolff> For now we should keep doing the old ones, so breakage is easy to spot. But I think some will get
20:21:21 <brunowolff> dropped.
20:21:28 * nirik has to step away again for a bit.
20:21:44 <cwickert> ok, thanks for your report, nirik!
20:22:03 <cwickert> brunowolff: I agree we should do the old spins for now
20:22:34 <brunowolff> For example Design Suite is broken because it was not based on the Desktop spin and wasn't updated for gnome changes.
20:23:04 <cwickert> jepp
20:23:11 <cwickert> I need to poke them
20:23:23 <cwickert> lets summarize
20:24:39 <cwickert> #info nirik has been working on the nightly composes. They are now using koji instead of a homebrew script. This has many advantages such as faster creation and an archive of the last two weeks of composes
20:25:19 <cwickert> #link http://www.scrye.com/~kevin/fedora/2011-03-20-nightly-spins.html
20:26:29 <cwickert> brunowolff, nirik: so we agree to switch to niriks new compose method?
20:26:56 <brunowolff> +1
20:26:59 <cwickert> +1
20:27:18 <cwickert> #agreed the spins SIG agreed to use niriks new compose method
20:28:03 <cwickert> #agreed to compose all the old spins for now even if we haven't heared back from their owners in order to spot problems in the spins
20:28:16 <brunowolff> When the change actually happens we should advertise it on at least one list and update the Spins SIG page.
20:28:17 <cwickert> brunowolff: ok, anything more from your side?
20:28:24 <cwickert> yupp
20:28:34 <brunowolff> That's it.
20:29:09 <cwickert> #action cwickert to poke all spins maintainers once again. a lot of spins are broken ATM because of the GNOME changes and we are not sure all spin maintainers are aware of it
20:29:25 <cwickert> #topic Open Action items
20:29:44 <cwickert> we have two open action items from previous meetings
20:30:05 <cwickert> from last week we have:    rdieter and the KDE SIG to make a formal spins page for the KDE spin
20:30:48 <cwickert> and from the week before we have: cwickert to contact the desktop folks and ask them about the size they are targeting
20:31:00 <cwickert> this is what I will do together with the other mail just now
20:31:13 <cwickert> and we have a third action item which is not in the meeting minutes
20:31:49 <cwickert> it was: jsmith to ask rel-eng for info about the compose process
20:31:58 <brunowolff> Related to this the Cloud guys had a draft spin page as well, that they are reviewing.
20:32:14 <brunowolff> Don't think it was ready for us just yet.
20:32:17 <cwickert> I will do my part and poke the owners of the action items once again
20:32:23 <cwickert> you have the url?
20:32:53 <brunowolff> Just a min...
20:32:55 <cwickert> #action cwickert to poke the owners of previous action items once again
20:33:31 <brunowolff> #link http://fedoraproject.org/wiki/EC2_unspin
20:33:48 <brunowolff> I suggested not using unspin as part of the name.
20:33:53 * cwickert looks
20:34:32 <cwickert> I think they wanted to indicate it's not a spin and doesn't need to follow the guidelines
20:34:55 <cwickert> not sure about this but I do know that I dislike the name as well
20:35:15 <cwickert> ok, I think that's all for today
20:36:03 <cwickert> the 'unspin' page is way from complete, lets wait until it's finished and they come back at us
20:37:05 * cwickert will end the meeting in 3 mins
20:40:33 <cwickert> #endmeeting