#fedora-meeting-2: F20 Alpha Go/No-Go meeting #2

Meeting started by jreznik at 17:00:21 UTC (full logs).

Meeting summary

  1. Roll Call (jreznik, 17:00:45)
  2. Purpose of this meeting (jreznik, 17:03:34)
    1. Purpose of this meeting is to see whether or not F20 Alpha is ready for shipment, according to the release criteria. (jreznik, 17:04:26)
    2. This is determined in a few ways: (jreznik, 17:04:26)
    3. No remaining blocker bugs (jreznik, 17:04:28)
    4. Test matrices for Alpha are fully completed (jreznik, 17:04:29)
    5. http://qa.fedoraproject.org/blockerbugs/milestone/20/alpha/buglist (jreznik, 17:04:31)
    6. https://fedoraproject.org/wiki/Test_Results:Fedora_20_Alpha_RC4_Install (jreznik, 17:04:32)
    7. https://fedoraproject.org/wiki/Test_Results:Fedora_20_Alpha_RC4_Base (jreznik, 17:04:34)
    8. https://fedoraproject.org/wiki/Test_Results:Fedora_20_Alpha_RC4_Desktop (jreznik, 17:04:35)
    9. up for review today, we have: (tflink, 17:06:34)
    10. 3 Proposed Blockers (tflink, 17:06:37)
    11. 2 Accepted Blockers (tflink, 17:06:37)

  3. (1009278) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128) (tflink, 17:07:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1009278 (tflink, 17:07:04)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 17:07:07)
    3. there seems to be interest in doing a quick RC5 for just this fix but we want to go through the other proposed blockers to see if there are other accepted and unaddressed blockers (tflink, 17:21:57)
    4. will revisit this bug after discussing and deciding on the others (tflink, 17:22:11)

  4. (1009833) initial-setup fails to run on F20 Alpha RC4 ARM minimal image on Trimslice (tflink, 17:22:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1009833 (tflink, 17:22:31)
    2. Proposed Blocker, initial-setup, NEW (tflink, 17:22:34)
    3. AGREED: 1009833 - RejectedBlocker - While unfortunate, initial-setup appearing only on the serial console is expected behavior and thus, this bug is rejected as a blocker for F20 alpha. However, it should be documented in some combination of release notes and commonbugs (tflink, 17:27:21)

  5. (1009828) UEFI boot menu doesn't contain safe graphics mode (tflink, 17:27:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1009828 (tflink, 17:27:31)
    2. Proposed Blocker, LiveCD, NEW (tflink, 17:27:31)
    3. AGREED: 1009828 - RejectedBlocker - While unfortunate, basic video drivers have not ever worked on UEFI machines and this is not a regression in functionality. Therefore rejected as a release blocking bug for F20 alpha (tflink, 17:31:55)

  6. (1009278) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128) (tflink, 17:33:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1009278 (tflink, 17:33:56)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 17:33:58)
    3. AGREED: 1009278 - RejectedBlocker - While nasty, this only affects live images and there are acceptable workarounds (update anaconda before install, use DVD/netinstall). Therefore, it was decided that this isn't serious enough to block release of F20 alpha and is rejected as a release blocking bug. (tflink, 17:40:16)
    4. https://git.fedorahosted.org/cgit/anaconda.git/log/pyanaconda/keyboard.py (tflink, 17:42:05)

  7. Test Matrices coverage (jreznik, 17:44:42)
    1. DVD optical media coverage is concern but +3 on test@ to push that off until beta when the images are required to be properly sized (jreznik, 17:47:53)
    2. otherwise QA is ok with F20 Alpha RC4 Test Matrices coverage (jreznik, 17:49:15)

  8. Go/No-Go decision (jreznik, 17:49:54)
    1. devel is Go (jreznik, 17:52:00)
    2. QA is Go (matrices are OK and no unaddressed blockers) (jreznik, 17:52:16)
    3. AGREED: Devel and QA votes Go for Fedora 20 Alpha (RC4) as matrices are covered and there are no unaddressed blocker bugs (jreznik, 17:54:33)
    4. ACTION: nirik to send release announcement on the Fedora 20 Alpha release day (2013-09-24) (jreznik, 17:57:50)
    5. https://fedoraproject.org/wiki/Go_No_Go_Meeting?rd=Engineering_Readiness_Meetings (nirik, 17:59:28)
    6. ACTION: jreznik to announce Go decision (jreznik, 18:02:12)


Meeting ended at 18:03:11 UTC (full logs).

Action items

  1. nirik to send release announcement on the Fedora 20 Alpha release day (2013-09-24)
  2. jreznik to announce Go decision


Action items, by person

  1. jreznik
    1. jreznik to announce Go decision
  2. nirik
    1. nirik to send release announcement on the Fedora 20 Alpha release day (2013-09-24)


People present (lines said)

  1. jreznik (80)
  2. tflink (77)
  3. Viking-Ice (45)
  4. nirik (32)
  5. kparal (23)
  6. roshi (20)
  7. pwhalen (13)
  8. pschindl (11)
  9. mkrizek (6)
  10. drago01 (6)
  11. dgilmore (6)
  12. zodbot (4)
  13. satellit (1)
  14. thunderbirdtr (1)


Generated by MeetBot 0.1.4.