17:00:21 <jreznik> #startmeeting F20 Alpha Go/No-Go meeting #2
17:00:21 <zodbot> Meeting started Thu Sep 19 17:00:21 2013 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:28 <jreznik> #meetingname F20 Alpha Go/No-Go meeting #2
17:00:28 <zodbot> The meeting name has been set to 'f20_alpha_go/no-go_meeting_#2'
17:00:45 <jreznik> #topic Roll Call
17:00:59 <jreznik> hey, who's here for go/no-go fun?
17:01:04 * nirik waves
17:01:05 * tflink is here
17:01:06 <nirik> morning
17:01:17 * roshi here
17:01:33 * mkrizek is here
17:01:39 * satellit listening
17:02:00 * thunderbirdtr sit corner and listen..
17:02:08 <drago01> .
17:02:16 <jreznik> let's wait a sec...
17:03:01 * pwhalen is here
17:03:34 <jreznik> #topic Purpose of this meeting
17:03:57 * Viking-Ice is here
17:04:26 <jreznik> #info Purpose of this meeting is to see whether or not F20 Alpha is ready for shipment, according to the release criteria.
17:04:26 <jreznik> #info This is determined in a few ways:
17:04:28 <jreznik> #info No remaining blocker bugs
17:04:29 <jreznik> #info Test matrices for Alpha are fully completed
17:04:31 <jreznik> #link http://qa.fedoraproject.org/blockerbugs/milestone/20/alpha/buglist
17:04:32 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_20_Alpha_RC4_Install
17:04:34 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_20_Alpha_RC4_Base
17:04:35 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_20_Alpha_RC4_Desktop
17:05:17 <jreznik> well, let's start with blocker review
17:05:30 <jreznik> #chair tflink
17:05:30 <zodbot> Current chairs: jreznik tflink
17:05:37 <jreznik> tflink: may I ask you?
17:05:42 <tflink> sure
17:05:50 <jreznik> (usual target)
17:06:34 <tflink> #info up for review today, we have:
17:06:37 <tflink> #info 3 Proposed Blockers
17:06:37 <tflink> #info 2 Accepted Blockers
17:06:51 <tflink> starting with the proposed blockers
17:07:02 <tflink> #topic (1009278) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)
17:07:04 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1009278
17:07:07 <tflink> #info Proposed Blocker, anaconda, MODIFIED
17:07:16 <tflink> This bug is an issue with adding keyboard layouts during live install
17:07:32 <tflink> click on the '+' button in the keyboard spoke and crash
17:08:11 * kparal comes
17:08:15 * pschindl is here
17:08:41 <tflink> the biggest issue here is how easy it is to hit
17:08:58 <tflink> the crash doesn't seem to happen for DVD/netinstall
17:09:00 <roshi> my brain might have been fried last night - but I didn't see this on i686
17:09:11 * roshi re-checks
17:09:15 <tflink> roshi: livecd adding keyboard layouts?
17:09:20 <roshi> yeah
17:09:26 <Viking-Ice> I'm leaning towards +1 due to it's easy to hit
17:09:33 * kparal checks
17:10:15 * nirik reads up on it.
17:10:30 <kparal> crashes for me even with 32bit Live
17:10:49 <kparal> it's in python, so it should crash on both archs
17:11:19 <jreznik> kparal: yeah, fix is one liner just .decode("utf-8")
17:11:44 <nirik> fun.
17:11:49 <nirik> what critera does this hit?
17:12:32 <tflink> I'd put it as a conditional violation of "When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."
17:12:43 <Viking-Ice> F20 alpha release criteria for installs using a non-en-us keyboard: "The installer must run when launched normally from the release-blocking images."
17:13:04 <roshi> yep - brain was fried
17:13:11 <roshi> it just crashed :)
17:13:37 * nirik agrees it's a nasty one. Don't look forward to another week slip for a 1 line change tho. ;(
17:14:03 <Viking-Ice> such is life
17:14:20 <jreznik> well, we respun for bigger issues and were able to release
17:14:34 <jreznik> just it should not happen that such crasher is found so late...
17:14:47 <kparal> jreznik: it's a very late regression
17:14:48 <nirik> so this only affects lives?
17:14:49 <Viking-Ice> this is a regression
17:14:57 <tflink> it appears to be a regression between RC2 and RC3
17:15:36 <jreznik> kparal: it is but first rc3 live install test should show it
17:15:54 <kparal> jreznik: it was reported, just not marked as a blocker
17:16:09 <kparal> jreznik: we don't visit all dialogs for every compose
17:16:23 <jreznik> sorry, ot now
17:16:37 <drago01> can't we just do an rc5 with the fix and retest?
17:16:41 <jreznik> (and yes, dogtail, hint :)
17:16:53 <kparal> if the fix is _that_ limited, we could actually respin and transfer most results from rc4
17:16:56 <drago01> and at worst slip one day not a full week again *sigh*
17:17:00 <Viking-Ice> drago01, just like that
17:17:01 <jreznik> drago01: if we start moving now, it should be possible
17:17:14 <jreznik> so ideas? workaround, votes...
17:17:29 <kparal> jreznik: can anaconda make a build with just this single fix, nothing else?
17:17:37 <tflink> the workarounds would be to not change keyboard layout during live install
17:17:38 <Viking-Ice> well the workaround is obvious dont change the keyboard
17:17:52 <tflink> if you need to set up a keyboard, use the DVD or netinstall
17:18:02 <Viking-Ice> or just do it after install
17:18:20 <kparal> I'd rather spin up TC5 and test it very fast, then release TC4
17:18:35 <kparal> er, RC
17:18:45 <drago01> kparal: whats the point?
17:18:47 <roshi> should we hit the rest of the blockers before we start thinking about a rushed RC5? or am I missing something?
17:18:54 <drago01> kparal: why would we release rc4 then?
17:18:59 <roshi> (which is possible)
17:19:06 <kparal> drago01: sorry, then->than
17:19:18 <nirik> if it's also live, we could also just respin lives? thats kinda gross tho
17:19:24 <Viking-Ice> rc5 means retest everything if we are hitting regression between rc it might bring about other regressions
17:19:48 * nirik nods.
17:19:50 <tflink> yeah, the RCX.1 spins in the past have been less than optimal
17:20:04 <jreznik> Viking-Ice: that's why I'm checking if we can have just isolated anaconda build...
17:20:04 <drago01> Viking-Ice: unlikely if we do just the one line anaconda fix ..
17:20:06 <Viking-Ice> let's go through the rest as roshi proposes and revisited it afterwards
17:20:22 <tflink> Viking-Ice: for that one line change? normally I'd agree with you somewhat but that looks like a _very_ isolated change
17:20:27 <tflink> isolated and simple
17:20:41 <tflink> famous last words, I know
17:20:42 <Viking-Ice> we might be wasting time discussing this if we end up having to do rc5 anyway
17:20:50 <jreznik> yep
17:20:53 <roshi> yah
17:21:00 * nirik nods again
17:21:18 <jreznik> let's go quick through the rest, if not other blocker - let's talk about rc5
17:21:57 <tflink> #info there seems to be interest in doing a quick RC5 for just this fix but we want to go through the other proposed blockers to see if there are other accepted and unaddressed blockers
17:22:11 <tflink> #info will revisit this bug after discussing and deciding on the others
17:22:19 <tflink> moving on ...
17:22:28 <tflink> #topic (1009833) initial-setup fails to run on F20 Alpha RC4 ARM minimal image on Trimslice
17:22:31 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1009833
17:22:34 <tflink> #info Proposed Blocker, initial-setup, NEW
17:22:53 <pwhalen> this is the expected behavior of initial-setup-text
17:22:55 <Viking-Ice> "Release-blocking ARM disk images must boot to the initial-setup utility. "
17:23:09 <tflink> this hadn't been reported as a blocker up until now because the behavior was expected
17:23:11 <pwhalen> it runs on the serial console.
17:23:17 <tflink> and only the serial console
17:23:31 <tflink> if you boot the minimal arm image and don't have the serial console hooked up, you're out of luck
17:23:33 <nirik> sounds like a good release note?
17:23:33 <Viking-Ice> is it expected to run only on the serial console
17:23:52 <tflink> graphical initial-setup runs fine on the KDE arm image
17:23:55 <Viking-Ice> nirik, depends if this is the most common way of doing ti
17:24:02 <roshi> do we need secretary duty for this? /me will update bugs if they need it
17:24:08 <pwhalen> Viking-Ice, it is..
17:24:11 <tflink> roshi: thanks
17:24:13 <nirik> well, sounds like it is to me, yes.
17:24:23 <nirik> pwhalen: is that expected to change after alpha?
17:24:25 <Viking-Ice> pwhalen, so the most common way is to have an serial console
17:24:35 <pwhalen> nirik, its not to my knowledge
17:24:39 <nirik> ok
17:25:11 <tflink> at the least, I agree that releasenotes/commonbugs are needed here
17:25:13 <Viking-Ice> so -1 and a line in the release notes
17:25:21 <jreznik> so it seems like expected behaviour, at least for now - release notes/common bugs; -1 blocker
17:25:32 <pwhalen> -1 blocker
17:25:36 <nirik> -1 blocker
17:25:46 <tflink> adam and I would have been spinning our wheels for a while last night if I didn't always hook up the serial console to my trimslice
17:25:50 <roshi> -1
17:26:35 <kparal> -1
17:26:55 <pschindl> -1
17:26:58 <tflink> proposed #agreed 1009833 - RejectedBlocker - While unfortunate, initial-setup appearing only on the serial console is expected behavior and thus, this bug is rejected as a blocker for F20 alpha. However, it should be documented in some combination of release notes and commonbugs
17:27:01 <Viking-Ice> ack
17:27:03 <roshi> ack
17:27:03 <tflink> ack/nak/patch?
17:27:09 <pschindl> ack
17:27:13 <nirik> ack
17:27:14 <pwhalen> ack
17:27:17 <mkrizek> ack
17:27:21 <tflink> #agreed 1009833 - RejectedBlocker - While unfortunate, initial-setup appearing only on the serial console is expected behavior and thus, this bug is rejected as a blocker for F20 alpha. However, it should be documented in some combination of release notes and commonbugs
17:27:31 <tflink> #topic (1009828) UEFI boot menu doesn't contain safe graphics mode
17:27:31 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1009828
17:27:31 <tflink> #info Proposed Blocker, LiveCD, NEW
17:27:51 <jreznik> we already had this one for f19 alpha reported by kparal :)
17:28:05 <Viking-Ice> safe mode at alpha
17:28:08 <Viking-Ice> lol
17:28:10 <Viking-Ice> -1
17:28:14 <Viking-Ice> blocker
17:28:32 <jreznik> what's sad - we are not very good to push bugs like this to be fixed by next release :(
17:28:54 <kparal> that's why I intend to propose it at least for Final, if we reject it now
17:29:01 <jreznik> kparal: +1
17:29:14 <jreznik> (and make sure someone would push it)
17:29:30 <tflink> it sounds like a non-trivial fix as well
17:29:32 * nirik is -1 alpha blocker, but yeah, we should fix it.
17:29:32 <tflink> at least to me
17:29:46 <kparal> please note that even if we fix this bug, there are several more bugs related to safe grapics on uefi (jsedlak will report them soon), so this single fix solves nothing at all
17:29:59 <tflink> -1 blocker
17:30:06 <roshi> -1 blocker
17:30:08 <jreznik> -1 blocker
17:30:09 <tflink> kparal: being able to load vesa drivers explicitly?
17:30:14 <mkrizek> -1 blocker
17:30:22 <pwhalen> -1 blocker
17:30:22 <kparal> tflink: vesa doesn't work on uefi, mostly
17:30:58 <kparal> tflink: instead, the menu has to specify fbdev. or maybe something else, I don't have the expertise
17:31:30 <tflink> proposed #agreed 1009828 - RejectedBlocker - While unfortunate, basic video drivers have not ever worked on UEFI machines and this is not a regression in functionality. Therefore rejected as a release blocking bug for F20 alpha
17:31:32 <Viking-Ice> ack
17:31:35 <pschindl> ack
17:31:40 <kparal> ack
17:31:41 <mkrizek> ack
17:31:45 <jreznik> ack
17:31:51 <pwhalen> ack
17:31:55 <tflink> #agreed 1009828 - RejectedBlocker - While unfortunate, basic video drivers have not ever worked on UEFI machines and this is not a regression in functionality. Therefore rejected as a release blocking bug for F20 alpha
17:32:44 <tflink> which brings us back to ...
17:33:00 <tflink> well, we do have 2 accepted blockers but those are VERIFIED
17:33:05 <Viking-Ice> so given that we are not forced to respin for any more serious is I'm -1 to rc5 and think we should just mention it in the release
17:33:16 <tflink> does anyone want to go over them before getting back to the keyboard bug?
17:33:21 <Viking-Ice> s/is/isssue
17:33:44 * tflink takes that as a no
17:33:53 <tflink> #topic (1009278) UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)
17:33:56 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1009278
17:33:58 <tflink> #info Proposed Blocker, anaconda, MODIFIED
17:33:58 * nirik is kinda on the fence. It's a nasty bug, but I guess it is alpha...
17:34:33 <Viking-Ice> it's alpha with an easy workarounds
17:34:48 <jreznik> same here, and workaround is to use DVD in case you really want your keyboard
17:34:55 <pschindl> I don't think that we should block alpha because of this bug.
17:34:58 <nirik> yeah, but then you have to download the dvd
17:35:02 <tflink> can/did someone else confirm that the DVD/netinstall works?
17:35:06 <pschindl> or netinst
17:35:17 <Viking-Ice> nirik, or just change it afterwards
17:35:20 <kparal> tflink: netinst works, I tested it
17:35:25 <nirik> could we also do a updates.img?
17:35:41 <Viking-Ice> or not risk hitting more regressions
17:35:44 <tflink> kparal: ok, just making sure someone else had tried it :)
17:35:58 <tflink> I don't remember if we can do updates.img in a livecd
17:36:11 <nirik> or... for that matter, 'yum update anaconda' on the live media and running it should work provided we get the fixed one in updates-testing no?
17:36:19 <tflink> since this only affects lives, another workaround would be to update anaconda before attempting install
17:36:24 <nirik> yeah
17:36:28 <jreznik> yep
17:36:39 <tflink> which makes me lean more -=
17:36:40 <tflink> -1
17:36:44 <nirik> yeah, me too.
17:36:58 <pschindl> -1 from me too
17:37:01 <Viking-Ice> -1
17:37:04 <pwhalen> -1
17:37:05 <mkrizek> -1
17:37:14 <jreznik> not a nice bug, simple fix but also bcl told me we would have to accept three more fixes to get build
17:37:17 <jreznik> -1
17:37:20 <nirik> ok, -1... common bugs and workarounds.
17:37:31 <roshi> -1
17:37:35 <kparal> I still believe we should resping, but I'm overvoted
17:37:36 <pschindl> But if it means that kparal will beat us tomorrow I'm +1 :)
17:37:41 <kparal> *respin
17:37:43 <Viking-Ice> oh wait how did the cloud testing go?
17:37:45 * roshi snickers at "since this only affects lives"
17:37:55 <nirik> Viking-Ice: openstack was good/fine.
17:38:10 <nirik> I think tflink tested ami's
17:38:21 <Viking-Ice> really ?
17:38:29 <tflink> proposed #agreed 1009278 - RejectedBlocker - While nasty, this only affects live images and there are acceptable workarounds (update anaconda before install, use DVD/netinstall) this isn't serious enough to block release of F20 alpha and is rejected as a release blocking bug.
17:38:48 <pschindl> ack
17:38:59 <jreznik> kparal: there are three more fixes, one to custom spoke, one for username tui validation, not sure about third, so should be doable but with workarounds and only lives affected...
17:39:00 <tflink> Viking-Ice: yeah, I did some basic testing of the RC4 amis
17:39:10 <jreznik> ack
17:39:14 <mkrizek> ack
17:39:19 <pwhalen> ack
17:39:24 <Viking-Ice> ack
17:39:32 <roshi> ack
17:39:36 <nirik> ackey
17:39:37 <kparal> jreznik: Lives are what most people care about
17:40:16 <tflink> #agreed 1009278 - RejectedBlocker - While nasty, this only affects live images and there are acceptable workarounds (update anaconda before install, use DVD/netinstall). Therefore, it was decided that this isn't serious enough to block release of F20 alpha and is rejected as a release blocking bug.
17:40:23 * tflink made a slight change in the grammar
17:40:36 <tflink> will undo and re-propose if anyone disagrees with it
17:40:54 <jreznik> kparal: I'd be with you and I expected us to go that route but if "simple" anaconda update is enough... I care more about - how to avoid this kind of bugs appear so late (and again mention dogtail...)
17:41:13 <roshi> looks good to me tflink
17:41:21 <tflink> jreznik: we're well aware of dogtail
17:41:43 <kparal> jreznik: well let's ask then if the relevant code had to be updated between RC2 and RC3... ;)
17:42:05 <tflink> https://git.fedorahosted.org/cgit/anaconda.git/log/pyanaconda/keyboard.py
17:42:25 <jreznik> tflink, kparal: sorry, I'm just in a bit bad mood - not feeling very well, don't want to sound offensive to you :)
17:43:04 <Viking-Ice> hey let's move on we can deal with how to prevent this and yata yata on QA meeting or on list
17:43:09 <jreznik> tflink: it was
17:43:19 <jreznik> Viking-Ice: sure, sorry
17:43:23 <tflink> works for me
17:44:03 <jreznik> can I move on?
17:44:35 <jreznik> silence means yes
17:44:35 <nirik> please
17:44:42 <jreznik> #topic Test Matrices coverage
17:45:24 <jreznik> guys, are you ok with current coverage (looks solid to me)
17:46:01 <tflink> yep
17:46:16 <tflink> the only potential snag is lack of DVD optical media testing
17:46:23 <Viking-Ice> yeah I saw that
17:46:36 <tflink> but we have +3 on test@ to push that off until beta when the images are required to be properly sized
17:46:45 <Viking-Ice> true
17:47:05 <Viking-Ice> well actually arguably sizing issue should be taking care of at alpha
17:47:08 <Viking-Ice> not beta
17:47:16 <Viking-Ice> but anyway lets move on
17:47:53 <jreznik> #info DVD optical media coverage is concern but +3 on test@ to push that off until beta when the images are required to be properly sized
17:48:17 <tflink> Viking-Ice: yeah, that would be another option but I think it's too late to be moving criteria like that from beta to alpha
17:48:40 <Viking-Ice> at this point anyway
17:48:57 <tflink> other than that, the matrices look good to me
17:49:15 <jreznik> #info otherwise QA is ok with F20 Alpha RC4 Test Matrices coverage
17:49:23 <jreznik> anything else?
17:49:31 <tflink> not from me
17:49:42 <jreznik> ok, let's move on
17:49:54 <jreznik> #topic Go/No-Go decision
17:50:25 <nirik> +1 go.
17:50:31 <pschindl> +1
17:50:33 <pwhalen> +1 go
17:50:37 <Viking-Ice> +1
17:50:42 <roshi> +1
17:51:47 <tflink> matrices are OK and no unaddressed blockers. therefore, QA is GO
17:52:00 <jreznik> #info devel is Go
17:52:16 <jreznik> #info QA is Go (matrices are OK and no unaddressed blockers)
17:53:32 <jreznik> proposal #agreed Devel and QA votes Go for Fedora 20 Alpha (RC4) as matrices are covered and there are no unaddressed blocker bugs
17:53:44 <dgilmore> releng is go
17:53:46 <tflink> ack
17:53:47 <roshi> ack
17:53:50 <dgilmore> ack
17:53:51 <Viking-Ice> ack
17:53:55 <pschindl> ack
17:53:56 <pwhalen> ack
17:54:20 <jreznik> fpgm based on qa/devel/releng votes is go to (just for the record)
17:54:33 <jreznik> #agreed Devel and QA votes Go for Fedora 20 Alpha (RC4) as matrices are covered and there are no unaddressed blocker bugs
17:55:42 <jreznik> nice, thank you guys
17:55:55 * jreznik should use a bit of pirate talk but he's not pirate at all
17:56:12 <roshi> jreznik: just add "me matey" to the end of something
17:56:26 <jreznik> dgilmore, nirik: for release announcement - who would be the person to send it as dgilmore is going to be out?
17:56:34 <dgilmore> jreznik: nirik
17:56:48 <jreznik> ok
17:56:52 <nirik> I can.
17:57:06 <jreznik> thanks, better than "at" :)
17:57:24 <dgilmore> jreznik: at would work fine ;)
17:57:50 <jreznik> #action nirik to send release announcement on the Fedora 20 Alpha release day (2013-09-24)
17:58:24 <jreznik> ok, anything else? otherwise I'll set tflink's patented fuse
17:58:33 <jreznik> and thanks for coming!
17:58:38 <Viking-Ice> wait arent we like missing a bunch of teams
17:58:40 <dgilmore> damn patents
17:58:45 <Viking-Ice> like doc the ok from fpl and what not
17:59:02 <jreznik> Viking-Ice: Go/No-Go is currently defined as Devel and QA
17:59:03 * tflink makes note to send licensing invoice to jreznik for usage of the patented fuse :)
17:59:11 <dgilmore> jreznik: since when?
17:59:13 <jreznik> that's why adamw does not like if I say Go :)
17:59:17 <nirik> "Development, QA, and Release Engineering"
17:59:28 <nirik> https://fedoraproject.org/wiki/Go_No_Go_Meeting?rd=Engineering_Readiness_Meetings
17:59:30 <jreznik> dgilmore, nirik: ok, sorry for missing dgilmore
18:00:07 <Viking-Ice> hm maybe docs should be here with us
18:00:18 <jreznik> Viking-Ice: there's readiness meeting
18:00:25 <Viking-Ice> already then
18:00:32 <Viking-Ice> mean alrighty then
18:00:48 <jreznik> and for Alpha, not much docs is done at all (we just have to make sure bugs are covered on common bugs page)
18:01:16 <jreznik> time for Board meeting...
18:01:19 <jreznik> 3...
18:02:12 <jreznik> #action jreznik to announce Go decision
18:02:15 <jreznik> 2...
18:02:50 <jreznik> 1...
18:03:09 <jreznik> thanks again!
18:03:11 <jreznik> #endmeeting