17:01:01 <jreznik> #startmeeting F20 Beta Go/No-Go meeting
17:01:01 <zodbot> Meeting started Thu Oct 24 17:01:01 2013 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:13 <jreznik> #meetingname F20 Beta Go/No-Go meeting
17:01:13 <zodbot> The meeting name has been set to 'f20_beta_go/no-go_meeting'
17:01:32 <jreznik> #topic Roll Call
17:01:54 * nirik is here.
17:01:55 <jreznik> so, hi! who's with me today?
17:01:55 * satellit listening
17:02:01 <jwb> i'm here for kernel stuff if needs be.  please ping if so
17:02:09 * mclasen lurks
17:02:17 <nirik> should be a short meeting I fear.
17:02:21 * roshi is here
17:02:56 <jreznik> nirik: yeah, how I like 5 hours+ go/no-go with light in the end of the tunnel compared to this one
17:03:22 * tflink is present
17:03:45 <jreznik> btw. I have some issues with my modem but I hope it would stay stable during meeting... already had to hard reset it
17:04:04 * satellit listening but afk
17:04:16 <jreznik> ok, let's move on
17:04:29 <jreznik> #info just a reminder - Readiness meeting follows in two hours later, even we say No-Go today
17:05:02 <jreznik> #topic Purpose of this meeting
17:05:04 <jreznik> #info Purpose of this meeting is to see whether or not F20 Beta is ready for shipment, according to the release criteria.
17:05:06 <jreznik> #info This is determined in a few ways:
17:05:07 <jreznik> #info No remaining blocker bugs
17:05:08 <jreznik> #info Test matrices for Beta are fully completed
17:05:10 <jreznik> #link http://qa.fedoraproject.org/blockerbugs/milestone/20/beta/buglist
17:05:11 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_TC5_Install
17:05:13 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_TC5_Base
17:05:14 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_TC5_Desktop
17:05:30 <jreznik> as you know, we don't have RC yet
17:05:49 <jreznik> so lines above are just FYI today
17:06:14 <nirik> yeah, there's 0 way we could be go today.
17:06:25 <jreznik> but it still would be worth to check at least proposed blockers we can move on with and check test matrices coverage
17:06:30 <nirik> but perhaps we can see where we are blocked and move those things forward....
17:06:33 <nirik> yeah
17:06:55 * pwhalen is here
17:06:57 <tflink> the biggest thing is partitioning stuff, lvm thinp and btrfs
17:07:10 <tflink> but the oversize problem is still there
17:07:19 <jwb> wait, btrfs is blocking?
17:07:25 <jreznik> after a quick review, it looks like there are that two bugs tflink mentioned
17:07:39 <jreznik> jwb: that's something I'm not very ok with...
17:07:40 <tflink> jwb: anaconda's use of it is, yes
17:07:52 <tflink> jreznik: we touched on that a bit yesterday
17:07:55 <jwb> sorry, i missed this in the meeting yesterday...
17:08:12 * jreznik would prefer not to block on brtfs and in case anyone would like to use it - it would say "tech preview"
17:08:21 <jreznik> yeah, I know we touched it yesterday...
17:09:20 <jwb> this is 1022206 ?
17:09:20 <jreznik> but tflink is right - it's in Anaconda, it should work, if we are not sure about quality, it should not be visible at all (or with that banner above)
17:09:40 <tflink> yeah, if it's offered as an option - it shouldn't crash
17:09:47 <tflink> it should work, rather
17:10:10 <tflink> jwb: that's one of them, yes
17:10:52 <jwb> ok, ignore me.  i'll go read the minutes from yesterday
17:10:52 <jreznik> two unresolved 986575 and 1016959, the rest is in POST state or has a fix available in bug
17:11:56 <jreznik> tflink: do we want to have quick blocker review for that two bugs? so the question is how many people do we have here, but I'd like to move forward with that bugs earlier than later
17:12:38 <tflink> either way is fine by me if we have enough people
17:13:03 <tflink> but we're slipping anyways, so I don't think it's a big deal
17:13:29 <jreznik> tflink: but rushing that bugs early next week is also not a best what we can do
17:14:11 <tflink> true, but I don't think accepting them now will make them be fixed any faster
17:14:21 <jreznik> so from dlehman, 986575 should be POST too, so we have one anaconda bug left so far and that pungi issue... I'm going to work on that with dmach tomorrow morning
17:14:52 <jreznik> tflink: I'll let it up to you, you're the blocker bug review boss :)
17:15:38 <jreznik> for 1010495 bcl says it's not fixed and people were lucky not to hit it
17:17:26 <tflink> sure, we can go through them
17:17:41 <tflink> still not sure we have nough active people but I guess we'll find out
17:17:50 <jreznik> yep, we'll see
17:18:44 <tflink> #topic (1022810) LVMError: lvactivate failed for [pool_tdata]: running lvm lvchange -a y vg_stacked/[pool_tdata] failed
17:18:47 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1022810
17:18:49 <tflink> #info Proposed Blocker, anaconda, NEW
17:18:54 <tflink> I'm not chair, am I?
17:19:28 <jreznik> #chair tflink
17:19:28 <zodbot> Current chairs: jreznik tflink
17:19:32 <jreznik> now you are, sorry
17:19:48 <tflink> #topic (1022810) LVMError: lvactivate failed for [pool_tdata]: running lvm lvchange -a y vg_stacked/[pool_tdata] failed
17:19:51 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1022810
17:19:54 <tflink> #info Proposed Blocker, anaconda, NEW
17:21:06 <tflink> that criterion isn't correct but it appears to be a blocker
17:21:22 <nirik> so the thin pool stuff is in the ui? I didn't think it was yet...
17:21:45 <tflink> "When using the custom partitioning flow, the installer must be able to ... Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions "
17:22:13 <tflink> it's available in guided partitioning w/o raid or custom part w/ raid, IIRC
17:22:25 <tflink> I know it's available w/o raid as a guided option
17:22:38 <nirik> ok. then yeah, +1 blocker
17:22:50 <tflink> +1
17:23:00 <jreznik> nirik: it's f20 Change
17:23:19 <jreznik> but purely based on criteria, I have to +1
17:23:20 <nirik> yes, I know... I just didn't think it had been completed, but I'm likely just misremembering.
17:23:41 <tflink> i don't think it's working, but it is implemented in anaconda's UI
17:23:46 * roshi will secretary things
17:23:51 <tflink> working 100%, anyways
17:23:56 <tflink> roshi: thanks
17:24:53 <tflink> proposed #agreed 1022810 - AcceptedBlocker - Violates the following F20 beta release criterion for systems with lvm thinp on raid: "When using the custom partitioning flow, the installer must be able to ... Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 par
17:25:07 <nirik> ack
17:25:10 <roshi> +1 ack
17:25:14 <jreznik> ack
17:25:17 <nirik> well, (got cut off, but otherwise)
17:25:25 <tflink> how far did it get?
17:25:33 <jreznik> ext4 par
17:25:40 <roshi> half way through the last word
17:25:44 <tflink> yay for irc limits
17:25:53 <tflink> which ext4 par?
17:25:59 <tflink> the first one or the second one
17:26:02 <roshi> last
17:26:04 <roshi> second
17:26:31 <tflink> proposed #agreed 1022810 - AcceptedBlocker - Violates the following F20 beta release criterion for systems with lvm thinp on raid: "When using the custom partitioning flow, the installer must be able to ... Correctly interpret and modify any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"
17:26:50 <nirik> right. ack
17:27:02 <tflink> #agreed 1022810 - AcceptedBlocker - Violates the following F20 beta release criterion for systems with lvm thinp on raid: "When using the custom partitioning flow, the installer must be able to ... Correctly interpret and modify any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"
17:27:12 <tflink> #topic (1022811) Selecting one disk from multi-disk VG displays no information about the VG
17:27:15 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=1022811
17:27:18 <tflink> #info Proposed Blocker, anaconda, NEW
17:27:31 <tflink> I'm not so sure this is a blocker
17:28:00 <jreznik> same here
17:28:17 <nirik> yeah, me either.
17:28:24 <tflink> a bug, certainly but not sure it qualifies as a blocker
17:29:06 <tflink> -1
17:29:10 <nirik> I'm not sure how commonn multi pv lvm setups are really... most everyone I know avoids them because if you drop one pv you are doomed.
17:29:40 <tflink> I have one on top of raid
17:29:47 <nirik> so, yeah, weak -1 I guess. it's a bug and should be fixed, but for a beta...
17:29:49 <tflink> but also not sure how common it is :)
17:30:03 <nirik> tflink: yeah, me too. I think thats vastly more common.
17:30:24 <jreznik> -1, not sure about FE
17:30:24 <tflink> I suppose that's a single pv as far as lvm is concerned, though
17:30:30 <tflink> I'm probably -1 FE
17:30:36 <pwhalen> move to final?
17:30:50 <tflink> this gets into territory that shouldn't get touched during freeze unless it's a blocker
17:31:09 <jreznik> tflink: that was my "not sure", so -1/-1
17:31:39 <jreznik> pwhalen: could be reproposed for final, I'd not move it automatically now
17:31:39 <tflink> yeah, I just wasn't going to vote -1 FE unless someone proposed it :)
17:31:46 <pwhalen> -1 , but think it should get fixed for final
17:31:48 <tflink> I'm not even sure this qualifies as a final blocker
17:32:06 <tflink> I suspect this isn't a new bug
17:32:34 <tflink> which doesn't mean that it shouldn't get fixed, just that it's been around for a while and doesn't seem to have caused any horrible problems
17:32:41 <tflink> other thoughts?
17:33:22 <jreznik> seems like not, clear -1/-1
17:33:41 <jreznik> and I'd avoid moving it to final now, seems like we have agreement on that too
17:35:10 <tflink> proposed #agreed 1022811 - RejectedBlocker RejectedFreezeException - While unfortunate, this bug was judged as not to violate any of the F20 beta release criteria. As any fix is in a sensitive area of the code base, fixes would not be considered past freeze unless they are blocking release.
17:35:15 <tflink> ack/nak/patch?
17:35:33 <jreznik> ack
17:35:34 <pwhalen> ack
17:35:51 <nirik> ack
17:35:57 <tflink> #agreed 1022811 - RejectedBlocker RejectedFreezeException - While unfortunate, this bug was judged as not to violate any of the F20 beta release criteria. As any fix is in a sensitive area of the code base, fixes would not be considered past freeze unless they are blocking release.
17:36:05 <tflink> OK, that's all of the proposed blockers on the list
17:36:21 <jreznik> thanks tflink
17:36:28 <tflink> did we want to go through the non-verified accepted blockers?
17:36:41 <tflink> but I think they were all covered yesterday in the review meeting
17:37:13 <jreznik> there's some progress I tried to sum up in the beginning
17:37:36 <jreznik> according to dlehman, 986575 should be in POST now
17:38:16 <jreznik> but that's probably all we have now
17:38:49 <pwhalen> in devel jwb mentioned he didnt see the kernel FE on the list to be pulled in, did I miss something?
17:39:11 <tflink> list to be pulled in?
17:39:31 <pwhalen> not sure what he was referring to, just saw the msg
17:39:35 <pwhalen> jwb?
17:40:23 <tflink> assuming you're talking about 1022604, that's a FE, not a blocker
17:41:49 <pwhalen> right, okay. just wanted to check on it, as in the past we've had some fe's not get pulled in
17:42:17 <jreznik> ok, tflink is there anything in test matrices you'd like to point out we should focus on?
17:42:24 <tflink> I assume that it wouldn't get pulled in til' after the next TC/RC
17:42:36 <pwhalen> sure, wasnt sure if i missed something.
17:42:57 <pwhalen> all based on the comment in channel, carry on, sorry to derail
17:43:08 <tflink> nothing huge outside of the blockers
17:43:25 <tflink> but we've not been able to test optical media for the DVD yet due to the oversize bug
17:44:09 <jreznik> tflink: I'm going to kick dmach to take a look on that pungi bug tomorrow morning, he promised me to take a look (he's the author of the code)
17:44:38 <jreznik> #info nothing huge missing in test matrices, optical media tests blocked by DVD oversize bug
17:44:45 <jreznik> ok, thank, anything else from QA?
17:44:52 <jreznik> if not, I'll move on
17:45:39 <jreznik> ok
17:45:41 <jreznik> #topic Go/No-Go decision
17:45:44 <tflink> nothing else, no
17:46:05 <jreznik> well, it's pretty obvious - No-Go
17:46:14 <tflink> QA is no-go
17:46:56 * nirik nods sadly.
17:46:59 <jreznik> #info QA is No-Go
17:47:18 <jreznik> I get it as No-Go too
17:47:26 <jreznik> #info devel is No-Go
17:48:38 <jreznik> proposal #agreed Fedora 20 Beta is No-Go by QA, devel and FPGM due to unresolved blocker bugs; Fedora 20 Beta to slip by one week
17:48:45 <tflink> ack
17:48:46 <nirik> ack
17:48:49 <pwhalen> ack
17:48:51 <roshi> ack
17:49:11 <jreznik> #agreed Fedora 20 Beta is No-Go by QA, devel and FPGM due to unresolved blocker bugs; Fedora 20 Beta to slip by one week
17:49:29 * jreznik is going to announce it and adjust schedules
17:49:44 <jreznik> #action jreznik to announce slip and adjust schedule
17:51:04 <jreznik> otherwise we will track blocker bugs
17:51:05 <jreznik> there're quite a lot of POST Anaconda bugs, so let's hope it will be built soon for another TC or RC in case of we will be lucky
17:51:22 <jreznik> anything else to mention?
17:52:32 <jreznik> if no, thanks for coming, even it was a bit sad meeting today
17:52:41 <jreznik> setting fuse to 3...
17:54:18 <jreznik> 2...
17:55:27 <jreznik> 1...
17:55:30 <jreznik> #endmeeting