15:00:38 <pwhalen> #startmeeting Fedora ARM & AArch64 Status Meeting
15:00:38 <zodbot> Meeting started Tue Jan 13 15:00:38 2015 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:38 <pwhalen> #chair pwhalen jonmasters bconoboy pbrobinson dgilmore dmarlin hrw jsmith kyle ahs3 bemk
15:00:38 <zodbot> Current chairs: ahs3 bconoboy bemk dgilmore dmarlin hrw jonmasters jsmith kyle pbrobinson pwhalen
15:00:48 <pwhalen> .fas pwhalen
15:00:49 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
15:01:00 <pwhalen> good day folks
15:01:12 <hrw> .fas juszkiewicz
15:01:13 <zodbot> hrw: hrw 'Marcin Juszkiewicz' <mjuszkiewicz@redhat.com>
15:01:43 * pbrobinson is here
15:01:50 <bemk> Hi
15:01:55 <yselkowitz> .hellomynameis yselkowitz
15:01:56 <zodbot> yselkowitz: yselkowitz 'Yaakov Selkowitz' <yselkowi@redhat.com>
15:02:24 <bconoboy> .fac blc@
15:02:32 <bconoboy> .fas blc@
15:02:33 <zodbot> bconoboy: blc '' <blc@redhat.com>
15:03:03 <pwhalen> thanks for coming
15:03:19 <pwhalen> #topic 1) ==== Kernel Status ====
15:03:37 <pbrobinson> so 3.18.x should be headed to F-21 shortly
15:04:01 <hrw> pbrobinson: both arm and aarch64 will get it?
15:04:02 <pbrobinson> so if people could test and report any issues, probably to IRC or the mailing list that would be fab
15:04:21 <pbrobinson> hrw: as per everything in mainline it will land in aarch64 too
15:04:22 <pwhalen> #info 3.18.x should be headed to F-21 shortly
15:04:26 <hrw> cool
15:04:35 <pbrobinson> hrw: not sure why you even need to ask that ;-)
15:04:54 <pwhalen> 3.18 has looked good in my testing, as has 3.19
15:05:11 <pwhalen> #link https://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/Kernel_Testing/Fedora_22#kernel-3.19.0-0.rc3.git2.1.fc22
15:05:12 <hrw> pbrobinson: I hope for f21 installer image refresh after 3.18
15:05:15 <pbrobinson> I believe omap4 might have some issues but I've not tested GA 3.18 kernels
15:05:29 <pbrobinson> hrw: nope, that's not going to happen, never does
15:05:40 <pbrobinson> hrw: please keep on topic
15:05:43 <hrw> pbrobinson: sure
15:06:14 <pbrobinson> so 3.19rc4 is in rawhide now so please test that as well. aarch64 in rawhide is generally trailing but more on that later
15:06:24 <pwhalen> the jetson tk1 has working network with 3.18.1-2
15:06:31 <pbrobinson> nice!
15:06:54 <pwhalen> i'll check out display
15:07:24 <pbrobinson> I don't think that's quite there yet
15:07:33 <pbrobinson> maybe with wayland
15:07:37 <pwhalen> for those interested in testing aarch64 kernels, i usually do a scratch build on arm.koji, so if you search my builds you should see the latest
15:07:51 <pwhalen> prior to the official builds
15:08:25 <pwhalen> anything else for kernels?
15:08:41 <pwhalen> #topic 2) ==== Rawhide Testing Status ====
15:08:44 <pbrobinson> nope.... just test test test.... report report report :-)
15:09:01 <pwhalen> did anyone have a chance to look at rawhide?
15:09:08 <pbrobinson> personally I've done not much here as I've been on PTO for 3 weeks
15:09:12 <hrw> I use rawhide daily on mustang
15:09:34 <pwhalen> excellent, have you encountered any problems, new bugs?
15:09:53 <pbrobinson> well "rawhide" on aarch64 is quite old now
15:10:05 <hrw> pwhalen: the problem is that no new issues arrived
15:10:50 <pwhalen> i did some installation testing, on armhfp, aarch64. only issue i encountered was the server repo defaulting to 'cloud server ' package selection. choosing fedora server worked ok. but that was all
15:10:57 * ctyler sneaks in side door, takes a seat at the back of the room
15:11:38 <pwhalen> #info Please test Rawhide on both armhfp and aarch64, report issues to the list or IRC
15:12:23 <pwhalen> #info Fedora 22 Rawhide 20150110 nightly compose nominated for testing
15:12:56 <pwhalen> #info add test results to the wiki - https://fedoraproject.org/wiki/Test_Results:Fedora_22_Rawhide_20150110_Summary
15:13:12 <pwhalen> #topic 3) ==== Problem Packages (AArch64/Armhfp) ====
15:13:27 <hrw> Python 2.7 on aarch64
15:13:58 <pwhalen> #info Python 2.7 continues to be a blocker on aarch64
15:14:01 <pbrobinson> that, at the moment is basically is as python is now blocking all builds
15:14:15 <yselkowitz> what is the issue?
15:14:20 <pbrobinson> basically all that appears in the compse at the moment is noarch imports
15:14:25 <pwhalen> i saw you guys chatting.. any update on it ?
15:14:38 <pbrobinson> issue is failing tests
15:15:02 <pbrobinson> #info python RHBZ with details is 1174037
15:15:09 <pwhalen> thanks
15:15:47 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=1174037
15:17:26 <pwhalen> whats the plan here, you guys mentioned kyle?
15:18:31 <pbrobinson> well I was kind of hoping the python devs would have pulled their finger out by now and closed it out. bconoboy: thoughts?
15:19:02 <hrw> for me it looks like issue is somewhere deeper in python 'ctypes' module code
15:19:11 <yselkowitz> or in libffi
15:19:22 <hrw> C code itself works when extracted to separate file
15:19:24 <bconoboy> last I saw the gdb team was helping the guys looking at the issue
15:19:31 <bconoboy> but that was thursday.  it could use somebody's help.
15:21:16 <hrw> python test calls C version of code by 'ctypes' module. called function has 8 arguments and fails. one argument less and it works
15:22:37 <hrw> those 8 arguments are created from 3 variables: counter int, rect (direct and by pointer) and point (given twice directly)
15:22:49 <hrw> second point (which is 7 argument) is broken
15:23:36 <pbrobinson> I wonder why this doesn't happen on x86? or is it different code path, or using different code paths in libraries on x86?
15:24:04 <hrw> should be same code
15:24:13 <hrw> but issue may be in libffi
15:24:22 <bconoboy> I've pinged anthony green (libffi maintainer) asking him to have a look
15:24:46 <pbrobinson> OK, bconoboy can you keep me in the loop on responses etc
15:24:46 <pwhalen> #info Python issue may be with libffi
15:25:41 * pbrobinson doesn't like "may be" ..... I like definitely is or is not :-)
15:25:55 <bconoboy> pbrobinson: sure
15:25:55 <pwhalen> #info libeffi maintainer (Anthony Green) pinged to take a look
15:26:10 <pwhalen> #action bconoboy to update pbrobinson
15:26:13 <pwhalen> :)
15:26:19 <pwhalen> any armhfp issues?
15:26:56 <pwhalen> alright, next?
15:27:45 <pwhalen> #topic 4) ==== AArch64 Build Host Maintenance ====
15:27:45 <pwhalen> #info == arm.koji will temporarily be at half capacity for firmware upgrade on 2014-01-14 (tomorrow) ==
15:28:02 <pwhalen> more an info item, but does that work for everyone?
15:28:11 <hrw> pwhalen: fine for me
15:29:00 <pwhalen> once the first group is updated, confirmed, i'll bring down the second group for update
15:29:10 <pbrobinson> fine by me
15:29:25 <pwhalen> #topic 4) == Open Floor ==
15:29:36 <pbrobinson> I need to start looking at the phx hosts too so I'll ping you about process etc at some point soon
15:29:51 <pwhalen> pbrobinson, sounds good
15:30:14 <pbrobinson> I had an item in my mind for this...... and have since forgot it :-/
15:30:52 <pwhalen> its late for you :)
15:31:35 <pwhalen> ....last call
15:33:22 <pwhalen> #endmeeting