#fedora-meeting-2: Env and Stacks (2015-02-12)

Meeting started by hhorak at 13:08:40 UTC (full logs).

Meeting summary

  1. Env&Stacks Governance Charter Review as per https://fedoraproject.org/wiki/Env_and_Stacks/Governance_Charter#Changing_These_Rules (hhorak, 13:10:10)
    1. https://fedoraproject.org/wiki/Env_and_Stacks/Governance_Charter#Changing_These_Rules (hhorak, 13:10:15)
    2. AGREED: (phracek, 13:12:15)
    3. ACTION: all to read Governance charter and if there are any issues that should be revisited, let's bring them on ML or add them to agenda for some of the next weeks (hhorak, 13:12:29)

  2. Follow-ups -- what has changed since last meeting (hhorak, 13:12:55)
    1. update about devpi - upstream wanted us to create a formal proposal for the feature we need. I passed the work on to Matej Stuchlik and we now have the proposal for upstream https://groups.google.com/forum/#!topic/devpi-dev/py-B9kwaK5Y and are waiting for comments (hhorak, 13:13:32)
    2. the devpi feature seems to be the only blocker. once it's done, we can go on and deploy devpi testing instance (hhorak, 13:16:17)
    3. https://fedoraproject.org/wiki/Env_and_Stacks/Projects/LanguageSpecificRepositories (hhorak, 13:16:25)
    4. http://pulp-python.readthedocs.org/en/latest/ (ncoghlan, 13:16:47)
    5. the plan is the package would get into fedora, then its upstream would be mirrored, at least for the time being (hhorak, 13:22:38)
    6. longer term, the upstream packaging may be mirrored first and a potentially non-policy compliant RPM got into COPR (hhorak, 13:22:38)
    7. PEP 426 should allow autopackage stuff from devpi instance to rpm (hhorak, 13:26:16)
    8. https://www.python.org/dev/peps/pep-0426/ (hhorak, 13:26:16)
    9. https://github.com/pypa/interoperability-peps if you spot any major issues (ncoghlan, 13:31:31)
    10. https://people.gnome.org/~walters/docs/build-api.txt (hhorak, 13:34:16)
    11. it would be nice to have a tool independent "How do we build this?" description format (ncoghlan, 13:34:33)
    12. https://github.com/jpakkane/meson/wiki/IDE-integration (ncoghlan, 13:34:41)

  3. DevConf legacy -- something interesting from DevConf we should mention here? (hhorak, 13:40:37)
    1. it makes things simple and more clear to have scls in current dist-git in special branches.. it will be easier to implement in rcm and pkgdb. (hhorak, 14:00:26)
    2. First, we need to have the guidelines if this way is fine, some agreement for branches naming, etc.. (hhorak, 14:00:26)

  4. Open Floor (hhorak, 14:04:48)


Meeting ended at 14:15:08 UTC (full logs).

Action items

  1. all to read Governance charter and if there are any issues that should be revisited, let's bring them on ML or add them to agenda for some of the next weeks


People present (lines said)

  1. ncoghlan (53)
  2. hhorak (37)
  3. walters (27)
  4. bkabrda (18)
  5. phracek (9)
  6. vpavlin (4)
  7. zodbot (4)
  8. ttomecek (2)
  9. langdon (1)
  10. sicampbell (0)
  11. juhp (0)


Generated by MeetBot 0.1.4.