17:05:02 <geppetto> #startmeeting fpc
17:05:02 <zodbot> Meeting started Thu Feb 12 17:05:02 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:05:08 <geppetto> #meetingname fpc
17:05:08 <zodbot> The meeting name has been set to 'fpc'
17:05:21 <geppetto> #topic Roll Call
17:05:22 <geppetto> #chair tibbs|w
17:05:22 <zodbot> Current chairs: geppetto tibbs|w
17:05:31 <geppetto> #chair orionp
17:05:31 <zodbot> Current chairs: geppetto orionp tibbs|w
17:05:36 <geppetto> #chair Rathann
17:05:36 <zodbot> Current chairs: Rathann geppetto orionp tibbs|w
17:05:40 <geppetto> #chair mbooth
17:05:40 <zodbot> Current chairs: Rathann geppetto mbooth orionp tibbs|w
17:06:31 <geppetto> #chair tomspur
17:06:31 <zodbot> Current chairs: Rathann geppetto mbooth orionp tibbs|w tomspur
17:07:14 <geppetto> #topic #126 	bundling exception for scintilla
17:07:18 <geppetto> https://fedorahosted.org/fpc/ticket/126
17:07:53 <geppetto> #chair racor
17:07:53 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor tibbs|w tomspur
17:08:42 <tibbs|w> So, this one is old.
17:08:46 <geppetto> indeed
17:08:53 <tibbs|w> It's kind of annoying, too.
17:09:32 <tibbs|w> A whole lot of things bundle scintilla.  I don't know what security impact it has.
17:09:54 <tibbs|w> This one may fall under the "too big to do anything about" rule, but I don't know.
17:11:26 <tibbs|w> scintilla is rather a lot of code, too.
17:11:46 <tibbs|w> But the packages may not be bundling all of it.
17:11:55 * tomspur wonders what changes all packages need to do each time
17:12:43 <tibbs|w> So, in all that time we never really got a handle on what's being modified, and whether everything that's bundling it actually modifies it.
17:13:01 <mbooth> Some packages seem to require qscintilla without bundling it...
17:13:17 <tibbs|w> But is qscintilla even the same thing as scintilla?
17:13:36 <orionp> QScintilla is a port to Qt of Neil Hodgson's Scintilla C++ editor control.
17:13:41 <tibbs|w> It could be that scintilla bundles scintilla, and then things pull in scintilla.
17:13:54 <tibbs|w> Or whatever I intended to say but didn't type sensibly.
17:14:39 <tibbs|w> This all needs a rather complete analysis, and nobody seems to want to do that in the ticket.
17:15:05 <Rathann> well granting an exception is an easy way out, but being the FPC, we shouldn't do that
17:15:27 <tibbs|w> Proposal: try to find what's bundling scintilla, and try to do a rundown of what would need an exception.
17:15:41 <geppetto> you are volunteering?
17:15:46 <tibbs|w> I don't think a blanket exception is warranted at this point.  It's not supposed to be a copylib in any case.
17:15:54 <tibbs|w> I can try to find some things; there's a list in the package.
17:16:08 <Rathann> I'd be +1 to a temporary exception while someone works on the analysis, however
17:16:10 <tibbs|w> But mainly it will just be pinging package maintainers for info.
17:16:25 <tibbs|w> Rathann: I don't see the point.  The stuff is in there already.
17:16:27 <Rathann> sadly, I can't devote too much time to this for the next couple of weeks
17:16:38 <tibbs|w> geppetto: Yes, I'll volunteer to do what I can, but I doubt I could find everything.
17:16:58 * geppetto nods
17:17:05 <tibbs|w> Don't really relish doing a full checkout, prep and grep of the entire package set.
17:17:30 <tibbs|w> Not sure how else you'd find an exhaustive list of what's bundling it, though.
17:18:17 <tibbs|w> Anyway, I can try to do some analysis from the list given in comment 14.
17:18:44 <tibbs|w> I suspect lots of things are bundling an old version, which means we kind of get more evidence of why bundling is bad.
17:18:49 <Rathann> tibbs|w: I wish we had something like https://codesearch.debian.net/
17:18:56 <tibbs|w> One day, maybe.
17:19:01 <tibbs|w> Anyway, action that and move on?
17:19:08 <orionp> Is it even worth pursuing?
17:19:19 <tibbs|w> orionp: What's "it"?
17:19:23 <orionp> http://mmaslano.fedorapeople.org/review/perl-Wx-Scintilla.spec -> 404
17:19:26 <geppetto> #action tibbs try to find what's bundling scintilla, and try to do a rundown of what would need an exception.
17:19:49 <racor> orionp: in CPAN Wx::Scintilla looks dead
17:19:54 <geppetto> #topic #202 	Application for exemption from "No bundling" rule: Gargoyle
17:19:59 <geppetto> https://fedorahosted.org/fpc/ticket/202
17:20:55 <geppetto> tibbs|w: You seem to think this is too small to care about?
17:21:00 <tibbs|w> This was an old one, would probably be accepted under our "too insignificant to care" rule, but I think the package submitter gave up.
17:21:12 <tibbs|w> Not really small, just kind of pointless.
17:21:19 <tibbs|w> To recap,
17:21:29 <tibbs|w> It's a program that plays various kinds of text adventures.
17:21:45 * geppetto nods
17:21:50 <tibbs|w> It bundles some of the interpreters and modifies them to work within its framework.
17:22:04 <tibbs|w> Which is basically just shoving them into the main window.
17:22:13 <tibbs|w> Most of the things bundled are dead upstream.
17:22:29 <tibbs|w> And a lot of work went into unbundling some of the stuff, I think.  It's been a long time.
17:23:18 <tibbs|w> But I can see just closing this since it doesn't really matter.  I actually wanted to use it but I can build it myself.  I guess I could reopen if I or limb wanted to submit it in the future.  (He does a lot of game stuff.)
17:23:46 <tibbs|w> Don't really want to waste meeting time on it, though.
17:24:04 <geppetto> yeh, I mean I can see the desire to just accept it as is
17:24:19 <geppetto> but, I don't think I'd normally want to pass it given the size etc.
17:24:21 * geppetto shrugs
17:24:37 <geppetto> Anyone else have an opinion?
17:25:03 <tomspur> What is the "too insignificant to care" rule? Could it be written down somewhere? ;)
17:25:16 <tibbs|w> I don't know if we ever actually wrote those down.
17:25:21 <tibbs|w> If not, it would suck.
17:25:29 <mbooth> Carlo has not responded since before the FPC last discussed this in 2012?
17:25:39 <mbooth> Either in trac or bugzilla
17:25:52 <tibbs|w> Yeah, let's just move on with it and if I feel like taking it over I'll start afresh.
17:26:45 <geppetto> #action Still no, close and reopen if someone wants to start afresh
17:26:55 <geppetto> #topic #221 	Bundling exception request: numptyphysics and Box2D
17:26:59 <geppetto> https://fedorahosted.org/fpc/ticket/221
17:27:26 <tibbs|w> Postpone until we can get limb here?
17:27:35 <tibbs|w> I don't recall where he's gone lately.
17:27:36 <geppetto> That's fine.
17:28:09 <geppetto> #action postpone until limburgher is at the meeting.
17:28:19 <geppetto> #topic #235 	exception for bundling a library into uif2iso package
17:28:23 <geppetto> https://fedorahosted.org/fpc/ticket/235
17:28:52 <tibbs|w> This is another ancient one.  Last comment two years ago.
17:28:56 <tibbs|w> We really kind of fell down.
17:29:47 <tibbs|w> Oops.
17:30:09 <mbooth> I agree we should find out if this is still relevant -- bundling encryption makes me nervous
17:30:42 <geppetto> yeh, but I'm confused … does he just want to bundle a single gost.c file from an ancient version of libmcrypt?
17:30:45 <tibbs|w> I can bump back to needinfo.  ufs2iso doesn't seem to be in the distribution.
17:31:18 <tomspur> the review request is still ongoing. Last comment a year ago
17:31:30 <tomspur> oh two years ago...
17:31:38 <tibbs|w> I can close the review request if we close the ticket.
17:31:54 <geppetto> That is probably the easiest
17:31:59 <tibbs|w> Yep.
17:32:21 <tomspur> Upstream also seems quite dead if they "don't want to modify it as it suits their needs"...
17:32:26 <geppetto> #action Just close this out, open a new ticket if someone wants to start afresh
17:32:26 <tibbs|w> Yeah.
17:32:45 <geppetto> #topic #338 	%doc and %_pkgdocdir duplicate files and cause conflicts
17:32:49 <geppetto> https://fedorahosted.org/fpc/ticket/338
17:32:57 <tibbs|w> Something more meaty....
17:33:16 <tibbs|w> Unfortunately I don't really know what to do here.
17:34:18 <tibbs|w> Hmm, looks like I was supposed to do something there.  Crap.
17:34:31 <tibbs|w> I just read the meeting notes from three weeks ago.
17:35:07 <tibbs|w> I'll do what I promised to do (restate the proposal) and we can see if anyone cares enough to vote.
17:35:20 <geppetto> ok
17:35:32 <tibbs|w> geppetto and tibbs just voted +1 to the last proposal in there in that meeting but nobody else had any opinion.
17:35:56 <geppetto> Does anyone else want to vote now?
17:36:12 <geppetto> mbooth: racor: Rathann: ?
17:36:16 <geppetto> tomspur: ?
17:36:25 <tibbs|w> I think it needs a proper draft.  There's a lot to read in that ticket.
17:36:55 <tomspur> yeah, a draft would be helpful
17:37:05 <geppetto> The proposal was fairly simple .... " "Packages must not use both relative %doc in the %files section and manual installation of documentation files into %{_docdir} in a single spec file""
17:37:38 <geppetto> I can put you do to do an official policy change though, if you want tibbs|w?
17:37:50 <tibbs|w> Also interesting is that we have no Fedora release with unversioned docdirs these days.
17:38:02 <geppetto> indeed
17:38:05 <tibbs|w> Sure, action that I'll do a draft.
17:38:09 <mbooth> geppetto: Aha, I could not find the "proposal"in the ticket
17:38:31 <tibbs|w> Yeah, there's a lot of stuff there.  Which is why I promised to restate it at the bottom, and then failed.
17:38:36 <geppetto> #action tibbs Restate the proposal as a policy change, so we can vote on it
17:38:56 <geppetto> #topic #346 	Bundling exception request for Eclipse Sisu
17:39:02 <geppetto> https://fedorahosted.org/fpc/ticket/346
17:39:26 <tibbs|w> I thought we had a solution that didn't involve FPC at all, but there was no response.
17:39:39 <tibbs|w> Well, no response to my last comment.
17:39:50 <geppetto> given comment #9 … this seems trivial … they should just fix it
17:40:20 <mbooth> I am familir with ASM package -- I could propose a patch
17:40:28 <geppetto> cool
17:40:34 <tibbs|w> I think the patch is already in the sisu package.
17:40:59 <tibbs|w> This is just moving it to a better place, the asm package, so everything automatically works whenever asm is updated and there's no actual bundling at all.
17:41:27 <tibbs|w> I'd suggest we close the ticket since there's a sensible non-bundling solution, and then they can reopen if it doesn't work.
17:41:38 <mbooth> Sure -- I am happy to fix asm so mikolaj can unbundle from sisu
17:41:59 <tibbs|w> Awesome.
17:42:00 <geppetto> #action No bundling, do the automatic re-namespacing in sub-package fix.
17:42:11 <geppetto> #topic #381 	Bundling exception for python-matplotlib fonts
17:42:17 <geppetto> https://fedorahosted.org/fpc/ticket/381
17:43:04 <tibbs|w> I don't know what's left to do.
17:43:24 <geppetto> yeh, I wasn't sure if I should just delete it
17:43:41 <geppetto> but given the last comment asking for comments
17:43:49 <geppetto> I thought we might as well take a look
17:43:51 <tibbs|w> We already granted an exemption, I think, though now re-reading I can't see where.
17:44:38 <tibbs|w> Not sure if comment 2 was what we voted on, or what we were going to vote on.
17:44:44 <geppetto> comment #2 I guess
17:45:10 <tibbs|w> But if the former, I don't think the fonts ever got pushed into the subpackage as requested.
17:45:23 <geppetto> I think we voted on it
17:45:40 <tibbs|w> There's no python-matplotlib-whatever-fonts package in F21, at least.
17:45:40 <geppetto> isn't that what the last comment is about?
17:46:00 <tibbs|w> Oh, durr, I'm wrong.
17:46:24 <tibbs|w> He did what we asked, and I don't really see any further issue.
17:46:42 <geppetto> yeh, ok … worth the 5 minutes to double check :)
17:47:01 <geppetto> #action Everything going as planned, excellent. Can close.
17:47:11 <geppetto> #topic #399 	request for bundled library exception - clustal omega
17:47:16 <geppetto> https://fedorahosted.org/fpc/ticket/399
17:48:06 <tibbs|w> Still no movement; we're at +4, though some of those plusses are from people not on the committee so there's a fun issue there.
17:48:17 <tibbs|w> "not currently on the committe"
17:48:28 * geppetto nods
17:48:41 <geppetto> "I contacted the upstream author - my understanding is that they are not interested in getting any "outside" code changes. "
17:48:44 <geppetto> Always a good lol
17:48:50 <tibbs|w> It's a copylib, I guess.
17:49:06 <geppetto> Yeh, I guess I'm still +1
17:49:10 <tibbs|w> I mean, he dumped some code out there, but doesn't want the overhead of "developing" it.  I can sort of understand that.
17:49:25 <geppetto> mbooth: racor: Rathann: tomspur: vote ?
17:49:28 <tibbs|w> I'm +1 as well as stated in the ticket.  Hoped other folks would just vote there, but nothing has happened.
17:49:58 <geppetto> Rathann: was -1
17:50:02 <geppetto> so I guess he still is
17:50:12 <tomspur> Rathann mentionedthat the bundled code is just sloppy coding...
17:50:15 <Rathann> yes, sorry, got a little crisis around here
17:50:21 <geppetto> no problem
17:50:37 <Rathann> I'm -1
17:50:44 <tibbs|w> Alternative is to just fork the damn library and package it properly.
17:50:51 <tibbs|w> I doubt anything else uses it.
17:50:54 <tomspur> So asking upstream for upstreaming the code first, would be nice
17:51:19 <Rathann> well, squid upstream is apparently not accepting patches
17:51:31 <mbooth> I agree with Rathann's assessment in the ticket, but I am not super against bundling
17:51:36 <tibbs|w> tomspur: They did.
17:51:42 <tibbs|w> Upstream doesn't care.
17:51:51 <Rathann> hm
17:51:51 <mbooth> +0, I guess
17:52:01 <Rathann> is anything else in Fedora bundling?
17:52:02 <tomspur> hmm... +1 then also... :/
17:52:04 <geppetto> where doesn't care == doesn't care to accept patches
17:52:21 <Rathann> *bundling this squid code
17:52:34 <geppetto> so atm. we are at (+1:3, 0:1, -1:1)
17:52:37 <tibbs|w> Rathann: I don't know an easy way to find that in any case.
17:53:14 <Rathann> ah wait
17:53:14 <tibbs|w> Would everyone be happy if they forked squid and packaged it separately?
17:53:31 <Rathann> it was said that clustal is the only consumer in Fedora atm
17:53:34 <tibbs|w> Of course, it would need a different name, because squid is kind of already taken.
17:53:55 <Rathann> so I'll change my vote to +1, if only because there's no
17:54:20 <Rathann> real benefit in unbundling in this case
17:54:23 <tibbs|w> And back to +4, I guess.
17:54:41 <Rathann> this raises the bar for the next squid bundler I suppose
17:55:05 <racor> sorry folks, I was distracted on the phone and now am trying to catch up, but you're too fast ...
17:55:22 <tomspur> How about a -squid subpackage and it should be fine/"too insignificant to care"? ;)
17:55:31 <tibbs|w> Mad typor skillz.
17:55:35 <geppetto> mbooth: You want to change to +1 now that Rathann has ?
17:55:46 <Rathann> tomspur: it's modified so not really upstream compatible
17:55:48 <Rathann> no point
17:56:19 <Rathann> as I said, it could've been made upstream API-compatible (maybe even ABI-) with a bit of effort
17:56:23 <mbooth> geppetto: It still passes whether I do or not :-)
17:56:31 <geppetto> :)
17:56:51 <Rathann> it needs +5, and we're at +4
17:56:59 <geppetto> Aren't we are +1:4 now?
17:57:00 <Rathann> or am I counting wrong?
17:57:01 * geppetto nods
17:57:35 <geppetto> I get geppetto tibbs Rathann tomspur as +1
17:57:43 <mbooth> Oh we need unanimous +1's?
17:57:50 <geppetto> no … we need +5
17:58:24 <tibbs|w> Even if people aren't here, we still need more than half of the committee.
17:58:35 <Rathann> mbooth: there are 9 FPC members in total, so 5 of 9 is the majority
17:58:58 <mbooth> Rathann: I thought so, I guess there's only 5 of us here today
17:59:10 <racor> My vote on squid: 0
18:00:16 <tibbs|w> Not going to pass today, I guess.  Back to the voting state?
18:00:42 <mbooth> Well I guess I can +1 this
18:01:07 <mbooth> I wanted to show my ambivilence
18:01:15 <tibbs|w> I know the feeling.
18:01:26 <racor> my vote on #381 (python-mathplotlib-fonts): -1
18:01:36 * geppetto nods
18:02:06 <geppetto> #action request for bundled library exception - clustal omega (+1:5, 0:1, -1:0)
18:02:10 <tibbs|w> racor: Thing is, we approved that ages ago.  It just never got closed out,
18:02:25 <geppetto> #topic #401 	(reverse) bundling exception for stream-lib
18:02:30 <tibbs|w> If another squid consumer comes up, though, someone needs to fork it properly.
18:02:30 <geppetto> https://fedorahosted.org/fpc/ticket/401
18:02:55 <geppetto> this is another that got some votes, but not enough
18:03:24 <tibbs|w> I think it's at +3 currently, excluding Toshio who is no longer on the committee.
18:03:45 <tibbs|w> I can't remember the details of this in any case, but I doubt anything happened to change my mind.
18:04:19 <geppetto> yeh, I'll let Rathann, tomspur, mbooth, racor have a look
18:05:13 <Rathann> +1 I guess, but what happens when someone wants to package Cassandra
18:05:54 <geppetto> I'm not sure it's a problem
18:06:12 <geppetto> they took an API that's part of cassandra, and changed the API to make it easier to use
18:06:17 * geppetto shrugs
18:06:36 <mbooth> It's been 11 months, is willb still interested in this? willb seems AWOL from his other packages
18:06:48 <tibbs|w> Can certainly ping.
18:06:48 <geppetto> not sure
18:06:57 <mbooth> Mostly Scala things that FTBFS for a looong time
18:06:57 <willb> mbooth, not AWOL, just hitting snags
18:07:00 <tibbs|w> Probably should have just done that instead of putting it to voting.
18:07:07 <mbooth> Oh hi willb!
18:07:07 <geppetto> we can always approve it anyway, and if someone else wants to pick it up they can
18:07:11 <Rathann> also, stream-lib seems to bundle murmurhash
18:07:51 <mbooth> willb: Sorry for assuming your absence
18:08:13 <racor> My vote on #401: -1
18:08:48 <geppetto> ok, that's at +1:3, 0:0, -1:1 … now, I think
18:08:58 <willb> mbooth, no prob, sorry to give that impression!
18:10:31 <geppetto> mbooth: tomspur Rathann: vote?
18:10:48 <tibbs|w> From what's in the ticket I really think this is a clean fork.
18:11:01 <geppetto> I would have said so too
18:11:17 <mbooth> Yeah, +1 from me
18:11:44 <geppetto> tibbs|w: although they are tracking cassandra's git commits … so it's a bit greyer
18:11:51 <geppetto> ok, that's at +1:4, 0:0, -1:1 … now, I think
18:12:08 <Rathann> geppetto: I already said +1
18:12:16 <geppetto> Rathann: Ahh, sorry, missed it
18:13:07 <geppetto> #action bundling/forking of cassandra bloom filters for stream-lib (+1:5, 0:0, -1:1)
18:13:13 <tomspur> Great, so I can stay at a clean +0...
18:13:21 <geppetto> #undo
18:13:21 <zodbot> Removing item from minutes: ACTION by geppetto at 18:13:07 : bundling/forking of cassandra bloom filters for stream-lib (+1:5, 0:0, -1:1)
18:13:24 <geppetto> #action bundling/forking of cassandra bloom filters for stream-lib (+1:5, 0:1, -1:1)
18:13:35 <geppetto> #topic #426 	Need policy and macros for binfmt.d file handling
18:13:40 <geppetto> https://fedorahosted.org/fpc/ticket/426
18:14:38 <geppetto> tibbs|w: What did you want us to vote on here?
18:14:46 <Rathann> regarding #381 I'm +1 to temporary bundling ttf versions of STIX-1.0 fonts until upstream supports 1.1
18:17:09 <tomspur> Is it /lib or /usr/lib/binfmt.d?
18:17:38 <geppetto> I'd assume the later
18:18:00 <Rathann> both seem to be checked in systemd-binfmt.service
18:18:10 <tomspur> spots draft says just /lib
18:18:14 <geppetto> does the former exist?
18:18:15 <Rathann> but the manpage speaks of /usr/lib
18:18:36 <Rathann> well on modern Fedora it's a symlink to /usr/lib anyway
18:19:05 <geppetto> and on older distros. it doesn't exist
18:19:57 <geppetto> tibbs|w: Was it just the /lib vs. /usr/lib confusion, or something else?
18:20:17 <tibbs|w> Not much different than libreoffice, I think.
18:20:20 <tibbs|w> I think that's +5, -1 now.
18:20:21 <tibbs|w> So...
18:20:32 <tibbs|w> Whoa, I just got a torrent of stuff.
18:20:53 <geppetto> ?
18:20:53 <tibbs|w> I must have lagged out or freenode is having issues or something.
18:20:58 <geppetto> ahh
18:21:34 <mbooth> I have to go, did we get through everything?
18:21:55 <tibbs|w> Basically, before writing that up, I wanted to make sure that what we voted on still made sense given that in the meantime we added %binfmt_apply.
18:22:08 <geppetto> mbooth: There was one more I wanted to look at
18:22:20 <geppetto> And that was then all of the really old tickets
18:22:36 <geppetto> tibbs|w: So we good with 426 now?
18:23:01 <tibbs|w> I.. don't know.
18:23:01 <geppetto> Ahh, nevermind I just saw your reply
18:23:05 * geppetto nods
18:23:37 <tibbs|w> That draft was written before systemd-binfmt existed, and I suspect it's no longer correct, but I don't know.
18:23:51 <tomspur> I don't find _binfmtdir in the guidelines, would anyone mind, if I just add it to: https://fedoraproject.org/wiki/Packaging:Guidelines#binfmt.d.2C_sysctl.d_and_tmpfiles.d ?
18:23:58 <tibbs|w> I'll try to figure out what on earth systemd-binfmt actually does.
18:24:31 <tibbs|w> Yeah, 426 is completely obsoleted by the link tomspur just posted, I think.
18:24:36 * geppetto nods
18:24:41 <geppetto> Yeh I think so
18:25:23 <tibbs|w> tomspur: Yes, I think that you just change /usr/lib/binfmt.d to %_binftdir i that section.
18:25:26 <tibbs|w> I'd say just do it.
18:25:53 <geppetto> no do it the same way it's done for sysctldir above it
18:26:00 <tibbs|w> Sure.
18:26:02 <tomspur> It seems like %binfmt_apply doesn't restart binfmt. Seems like that was spots proposal
18:27:13 <geppetto> tomspur: the text you posted doesn't imply that needs to happen
18:27:22 <geppetto> it suggests that binfmt_apply does everything that's needed
18:27:46 <tibbs|w> tomspur: Hmm, crap.
18:28:03 <tomspur> binfmt_apply just calls /usr/lib/systemd/systemd-binfmt (whatever that does...)
18:28:14 <tibbs|w> Let me just ping the systemd folks and try to clear this up for next week.
18:28:27 <geppetto> Either way I'm pretty sure spot's proposal was just about the paths, and not changing restarting
18:28:45 <geppetto> I think we can close this as obsolete
18:29:08 <tibbs|w> Fine with me.
18:29:27 <tibbs|w> This is an incredibly rare thing to do anyway.
18:29:43 <tibbs|w> Not everything has to have a complete set of guidelines and examples.
18:29:49 <geppetto> #action Seems to be obsolete by the new wording we have for binfmt_apply.
18:29:59 <geppetto> #topic #435 	%py3dir not removed by rpmbuild --clean
18:30:04 <geppetto> https://fedorahosted.org/fpc/ticket/435
18:31:26 <Rathann> regarding #426, systemd-binfmt.service simply calls /usr/lib/systemd/systemd-binfmt if any of the directories are present
18:31:27 <geppetto> I agree with rathan … and I've done similar things in packages (just copy the entire tree)
18:31:50 <Rathann> so it seems binfmt_apply does  everything that's needed
18:31:53 <geppetto> agree with Rathann too ;)
18:32:18 <tibbs|w> So, on 435, can someone who understand this whip up a draft?
18:32:24 <racor> sorry, it's 30 past the hour, ... time for me  to quit.
18:32:29 <Rathann> tibbs|w: I can do that
18:32:30 <geppetto> Rathann: Did you still want to propose a draft?
18:32:38 <geppetto> racor: ok, should be ending soon anyway
18:32:44 <tomspur> Rathann: Would changing %py3dir to be in %{buildroot}/%{name}-%{version}/.py3copy also work?
18:32:57 <Rathann> basically we scrap py3dir and make a generic guideline
18:34:01 <Rathann> well py3 is not so special a case, so I'd rather have a generic guideline for this type of thing (MPI is similar)
18:34:29 <tomspur> ok
18:34:39 <Rathann> tomspur: not %{buildroot}, it should be under builddir
18:34:50 <Rathann> if I remember correctly
18:35:20 <tomspur> For MPI, I just pushd/popd to a subfolder and call ../configure. Haven't tried that with python stuff yet
18:35:28 <Rathann> speaking of buildroot, it's really a misnomer and should be renamed to installroot ;)
18:35:35 <tomspur> Rathann: sorry, I meant builddir...
18:37:24 <Rathann> I'll prepare a draft for next week
18:37:29 <geppetto> ok
18:37:48 <geppetto> #action Rathann Will prepare a draft we can vote on for next week
18:38:00 <geppetto> #topic Open Floor
18:38:08 <geppetto> Ok, does anyone want to bring anything up?
18:38:20 <tibbs|w> I did push that buildroot thing to the packaging list.
18:38:30 * geppetto nods
18:38:57 <geppetto> we didn't get to 495, 497, 498 this week … but I don't think they are urgent … and we did do all the really old tickets
18:39:11 <tibbs|w> I guess we're plowing through things, and hopefully future meetings will have a shorter agenda.
18:39:17 <tibbs|w> Would be nice to get back to one hour meetings.
18:39:24 <geppetto> yeh, that would be nice :)
18:39:31 <geppetto> we are getting there
18:39:42 <tibbs|w> There was a lot of stuff.
18:40:20 <Rathann> yeah, sorry I didn't comment on several tickets today
18:40:35 <Rathann> I was a bit distracted
18:41:05 <tibbs|w> We're down to 41 total tickets before this meeting, and we've closed out a few now.
18:41:06 <geppetto> it's ok … as tibbs|w said … hopefully it'll be a bunch less work soon
18:41:19 <tibbs|w> Plus several more needinfo ones are going to get closed soon.
18:42:08 <tibbs|w> Hmm, a new proposal for doing less package review was just posted to packaging@.
18:43:01 <tibbs|w> A lot of that is going to go directly to us, too, so prepare for a big one, I guess.
18:43:23 <tibbs|w> But it seems some people really liked the core/extras split and want to bring it back.
18:43:45 <tibbs|w> Actually, it seems more like some people liked the old RHL contrib directory and want to bring it back.
18:45:10 <sgallagh> Oh, hey. FPC Open Floor. That would be a perfect place to note the straw-man proposal I just sent out :-)
18:45:39 <tibbs|w> First reaction: hell no.  Sorry.
18:47:16 <geppetto> sgallagh: So ring packages are just a giant bundling exception?
18:47:16 <sgallagh> tibbs|w: The general sense of that email is this: only have the extremely restrictive rules on the stuff that everyone uses. Lower the bar for the wider package collection
18:47:29 <tibbs|w> Yeah, I read it.
18:47:33 <tibbs|w> I just don't agree with it.
18:47:43 <tomspur> yeah... If the projects are so fast moving, it's best to install it locally and not distribute, isn't it?
18:47:44 <sgallagh> That's fair. I'm not expecting it to go unchallenged.
18:47:47 <geppetto> I've skimmed it … and talked with other people about things like it before
18:48:11 <sgallagh> tomspur: At which point, why does anyone bother installing Fedora?
18:48:15 <sgallagh> They can do that with any distro.
18:48:16 <geppetto> In general I think it'd be fine to have "ring packages" _as long as they aren't in the default repo_
18:48:24 <sgallagh> We give them the advantage of an easy way to get it
18:48:39 <sgallagh> geppetto: That's basically COPR, but I'm convinced that's not enough.
18:49:03 <sgallagh> It's a good start, but not enough and not very discoverable
18:49:04 <geppetto> So if we ship fedora and fedora-ring … even if they are both enabled by default … I'm much more likely to +1 whatever the exceptions are on ring packages than if you lump them in with good ones
18:49:19 <sgallagh> Ah, if they're both enabled, that's a different story.
18:49:28 <sgallagh> We kind of already do that, though
18:49:38 <sgallagh> We ship the install trees and the Everything tree.
18:49:43 <geppetto> yeh, there's 3 levels as I see it … COPR, installed by default, installed and enabled by default
18:50:09 <tomspur> sgallagh: I don't think that ignoring security issues is a reason to install Fedora
18:50:40 <sgallagh> tomspur: Well, it would also mean an end to pretending that people aren't just bundling (often accidentally) already.
18:50:40 <geppetto> I'm somewhat happy to have some way to get beta packages into fedora at level 3 … but there needs to be able easy way to fix it (Eg. manually disable that repo(s))
18:51:22 <sgallagh> geppetto: Well, "beta" packages belong in COPR. I think that's hard to disagree with, yes?
18:51:41 <geppetto> Well … that would depend on how you described docker ;)
18:51:48 <sgallagh> /me snickers
18:52:41 <tomspur> Accidental bundling is better than on purpose bundline :)
18:52:46 <geppetto> I think how many rings you want, and what the differences should be is a weird debate … and I don't think FPC should be the only person in deciding that
18:53:01 <sgallagh> tomspur: I disagree. If you bundle on-purpose, at least you know it's there and can react when needed
18:53:27 <sgallagh> geppetto: Oh, absolutely not. That's why the email was posted to devel@ with packaging@ on the CC
18:53:40 <geppetto> I think I would be against a blanket bundling exception for any of the rings … but maybe could be convinced otherwise
18:54:11 <tibbs|w> I don't think bundling is the holdup for getting packages into the distro anyway.
18:54:41 <geppetto> Having some kind of specialize bundling exception could be doable though (Eg. allowed to bundle parts of other ring packages for N weeks, when features/APIs are needed)
18:54:46 <sgallagh> You might be surprised how often that is the case, but it's not the only issue.
18:55:13 <sgallagh> geppetto: Also, part of the bundling problem is the time-sink it becomes to the FPC
18:55:40 <sgallagh> Since you have to review every one individually (and generally only at meetings, which means it can drag out for some time)
18:55:42 <geppetto> yeh, but that's there in the hope that people won't want to bundling 666 things
18:56:05 <geppetto> Obviously Java/Ruby/Go upstreams don't quite agree
18:56:07 <sgallagh> geppetto: How has that worked out? :)
18:57:10 <sgallagh> I figure we can either continue to drain the river with a bucket or we can try to redirect it so it runs past where we want to be.
18:57:42 <tibbs|w> The thing is, you're dealing with upstreams who don't want to be distro-packaged.
18:57:49 <tibbs|w> That's basically the top and bottom of it.
18:58:12 <sgallagh> I think it's not "don't want" and more "don't care"
18:58:30 <tibbs|w> EIther way, why package them at all?
18:58:55 <geppetto> Because Fedora wants to ship them
18:59:27 <sgallagh> Because it's still better for our *users*
18:59:30 <geppetto> at least in some semi usable way … that isn't just "Please type: wget | sh" … :-o
18:59:47 <sgallagh> Being able to click on an icon in GNOME Software and have something that works in a few minutes is a significant value
18:59:59 <sgallagh> (for example)
19:00:10 <tibbs|w> If Fedora wants to ship them, Fedora has work to do to make sure it has a functional distro.
19:00:23 <tibbs|w> Fedora has decided that bundling is antithetical to having a functional distro.
19:00:53 <sgallagh> tibbs|w: It decided that at a point in history where most upstreams wanted to be part of the major distros.
19:00:58 <tibbs|w> I just don't see how packaging software developed by people who don't want us to package software is helping anyone.
19:01:03 <sgallagh> As the times change, we need to adapt or fail.
19:01:19 <sgallagh> tibbs|w: Again, it's not usually a matter of "don't want".
19:01:40 <sgallagh> It's usually a matter of "I'm not changing my upstream to accommodate your needs, so deal with it yourself"
19:01:48 <tibbs|w> I think fundamentally that's the same thing.
19:01:53 <sgallagh> And there's another possibility here
19:02:27 <sgallagh> Deliver things *well* so that people are using them, and upstreams may catch on to the fact that distros shipping them actually does still have value.
19:02:35 <sgallagh> Which can translate into a better conversation about "how"
19:04:53 <tomspur> I can see the bonus from a user perspective. Yet, I don't think I want to "maintain" such a package...
19:04:55 <geppetto> I'm less convinced that this will reverse any trends … From what I've seen some of it is due to a lot of people using Mac OS X, or even Ubuntu … and so nothing we do on the packaging side will make them think it's worth their time
19:06:52 <geppetto> As I said though, I think it would be good for Fedora to not pretend that we have one giant set of packages that are all at the same level of quality/maintenance
19:07:27 <geppetto> And the ring packages, with different repos., is a good way to delineate those lines
19:07:30 <sgallagh> tomspur: Anyone can obviously opt to maintain the package by the current standards. That's preferred, of course.
19:08:06 <sgallagh> geppetto: Yes, I agree about the level of quality.
19:08:21 <sgallagh> Of course, to the end-user, that's probably not something they'd often see.
19:08:43 <sgallagh> Most people on Ubuntu use Universe (and Multiverse!) packages without realizing they're not *really* part of the curated set.
19:09:07 <geppetto> For someone using gnome-software … no, they probably won't be able to tell the difference between now and then … but that's probably fine.
19:09:15 <sgallagh> /me nods
19:09:53 <sgallagh> geppetto, others: Would you mind adding your thoughts to the mail thread? I think it would be very useful to have your voices there.
19:10:04 <sgallagh> (Yes, even if you disagree with me :) )
19:10:14 <geppetto> Yeh, I can try and respond … will probably be tomorrow though
19:10:23 <sgallagh> That's fine. Thank you.
19:11:03 <tomspur> sgallagh: :) I just have my doubts that (at least some) packagers do more than just compile something and ship it
19:11:31 <geppetto> #action Everyone should try to respond with some of their thoughts on the ring packages thread.
19:12:06 <geppetto> Ok, I'm going to wait a minute or two and then close unless anyone grins something new up … thanks for coming, and see you next week.
19:12:16 <geppetto> *brings :-o
19:13:34 <tomspur> see you, thanks
19:18:00 <geppetto> #endmeeting