#fedora-meeting-2: Env and Stacks (2015-03-12)

Meeting started by hhorak at 13:00:25 UTC (full logs).

Meeting summary

  1. Dockerfiles recommended tips (hhorak, 13:05:33)
    1. people are much more likely to react to warnings/errors than read a document about how things should be done (hhorak, 13:12:16)
    2. the linter should say "warning: this and that is bad, have a look at the long explanation in guidelines to see why" (hhorak, 13:12:16)
    3. the linter should (maybe already does) display a little message which could have a link now (hhorak, 13:12:16)
    4. dockerfiles for F22 need ported to dnf (hhorak, 13:16:41)
    5. ACTION: ncoghlan to suggest to rpmgrill devs that they join Envs & Stacks to discuss dockerfile_lint (ncoghlan, 13:22:51)
    6. the documentation about dockerfiles practices/guidelines should be based on use cases (what am I creating the dockerfile for) and some general sections.. (hhorak, 13:42:27)

  2. Playground repo revisiting (hhorak, 13:42:40)
    1. https://fedoraproject.org/wiki/Changes/Playground_repository (hhorak, 13:44:17)
    2. https://fedoraproject.org/wiki/Env_and_Stacks/Playground_repository_%28draft%29 (hhorak, 13:44:17)
    3. ACTION: all to refresh the discussion we had few months back from logs/the links above (draft, change proposal), so we don't invent the same square wheels again.. and let's continue on ML/next meeting.. (hhorak, 14:19:06)
    4. so far it seems we can either have one big repo composed of N non-conflicting repos or a bunch of (possibly conflicting) repos (hhorak, 14:19:24)

  3. open floor (hhorak, 14:19:30)


Meeting ended at 14:23:33 UTC (full logs).

Action items

  1. ncoghlan to suggest to rpmgrill devs that they join Envs & Stacks to discuss dockerfile_lint
  2. all to refresh the discussion we had few months back from logs/the links above (draft, change proposal), so we don't invent the same square wheels again.. and let's continue on ML/next meeting..


Action items, by person

  1. ncoghlan
    1. ncoghlan to suggest to rpmgrill devs that they join Envs & Stacks to discuss dockerfile_lint


People present (lines said)

  1. hhorak (58)
  2. ncoghlan (52)
  3. bkabrda (22)
  4. langdon (15)
  5. ttomecek (8)
  6. zodbot (5)
  7. dgilmore (1)
  8. walters (1)
  9. phracek (0)
  10. sicampbell (0)
  11. vpavlin (0)
  12. juhp (0)


Generated by MeetBot 0.1.4.