15:00:30 <pwhalen> #startmeeting Fedora ARM & AArch64 Status Meeting
15:00:30 <zodbot> Meeting started Tue Jun  9 15:00:30 2015 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:30 <pwhalen> #chair pwhalen bconoboy pbrobinson dgilmore hrw jsmith kyle dmarlin
15:00:30 <zodbot> Current chairs: bconoboy dgilmore dmarlin hrw jsmith kyle pbrobinson pwhalen
15:00:40 <pwhalen> good morning folks, hope all is well
15:01:33 * pbrobinson waves
15:01:40 <hrw> o/
15:03:32 <pwhalen> looks like its us three so far, hopefully others will join ..
15:03:35 <pwhalen> #topic 1) ==== Package Status & Issues  ====
15:03:43 <pwhalen> how we doing?
15:04:38 <pbrobinson> very good, down to around 770 older packages and around 1100 missing builds total
15:04:54 <hrw> systemd/binutils issue still not solved. but looks like Nick tries to start working on it
15:05:18 <pbrobinson> yes, and systemd has been worked around in the interim
15:05:30 <pwhalen> hrw, is there a bz, or something to note in our logs?
15:05:46 <hrw> moment, will find
15:05:56 <pbrobinson> atlas I think is the current one, I believe that's just that the aarch64 patches are, wrongly IMO, applied using %ifarch and the maintainer didn't rebase
15:06:03 <pwhalen> thanks, just makes it more useful for those who read the logs after
15:06:09 <hrw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1225156
15:06:12 <pbrobinson> hrw could you take a look, with the new version we might not even need them
15:06:15 <pwhalen> thanks hrw
15:06:24 <hrw> pbrobinson: will do.
15:06:34 <pbrobinson> hrw: awesome, thanks
15:06:37 <hrw> #action hrw to get atlas into building state
15:07:03 <pbrobinson> hrw: if there's support upstream and upstream support looks fine I'd drop them if possible
15:07:14 <hrw> sure
15:07:43 <pwhalen> anything others?
15:07:51 <pwhalen> or any others
15:08:33 <pbrobinson> not really, all looking pretty good from my PoV
15:08:41 <pbrobinson> should have a clean run done in a few hours
15:08:56 <hrw> cool
15:09:19 <pwhalen> nice. may as well ask now, do we plan on turning on nightlies for aarch64 rawhide?
15:09:43 <pbrobinson> nightly what? We're already doing nightly rawhide composes
15:10:33 <pwhalen> okay, then i guess their broken then - https://dl.fedoraproject.org/pub/fedora-secondary/development/rawhide/aarch64/os/
15:11:16 <pbrobinson> well the report runs OK and it's about the last thing to go out https://lists.fedoraproject.org/pipermail/arm/2015-June/009549.html
15:11:26 <pbrobinson> I'll have a look to see what's missing
15:12:03 <pbrobinson> pwhalen: I know what it is.... nothing to do with nightlies, will deal :)
15:12:13 <pwhalen> thanks, so its the install tree .. also armhfp hasnt been generated in a few days..
15:12:36 <pwhalen> #topic 2) ==== Kernel Status ====
15:12:48 <pbrobinson> yea, there's other issues there with anaconda as they move to python3 so there's a bit broken in rawhide in general ATM
15:12:56 * masta looks in
15:13:02 <masta> hey folks
15:13:04 <pwhalen> ah, right.. ok, thanks
15:13:23 <pbrobinson> 4.1rc7 is out and built, please test and report issues
15:13:38 <pbrobinson> other than that I don't currently have much
15:13:43 <pwhalen> i'm just finishing a local install tree with rc7 for armhfp.
15:14:34 <pbrobinson> anyone else done any kernel testing?
15:14:39 <hrw> pcie on mustang is terribly broken. have to resend my email to linux-pci ML directly to xgene pcie maintainer
15:14:40 <pwhalen> pbrobinson, seeing that spam about the clock i sent you last week on rc6
15:14:53 <pwhalen> but will update today on rc7
15:16:01 <pwhalen> ok,  anything else kernel related?
15:16:11 <pbrobinson> is that on all devices or a particular SoC?
15:17:00 <pwhalen> so far on allwinner/imx.. others yet to be tested
15:17:45 <pbrobinson> OK, so quite wide, hopefully others picked it up and it's already fixed in rc7
15:18:20 <pwhalen> agreed.
15:19:35 <pwhalen> #topic 3) == Open Floor ==
15:19:57 <pbrobinson> Fedora 23 planning....
15:20:10 <pbrobinson> anyone working on any particular features? Anyone planning to?
15:21:13 <pwhalen> pbrobinson, i plan on updating the install script, add a couple of things we talked about, like easier uboot installations
15:21:48 <pbrobinson> and updates ;-)
15:22:30 <pwhalen> right. also looking at further automation of testing with openqa/taskotron this week. should have something to report next week
15:22:34 <bconoboy> do we have a plan for testing out the 32 on 64 qemu stuff dmarlin has been working on?
15:23:00 <pwhalen> not yet, just the initial number from dmarlin
15:23:02 <pbrobinson> bconoboy: yes
15:23:06 <pwhalen> oh
15:23:09 <pbrobinson> bconoboy: I'll be working on it soon
15:23:14 <pwhalen> cool
15:23:17 <bconoboy> pbrobinson: Awesome, I'll ask again next week ;-)
15:24:22 <pbrobinson> bconoboy: please do ;-) I've got a newer rev of Mustang HW now that I smuggled out of the office (not really) and I'll be working to take dmarlin's great work to get it well integrated so we can start some wider testing
15:24:52 * bconoboy wags his tail
15:24:53 <hrw> pbrobinson: B0 finally?
15:25:08 <pbrobinson> hrw: no, what ever the latest A rev is
15:25:28 <hrw> ah
15:25:56 <pbrobinson> it's more stable that the rev I had prev
15:26:11 <hrw> A3 probably
15:26:43 <hrw> " sudo cat /sys/firmware/dmi/entries/4-0/raw" would tell
15:27:30 <pbrobinson> anyway so we can't really easily use raw qemu instructions etc in infra so I'll work on those bits
15:27:49 <pbrobinson> there's also work to be done with koji and other bits before we can move the builders to F-22
15:28:38 <pbrobinson> but I've got a huge bunch of work to do on infra in the next couple of weeks
15:29:35 <pwhalen> sounds like fun, do let us know if we can help
15:29:39 <pwhalen> anything else for today?
15:29:44 <masta> I'm still working on a 2012 chromebook remix - not much to report - mostly working out what needs to get into the kernel.
15:30:05 <pbrobinson> so from my PoV I have the following that I'm working on for F-23:
15:30:05 <pbrobinson> * Cloud and other images (inc integration in koji)
15:30:06 <pbrobinson> * RPi2
15:30:06 <pbrobinson> * v7 on aarch64
15:30:32 <masta> the f22 kernel appears to have most everything we should need for chromebook, so I'm zeroing in on the config requirements.
15:30:32 <pbrobinson> masta: you've been working on that a couple of cycles apparently, still awaiting patches for kernel etc ;-)
15:31:19 <masta> pbrobinson: I've been doing in spare time, so slow going... but gradually getting there. hopefully more to report in a week
15:33:49 <pwhalen> ok, last call..
15:34:05 <pbrobinson> I'll also be rebasing to 2015.07rc2 this week for u-boot
15:34:12 <pbrobinson> so testing there would be useful
15:34:23 <pbrobinson> that's it for me ATM
15:35:15 <pwhalen> #endmeeting