12:02:14 <hhorak> #startmeeting Env and Stacks (2015-07-02)
12:02:14 <zodbot> Meeting started Thu Jul  2 12:02:14 2015 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:17 <hhorak> #meetingname env-and-stacks
12:02:17 <zodbot> The meeting name has been set to 'env-and-stacks'
12:02:29 <hhorak> #chair bkabrda hhorak juhp ncoghlan vpavlin jkaluza walters ttomecek phracek
12:02:29 <zodbot> Current chairs: bkabrda hhorak jkaluza juhp ncoghlan phracek ttomecek vpavlin walters
12:02:40 <phracek> hhorak: Hi
12:02:45 <jkaluza> hi all
12:02:52 <hhorak> hi
12:03:07 <hhorak> jkaluza: welcome on board!
12:03:11 <jkaluza> hhorak: thanks :)
12:03:19 <phracek> jkaluza: Congrats on election:)
12:03:25 <phracek> to both:)
12:04:42 <hhorak> #topic init process
12:07:34 <hhorak> vpavlin and bkabrda are not joining today, so let's start and see if anybody else joins..
12:07:54 <hhorak> #topic New meeting time?
12:08:41 <hhorak> jkaluza: since you're a new member, I'd like to make sure whether the time-slots we have now are fine for you -- 2pm and 7pm CET (Thursdays)
12:08:59 <jkaluza> they should be OK
12:09:14 * langdon lurks
12:09:42 <hhorak> nice, so I hope we can avoid new time-slot voting, it is always hard to find some reasonable time for people from various parts of the world
12:10:23 <hhorak> #info jkaluza is fine with current time-slots, so we don't need to find new time-slots for meeting
12:11:01 <hhorak> #topic Elections wrap-up
12:11:49 <hhorak> I've already re-send the results to the ML, but let me again thank you for candidate!
12:13:20 <hhorak> jkaluza: to describe you how it works here -- I usually send agenda to our ML a day before the meeting (well, sometimes only hours like today)
12:13:50 <phracek> hhorak: jkurik contacted me regarding update of new members on our wiki. All is done.
12:14:06 <jkaluza> hhorak: right, that part is described on the env and stacks wiki page.
12:14:11 <hhorak> but I'd like to encourage everybody to put own items on the agenda ideally sending to the ML
12:14:16 <hhorak> phracek: thanks!
12:14:38 <hhorak> jkaluza: ok, so you should be all set :)
12:15:45 <hhorak> #topic Changes in governance
12:15:50 <hhorak> #undo
12:15:50 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x340d6210>
12:15:56 <hhorak> #topic Changes in governance charter
12:16:10 <hhorak> #link https://fedoraproject.org/wiki/Env_and_Stacks/Governance_Charter
12:16:47 <ncoghlan> With the new process this time, I actually like the idea of staying in sync with the FESCo elections
12:17:10 <ncoghlan> it felt a lot more meaningful with jhurik's questions and the Fedora magazine posts
12:18:32 <ncoghlan> I probably should have mentioned this in the previous post, but I'd volunteer to do a follow-up post for Fedora Magazine linking back to those interviews for the successful candidates
12:18:43 <ncoghlan> s/previous post/previous topic/
12:19:13 <ncoghlan> and summarising what we each saw as important problems
12:20:00 <hhorak> ncoghlan: well, I liked that questionnaire style and kind of took that as a good time to self-reflection.. which part do I need to play in Fedora and similar stuff..
12:20:00 <hhorak> so even if I proposed changes in the election scheme before, I actually changed my mind and now I agree with ncoghlan that we should rather stick with the current way..
12:20:30 <hhorak> ncoghlan: the follow-up would be great!
12:20:45 <jkaluza> follow-up sounds great
12:21:15 * ncoghlan moved over to working on Fedora as of yesterday, so will be more willing to volunteer for things ;)
12:22:13 <hhorak> Well, still, if anybody would like to propose some changes in the Governance Charter, feel free to propose the change and we can vote about it..
12:22:35 * ttomecek1 is sorry for being so late
12:22:42 <hhorak> #action all to reflect on the Governance Charter and propose changes on ML if there is anything worth changin
12:24:36 <jzeleny_> ncoghlan: just make sure you volunteer for the right things, you represent our team now :-)
12:24:46 <ncoghlan> jzeleny_: :)
12:25:19 <hhorak> ncoghlan: ah, almost forgot, welcome on board!
12:26:00 <ncoghlan> thanks!
12:26:52 <hhorak> #topic Fedora users feedback
12:27:36 <hhorak> #link http://piratepad.net/env-and-stacks-users-feedback
12:29:37 <ttomecek> ncoghlan, hhorak: can I edit the pad a bit?
12:29:53 <hhorak> ttomecek: sure!!
12:32:29 <hhorak> So we have quite good base for gathering feedback, but I'm thinking what to do now -- langdon said it was more desired we as a group without a big obvious base of direct users would just pass the questions to other groups (server, workstation, cloud) and those would try to gather feedback from their users..
12:32:41 <hhorak> it's actually coming from "Fedora Modularization: Fedora.next: What is Next (Requirements Phase)"
12:32:47 <hhorak> #link https://fedorahosted.org/council/ticket/26
12:32:50 <ncoghlan> hhorak: that sounds like a good approach to me
12:32:59 <ncoghlan> we want to be able to segment the answers by audience
12:34:05 <ncoghlan> e.g. deployment tool choice difference between Server audience and Workstation audience
12:35:54 <hhorak> ncoghlan: right, that would be great input... so let's get in touch with the other working groups to see what is their plan about gathering other feedback
12:36:48 <hhorak> and then we either just pass the etherpad to them or create some kind of questionnaire somewhere..
12:37:09 <hhorak> speaking about a service for creating such kind of forms -- anybody has some recommendations?
12:38:23 <hhorak> google offers some forms service, but I never created one..
12:39:09 <hhorak> surveymonkey.com is also quite heavily used..
12:39:47 * jkaluza has no experiences with these tools
12:39:54 <jkaluza> *experience
12:40:13 <jkaluza> When I receive something like that, it usually uses the google forms.
12:40:52 * langdon was on the phone
12:41:27 <ncoghlan> I think the idea was not to run the survey ourselves, but provide suggested questions back to other WGs
12:41:53 <langdon> G forms requires a google account (last I knew).. Surveymonkey  might be better.. Both are *very* easy
12:42:29 <langdon> ncoghlan ack
12:43:04 <ncoghlan> And https://www.limesurvey.org/en/ is the default open source option
12:43:43 <langdon> ncoghlan Ohh right.. Forgot that one
12:44:12 <hhorak> ncoghlan: yeah, but if the other groups ask us to create the form, so they will just share the link with their user base.. maybe a back-up plan, but since on the topic, I wanted to educate myself a bit about various solutions for gathering feedback :)
12:44:56 <hhorak> #link https://www.limesurvey.org/en/
12:45:13 <hhorak> #info limesurvey.org is the default open source option
12:45:19 <ncoghlan> hhorak: the other main one I'm aware of is KeySurvey: https://www.keysurvey.com/
12:45:32 <ncoghlan> but we're well within what LimeSurvey can do
12:46:37 <hhorak> other not so open source are: https://www.keysurvey.com/ https://www.google.com/forms https://www.surveymonkey.com/
12:46:59 <hhorak> #info other not so open source are: https://www.keysurvey.com/ https://www.google.com/forms https://www.surveymonkey.com/
12:47:38 <hhorak> now, my favorite question -- any volunteer to get in touch with other working groups to handle this?
12:50:04 <langdon> ncoghlan can you and I do it together?
12:50:49 * jkaluza thinks it should be someone with longer history in this group than he
12:51:20 <ncoghlan> I'd prefer to pass on that one right now - already have a heap of new connections to make for the internal tools -> Platform developer experience move
12:51:39 * hhorak worried about his language skills :)
12:51:49 <hhorak> langdon: but we can somehow do it together I guess :)
12:52:02 <ncoghlan> langdon: although happy to help out if someone else is the main driver :)
12:52:23 <langdon> Well.. Isn't the group coming up with the qs? And just this part is outreach?
12:52:34 <ncoghlan> also happy to help iterate on the questions
12:53:07 <ncoghlan> the limit's more to do with building mental maps of people and interconnections in my brain
12:54:07 <langdon> Not really my place to propose .. But how about a one off meeting to just do qs? Then hhorak (with English help from me and ncoghlan) can send to the wgs?
12:55:00 <hhorak> langdon: we already have something: http://piratepad.net/env-and-stacks-users-feedback
12:55:40 <ncoghlan> place to start might be to ask the other WGs what their survey plans are, and if they'd mind us providing additional questions
12:55:50 * langdon recognizes again the time damage submit did..
12:58:01 <ncoghlan> (one of my main concerns with our current draft is that it's quite long, so it would be nice to come up with a way to cull it a bit)
12:58:09 * hhorak recognizes again he doesn't recognize what langdon's last thought was trying to say :)
12:58:30 <hhorak> ncoghlan: +1
12:58:32 <ncoghlan> hhorak: "summit", I'm guessing (lots of folks were very busy for that)
12:59:14 <langdon> hhorak lol... Missed that list in my struggle to keep my head above water during the run up to summit
12:59:27 <ncoghlan> this could be a good discussion to take back to the ML
12:59:45 <ncoghlan> I think we need to consider what *we* would want to get out of the survey a bit more
13:00:49 <ncoghlan> and perhaps focus the questions a bit more on work we're already doing
13:00:51 <jkaluza> What will we do with the output of that survey?
13:01:16 <ncoghlan> jkaluza: exactly :)
13:01:26 <jkaluza> I mean, if we find out that most of people do web development using ruby, we will try to focus on that more?
13:01:49 <jkaluza> For every question, we should probably evaluate what we will do based on the outcome.
13:01:51 <ncoghlan> we already have quite a few plans - the Aleph multi-stage review concept, SCLs-for-Fedora
13:02:18 <ncoghlan> we probably want to look for potential course-correcting feedback on those plans
13:03:10 <ncoghlan> as well as highlighting relevant areas of concern for *existing* users
13:03:39 <langdon> Partially it is to produce report to the council..  So that they (we) can gather all the feedback and get a better sense of the community as a whole
13:04:29 <ncoghlan> langdon: ah, in that case, I think our broader development & deployment stack questions *do* make sense
13:04:38 <jkaluza> right
13:04:44 <ncoghlan> even if they're not immediately useful to *us*
13:04:56 <ncoghlan> they'd be interesting to track over time, and across editions
13:06:19 <jkaluza> if it would be just to find out where env and stacks should be going, we should probably evaluate the projects we are working on and do questions based on that.
13:07:07 <hhorak> I see there basically these areas: What you do with fedora now? What you want to do with Fedora in the future? What do you think about <thing>? All seem valid for us for different reasons (learn the audience more, gather priorities)
13:08:07 <ncoghlan> langdon: could you take that request for clarification back to the Council?
13:08:24 <ncoghlan> langdon: are we looking to build a survey we could re-use and refine year after year?
13:08:54 * langdon reading
13:09:20 <ncoghlan> langdon: or something aimed more at checking the validity of our current ideas for the next year or so?
13:10:01 <ncoghlan> anyway, we don't need to resolve this tonight - we can follow up on the mailing list
13:10:06 <jkaluza> +1 here
13:10:14 <hhorak> +1
13:10:26 <phracek> +1
13:10:38 * jkaluza also needs to think a bit more about those questions, since he saw them for first time today.
13:10:56 <hhorak> #action hhorak to ask other wgs about what are their plans for feedback gathering
13:11:03 <langdon> ncoghlan I would say that we want to do similar surveys more regularly.. Maybe even every release.. But.. For now, yeah.. Like every year..
13:11:15 <langdon> But I can formally ask the council too
13:11:44 <ncoghlan> langdon: yeah, explicit clarification would be good, and I agree the "recurring questions" would likely prove more valuable
13:12:23 <ncoghlan> I think our current near term plans are based on enough "won't somebody please make the pain stop?" real world experience to be sufficiently validated already :)
13:12:56 <ncoghlan> but tracking trends in tool usage over time will never get old
13:13:11 <hhorak> #action langdon to ask council about whether the "recurring questions" would make sense
13:13:49 <hhorak> #topic open floor
13:13:58 <hhorak> anybody has anything else?
13:16:29 <jkaluza> not me :)
13:16:30 <hhorak> Actually I have :) josh just reminded me we're supposed to bring update on our area's progress and goals for f23 and f24..
13:16:45 <phracek> no
13:16:53 <hhorak> ...to the council..
13:17:05 <phracek> you mean our tasklist?
13:17:55 <hhorak> phracek: well, it may be based on that..
13:20:15 <jkaluza> hhorak: those can be even new ideas? :)
13:21:18 <hhorak> jkaluza: yes :)
13:22:00 <jkaluza> I might have some, but wouldn't it be better to discuss that on mailing list?
13:22:00 <hhorak> #link https://lists.fedoraproject.org/pipermail/env-and-stacks/2015-May/000786.html
13:22:56 <hhorak> jkaluza: it would but the meeting where we should present it is on Monday next week :)
13:25:24 <hhorak> langdon: do you know when the council meeting is planed? (I can't find the time anywhere)
13:26:17 <langdon> 1300 est
13:26:26 <hhorak> langdon: ok, thanks..
13:26:34 * handsome_pirate waves
13:27:05 <jkaluza> hhorak: if you want some idea I had for some time, I would like to do project based on fedmsg which would allow sending POST request when new package is in some stable fedora release, so you could rebuild the docker image based on that.
13:27:13 <hhorak> I probably can give some update, but need to have an update whether the ideas are planned for F23/F24 time-frame.. so let me know about changes you plan for those..
13:27:37 <jkaluza> hhorak: not sure if that can count into this group :) I plan to do that anyway for my evil plans :)
13:28:17 <hhorak> jkaluza: would you be able to create at least a short wiki page about it?
13:29:03 <jkaluza> yes.
13:29:50 <hhorak> #action all to think about update on our area's progress and goals for f23 and f24.. send it to ML until this Monday, 10 EST, if it should be mentioned on the council meeting..
13:30:03 <hhorak> jkaluza: thanks!
13:30:25 <jkaluza> (Basically I would like to test an idea of daemons packaged as docker images based on fedora and updated when new package hits the stable)
13:30:26 <hhorak> and thanks everybody else as well, will close this soon if nobody protests..
13:30:36 <jkaluza> np :)
13:30:54 <hhorak> jkaluza: I like that idea :)
13:32:10 <jkaluza> It's all for longer discussion probably, I don't want to waste your time right now ;).
13:33:04 <hhorak> #endmeeting