15:00:23 <pwhalen> #startmeeting Fedora ARM and AArch64 Status Meeting
15:00:23 <zodbot> Meeting started Tue Aug 16 15:00:23 2016 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:23 <zodbot> The meeting name has been set to 'fedora_arm_and_aarch64_status_meeting'
15:00:24 <pwhalen> #chair pwhalen pbrobinson dgilmore hrw dmarlin yselkowitz jonmasters ahs3 msalter
15:00:24 <zodbot> Current chairs: ahs3 dgilmore dmarlin hrw jonmasters msalter pbrobinson pwhalen yselkowitz
15:00:30 <pwhalen> morning folks, whos here today?
15:03:20 * pbrobinson o/
15:03:59 <cov> hi
15:04:35 <pwhalen> ok! couple of people, some lurkers.. lets do it
15:04:45 <pwhalen> #topic 1) ==== Package Status & Issues  ====
15:04:58 <pbrobinson> nothing to report here that I know of
15:05:05 <pwhalen> w00t!
15:05:08 <pbrobinson> f25: statistics: {'older': 46, 'local_only': 1, 'remote_only': 289, 'same': 17989, 'newer': 5, 'total_missing_builds': 89}
15:05:09 <pwhalen> perhaps stats?
15:05:14 <pwhalen> thanks
15:05:19 <pbrobinson> f26: statistics: {'older': 59, 'local_only': 1, 'remote_only': 279, 'same': 18052, 'newer': 2, 'total_missing_builds': 71}
15:05:23 <pwhalen> #info No package issues.
15:05:28 <pwhalen> #info f25: statistics: {'older': 46, 'local_only': 1, 'remote_only': 289, 'same': 17989, 'newer': 5, 'total_missing_builds': 89}
15:05:30 <pbrobinson> yea, I can't copy and paste that fast
15:05:38 <pwhalen> #info f26: statistics: {'older': 59, 'local_only': 1, 'remote_only': 279, 'same': 18052, 'newer': 2, 'total_missing_builds': 71}
15:05:47 <pwhalen> nice numbers
15:05:56 <pbrobinson> so I've been looking at various remaining packages to see what we're missing
15:06:27 <pbrobinson> we should have mono with 4.6 landing in the f26 cycle, I've has some comms with the maintainer
15:06:49 <pwhalen> nice
15:07:13 <pwhalen> #info Should have mono with 4.6 landing in the f26 cycle.
15:07:25 <pwhalen> does anyone have any other package issues?
15:07:35 <pbrobinson> then the other languages that could do with bootstrap assistance (supported in all cases I believe) are sbcl (lisp), D and fpc (pascal)
15:08:11 <pbrobinson> #info anyone wish to help with  bootstrap assistance (supported in all cases I believe) are sbcl (lisp), D and fpc (pascal)
15:08:16 <pbrobinson> #undo
15:08:16 <zodbot> Removing item from minutes: INFO by pbrobinson at 15:08:11 : anyone wish to help with  bootstrap assistance (supported in all cases I believe) are sbcl (lisp), D and fpc (pascal)
15:08:36 <pwhalen> #info Other languages that could do with bootstrap assistance (supported in all cases I believe) are sbcl (lisp), D and fpc (pascal). Those interested please send mail to the fedora-arm list or on Freenode #fedora-arm,
15:08:38 <pbrobinson> #info anyone wish to help with  bootstrap assistance (supported in all cases I believe) are sbcl (lisp), D and fpc (pascal) please reach out to pbrobinson for details
15:08:42 <pwhalen> heh
15:09:00 <pbrobinson> can be there twice, has all the info!
15:09:09 <pwhalen> so nice, we said it...
15:09:12 <pwhalen> ok..
15:09:29 <pwhalen> #topic 2) ==== Kernel Status ====
15:10:10 <pbrobinson> basically here both 4.7 (4.7.1 should be coming this week) and 4.8rc2 need testing. Please feedback any issues you find
15:11:03 <pbrobinson> #info 4.8rc2 has ACPI pci-e support, NUMA support (DT and ACPI) and initial Cavium ThunderX support. For those interested in those features please test and feed back to list or #fedora-arm
15:11:50 <pwhalen> 4.7 currently isnt booting on Trimslice and Jetson TK1, hopefully resolved with the next build.
15:12:00 <pbrobinson> I need to rebase Pine64 support for 4.7/4.8, it's on my todo list
15:12:32 <pbrobinson> pwhalen: so 4.7 booted fine on my Jetson actually.... just no network or display so not very useful (serial console etc was fine)
15:12:51 <pwhalen> hrm, -2?
15:13:08 <pbrobinson> yes, there is no other
15:13:43 <pwhalen> oh right, the -1 failed.. ok, will try again. ive been having general issues with it on this uboot
15:15:06 <pbrobinson> I'm on an older u-boot, no idea which one TBH
15:15:19 <pwhalen> #info Tested on 4.7 - Wandboard, Beaglebone Black, Cubietruck, Banana Pi, Rpi2, Highbank.
15:16:17 <pwhalen> #info Tested on 4.8 RC2 - Wandboard, Rpi2, Highbank, Banana Pi
15:16:41 <pwhalen> anything else?
15:17:04 <pbrobinson> not from me
15:17:21 <pwhalen> #topic 3) ==== Bootloader Status ====
15:17:49 <pbrobinson> so u-boot in rawhide is at 2016.09rc1, I thought there should be a rc2 by now
15:17:58 <pbrobinson> and 2016.07 is in f25
15:18:18 <pbrobinson> I'll be testing this a lot wider in the next few days (along with kernels and f25 over all)
15:19:04 <pbrobinson> there were some minor issues with uEFI/grub2 on aarch64 a feww days back but I think this has settled down now
15:19:08 <pwhalen> Ive been using 2016.07 without any surprises, 2016.09rc1 on the bpi is ok so far. others to follow
15:20:30 <pwhalen> #info efibootmgr calls in anaconda crashing since efivar-0.24-1.fc25 landed  ( https://bugzilla.redhat.com/show_bug.cgi?id=1352680 )
15:21:08 <pwhalen> thats still an issue, but installs work. just accept the error
15:21:39 <pwhalen> any other issues?
15:22:25 <pbrobinson> none that I'm aware of
15:22:30 <pwhalen> #topic 4) == F24 Alpha ==
15:22:35 <pwhalen> #undo
15:22:35 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4a0e8c10>
15:22:39 <pwhalen> #topic 4) == F25 Alpha ==
15:23:27 <pbrobinson> so nightly branched composes are happening, mostly at least, so please test and report issues
15:23:39 <pbrobinson> we're not quite there for alpha but we're getting close
15:24:03 <pbrobinson> so any testing on ARMv7 or aarch64 is valuable
15:24:23 <pwhalen> go nogo is scheduled for thursday, release is supposed to be next week. there are a few blockers unresolved
15:24:43 <pwhalen> #info https://qa.fedoraproject.org/blockerbugs/milestone/25/alpha/buglist
15:26:23 <jonmasters> sorry I'm late
15:26:27 <pwhalen> #info Please assist us in testing the Alpha release for aarch64 and armv7.
15:27:34 <pwhalen> welcome jonmasters
15:27:41 <jonmasters> :)
15:27:43 <pwhalen> anything else for f25 alpha?
15:27:47 <cov> noob question, how does one test the Alpha release for aarch64 and armv7?
15:29:08 <pbrobinson> cov: you can get cloud/docker/install (net or DVD) and test install process etc, pwhalen can provide a link to the test criteria
15:29:27 <pwhalen> cov, testing the nightlies repos posted here - http://dl.fedoraproject.org/pub/fedora/linux/development/25/  or http://dl.fedoraproject.org/pub/fedora-secondary/development/25/
15:29:58 <pbrobinson> #info aarch64 Fedora 25 nightly components can be found here (or your nearest mirror) https://dl.fedoraproject.org/pub/fedora-secondary/development/25/
15:30:03 <pwhalen> there are also nominated nightlies here (for armv7)- https://fedoraproject.org/wiki/Test_Results:Current_Summary
15:30:14 <jonmasters> (may not be on all mirrors since aarch64 is secondary)
15:30:26 <pbrobinson> #info ARMc7  Fedora 25 nightly components can be found here (or your nearest mirror) http://dl.fedoraproject.org/pub/fedora/linux/development/25/
15:30:52 <pbrobinson> #info mirror list for both primary and alt arches is here https://admin.fedoraproject.org/mirrormanager/
15:31:33 <pwhalen> #info Test all the things.
15:31:55 <pbrobinson> cov: if you've got any queries about it feel free to ping on #fedora-arm at any point
15:32:15 <pwhalen> #topic 5) == Open Floor ==
15:32:57 <cov> thanks
15:33:25 <pbrobinson> anyone got any random questions?
15:33:41 <pbrobinson> arm related of course :-P
15:34:59 <pbrobinson> jonmasters: your very quiet :-P
15:35:06 <pbrobinson> you're even....
15:35:10 <jonmasters> hahahahaha
15:35:36 <jonmasters> plotting and scheming. I think you and I were fairly aligned earlier. I'll poke internally on U-Boot progress, and look at the ACPI table fixes needed for m400
15:36:28 <jonmasters> also 48-bit VA prep for F25 is a thing that should happen
15:36:39 <pwhalen> #action jonmasters - Plotting and Scheming.
15:36:41 <pbrobinson> jonmasters: I have to adjust the u-boot packages so we can ship the ELF u-boot for qemu
15:36:56 <pbrobinson> jonmasters: then I think I should have a working demo of the issue I'm seeing
15:37:14 <jonmasters> ok
15:37:25 <pbrobinson> jonmasters: I'm just waiting for details from you about 48bit VA
15:37:46 <jonmasters> I've asked internally for someone to drive this for RHELSA but I want Fedora done first - ARM know this too (hint)
15:38:32 <jonmasters> so what I expect is for interested parties/partners to drive this upstream and get it working in Fedora properly, but I am also looking for someone internal to RH to help assist with lining things up
15:38:38 <pbrobinson> jonmasters: which u-boot are you referring to?
15:39:10 <jonmasters> for U-Boot, I mean a v7 one built for aarch64 to run VMs for v7 builders - the above was about 48-bit VA prep tho
15:40:16 <jonmasters> there is one overarching goal I can see for the next year that straddles internal and external stuff, and that is getting VM device assignment to work well. That touches 48-bit VA, as well as SMMU activity, KVM, QEMU, VM machine models, lots of things
15:40:29 <pbrobinson> jonmasters: cool, can you ensure they sync with me please, I can spill my brain
15:40:34 <jonmasters> yep
15:40:42 <pbrobinson> won't be on the conf call this evening
15:41:01 <jonmasters> I just want someone to help coordinate the package rebuilds and stuff for 48-bit that's not me to ensure it's someone's focus
15:41:30 <pbrobinson> jonmasters: you were going to send me any kernel bits or verify it was just the one option to change
15:41:47 <jonmasters> kernel wise it's just the one option
15:42:02 <jonmasters> and it might even work without VM bugs being exposed in the latest kernels ;)
15:42:15 <pbrobinson> OK
15:42:15 <jonmasters> but there's that pesky issue of breaking userspace
15:42:32 <jonmasters> I want to make sure someone is tracking all of the places that break with mozjs or similar
15:42:39 <pbrobinson> jonmasters: will look at doing a test kernel for people to play with
15:43:03 <jonmasters> and that means fixing the upstream projects and getting folks to use them, not just hacking up the Fedora packages (the mistake that ARM made yet again last time)
15:43:43 <jonmasters> so the person driving this (to be figured out) is going to have to track down any places where e.g. desktop folks need to be convinced and do that convincing
15:44:06 <jonmasters> pbrobinson: thanks for the test kernel
15:44:09 <pbrobinson> yep, so the usual then
15:44:37 <jonmasters> pbrobinson: I spoke with Mark Langsdorf about this yesterday and we agreed we're going to push everyone to do things in upstream and Fedora before they come crying for them in RHEL. Sick and tired of it being the other way
15:44:44 <pbrobinson> jonmasters: so my x86 laptop rpeorts "address sizes	: 39 bits physical, 48 bits virtual"
15:45:10 <pbrobinson> presumably the issue is around assumptions on aarch64 specifically then?
15:45:42 <jonmasters> yes, and the shift specifically, as on x86 pointer tagging when it is used uses a different shift
15:47:14 <jonmasters> our achilles heel seems to be coordinating kernel and userspace interaction for these things. It's amazing sometimes that anything happens in Linux with these different camps being separate :) I guess that's +1 for an aarch64 discussion at Plumbers or something
15:47:48 <jonmasters> I'm hoping to rope cov into helping with 48-bit VA. We need competent partners engaged in this as well ;)
15:48:35 <pbrobinson> jonmasters: interesting /proc/cpuinfo doesn't report it on aarch64, any idea where you can verify it there?
15:48:58 <jonmasters> cov was working on getting an aux vector added to report the VA space
15:49:06 <jonmasters> I don't know the latest
15:49:36 <jonmasters> this is why I need someone to help drive who can fault in the latest and be given a brain dump to get started
15:49:53 <jonmasters> I'll try to get that moving today. This might end up being an F26 thing, but if we don't do it now, it'll never happen
15:50:33 <jonmasters> I think we could also do with gathering a few thoughts for the next year on similar stuff we want to do - especially with VMs and virt and the like
15:50:47 <jonmasters> I can sync with pwhalen and see about getting some stuff into the wiki
15:51:21 <jonmasters> anyway, that's mostly what I have for now. Thanks for letting me ramble
15:51:53 <pbrobinson> I think rawhide/f26 is the best spot to start, easy to pull fixes back to f25 then
15:51:53 <pwhalen> ramble on.. as Jimmy used to say.. :)
15:52:01 <jonmasters> pbrobinson: +1
15:52:37 <jonmasters> first and foremost is to make sure we get the last piece into 4.9 (PCI quirks) to make ARM servers actually useful (where's my laughing crying emoji when I want it?)
15:52:42 <pbrobinson> even emails to the list would be a start, it's easy to find
15:52:50 <jonmasters> sure, point noted :)
15:52:59 <pbrobinson> right, anyone else with anything?
15:53:15 <pwhalen> last call..
15:53:26 <pwhalen> #endmeeting