15:37:47 <dgilmore> #startmeeting RELENG (2016-11-14)
15:37:47 <zodbot> Meeting started Mon Nov 14 15:37:47 2016 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:37:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:37:47 <zodbot> The meeting name has been set to 'releng_(2016-11-14)'
15:37:47 <dgilmore> #meetingname releng
15:37:47 <zodbot> The meeting name has been set to 'releng'
15:37:47 <dgilmore> #chair dgilmore nirik tyll sharkcz bochecha masta pbrobinson pingou maxamillion mboddu
15:37:47 <zodbot> Current chairs: bochecha dgilmore masta maxamillion mboddu nirik pbrobinson pingou sharkcz tyll
15:37:50 <dgilmore> #topic init process
15:37:54 <nirik> morning
15:37:57 <maxamillion> .hello maxamillion
15:37:58 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:38:09 <mboddu> .hello mohanboddu
15:38:10 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
15:38:19 <sharkcz> .hello sharkcz
15:38:19 <zodbot> sharkcz: sharkcz 'Dan HorĂ¡k' <dan@danny.cz>
15:38:51 <pwhalen> .hello pwhalen
15:38:52 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
15:39:12 * pbrobinson o/
15:40:21 * masta is here, kinda. (in another meeting)
15:40:38 <bowlofeggs> .hello bowlofeggs
15:40:40 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
15:40:45 <dgilmore> lets get started
15:40:51 <dgilmore> #topic pagure
15:41:12 <dgilmore> nirik: what is the status of the issue preventing ticket importing?
15:41:36 <nirik> I haven't heard anything. Will ping on it.
15:42:16 <nirik> https://pagure.io/pagure-importer/issue/60
15:42:55 <pbrobinson> seems we also have an issue with not all merges working too
15:42:56 <dgilmore> #info nothing further yet
15:43:15 <dgilmore> pbrobinson: thats not really relevent for this topic
15:43:29 <dgilmore> this is just about migrating the issues
15:43:45 <dgilmore> though I was very vague
15:44:11 <pbrobinson> dgilmore: well the topic is "pagure" which to me is general so be more specific in the topic naming then
15:44:24 <dgilmore> not intentional
15:44:26 <dgilmore> or intended
15:44:45 <dgilmore> I was only intending to bring up the issue of importing the issues
15:45:04 <dgilmore> any issues with bugs in pagure need to be filed with pagure for pingu to deal with
15:45:15 <dgilmore> but it does seem to be an issue
15:45:18 <nirik> yep. Please do file stuff as you see it
15:45:31 <dgilmore> #info seems to be a random issue of PR's failing to be merged
15:46:19 <dgilmore> https://pagure.io/pagure/issue/1190
15:46:28 <dgilmore> pbrobinson: there is an issue open for it
15:47:15 <pbrobinson> dgilmore: will add some details to it
15:48:28 <dgilmore> does anyone have anything else on pagure?
15:49:16 <nirik> oh, did we want to adjust the messages to #fedora-releng any?
15:49:46 <dgilmore> probably
15:50:19 <nirik> it might be nice to see PR's opened on some projects there... to remind us to look at/merge them
15:50:30 <dgilmore> I do not like that messages go to #fedora-admin and #fedora-apps for every comment to a issue
15:50:47 <dgilmore> but it would be good to have messages for new and closed issues and PR's
15:51:45 <nirik> that is an issue because admin has 'fedora-infrastructure' pagure, and apps has 'infrastructure' in the body... I will fix that sometime, but we are in freeze, and its not been high pri
15:51:58 <dgilmore> nirik: do we file an issue with infra to update the irc bot configs?
15:52:03 <nirik> yes
15:52:15 <dgilmore> nirik: its not just the duplication
15:52:34 <nirik> to be more clear, apps has the github 'infra' stuff by looking at the body... which also matches pagure fedora-infrastructure stuff
15:52:40 <dgilmore> nirik: the noise of a message for every comment gets noisy
15:53:13 <nirik> well, it lets you know when/what issues are active and need to be looked at...
15:53:15 <dgilmore> just doubly annoying when its in both and koji is in the issue name
15:53:37 <dgilmore> sure
15:53:49 <dgilmore> there needs to be a good signal to noise ratio
15:53:58 <nirik> but yeah, we can try and adjust this stuff. I guess we should just wait until after freeze then we can tweak it as we like.
15:54:03 <dgilmore> and I think that the infra ones are a bit too much noise
15:54:29 <dgilmore> but that may be my opinion alone
15:55:23 <dgilmore> #info post freeze we will look at some options
15:55:27 <dgilmore> #undo
15:55:28 <zodbot> Removing item from minutes: INFO by dgilmore at 15:55:23 : post freeze we will look at some options
15:55:54 <dgilmore> nirik: well I am going to be on PTO for the next two weeks
15:56:03 <dgilmore> so we can look at it
15:56:17 <nirik> cool. We can mess it all up for your return. ;)
15:56:18 * nirik runs
15:56:37 <dgilmore> #info post freeze we will look at some options for getting messages from pagure into #fedora-releng
15:56:42 <dgilmore> :P
15:57:03 <dgilmore> #topic Alternative Architectures updates
15:57:16 <dgilmore> pbrobinson: sharkcz: how are things looking for Fedora 25?
15:58:19 <sharkcz> they still look good, except the broken dep issue (anaconda addon <-> docker) breaking the rc compose
15:58:33 <sharkcz> but nightlies are correct
15:58:50 <dgilmore> okay
15:59:00 <dgilmore> is that an issue that is fixable?
15:59:42 <sharkcz> it must be, pbrobinson should know more about the cause, looks like a slight diff between the nightlies and the rc setup
16:00:04 <pbrobinson> I believe it's skopeo (sp?)
16:00:08 <sharkcz> yes
16:00:45 <pbrobinson> seems to be the same issue on all alt arches and in typical dnf fashion there's near zero output of use as to what the problem actually it
16:01:16 <sharkcz> but when I check the s390 rc repo, it should be all there, at least from repodiff output (but it's yum-based, no dnf-based version yet ...)
16:01:53 <pbrobinson> yep
16:01:56 <dgilmore> #info alternative arch f25 composes failing due to some package conflicts.
16:02:23 <sharkcz> for the record - dnf2 in rawhide has the outputs much improved
16:02:49 <dgilmore> sharkcz: they still miss many use cases
16:03:00 <dgilmore> I have tried to get our bug priority raised
16:05:29 <dgilmore> https://bugzilla.redhat.com/show_bug.cgi?id=1303978
16:06:25 <dgilmore> #info bug that needs to be resolved to make debugging compose/build issues
16:07:05 <dgilmore> anything else we need to discuss?
16:07:24 <nirik> I wanted to talk a bit about the dec 12th flag day.
16:08:21 <dgilmore> okay, we can get to that
16:08:30 <dgilmore> #topic Flag Day on Dec 12th
16:08:39 <dgilmore> nirik: what is up?
16:08:59 <nirik> so, I think we should write up everything we are doing, make sure all the packages are pushed (just fedpkg?) and announce it...
16:09:17 <maxamillion> what is Flag Day as it relates to Fedora?
16:09:42 <maxamillion> I've heard that term before but I'm not familiar with how it relates to Fedora
16:10:08 <masta> when things change, things might break, but not if the plan is written out and thought about.
16:10:29 <nirik> my understanding: 1) switch sources lookaside to sha256, 2) switch to kerb auth? 3) disable certs 4) change koji.fedoraproject.org and pkgs.fedoraproject.org ssl certs to be the well known one 5) start gating/signing all rawhide, 6) ?
16:10:35 <dgilmore> nirik: we need a koji update with gssapi support
16:10:54 <nirik> maxamillion: basically a day where we say: this changes, you need the new version of your client to keep working.
16:11:16 <dgilmore> maxamillion: we are making changes that will break existing setups
16:11:27 <dgilmore> people will need to do something to have things work
16:11:41 <nirik> sso, a koji update and a fedpkg for the rawhide targets... we ended up not needing a kerb change for fedora-packager right?
16:12:10 <dgilmore> which will be new koji configs, needing a newer fedpkg, fedora-packager
16:12:41 <dgilmore> nirik: right we will need new koji configs which is koji and fedora-packager
16:13:23 <dgilmore> rhel6 is getting harder to support as a client os
16:13:32 <maxamillion> nirik: what?
16:13:48 <maxamillion> nirik: oh ok, sorry .. nvm
16:13:52 <maxamillion> my brain didn't properly parse that
16:14:08 <dgilmore> we need to start communicating it loudly
16:14:35 <nirik> yeah. we should get the updates out at least by f25 release and send a prelim announcement to devel-announce about it.
16:14:55 <nirik> did we have a ticket for this? I cannot seem to find it.
16:14:57 <dgilmore> #action dgilmore to get toegethr the list of server side and client side changes, send email to devel-announce, and blog about it
16:15:05 <dgilmore> nirik: not sure we did
16:15:23 <nirik> ah, there it is: https://fedorahosted.org/rel-eng/ticket/6111
16:16:58 <nirik> cool. Thats all... thanks.
16:17:11 <dgilmore> thats a bit incomplete and out of date
16:17:38 <nirik> yeah
16:17:50 <dgilmore> I will add some comments there also
16:18:02 <nirik> oh, looks like that pagure importer issue was already fixed. New release will be out tonight/tomorrow... I can move things as soon as it's available.
16:18:22 <dgilmore> nirik: awesome
16:18:25 <dgilmore> #topic livecd-creator
16:19:00 <dgilmore> so overthe weekend there was a notice that some people had forked livecd-creator and ported to dnf and python3
16:19:14 <dgilmore> which is not a good thing
16:19:26 <nirik> well, it's open source, they are welcome to...
16:19:34 <dgilmore> apparently some people have found livemedia-creator to hard to use
16:19:44 <nirik> not that it obligates us to use it. :)
16:19:54 <dgilmore> nirik: sure. it just is not the most helpful thing
16:20:33 <dgilmore> in a discussion on Saturday night I commited to writing up some docs on how it all works in fedora
16:20:45 <dgilmore> people using the tools we use seems best
16:21:27 <dgilmore> i also wondered about havinga  pungi-build-livemedia command or something like it, that can mimic how we make a livecd in koi
16:21:42 <dgilmore> but do it locally in mock
16:21:57 <masta> that would be cool
16:22:28 <dgilmore> just to simplify the steps
16:22:41 <nirik> sounds good
16:22:48 <pbrobinson> yes, I thin that would be useful
16:23:02 <dgilmore> seems that the people doing respins feel like the tools we use do not work for them and it is too hard to get things fixed
16:23:29 <dgilmore> #info we need better documentation on how we run tools in Fedora
16:23:53 <dgilmore> #info having a tool to mimic how we build livecds in koji locally would be useful
16:24:14 <maxamillion> +1
16:24:40 <dgilmore> I think the same is probaby true of docker base  images, cloud images etc also
16:25:19 <dgilmore> anyway  just wanted to bring it up to raise awareness
16:25:26 <dgilmore> #topic Open Floor
16:25:37 <dgilmore> does anyone have anything to bring up?
16:25:49 <nirik> dgilmore: you are gone next week? or ?
16:26:14 <dgilmore> nirik: I will be gone for two weeks
16:26:25 <dgilmore> will need someone to run the meeting
16:26:40 <dgilmore> https://fedoraproject.org/wiki/ReleaseEngineering/Meeting_Process lays out how
16:26:43 <nirik> so you are back the 5th?
16:26:48 <dgilmore> though it will need some updates for pagure
16:26:52 <dgilmore> nirik: I am
16:27:12 <nirik> cool. ok. Note that puiterwijk and I will be out at PHX2 datacenter that week.
16:27:18 <dgilmore> I will have limited to no computer access from November 9th to December 4th
16:27:34 <dgilmore> Novemnber 19th
16:27:43 <maxamillion> I was about to say ;)
16:27:58 <dgilmore> #info dgilmore to be away from computer from November 19th to December 4th
16:28:51 <nirik> I suppose I could run meetings most likely... although next week I might be prepping for release (I hope)
16:29:15 <dgilmore> hopefully
16:29:46 <dgilmore> mboddu: will you be able to run the meeting?
16:30:02 <mboddu> dgilmore: I think I can
16:30:20 <dgilmore> #info mboddu to run the meeting the next two weeks
16:31:04 <dgilmore> mboddu: once the issues are all imported into pagure I will update the wiki page
16:31:12 <dgilmore> it updates the dates automatically
16:31:35 <mboddu> dgilmore: okay
16:31:42 <dgilmore> I will go over it with you later in the week
16:31:47 <mboddu> sure
16:31:56 <dgilmore> anything else we need to cover?
16:32:54 <dgilmore> #endmeeting