#fedora-meeting-2: RELENG (2017-01-16)

Meeting started by dgilmore at 15:34:03 UTC (full logs).

Meeting summary

  1. init process (dgilmore, 15:34:06)
    1. https://pagure.io/releng/issues?status=Open&tags=meeting (dgilmore, 15:35:31)

  2. Alternative Architectures updates (dgilmore, 15:39:04)
    1. sharkcz is checking with pbrobinson on shadow host reinstall and gettign the automation back running (dgilmore, 15:40:50)
    2. there is currently insufficent power builders (dgilmore, 15:46:03)
    3. we have not yet setup hosts to do aarch64 or power image builds on (dgilmore, 15:46:22)
    4. we need to identify changes needed to the bodhi processes for f26 to push alternate uarch updates to the correct locations (dgilmore, 15:49:15)

  3. 130 consider longer logs retention for koschei (dgilmore, 15:57:36)
    1. https://pagure.io/releng/issue/130 (dgilmore, 15:57:42)
    2. AGREED: we will change the log file retention from 1 day to 7 days for koschei (dgilmore, 15:59:29)

  4. 133 Enable Signed Repository Metadata (dgilmore, 16:00:29)
    1. https://pagure.io/releng/issue/133 (dgilmore, 16:00:36)
    2. we agree there is value in signing repodata (dgilmore, 16:06:45)
    3. ACTION: rhartman to follow up with the spacwalk teams code bases on signing of repodata and how it would work for them (dgilmore, 16:15:16)
    4. lets follow up next week. If someone wants to work on this please reach out to dgilmore (dgilmore, 16:17:58)

  5. #6557 Something broken in Rawhide's koji (dgilmore, 16:18:31)
    1. https://pagure.io/releng/issue/6557 (dgilmore, 16:18:39)
    2. we need to do better at triaging issues and providing feedback. the issue that resulted in this ticket seems to be a elfutils bug on aarch64 (dgilmore, 16:21:08)
    3. nirik added a kojipkgs02 instance (setup exactly like the 01 one)... then we moved both of them behind proxy01/10 and haproxy. (dgilmore, 16:24:40)
    4. new issue is that we seem to frequently get corrupted srpm downloads for build tasks (dgilmore, 16:26:38)
    5. new issue is that buildvm's seem unstable after moving to f25 (dgilmore, 16:26:56)
    6. new issue is that armv7hl builds get killed by oom much more frequently than previously (dgilmore, 16:27:31)
    7. https://bugzilla.redhat.com/show_bug.cgi?id=1413314 is some of the dmesg with 4.9.x kernel (nirik, 16:29:46)
    8. ACTION: puiterwijk, nirik and dgilmore to do more investigation (dgilmore, 16:33:40)
    9. arm builders are happier on 4.9 kernel (dgilmore, 16:34:32)

  6. #6570 Fedora Core 1 archive incomplete (dgilmore, 16:36:12)
    1. https://pagure.io/releng/issue/6570 (dgilmore, 16:36:20)
    2. we assume that something in the archiving process caused the issues (dgilmore, 16:40:37)
    3. dgilmore has access to the internal Red Hat copy of FC-1 it however looks different to what was shipped (dgilmore, 16:41:07)
    4. we should put back the missing content (dgilmore, 16:45:19)
    5. ACTION: dgilmore will put back the missing content (dgilmore, 16:45:33)
    6. ACTION: file an issue for new tooling to be using in archiving releases (dgilmore, 16:46:02)

  7. #6577 Fedora 26 mass rebuild (dgilmore, 16:46:37)
    1. https://pagure.io/releng/issue/6577 (dgilmore, 16:46:44)
    2. ACTION: dgilmore to add mboddu to list to recieve releng@fp.o email (dgilmore, 16:51:16)
    3. ACTION: dgilmore to add masta to list to recieve releng@fp.o email (dgilmore, 16:54:00)
    4. need to determine the status of all things needed prior to the mass rebuild (dgilmore, 16:54:25)

  8. #6578 run repoclosure before mering mass rebuilds (dgilmore, 16:55:33)
    1. https://pagure.io/releng/issue/6578 (dgilmore, 16:55:40)
    2. ACCEPTED: we will run repoclosure on side targets before merging (dgilmore, 16:59:46)
    3. ACTION: dgilmore to update the sop on how to run repoclosure (dgilmore, 17:00:02)

  9. #6587 PDC ownership in Fedora (dgilmore, 17:00:17)
    1. https://pagure.io/releng/issue/6587 (dgilmore, 17:00:23)
    2. https://pdc.fedoraproject.org/ (dgilmore, 17:02:32)
    3. somoene is needed to shppard and love PDC for us (dgilmore, 17:03:44)
    4. we need someone to guide and shappard it for Fedora's needs. be involved in upstream. ensure we get code updates and make the most of what PDC offers us (dgilmore, 17:04:40)

  10. Open Floor (dgilmore, 17:05:13)


Meeting ended at 17:07:57 UTC (full logs).

Action items

  1. rhartman to follow up with the spacwalk teams code bases on signing of repodata and how it would work for them
  2. puiterwijk, nirik and dgilmore to do more investigation
  3. dgilmore will put back the missing content
  4. file an issue for new tooling to be using in archiving releases
  5. dgilmore to add mboddu to list to recieve releng@fp.o email
  6. dgilmore to add masta to list to recieve releng@fp.o email
  7. dgilmore to update the sop on how to run repoclosure


Action items, by person

  1. dgilmore
    1. puiterwijk, nirik and dgilmore to do more investigation
    2. dgilmore will put back the missing content
    3. dgilmore to add mboddu to list to recieve releng@fp.o email
    4. dgilmore to add masta to list to recieve releng@fp.o email
    5. dgilmore to update the sop on how to run repoclosure
  2. masta
    1. dgilmore to add masta to list to recieve releng@fp.o email
  3. mboddu
    1. dgilmore to add mboddu to list to recieve releng@fp.o email
  4. nirik
    1. puiterwijk, nirik and dgilmore to do more investigation
  5. puiterwijk
    1. puiterwijk, nirik and dgilmore to do more investigation
  6. UNASSIGNED
    1. rhartman to follow up with the spacwalk teams code bases on signing of repodata and how it would work for them
    2. file an issue for new tooling to be using in archiving releases


People present (lines said)

  1. dgilmore (183)
  2. nirik (53)
  3. masta (19)
  4. puiterwijk (12)
  5. zodbot (10)
  6. sharkcz (9)
  7. mboddu (6)
  8. maxamillion (4)
  9. rhartman|rh (3)
  10. rsc (2)
  11. linuxmodder (1)
  12. tyll (0)
  13. bochecha (0)
  14. pbrobinson (0)
  15. pingou (0)


Generated by MeetBot 0.1.4.