14:00:13 <stickster> #startmeeting Worktation WG
14:00:13 <zodbot> Meeting started Mon Feb 13 14:00:13 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:13 <zodbot> The meeting name has been set to 'worktation_wg'
14:00:16 <stickster> #meetingname workstation
14:00:16 <zodbot> The meeting name has been set to 'workstation'
14:00:18 <stickster> #topic Roll call
14:00:21 <stickster> .hello pfrields
14:00:22 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
14:00:25 <kalev> .hello kalev
14:00:26 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
14:01:05 <stickster> #chair kalev juhp mcatanzaro
14:01:05 <zodbot> Current chairs: juhp kalev mcatanzaro stickster
14:02:13 <stickster> o/ kalev, sorry it's so quiet today :-)
14:02:29 <x3mboy> .hello x3mboy
14:02:30 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
14:02:49 <juhp_> .hello petersen
14:02:50 <zodbot> juhp_: petersen 'Jens Petersen' <petersen@redhat.com>
14:02:55 <stickster> o/ juhp_
14:03:21 * stickster gives a couple more minutes for stragglers
14:03:21 <juhp_> hi stickster
14:03:44 <mcatanzaro> .hello mcatanzaro
14:03:45 <zodbot> mcatanzaro: Sorry, but you don't exist
14:03:51 <mcatanzaro> .hello catanzaroe
14:03:52 <zodbot> mcatanzaro: Sorry, but you don't exist
14:03:52 <stickster> that's just rude zoddie
14:03:53 <mcatanzaro> ugh
14:03:57 <mcatanzaro> .hello catanzaro
14:03:58 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
14:04:11 <mclasen__> .hello mclasen
14:04:12 <mcatanzaro> \o/
14:04:12 <zodbot> mclasen__: mclasen 'Matthias Clasen' <mclasen@redhat.com>
14:04:20 <stickster> #chair mclasen__
14:04:20 <zodbot> Current chairs: juhp kalev mcatanzaro mclasen__ stickster
14:04:53 <stickster> We've got quorum, so let's get started... hopefully will see cschalle, otaylor, rdieter shortly
14:05:04 <stickster> #topic Performance tuning
14:05:31 <stickster> So the two items we had pending were (1) running systemd-readahead by default; and (2) CFQ vs. deadline scheduler by default
14:06:46 <stickster> We have a little time for self-contained changes, and I would consider these in that bin because they shouldn't involve any other system changes
14:07:26 * kalev isn't particularly well versed in kernel tuning.
14:07:49 <mclasen__> systemd-readahead is not a thing anymore, I thought ?
14:08:00 <mclasen__> didn't they drop it from systemd as irrelevant
14:08:24 <stickster> it still seems to be in F25 I think?... 'locate systemd-readahead'
14:08:50 <mcatanzaro> No, systemd-readahead was removed upstream
14:08:57 <stickster> oh wait, looks like locatedb out of date here
14:09:05 <stickster> welllll I guess that takes care of that item :-D
14:09:06 <mcatanzaro> We'd have to (a) patch it back in, or (b) use another readahead (Ubuntu maintains its own)
14:09:38 <mcatanzaro> The problem is removing systemd-readahead regressed boot time by roughly 40% unless you have an SSD, so we look pretty bad in comparison to Ubuntu on boot time now....
14:10:14 <juhp_> hmmm
14:10:17 <mcatanzaro> (i.e. it's not some minor optimization, it's a big deal)
14:10:41 <mclasen__> are there actual numbers somewhere ?
14:10:49 <stickster> yeah, I'd like to see those too
14:10:58 * mcatanzaro checks desktop list
14:11:13 <juhp_> is it since f25?
14:11:25 <mcatanzaro> juhp_: Since F22
14:11:29 <mclasen__> no, its been gone longer
14:11:29 <juhp_> ah
14:12:32 <mcatanzaro> There are numbers at http://www.hecticgeek.com/2015/06/fedora-22-review/ and http://www.hecticgeek.com/2016/12/fedora-25-review/. A bit anecdotal, but he's performing fresh installs and the difference is major.
14:13:54 <stickster> Hm, that is a pretty radical difference
14:14:16 <stickster> sesivany__: Do you know the story about this Endless patch and what it entails?
14:14:20 <mcatanzaro> Looks more like 35%
14:15:09 <mcatanzaro> stickster: It's pretty self-contained: https://github.com/endlessm/systemd/commit/793bb2abdb09fe8d57619bf9f7a231d56119d6e7
14:15:30 <stickster> Oh I see, just undoing the upstream drop
14:15:42 <mcatanzaro> Follow-ups: https://github.com/endlessm/systemd/commit/249ad5889afa8b195447532212431ce3584b7658 https://github.com/endlessm/systemd/commit/dd617a8302f3d9adbe71404cfbddc40eabba191c https://github.com/endlessm/systemd/commit/538cbc03535ecf32ac69454d2a4776e79b46f3d8
14:15:46 <stickster> but the readahead stuff is not maintained, AIUI
14:15:55 <mcatanzaro> (follow-ups look like they're for ostree)
14:16:04 <mcatanzaro> Right, it's unmaintained, which is why it was removed.
14:16:19 <juhp_> mclasen__, "irrelevant" means irrelevant to systemd?
14:16:32 <mclasen__> irrelevant to performance on modern laptops
14:16:36 * stickster doesn't like the idea of Workstation or Fedora maintainers picking up responsibility for this
14:16:39 <juhp_> ah
14:16:49 <stickster> better off finding a maintained upstream and trying that
14:17:01 <mclasen__> I'm maybe not the right person to talk, I reboot maybe once a month, at most
14:17:30 <juhp_> I only boot much at home... on a hdd
14:18:21 <mcatanzaro> It's irrelevant to performance if you have an SSD, yes. Laptops without SSDs are still selling, believe it or not!
14:18:43 <mclasen__> even if I had one of those, I wouldn't boot more than once a month...
14:18:44 <juhp_> unless ubuntu's solution would work for us, it may not be long hanging fruit :)
14:19:03 <stickster> IIUC theirs is "preload," and that appears to be packaged in Fedora
14:19:23 <juhp_> s/long/low/
14:19:37 <stickster> oh wait, I'm looking way back at 12.04
14:19:39 <mclasen__> its been hanging since f22, so long was alright...
14:19:58 <stickster> Nope, appears to be in modern U too
14:20:37 <stickster> mcatanzaro: juhp_ : Do you have any spinning disk systems?
14:20:59 <juhp_> mclasen__, haha
14:21:17 <juhp_> stickster, only :)
14:21:25 <mcatanzaro> stickster: I have an unused spinning disk that I could install stuff on. Not really motivated to work on it, though; just complaining. ;)
14:21:50 <juhp_> as in I don't have any SSDs
14:22:34 <juhp_> if we had readahead I would have been here slightly earlier ;)
14:23:12 <mclasen__> if we were to bring some form or readahead back, I think it would need to come with some release critera so we get it qa'ed
14:23:53 <stickster> agreed... need to make sure we aren't impacting people who are moving on to recent hw... although in truth it's much less noticeable then
14:24:29 <juhp_> I guess it is hard to detect hdd's?
14:24:46 <stickster> juhp_: Rotating vs. SSD? Don't know.
14:24:54 <juhp_> right
14:25:22 <juhp_> then again having separate paths may not be desirable for QA
14:26:00 <juhp_> I hope my next laptop will have an SSD
14:26:28 <juhp_> next year probably though
14:27:05 <stickster> Well look, if we want to move ahead here, I think the things to do are: (1) figure out what other faster-booting-on-spinning-rust distros are using for readahead; (2) see whether that can be used easily on Fedora; (3) test and gather data to see what the results are
14:27:43 <stickster> and those mean someone taking up that particular banner
14:28:02 <stickster> I have zero rotating media here at the moment, laptops + desktop all have SSDs
14:28:20 <mcatanzaro> Maybe we could float it by the new performance group and see if they're interested. (There is a new performance group, right? I'm not making that up?)
14:28:47 <stickster> mcatanzaro: like a performance SIG in Fedora?
14:29:10 <stickster> #chair cschalle
14:29:10 <zodbot> Current chairs: cschalle juhp kalev mcatanzaro mclasen__ stickster
14:30:18 * stickster wondering who this group is
14:30:28 <mcatanzaro> stickster: No, I thought I saw something fly by somewhere (a blog post maybe?) about some performance tuning group inside Red Hat that would be working on Fedora... you know, it might have been laptop battery life, that's not really related to this.
14:31:06 <mcatanzaro> Anyway I think nobody here wants to work on it, so we can keep it in the back of our minds and move on to the next item I guess.
14:31:07 <stickster> mcatanzaro: I think that was just a subset of people already involved in Workstation/desktop who were looking at various power management issues, more like a short term project
14:31:45 <stickster> Yeah, I don't see this as having a lot of incentive since it means picking up some kind of long-term maintenance
14:32:25 <stickster> Anyone beg to differ?
14:33:17 <cschalle> nope
14:33:19 <stickster> #agreed readahead is not really a priority, btw sticking with upstream and not having anyone willing to take up additional testing and then long-term maintenance
14:33:26 <juhp_> +1
14:33:28 <stickster> Let's move on to CFQ vs. deadline
14:34:57 <stickster> AIUI deadline is likely better for most desktop users, definitely better for SSD users
14:35:33 <stickster> So if we wanted to set this, it would be via the fedora-release-workstation package... do we do this via /etc/sysctl.d/ ? or something else?
14:36:20 <mclasen__> I think that was what josh outlined on the list ?
14:36:46 <mclasen__> dropping a file in there. or would this be a systemd preset ?
14:37:16 <stickster> that's what I was wondering... but only because I fumbled around and couldn't find the answer via /proc/sys/
14:38:11 <stickster> I know it's tunable via /sys/block/sda/ somewhere
14:39:10 <stickster> Has anyone asked Server WG about this?
14:39:29 <mclasen__> I don't think we need to figure out the exact mechanics here though ? enough to decide we want to do it, then I can tag somebody with figuring it out
14:39:35 <stickster> yeah
14:39:46 * rdieter waves late, sorry (got pulled out of the office for a bit)
14:39:53 <stickster> mclasen__: I would say it's worth putting in a change now, so that we get some test data out of e.g. Alpha
14:40:09 <stickster> #chair rdieter
14:40:09 <zodbot> Current chairs: cschalle juhp kalev mcatanzaro mclasen__ rdieter stickster
14:40:11 <stickster> o/ Rex
14:40:27 <mclasen__> right, so do we need to cobble together a f26 change page for this ?
14:40:36 <juhp_> So it is also a IO related thing?
14:40:37 <stickster> sgallagh: Did you see any of this conversation on CFQ vs. deadline via the list last month?
14:40:45 <stickster> juhp_: correct... default storage scheduler
14:40:51 <juhp_> thanks
14:41:02 <sgallagh> /me reads scrollback
14:41:28 <sgallagh> I remember reading about it at the time, but let me quickly refresh my memory.
14:41:34 <stickster> sgallagh: The only question for you/Server WG to ponder is whether changing to 'deadline' default would be useful at all for Server
14:41:48 <stickster> Otherwise we can just do this via the -workstation specific defaults
14:42:19 <sgallagh> stickster: Well, the real question should be "does it make sense as a general Fedora default?".
14:42:32 <stickster> sgallagh: it doesn't for Cloud from what I understand
14:42:55 <sgallagh> stickster: Let me rephrase: we should make the best decision for all of Fedora, then have specific exemptions.
14:43:16 <sgallagh> e.g., if Cloud is the only one it doesn't benefit, have *them* diverge
14:43:42 <sgallagh> I'd kind of like to take this to FESCo for evaluation, rather than try to come up with an answer off the cuff.
14:43:58 <sgallagh> (I thought someone was going to open a FESCo ticket back when this originally came up, but it didn't happen)_
14:44:30 <stickster> sgallagh: https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/message/DYZ2KXSASAYAO5KSK3N6MOYVCLYVGRDV/ also
14:45:03 <stickster> drago01 suggests that this could impact background I/O on things like tracker, which I believe we still use
14:45:23 <stickster> or rather, that it would impact users when that background I/O is happening
14:45:44 <sgallagh> Question: how is this configured? Can it be done as a tuned profile?
14:45:51 <stickster> in those cases, it's pretty much assured unskilled users would start flailing and turning things off
14:46:03 <stickster> sgallagh: we don't know the mechanics, but it's a runtime tunable in some form.
14:46:05 <sgallagh> Meaning: If we set it one way, can we make it really easy to switch to a different profile in Cockpit?
14:46:09 <stickster> yes
14:47:03 <stickster> sgallagh: cat /sys/block/sda/queue/scheduler
14:47:22 <stickster> or, 'echo deadline > /sys/block/sda/queue/scheduler'
14:47:33 <sgallagh> hmm
14:47:48 <stickster> That's per disk, there's a place to set it as the system wide policy
14:48:19 <mclasen__> mine says: noop deadline [cfq]
14:48:20 <sgallagh> stickster: I'd *much* rather see us figure out how to build a tuned profile that was e.g. "Desktop on SSD" or "Desktop on Spinning Rust", etc.
14:48:36 * mclasen__ would prefer to stick to kernel knobs if we can
14:48:37 <stickster> mclasen__: that's correct, you're on cfq. If you echo as above, it will set the new scheduler
14:48:50 <stickster> mclasen__: it's not going to be a kernel patch. no reason to do that
14:49:01 <mclasen__> its still a kernel knob
14:49:10 <sgallagh> stickster: I think he meant that /sys is effectively a knob
14:49:11 <mclasen__> I'm talking about avoiding a userspace agent like tuned
14:49:34 <stickster> sgallagh: tell you what, can I ask you to raise FESCo ticket?
14:49:44 <sgallagh> mclasen__: I'd want to see some sort of a remotable API that Cockpit could consume though
14:49:55 <sgallagh> It doesn't have to be tuned
14:50:09 <sgallagh> stickster: Sure, on it
14:50:28 <stickster> cc me + mclasen and we'll keep up on it from Workstation side, anyone else is welcome to pile on
14:50:53 <sgallagh> stickster: Is there a Workstation ticket I can link to?
14:50:53 <stickster> #action sgallagh file FESCo ticket and stickster + mclasen__ to monitor/provide input
14:51:20 <mclasen__> sgallagh: isn't /sys such a thing ?
14:52:00 <stickster> Ha, we have fedorahosted.org/workstation but never use it.
14:52:08 <stickster> That should really move to Pagure I guess
14:52:16 <stickster> sgallagh: so, no
14:52:19 <stickster> (not atm)
14:52:19 <sgallagh> mclasen__: I'm not sure I agree with remotable.
14:52:29 <sgallagh> It's essentially a local file.
14:52:37 <mclasen__> the original assumption of cockpit was always 'deep interop, all the way down to the kernel, no userspace silos'...
14:53:08 <mclasen__> sgallagh: but thats what cockpit runs a local agent for, no ?
14:53:20 * stickster has about 3 minutes left until he has to run next meeting elsewhere
14:53:46 <stickster> #info We didn't get to flatpak, but I don't see otaylor here... will save that for next time.
14:53:57 <sgallagh> mclasen__: Let's take this to #cockpit after the meeting.
14:54:03 <sgallagh> It may be that they'll say it's fine. I'm not sure.
14:54:49 <stickster> #agreed Nominally we'd like a way to deal with scheduler tunable in cockpit, if agreeable there
14:55:17 <stickster> Sorry this discussion ran long folks... in future will try to bring more facts in my back pocket ;-)
14:55:41 <stickster> #topic Open floor (60 sec free for all)
14:56:02 <mcatanzaro> This is old, but I just found it yesterday and I think it's wonderful: https://www.reddit.com/r/linuxmemes/comments/4mi4mc/linux_torvalds_quote_about_fedora/
14:56:23 * mcatanzaro has finally put open floor to good use!
14:57:05 <mcatanzaro> It must be his highest praise
14:57:24 <stickster> the community eating its own, lovely
14:57:36 <stickster> and with that... thanks for coming everyone, see you in two weeks!
14:57:43 <stickster> (or less, on #fedora-workstation)
14:57:45 <stickster> #endmeeting