#fedora-meeting-2: RELENG (2017-02-20)

Meeting started by dgilmore at 15:34:00 UTC (full logs).

Meeting summary

  1. init process (dgilmore, 15:34:03)
  2. #6601 Migrate the rel-eng tickets from (old) trac (dgilmore, 15:36:40)
    1. https://pagure.io/releng/issue/6601 (dgilmore, 15:36:48)
    2. current status is that issues had been filed via email2trac, we can not resolve all emails to fas accounts. (dgilmore, 15:50:14)
    3. we should set all unknown to nobody (dgilmore, 15:50:30)
    4. https://fedorahosted.org/rel-eng/query?reporter=~%3C&col=id&col=summary&col=status&col=type&col=milestone&col=component&order=priority (nirik, 15:50:30)
    5. pingou wants to wait until 2.13 of pagure is deployed (dgilmore, 15:50:56)
    6. we have until Feb 28 to complete task (dgilmore, 15:51:22)
    7. https://fedorahosted.org/rel-eng/ticket/26 we could probably just delete (dgilmore, 15:51:51)

  3. #6577 Fedora 26 mass rebuild (dgilmore, 15:54:24)
    1. https://pagure.io/releng/issue/6577 (dgilmore, 15:54:25)
    2. ACTION: mboddu to run the scripts that output failure and needs rebuild lists for at least 4 more weeks (dgilmore, 15:56:35)
    3. http://dl.fedoraproject.org/pub/alt/mass-rebuild/f26-failures.html (dgilmore, 15:57:35)
    4. http://dl.fedoraproject.org/pub/alt/mass-rebuild/f26-need-rebuild.html (dgilmore, 15:57:40)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=1423041 (dgilmore, 15:58:27)
    6. signing everything slowed down signing overall (dgilmore, 16:02:43)
    7. going forward we could look at ways to make signing scale better (dgilmore, 16:03:08)
    8. ACTION: dgilmore to make f27 key today/tomorrow (dgilmore, 16:06:05)
    9. https://fedoraproject.org/wiki/Releases/26/Schedule (dgilmore, 16:06:49)

  4. Fedora 26 movement (dgilmore, 16:07:47)
    1. this week we need to make the Fedora 27 gpg key for rpms (dgilmore, 16:08:08)
    2. this week we need to branch all of the compose configs for Fedora 26 (dgilmore, 16:08:28)
    3. https://pagure.io/pungi-fedora (dgilmore, 16:08:50)
    4. https://pagure.io/fedora-kickstarts/ (dgilmore, 16:09:04)
    5. https://pagure.io/fedora-lorax-templates (dgilmore, 16:09:17)
    6. https://pagure.io/fedora-atomic (dgilmore, 16:09:29)
    7. https://pagure.io/workstation-ostree-config (dgilmore, 16:09:52)
    8. https://github.com/rpm-software-management/mock will need an update with new mock configs (dgilmore, 16:10:32)
    9. https://docs.pagure.org/releng/ (dgilmore, 16:11:05)
    10. all packages for rawhide have to be signed with the f27 key and autosigning setup by COB Monday, so that as soon as we land all the changes for branching rawhide switches to f27 keys (dgilmore, 16:14:43)
    11. https://fedoraproject.org/wiki/ReleaseEngineering/Meeting_Process (dgilmore, 16:15:37)

  5. porting releng tools to DNF (dgilmore, 16:17:53)
    1. shortest path to using dnf is to have a multilib python module that supports yum and dnf, porting pungi and mash to using those. koji signed repos can then switch to and use it also (dgilmore, 16:40:05)
    2. that does not account for any other pieces where we have scripts and tools that use yum (dgilmore, 16:40:45)
    3. so there may be unknown breakage if we changed over (dgilmore, 16:40:59)
    4. pungi would need to land this week and mash would need to get its way to the bodhi-backend before alpha freeze on 2017-03-07 (dgilmore, 16:41:38)
    5. https://taiga.fedorainfracloud.org/project/acarter-fedora-docker-atomic-tooling/us/691 (mboddu, 16:49:10)

  6. open floor (dgilmore, 16:59:47)
    1. s390 builder situation looks to be getting resolved soon (dgilmore, 17:00:19)


Meeting ended at 17:03:33 UTC (full logs).

Action items

  1. mboddu to run the scripts that output failure and needs rebuild lists for at least 4 more weeks
  2. dgilmore to make f27 key today/tomorrow


Action items, by person

  1. dgilmore
    1. dgilmore to make f27 key today/tomorrow
  2. mboddu
    1. mboddu to run the scripts that output failure and needs rebuild lists for at least 4 more weeks


People present (lines said)

  1. dgilmore (175)
  2. nirik (54)
  3. ignatenkobrain (49)
  4. Son_Goku (38)
  5. pingou (17)
  6. puiterwijk (15)
  7. zodbot (14)
  8. maxamillion (14)
  9. mboddu (10)
  10. bowlofeggs (3)
  11. marc84 (1)
  12. sharkcz (1)
  13. tyll (0)
  14. masta (0)
  15. pbrobinson (0)


Generated by MeetBot 0.1.4.