#fedora-meeting-2: F26 Beta Go/No-Go meeting - 2nd round

Meeting started by jkurik at 17:00:02 UTC (full logs).

Meeting summary

  1. Roll Call (jkurik, 17:00:16)
  2. Purpose of this meeting (jkurik, 17:02:00)
    1. Purpose of this meeting is to check whether or not F26 Beta is ready for shipment, according to the release criteria. (jkurik, 17:02:04)
    2. This is determined in a few ways: (jkurik, 17:02:16)
    3. * No remaining blocker bugs (jkurik, 17:02:20)
    4. * Release candidate compose is available (jkurik, 17:02:27)
    5. * Release candidate compose is available (jkurik, 17:02:38)

  3. Current status (jkurik, 17:02:49)
    1. https://pagure.io/releng/issue/6808 - the ticket to build F26 Beta RC (jkurik, 17:03:08)
    2. https://kojipkgs.fedoraproject.org/compose/26/Fedora-26-20170531.0/compose/ - the RC compose (jkurik, 17:03:10)
    3. https://fedoraproject.org/wiki/Test_Results:Fedora_26_Beta_1.4_Summary - Test matrices (jkurik, 17:03:12)
    4. RC for F26 Beta is ready, testing is ongoing. (jkurik, 17:04:10)

  4. Mini-Blocker Review (jkurik, 17:05:06)
    1. https://qa.fedoraproject.org/blockerbugs/milestone/26/beta/buglist (jkurik, 17:05:08)

  5. Introduction (roshi, 17:05:10)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (roshi, 17:05:10)
    2. We'll be following the process outlined at: (roshi, 17:05:14)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (roshi, 17:05:17)
    4. The bugs up for review today are available at: (roshi, 17:05:19)
    5. http://qa.fedoraproject.org/blockerbugs/current (roshi, 17:05:22)
    6. The criteria for release blocking bugs can be found at: (roshi, 17:05:24)
    7. https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria (roshi, 17:05:27)
    8. https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria (roshi, 17:05:29)
    9. https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria (roshi, 17:05:32)

  6. (1457336) files from python-libs-2.7.13-2.fc25.x86_64 conflict with files from python2-libs-2.7.13-8.fc26.x86_64 (roshi, 17:06:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1457336 (roshi, 17:06:13)
    2. Proposed Blocker, python, MODIFIED (roshi, 17:06:16)
    3. https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-05-22/f26-blocker-review.2017-05-22-16.00.log.html (adamw, 17:14:35)
    4. AGREED: - RHBZ#1457336 - RejectedBlocker AcceptedFreezeException - This bug doesn't affect the default Server package set so it is not a blocker, but it is accepted as a freeze exception issue as some people will certainly run into it and it'd be good to push the fix stable ASAP. (adamw, 17:20:49)

  7. (1457626) F26 Beta crashes on login with Wayland on nouveau (roshi, 17:21:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1457626 (roshi, 17:21:06)
    2. Proposed Blocker, xorg-x11-drv-nouveau, NEW (roshi, 17:21:07)
    3. AGREED: - RHBZ#1457626 - RejectedBlocker - This bug only seems to affect specific hardware and isn't wide spread enough to warrant blocking Beta for. (roshi, 17:26:30)

  8. (1454897) Release-blocking Cloud base images missing from Fedora 26 composes (adamw, 17:27:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1454897 (adamw, 17:27:26)
    2. Accepted Blocker, distribution, ON_QA (adamw, 17:27:26)
    3. the relevant images are in Beta 1.4, we can go ahead and close this. (adamw, 17:29:25)

  9. (1438046) initial-setup.service: Failed to set up stdin: Inappropriate ioctl for device (adamw, 17:29:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1438046 (adamw, 17:29:39)
    2. Accepted Blocker, initial-setup, ON_QA (adamw, 17:29:39)
    3. pwhalen and lbrabec report this working fine in Beta 1.4, so it's 'addressed' for beta validation purposes (adamw, 17:30:59)

  10. (1443206) gnome-shell consistently crashes in the middle of first-login gnome-initial-setup (adamw, 17:31:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1443206 (adamw, 17:31:29)
    2. Accepted Blocker, libgweather, ON_QA (adamw, 17:31:29)
    3. this has been confirmed fixed by multiple testers (adamw, 17:31:38)

  11. (1446879) [abrt] gnome-shell: gweather_location_unref(): gnome-shell killed by signal 11 (adamw, 17:31:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1446879 (adamw, 17:31:43)
    2. Accepted Blocker, libgweather, ON_QA (adamw, 17:31:43)
    3. this has been confirmed fixed by multiple testers (adamw, 17:31:49)

  12. (1457645) Fedora 26 KDE x86_64 live image is oversized (size 1490026496, max 1400000000) (adamw, 17:32:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1457645 (adamw, 17:32:02)
    2. Accepted Blocker, LiveCD - KDE, NEW (adamw, 17:32:03)
    3. AGREED: as the KDE SIG representative, rdieter affirms that the KDE spin target size is changed to 2GB from F26. Note that the Spins process does not appear to have been properly followed for Fedora 26 cycle, so we consider it appropriate to make the adjustment in this meeting (adamw, 17:43:01)
    4. AGREED: #1457645 - close as fixed or notabug - as the target size has now been changed, the image is no longer over-sized (adamw, 17:44:49)

  13. (1348688) Anaconda cannot access LVM partitions in a LUKS-encrypted disk partition after decryption (adamw, 17:45:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1348688 (adamw, 17:45:20)
    2. Accepted Blocker, lvm2, ON_QA (adamw, 17:45:20)
    3. roshi is confirming the fix for this, we will discuss the next bug and then circle back to this one (adamw, 17:53:56)

  14. (1397087) Rpm hangs after updating to glibc >= 2.25 (adamw, 17:54:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1397087 (adamw, 17:54:06)
    2. Accepted 0-day Blocker, rpm, MODIFIED (adamw, 17:54:06)
    3. Note that previous releases do not need to have the fixes applied as all of the magic happens after libdb is updated to the fixed version. (mattdm, 18:17:47)
    4. circling back to the LVM bug to close out on that (adamw, 18:49:10)

  15. (1348688) Anaconda cannot access LVM partitions in a LUKS-encrypted disk partition after decryption (adamw, 18:50:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1348688 (adamw, 18:50:10)
    2. Accepted Blocker, lvm2, ON_QA (adamw, 18:50:11)
    3. roshi confirms this is fixed in Beta-1.3 and Beta-1.4, so it is considered addressed (adamw, 18:50:27)

  16. (1397087) Rpm hangs after updating to glibc >= 2.25 (adamw, 18:50:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1397087 (adamw, 18:50:34)
    2. Accepted 0-day Blocker, rpm, MODIFIED (adamw, 18:50:34)
    3. https://pagure.io/fesco/issue/974 (nirik, 19:17:23)
    4. AGREED: #1397087 - this is agreed to still be a clear blocker, and is at present unaddressed. However, as it's a 0Day / PreviousRelease blocker, it does not in itself invalidate the Beta-1.4 compose (adamw, 19:25:10)
    5. that covers all the outstanding proposed / agreed blockers (adamw, 19:25:36)

  17. Test Matrices coverage (jkurik, 19:26:44)
    1. https://fedoraproject.org/wiki/Test_Results:Fedora_26_Beta_1.4_Summary (jkurik, 19:26:52)
    2. AGREED: the following test cases needs to be sucessfully tested by tomorrow: "Testcase_install_to_hardware_RAID" and on ARM platform "Domain controller" and "Database server". Beside of this the coverage of the testing is considered as sufficient. (jkurik, 19:37:41)

  18. Go/No-Go decision (jkurik, 19:38:14)
    1. AGREED: QA team to buy sas hardware (dgilmore, 19:45:45)
    2. ACTION: adamw to not forget to buy sas hardware (dgilmore, 19:46:02)
    3. ACTION: dgilmore to remind adamw not to forget to buy sas hardware (adamw, 19:46:22)
    4. https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=26&build=Fedora-26-20170531.0&groupid=1 (adamw, 19:52:19)
    5. AGREED: : the Go/No-Go decision is postponed. Release Engineering starts to stage the current 1.4 Beta compose as GOLD asap. The "Go/No-Go team" meets on 2017-Jun-02 at 15:00 UTC on #fedora-meeting-2 channel to finish the meeting and make the ultimate decision. (jkurik, 19:57:01)
    6. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a4c41ecc27 (kparal, 15:07:50)
    7. AGREED: The decision from this meeting is No-Go for the F26 Beta compose 1.4. The main concern for not releasing this compose as GOLD is unclear resolution of bug #1397087, which is still causing some issues during testing. (jkurik, 15:34:56)
    8. ACTION: releng to stop mirroring the F26 Beta 1.4 compose (jkurik, 15:36:05)
    9. ACTION: jkurik to plan next go/no-go meeting for the next Thursday 2017-June-08 (jkurik, 15:36:53)
    10. ACTION: jkurik to announce the outcome of this meeting (jkurik, 15:37:20)
    11. ACTION: jkurik to announce there are no changes in F27 due to this slip (jkurik, 15:37:39)
    12. HELP: it'd be nice if someone with arm hardware could run "Domain controller" for ARM testcase (jkurik, 15:51:54)
    13. Test matrices wiil be reviewed again on the Go/No-Go meeting on 2017-June-08 (jkurik, 15:52:54)


Meeting ended at 15:56:51 UTC (full logs).

Action items

  1. adamw to not forget to buy sas hardware
  2. dgilmore to remind adamw not to forget to buy sas hardware
  3. releng to stop mirroring the F26 Beta 1.4 compose
  4. jkurik to plan next go/no-go meeting for the next Thursday 2017-June-08
  5. jkurik to announce the outcome of this meeting
  6. jkurik to announce there are no changes in F27 due to this slip


Action items, by person

  1. adamw
    1. adamw to not forget to buy sas hardware
    2. dgilmore to remind adamw not to forget to buy sas hardware
  2. dgilmore
    1. dgilmore to remind adamw not to forget to buy sas hardware
  3. jkurik
    1. jkurik to plan next go/no-go meeting for the next Thursday 2017-June-08
    2. jkurik to announce the outcome of this meeting
    3. jkurik to announce there are no changes in F27 due to this slip


People present (lines said)

  1. adamw (288)
  2. jkurik (160)
  3. roshi (124)
  4. nirik (102)
  5. dgilmore (77)
  6. mattdm (39)
  7. dustymabe (28)
  8. zodbot (25)
  9. mboddu (25)
  10. pwhalen (11)
  11. rdieter (10)
  12. besser82 (9)
  13. kparal (8)
  14. nb (4)
  15. sharkcz (3)
  16. KQfMtFwD (2)
  17. bexelbie[m] (1)
  18. sgallagh (1)


Generated by MeetBot 0.1.4.