13:01:21 <stickster> #startmeeting Workstation WG
13:01:21 <zodbot> Meeting started Mon Jun  5 13:01:21 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:21 <zodbot> The meeting name has been set to 'workstation_wg'
13:01:25 <stickster> #meetingname workstation
13:01:25 <zodbot> The meeting name has been set to 'workstation'
13:01:28 * mcatanzaro yawns
13:01:29 <stickster> #topic Roll call
13:01:32 <stickster> .hello pfrields
13:01:32 <mcatanzaro> .hello catanzaro
13:01:33 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:01:36 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
13:01:39 <otaylor> .hello otaylor
13:01:45 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
13:01:54 <mcatanzaro> (FYI I'll be leaving early today)
13:02:26 <ryanlerch> .hello ryanlerch
13:02:28 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:03:09 <stickster> mcatanzaro: no worries
13:03:10 <kalev_> .hello kalev
13:03:11 <zodbot> kalev_: kalev 'Kalev Lember' <klember@redhat.com>
13:03:20 <stickster> #chair mcatanzaro otaylor ryanlerch kalev_
13:03:20 <zodbot> Current chairs: kalev_ mcatanzaro otaylor ryanlerch stickster
13:04:35 * stickster rummages for agenda from the issues list
13:05:09 <stickster> #topic Nautilus add-on by default
13:05:10 <stickster> #link https://pagure.io/fedora-workstation/issue/10
13:05:32 <stickster> kalev_: did you get a chance to make this change, adding gnome-terminal-nautilus to default?
13:05:45 <stickster> er, default Workstation packages
13:06:20 <stickster> #chair mclasen
13:06:20 <zodbot> Current chairs: kalev_ mcatanzaro mclasen otaylor ryanlerch stickster
13:06:20 <kalev_> err, no, but let me go do this now
13:06:33 <stickster> kalev_: Thanks -- and when done, you can comment and close that issue as fixed
13:06:48 * stickster notes this may not change anything until post-Beta
13:06:53 <kalev_> yep, will do
13:07:45 <stickster> #action kalev_ is adding gnome-terminal-nautilus ASAP, should be in composes soon (no later than right after Beta, possibly for Beta)
13:09:07 <stickster> #topic Packaging guidelines for app independence
13:09:09 <stickster> #link https://pagure.io/fedora-workstation/issue/13
13:09:16 <stickster> mcatanzaro: Care to give update here?
13:09:54 <mcatanzaro> Since we decided that GNOME Software should report to the user when apps depend on each other, I toned down the wording of the policy significantly to reflect feedback from rdieter.
13:10:28 <mcatanzaro> Basically now it is toothless as everything is just a "should," but it is still worthwhile as it represents some formal guidelines we can point people too when we have problems. E.g. when blivet-gui turns up in the default install.
13:10:39 <mcatanzaro> So at this point I'm looking for approval to present this to the packaging committee.
13:10:47 <mcatanzaro> #link https://fedoraproject.org/wiki/PackagingDrafts/IndependentApplications
13:11:32 <otaylor> mcatanzaro: Hmm, to me, that sound slike a lot of technical work to work around a packaging bug
13:12:17 <stickster> mcatanzaro: Sorry if my memory is hazy -- is there an app whose behavior prompted this?
13:12:21 <rdieter> fwiw, I approve of the amended draft
13:12:39 <mcatanzaro> stickster: We've had several cases in the past, most recently anaconda depending on blivet-gui.
13:12:46 <stickster> Ah right
13:13:00 <stickster> I do recall now, thanks
13:14:25 <mcatanzaro> otaylor: My original draft considered this situation a packaging bug and had a bunch of MUST NOTs, but then we decided to modify gnome-software so it doesn't seem essential to avoid application interdependencies anymore. They can be useful in some circumstances (e.g. mclasen's example: game level editor). But in most cases, yeah it's just a bug, so
13:14:25 <mcatanzaro> talking about it in the packaging guidelines seems worthwhile.
13:14:27 * otaylor wonders if we can have a packaging guideline not to call your application "Blivet GUI" ;-)
13:14:58 <stickster> Like "what's a blivet, and why do I need a GUI to control it?".
13:15:09 <mclasen> and why is it on my system ?!
13:15:24 <otaylor> mcatanzaro: the thing is, that the cases that make sense, make sense
13:15:30 <stickster> As one of my team members is fond of saying, there are two difficult problems in software engineering: cache invalidation and naming things.
13:16:21 <otaylor> mcatanzaro: but yes, I think the "should not generally" is fine - it's just that the exceptions need to be made for the sake of the user rather than the sake of technical impossibility
13:17:33 <mcatanzaro> otaylor: That's pretty much what I was trying to get at with my current wording.
13:18:23 <kalev_> I think the draft looks good as it is now, no objections from me
13:18:31 <otaylor> mcatanzaro: Looks good to me too
13:19:06 <stickster> I made two trivial tweaks just now (just spelling-ish corrections), but this looks good to me as well.
13:20:16 <ryanlerch> should the instances of "application" be expanded out to GUI application in the application independence section?
13:20:45 <stickster> hmm, good point ryanlerch
13:21:08 * kalev_ agrees
13:21:09 <mcatanzaro> Could be, I figured it was assumed, but it's not in the existing text "If a package contains a GUI application"
13:21:24 <stickster> I took it to follow as well, mcatanzaro, but you know how people love to language lawyer stuff...
13:21:40 <mcatanzaro> OK, I'll add that and then take it to the packaging committee, agreed?
13:21:51 <stickster> mcatanzaro: So did I understand correctly that GNOME Software *is* getting some changes to expose to the user that some other app might be installed, in the case of a {soft,} dependency?
13:21:59 <ryanlerch> +1 from me
13:22:29 <mcatanzaro> stickster: That was mclasen's plan, yes.
13:22:32 <kalev_> stickster: yes
13:22:35 <stickster> gotcha, thanks
13:22:40 <mcatanzaro> This policy only makes sense if those changes land in gnome-software.
13:22:47 * stickster summarizes for minutes
13:23:07 <mcatanzaro> (Well it makes sense regardless, but it should be way stricter without those changes.)
13:23:13 <mclasen> plan ?
13:23:20 <stickster> #info mcatanzaro presented slightly altered packaging guideline change proposal, based on the fact that GNOME Software will soon gain ability to show when an app dependency will be installed
13:23:23 <mclasen> I didn't make a plan, I just voiced an opinion
13:23:37 <stickster> #undo
13:23:37 <zodbot> Removing item from minutes: INFO by stickster at 13:23:20 : mcatanzaro presented slightly altered packaging guideline change proposal, based on the fact that GNOME Software will soon gain ability to show when an app dependency will be installed
13:23:40 <mclasen> that doesn't magically make code appear in gnome-software
13:24:25 * stickster backs out minutes while we get to the bottom of what is actually happening here. ;-) Obviously we want the guideline to agree with reality
13:25:08 <kalev_> I put it on my todo list now to make the gnome-software change
13:25:08 <mclasen> I'm sure it is somewhere on hughsie's todo list, but I don't expect it to be near the top
13:25:09 <mcatanzaro> So if it's mclasen's opinion that gnome-software should do this, and kalev's opinion that gnome-software should do this... that sounds like a plan? ;)
13:25:15 <stickster> did anyone talk with hughsie about adding the capability in Software to show when a dependency is installed?
13:25:30 <stickster> mcatanzaro: mclasen: ^ That seems like the most important issue, not who agrees :-)
13:25:56 <mcatanzaro> kalev_?
13:26:11 <stickster> sorry kalev_, didn't mean to leave you out :-)
13:27:02 * stickster waits for a clarification...
13:28:09 <stickster> let me ask this in a different way... Who is going to be accountable to talk with hughsie about this feature? ;-)
13:28:37 <kalev_> I can be
13:28:41 <mclasen> I'll do it
13:29:49 <mcatanzaro> OK, I'll wait for an ACK from one of you that hughsie is OK with this before taking this policy to the packaging committee. So please let me know once you've chatted with him.
13:29:54 * stickster thinks all this makes sense, just want to get the ducks ordered correctly in their row ;-) ... I'll tag mclasen with this since kalev_ took the last one
13:30:05 * mcatanzaro needs to go now, ciao
13:30:17 <stickster> #info mcatanzaro presented slightly altered packaging guideline change proposal, based on the concept of GNOME Software gaining ability to show when an app dependency will be installed
13:30:31 <stickster> #info Needs sorting out with Software upstream first, though
13:30:57 <stickster> #agreed WG members agree with text of proposal, contingent on Software changes
13:31:12 <stickster> #action mclasen to chat w/ hughsie about changes in Software
13:31:52 <stickster> #action mcatanzaro move forward with guidelines based on outcome of Software change plan
13:31:58 <stickster> *whew* OK.
13:32:21 <stickster> #topic Repo fixes for default install
13:32:25 <stickster> #link https://pagure.io/fedora-workstation/issue/17
13:33:24 <stickster> Here's what I recall about this. cschaller contacted mboddu about changes for repos, based on sgallagh recommendation.
13:33:52 <stickster> But given the fact that we got no word back, and that locking everything up in one package goes against the spirit of the editions deciding the fate of third party repos, mattdm advised the following:
13:34:09 <stickster> * Third party repo policy needs to be finished, and...
13:34:41 <stickster> * ...contingent on that, it might be reasonable to ask for exception to keep carrying fedora-workstation-repositories
13:35:03 <stickster> but since I know cschalle hasn't had time to work on this, it's been stuck at the moment, expect more to happen this week
13:35:10 <mboddu> stickster: sorry, I was busy in the Beta mumbo-jumbo. I think I can take a look at it sometime this week
13:35:27 <stickster> mboddu: I figured -- that's been very draining, I'm sure. Thank you for working on Beta!
13:35:44 <mboddu> stickster: :)
13:35:50 <stickster> mboddu: If you are able to get this change in, we're happy to discuss further here or in #fedora-workstation.
13:36:21 <mattdm> On the above: specifically, if third-party repos are to be "owned" by the Edition WGs, it makes sense for the corresponding packages to also be so owned
13:36:44 <mboddu> stickster: sure, I will read more about it and I will come back to you
13:37:16 <stickster> mattdm: Agree or disagree: The third party repository policy must be completed and approved by {Council? FESCo? both?} before such a package is used.
13:37:47 * stickster just trying to clarify course of action here for the record, since this has been confusing and we don't want to ask rel-eng for multiple, clashy things.
13:38:18 <mattdm> stickster: agree.
13:38:36 <stickster> mattdm: and IIRC this is a Council approval, right?
13:39:05 <mattdm> The Council approved the direction the policy is going in, but we have not approved a final version
13:39:13 <stickster> *nod
13:39:22 <stickster> #nick cschalle
13:39:59 * mattdm is on the train to th enew Boston office; cell signal is really spotty at this point in the tunnel :)
13:40:11 <stickster> mattdm: no worries, I'm done summoning you :-D
13:40:12 <mattdm> The approval should not be a hard process at this point
13:40:34 <mattdm> just, the work of clearling up remaining questions and working out details needs to be done
13:41:03 <stickster> #info mattdm confirms, need to finish third party repo policy, present to Council for final approval, then the WG should be able to control its own third party repo package without needing to call on rel-eng for changes each time
13:41:23 <stickster> #action cschalle finish third party repo policy (with contribution from WG as needed) and present to Council
13:41:38 <stickster> OK, a lot of monologue from me there, sorry all
13:42:18 <stickster> kalev_: ryanlerch: mclasen: rdieter: otaylor: if you guys don't mind, I'd like to bring up an "other business" item
13:42:36 <kalev_> sure :)
13:42:42 <stickster> #topic Other biz: Setting meeting agenda
13:42:43 <otaylor> kalev_: sure
13:42:52 <otaylor> err, stickster: sure
13:43:28 <stickster> So just a reminder -- we now have https://pagure.io/fedora-workstation/issues rotating fairly regularly. I'm going to set meeting agenda based on one thing and one thing only: "meeting" tag set on an issue in that list, in order from earliest to latest unresolved issues.
13:43:37 * ryanlerch has one item with the backgrounds packages
13:44:04 <stickster> ryanlerch: sure, I'll be done in like 1 more minute
13:44:14 <ryanlerch> stickster: sorry, ack
13:44:43 <stickster> #info If you want something on the agenda, tag the issue with 'meeting' before the meeting happens. (Also open to last minute changes, we're not automatons after all.)
13:44:54 <stickster> Any problem with that?
13:45:15 <kalev_> sounds like a good plan
13:45:21 <ryanlerch> +1 from me
13:45:30 <stickster> This saves me from flailing about on a mailing list trying to determine what we need to talk about here :-)
13:46:05 <stickster> #action stickster to set meeting reminder to also include issues URL for everyone's reference in advance
13:46:17 <stickster> #topic Background wallpapers
13:46:20 <stickster> Go ahead ryanlerch
13:46:25 <ryanlerch> thanks stickster
13:46:43 <ryanlerch> i have the backgrounds package all ready to go:
13:46:45 <ryanlerch> https://bodhi.fedoraproject.org/updates/FEDORA-2017-f8e0ef2850
13:47:06 <ryanlerch> just a little uninformed on how to proceed at this point in the release cycle.
13:47:10 <otaylor> stickster: +1
13:48:06 <stickster> ryanlerch: mboddu might be able to correct me -- I think he knows enough about how this works now -- but I believe if that package is in stable, then we just make changes to comps at this point in order to fix the compose correctly
13:48:15 <ryanlerch> there is also the changes to the existing gnome-backgrounds package (splitting into sub-package), just not sure how to proceed at this point
13:48:49 <stickster> ryanlerch: Ah, that would be another change needed then -- should be a fairly simple packaging fix, but I don't know who has access to that one
13:48:56 <stickster> .whoowns gnome-backgrounds
13:48:56 <zodbot> stickster: kalev
13:49:01 <stickster> Ah, that's pretty easy then :-D
13:49:13 <ryanlerch> stickster: the changes are done.
13:49:20 <kalev_> ryanlerch: I think wait for the F26 Beta to get released so that packages can be pushed to stable again, then push this stable and make the change to gnome-backgrounds
13:49:31 <stickster> right, we're still in freeze
13:49:40 <kalev_> and put this through bodhi as well then
13:49:48 <ryanlerch> kalev_: okay!
13:49:59 <ryanlerch> the gnome-backgrounds change is in rawhide atm
13:50:00 <kalev_> we'll have several weeks of development time after the beta release and that should be plenty for this
13:50:14 <ryanlerch> just wasnt sure when to push that change into the f26 branch
13:50:25 <ryanlerch> kalev_: oh, ok!
13:50:32 * ryanlerch was worried that it was too late
13:50:34 <stickster> #action ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Bea
13:50:38 <stickster> #undo
13:50:38 <zodbot> Removing item from minutes: ACTION by stickster at 13:50:34 : ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Bea
13:50:42 <stickster> #action ryanlerch and kalev_ coordinate to get gnome-backgrounds and new fedora-workstation-backgrounds pushed at the proper time to include post-Beta
13:51:11 <ryanlerch> thanks stickster, kalev_
13:51:12 <stickster> ryanlerch: kalev_: Anything else on this one?
13:51:22 <stickster> sounds like not :-D
13:51:22 <ryanlerch> nothing from me
13:51:41 <kalev_> nothing from me
13:51:48 * stickster holds gavel for 30 sec in case someone else has something
13:51:56 <otaylor> On this, or something else?
13:52:19 <stickster> on anything otaylor  -- go ahead
13:52:47 <otaylor> so, I'm starting to work on some example modules for flatpak applications
13:52:58 <stickster> #topic Flatpak example modules
13:53:35 <otaylor> And finding some packaging changes that would be useful (simple example, wayland doesn't build currently because of graphviz incompatibility)
13:54:06 <otaylor> I'm currently targeting the f26 package set - partly because that's what modularity WG has been biulding on and f27 is in a lot of flux
13:54:50 <otaylor> What do people think about landing changes into dist-git on the f26 branch during the f26 cycle which *only* are for the module experiments, and not strictly helping for f26
13:55:07 * stickster sucks air in through teeth in a pained sort of way
13:55:45 <otaylor> I think alternativively I could make modules which were hybrid f27/f26
13:55:47 <stickster> My initial impression is, we're pretty risk-negative about f26 branch at this point. As in, any is bad
13:56:32 <stickster> Now, zero-day updates maybe? Or even negotiable about early post-Beta period, maybe. I don't think people would be chuffed about anything destabilizing, though.
13:56:36 <otaylor> stickster: It's probably a fair point that I shouldn't be fooling around on what we've released to people in production, even if I *think* it can't break anything
13:57:04 <otaylor> I'm really thinking post freeze - post release, not talking about doing anything that would destabilize the release
13:57:06 <stickster> Gee, it would be great if everyone had the ability to twiddle around and then do a compose to prove nothing breaks ;-)
13:57:24 <otaylor> But post freeze, people are using things day-to-day - so it's not like we should be casual then either :-)
13:57:30 <stickster> otaylor: that's probably a fair request
13:57:38 * stickster notes he needs to go run another meeting
13:57:58 <stickster> otaylor: might be something for devel@ list just to be clear about what you propose
13:58:15 <otaylor> OK - this can be brought up later - I'll see if I can make it more coherent and put it into a ticket
13:58:23 <stickster> let's take this to #fedora-workstation if we need to delve in, though
13:58:39 * stickster will close now -- thanks, everyone, for coming!
13:58:56 <stickster> #endmeeting