17:00:58 <geppetto> #startmeeting fpc
17:00:58 <zodbot> Meeting started Wed Aug  9 17:00:58 2017 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:58 <zodbot> The meeting name has been set to 'fpc'
17:00:58 <geppetto> #meetingname fpc
17:00:58 <geppetto> #topic Roll Call
17:00:58 <zodbot> The meeting name has been set to 'fpc'
17:01:12 <geppetto> #chair orionp
17:01:12 <zodbot> Current chairs: geppetto orionp
17:01:12 * limburgher oh captain my captain
17:01:16 <geppetto> #chair limburgher
17:01:16 <zodbot> Current chairs: geppetto limburgher orionp
17:01:48 <geppetto> ignatenkobrain: hopefully meeting starting soon
17:02:03 <ignatenkobrain> uhh, wasn't it supposed to be on Thursday? =(
17:02:16 <geppetto> ignatenkobrain: no … this week it's on Wed.
17:02:33 <ignatenkobrain> ohh
17:02:50 * ignatenkobrain is in rush to update Rust guidelines while you are discussing other stuff
17:03:49 <mbooth> Hi
17:04:01 <geppetto> #chair mbooth
17:04:01 <zodbot> Current chairs: geppetto limburgher mbooth orionp
17:06:50 <mbooth> Oof, these weds meetings are not in the habit of achieving quorum so you may have more time than you think to write those guidelines, ignatenkobrain  :-(
17:07:24 <geppetto> Yeh, summer has been bad too though … lots of holidays
17:09:14 <limburgher> On the bright side, my salad was lovely. #nonsequitor
17:09:35 <geppetto> What kind?
17:09:38 <Rathann> hi sorry
17:09:42 <geppetto> #chair Rathann
17:09:42 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp
17:10:09 <geppetto> Woo, and then there were 5!
17:10:45 <limburgher> Spinach, goat cheese, kalamata olives, black beans, edamame, more spinach, and asian sesame dressing.
17:10:50 <geppetto> #topic Schedule
17:10:51 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/NDA6IG5WZYIYZTTC77FUKYDXPF6MWHDT/
17:11:20 <geppetto> limburgher: My wife would probably like that … me, not so much
17:11:39 <mbooth> blurgh, olives
17:11:49 <geppetto> #topic #697 simplify github urls
17:11:49 <mbooth> Poison for mbooths
17:11:50 <limburgher> lol
17:11:53 <geppetto> .fpc 697
17:11:56 <zodbot> geppetto: Issue #697: simplify github urls - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/697
17:12:08 * geppetto agrees with mbooth
17:12:44 * Pharaoh_Atem waves
17:12:46 <Pharaoh_Atem> ignatenkobrain: hello
17:12:53 <mbooth> I already +1'd this on the ticket
17:13:13 <limburgher> I haven't.
17:13:18 <limburgher> Until now. +1
17:14:04 <orionp> +1 , but need to remove the line "Note that the numeric identifier after commit, gittag and shortcommit matches the associated identifier of the Source0: tag. "
17:14:27 <geppetto> This is just removing the # from the name because github supports it directly now?
17:15:00 <geppetto> Yeh, most of the changes here appear to be for the commit0 => commit change. Sigh.
17:15:02 <Pharaoh_Atem> well, if you do github.com/foo/archive/version/foo-version.tar.gz, it gives the tarball
17:15:04 <mbooth> geppetto: Yeah, github got saner
17:15:12 <limburgher> About time.
17:15:18 <geppetto> I'm +1
17:16:07 <orionp> the meat is the simplified github url.  But lots of commit0 -> commit as well (which is nice)
17:16:53 <limburgher> Though commit0 had a nice rubber-monstery feel to it.
17:17:10 <Rathann> +1
17:18:30 <geppetto> #action simplify github urls (+1:5, 0:0, -1:0)
17:18:57 <geppetto> #topic #698 Forbid the use of /usr/bin/python
17:19:05 <geppetto> .fpc 698
17:19:08 <zodbot> geppetto: Issue #698: Forbid the use of /usr/bin/python - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/698
17:20:13 <limburgher> Seems straightforward.
17:20:39 <geppetto> yeh, do we really need this yet?
17:21:00 <geppetto> What's upstream say about python … I thought it was still python == python2
17:21:06 <ignatenkobrain> it's always good to be prepared in advance, isn't it?
17:21:20 <limburgher> Given the typical lag between guideline and implementation, yes, do it now.
17:22:30 <geppetto> ignatenkobrain: are upstream planning on changing it soon?
17:22:43 <ignatenkobrain> geppetto: IIRC 2019 or 2020
17:22:48 <ignatenkobrain> but I didn't reember exact year
17:22:58 * geppetto nods … fair enough
17:23:10 <ignatenkobrain> but given how much time it took to add python3 subpackages...
17:23:11 <geppetto> I guess I'm +1
17:23:11 <limburgher> Sooner than widespread fusion energy.
17:23:21 <limburgher> +1 also if that wasn't clear.
17:23:25 <ignatenkobrain> one thing which I should mention here
17:23:37 <ignatenkobrain> is probably one should implement something like %chshebang
17:23:51 <ignatenkobrain> because sed copied over packages is nice, but everyone does their own stuff
17:24:21 <ignatenkobrain> moreover, if we want, we can even make some automation of this through brp scripts..
17:24:35 <ignatenkobrain> but that's "implementation details"
17:24:45 <Rathann> +1
17:25:06 <limburgher> Therein lie devils.
17:25:07 <orionp> +1 - i think with the orginal text
17:25:29 <geppetto> Yeh, if anything I'd prefer a %_foo bar.py … which changes the #! line.
17:26:09 <mbooth> +1 sounds okay to me
17:26:28 <mbooth> Also happy to deal with env in a different ticket
17:26:54 <limburgher> %conform_to_guidelines would be awesome.
17:27:11 <ignatenkobrain> limburgher: yeah, full spec file should look like that ;)
17:27:46 <limburgher> then %unbundle_all_the_things and %remove_bugs and we're golden.
17:28:04 <geppetto> ha
17:28:38 <tibbs> Folks, sorry, I've been on vacation the past two meeting times.
17:29:01 <Rathann> don't be sorry, everyone needs vacation
17:29:07 <Rathann> welcome back
17:29:08 <geppetto> #chair tibbs
17:29:08 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp tibbs
17:29:37 <geppetto> I think we're at +5 for this … did you want to loo at it tibbs or just move on?
17:30:06 <tibbs> No, that's fine.  I will read the log later.
17:30:08 <limburgher> geppetto: Eeeeew
17:30:43 <geppetto> #action Forbid the use of /usr/bin/python (+1:5, 0:0, -1:0)
17:30:53 <geppetto> #topic #700 Globally ban use of /usr/bin/env in executables
17:30:56 <geppetto> .fpc 700
17:30:58 <zodbot> geppetto: Issue #700: Globally ban use of /usr/bin/env in executables - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/700
17:31:11 <geppetto> I thought we'd already done this!
17:31:24 <tibbs> I had too.
17:31:50 <tibbs> But if it's actually in there somewhere I wasn't successful in finding it.
17:32:14 * geppetto nods … well. +1
17:32:54 <Rathann> orionp had a point about the second bullet point
17:33:27 <tibbs> True.
17:33:50 <orionp> I would move it into the paragraph above
17:33:50 <tibbs> could just remove "rules".
17:34:24 <tibbs> Not entirely sure what I was trying to communicate there.
17:34:25 <Rathann> also we should exempt templates from the rule like vondruch and churchyard wrote
17:34:50 <Rathann> but I guess they fall under "not executables"
17:34:53 <tibbs> Are templates installed as executables?
17:35:00 <Rathann> so might not need a specific mention
17:35:12 <tibbs> Not sure what they mean by templates, really.
17:35:52 <mbooth> Like examples that ship with docs, I suppose
17:36:07 <ignatenkobrain> those should be chmod -x anyway
17:36:10 <tibbs> I'd hope that wouldn't be executable.
17:36:17 * geppetto nods
17:36:23 <Rathann> yes, docs shouldn't be executable
17:36:23 <ignatenkobrain> so RPM will not pick dependencies for them
17:36:37 <mbooth> Sure, but that's what I understood by their use of "templates"
17:36:43 <geppetto> Although I don't actually mind if examples don't show ppl to use env
17:36:56 <ignatenkobrain> even if file is a %doc, we still generate deps for its shebang and such... there is bugzilla somewhere to make those deps as recommends or such, but we still didn't got to the point of discussing it
17:37:12 <tibbs> Sure, for your own code it's fine.  For system-packaged executables....
17:37:26 <tibbs> ln -s /bin/false ~/bin/python and see what breaks...
17:37:49 <Rathann> ;)
17:38:05 * Rathann guesses a lot
17:38:45 <tibbs> Part of the problem is that this seems so completely obvious to me that you wouldn't want some system-pacakged thing to break because you put something in your personal path.
17:38:46 <mbooth> Anyway, I'm +1 to the proposal
17:39:23 <tibbs> So I'll remove the second bullet point entirely.  I'm not sure why I put that there.
17:39:30 <limburgher> +1, env can DIAF
17:39:54 <Rathann> ok, the rest looks good to me, +1
17:40:45 <orionp> +1
17:40:45 <geppetto> Ok, I think that's +5 … just orionp not voted, yet
17:40:53 <geppetto> and there we go
17:41:00 <tibbs> I'm obviously +1 in any case
17:41:13 <geppetto> #action Forbid the use of /usr/bin/python (+1:5, 0:0, -1:0)
17:41:17 <tibbs> There was a comment that there should be a macro to fix this.
17:41:26 <ignatenkobrain> yup
17:41:35 <geppetto> #topic #705 Rust Packaging Guidelines
17:41:40 <ignatenkobrain> Pharaoh_Atem: ^
17:41:47 <tibbs> There are probably a thousand little things we could have macros for fixing.
17:41:48 <geppetto> #undo
17:41:48 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1e442090>
17:41:51 <geppetto> #undo
17:41:51 <zodbot> Removing item from minutes: ACTION by geppetto at 17:41:13 : Forbid the use of /usr/bin/python (+1:5, 0:0, -1:0)
17:42:00 <geppetto> #action Forbid the use of /usr/bin/python (+1:6, 0:0, -1:0)
17:42:06 <geppetto> #topic #705 Rust Packaging Guidelines
17:42:19 <geppetto> .fpc 705
17:42:20 <zodbot> geppetto: Issue #705: Rust Packaging Guidelines - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/705
17:42:23 <geppetto> ignatenkobrain: You ready?
17:42:31 <ignatenkobrain> yeah, I feel this will be hot and long discussion
17:42:51 <Pharaoh_Atem> ignatenkobrain: I finished writing the first round of revisions
17:42:52 <ignatenkobrain> probably we will not be able to merge them on this meeting, but we would love to hear feedback
17:42:58 <Pharaoh_Atem> it should be a little bit more comprehensible now
17:44:56 <ignatenkobrain> on a side note, RPM implementation of with/without rich dependencies is landing today/tomorrow (libsolv already has everything in)
17:44:56 <tibbs> Are the "# [dependencies]" and "# [dev-dependencies]" intended to be mandatory?
17:45:06 <ignatenkobrain> tibbs: nope, but useful to see
17:45:15 <ignatenkobrain> from where deps is coming from Cargo.toml
17:45:24 <ignatenkobrain> nowadays, rust2rpm generates all this
17:45:53 <ignatenkobrain> we are successfully built ~150 libraries and ~4 applications using these spec files
17:46:05 <ignatenkobrain> https://pagure.io/fedora-rust/playground
17:46:24 <ignatenkobrain> https://copr.fedorainfracloud.org/coprs/g/rust/playground/monitor/
17:46:25 <geppetto> The first line should be s/can not/MUST not/ ?
17:46:55 <geppetto> ignatenkobrain: As in … not from crates.io … MUST NOT use these
17:47:03 <tibbs> "Packagers MUST NOT package crates which do not work with distribution."
17:47:10 <tibbs> What does that actually mean?
17:47:11 <ignatenkobrain> geppetto: ack
17:47:26 <Pharaoh_Atem> tibbs: this should technically be which do not work with OS
17:47:26 <ignatenkobrain> tibbs: like windows-only / nightly-only / bsd-only dependencies
17:47:34 <Pharaoh_Atem> there are non-Linux crates, for example
17:47:39 * Pharaoh_Atem goes to reword
17:47:50 <ignatenkobrain> it is possible to package them, but they are completely useless
17:48:08 <Rathann> s/should become to/should become/
17:49:01 <ignatenkobrain> Rathann: ack
17:49:16 <geppetto> ignatenkobrain: Is rust_arches macro used anywhere apart from setting exclusivearch?
17:49:16 <Rathann> s/SHOULD try to/SHOULD/g
17:49:29 <ignatenkobrain> geppetto: only ExclusiveArch
17:49:34 <ignatenkobrain> so far at least
17:49:55 <orionp> 'for each "feature" crate provides' -> 'for each "feature" the crate provides'
17:50:07 <geppetto> Hmm, just wondering if it's better to have the public macro one that does the exclusivearch and the value
17:50:23 <Rathann> Pharaoh_Atem, ignatenkobrain, I think the "work with distribution" part is covered by the review guidelines
17:50:33 <limburgher> Nod.
17:50:37 <Rathann> which say the package should work as advertised
17:50:55 <ignatenkobrain> Rathann: in this case I think we should keep section but reference to main guidelines
17:51:04 <ignatenkobrain> because example is useful there
17:51:12 <ignatenkobrain> and also
17:51:18 <Pharaoh_Atem> Rathann: I just fleshed out that sentence a bit
17:51:26 <Pharaoh_Atem> so hopefully it's more obvious and Rust specific
17:51:30 <ignatenkobrain> people are expected to rip such crates from Cargo.toml for now
17:52:27 <Rathann> hm interesting
17:52:44 <Rathann> there's no way to specify platform-specific or weak dependencies?
17:52:50 <Rathann> I mean in .toml
17:53:00 <Pharaoh_Atem> there are ways to do platform-specific
17:53:04 <Pharaoh_Atem> but no concept of weak
17:53:13 <Rathann> ok
17:53:14 <orionp> are there going to be multiple versions of crates in a release?
17:53:22 <ignatenkobrain> but we were not able to automate parsing that platform-specific things so far
17:53:28 <Rathann> because the example patch simply deletes windows deps from .toml file
17:53:28 <ignatenkobrain> but that's planned in future
17:53:33 <Rathann> and that's not upstreamable
17:53:34 <ignatenkobrain> orionp: yes, but hopefully not much
17:53:51 <Rathann> so a better example would show how to do platform-specific deps
17:53:55 <ignatenkobrain> orionp: so far we have only 2 crates with 2 different versions
17:54:01 <ignatenkobrain> Rathann: agreed, will prepare better example
17:54:02 <Rathann> such patch could be sent upstream
17:54:08 <Rathann> thank you :)
17:54:40 <ignatenkobrain> others notes fixed
17:54:47 <ignatenkobrain> s/others/other/
17:55:11 <Rathann> of that's the kind of spec that rust2rpm generates then I'm quite happy with the result
17:55:17 <Rathann> s/of/if/
17:55:18 <Pharaoh_Atem> yeah
17:55:22 <Pharaoh_Atem> we spent a lot of time tuning it
17:55:29 <ignatenkobrain> Rathann: yep, that's what it does ;)
17:55:35 <Rathann> excellent job
17:55:36 <Pharaoh_Atem> we wanted to be automated-first, and fall back to manual only when needed
17:55:40 <limburgher> Seconded.
17:55:40 <Rathann> Pharaoh_Atem++
17:55:44 <geppetto> s/packagers MUST forward these upstream/SHOULD/ … opinions?
17:56:03 <limburgher> SHOULD.  Allows for dead upstreams for useful crates.
17:56:03 <Pharaoh_Atem> I think that if we're just fixing it to work with latest versions of crates, we MUST forward
17:56:06 <ignatenkobrain> geppetto: yeah, was asking Pharaoh_Atem to do this ;)
17:56:08 <Pharaoh_Atem> ah
17:56:11 <Pharaoh_Atem> okay, didn't think of that
17:56:13 <Pharaoh_Atem> downgrading now
17:56:37 <Pharaoh_Atem> downgraded
17:56:59 <ignatenkobrain> Rathann: main problem with parsing platform-specific stuff is that either we need to write our own parser or we should rewrite rust2rpm in rust...
17:57:08 <ignatenkobrain> so far we didn't have time to do any of those
17:57:15 <Pharaoh_Atem> I'm sort of loathed to do either
17:57:21 <Rathann> no opinions about the extraneous "try to" in https://fedoraproject.org/wiki/PackagingDrafts/Rust#Versions section?
17:57:27 * ignatenkobrain has been busy with work on upstream RPM and stuff like that
17:57:47 <Pharaoh_Atem> especially since the stuff isn't fully stabilized in cargo yet
17:57:56 <ignatenkobrain> Rathann: yeah, I think SHOULD implies "try to"
17:58:00 <ignatenkobrain> so I think we should remove it
17:58:08 <limburgher> What iganenkobrain said.
17:58:14 <ignatenkobrain> fixing
17:58:19 <Pharaoh_Atem> fixed
17:58:37 <ignatenkobrain> :D
17:58:56 <Rathann> is the "with" dep syntax documented somewhere?
17:59:16 <Pharaoh_Atem> there's an RFC I wrote about it...
17:59:17 <Pharaoh_Atem> one sec
17:59:27 <Rathann> I don't quite understand how Requires: ((crate(syn) >= 0.11.0 with crate(syn) < 0.12.0) with crate(syn/visit)) is different from
17:59:30 <ignatenkobrain> Rathann: we will document it in RPM release notes.
17:59:46 <Rathann> Requires: (crate(syn) >= 0.11.0 with crate(syn) < 0.12.0)
17:59:48 <Pharaoh_Atem> Rathann: http://lists.rpm.org/pipermail/rpm-ecosystem/2017-February/000471.html
17:59:49 <Rathann> Requires: crate(syn/visit
17:59:54 <ignatenkobrain> Rathann: it matches against one dependency
18:00:03 <Pharaoh_Atem> there will be formal documentation with the 4.14 release, but that gives you a good idea of what it does
18:00:18 <ignatenkobrain> basically one package must satisfy all conditions
18:00:27 <Pharaoh_Atem> ^
18:00:31 <ignatenkobrain> Rathann: I've found one upstream bug due to this btw
18:00:45 <Rathann> the use of "with" is not intuitive here, "and" would be much more appropriate
18:00:56 <ignatenkobrain> unfortunately, and means something different =(
18:01:05 <limburgher> Question for those less Rust-ignorant than myself: What does Rust do in lieu of ldconfig?
18:01:05 <Rathann> *sigh*
18:01:21 <ignatenkobrain> limburgher: it doesn't ;) until you do dynamic libs
18:01:25 <ignatenkobrain> which we don't do so far
18:01:27 <Pharaoh_Atem> nothing right now
18:01:30 <Pharaoh_Atem> we don't have dylibs
18:01:35 <geppetto> Rathann: and was already taken
18:01:50 <geppetto> I'm not sure either is more obvious about it's special feature
18:01:51 <Pharaoh_Atem> Rathann: I wish we could have used "and", but :(
18:01:56 <limburgher> Eew.  K, thanks.
18:02:04 <limburgher> :)
18:02:18 <Pharaoh_Atem> there's a *long* discussion about getting the rust ABI stabilized so we can switch to dylibs
18:02:18 <ignatenkobrain> otoh it makes sense in terms of `Requires: (kernel with flavor = desktop)`
18:02:29 <ignatenkobrain> in that case I wouldn't put `and` there ;)
18:02:54 <Rathann> ok, got it
18:02:56 <Rathann> thanks
18:03:00 <tibbs> So if there are no dynamic libraries, how do you ensure rebuilds are done?
18:03:17 <tibbs> Ocaml packaging ensures this through dependencies somehow.
18:03:23 <Pharaoh_Atem> we don't have fanciness, so I guess we're going to just do it like the poor guys who do Boost :/
18:03:38 <ignatenkobrain> tibbs: well... ;) same as with golang packages... we have ticket to get somehow information what was used to build binary
18:03:41 <Pharaoh_Atem> Boost and Go
18:03:45 <ignatenkobrain> but so far it seems it requires Rust RFC
18:03:57 <tibbs> Well, go still has no packaging guidelines.
18:04:11 <ignatenkobrain> once I will get free'd a bit, I will write upstream Rust RFC to put this information somewhere in binary
18:04:38 <Pharaoh_Atem> tibbs: we're trying to avoid the mistakes of golang :)
18:04:55 <Pharaoh_Atem> I maintain a huge Go package and I want everything I have to do there not a thing here :)
18:04:56 <ignatenkobrain> tibbs: true :) so for now, people have to rebuild stuff as they find it. I will try to make some additional deps asap
18:05:12 <ignatenkobrain> https://pagure.io/fedora-rust/rust2rpm/issue/39
18:05:24 <Pharaoh_Atem> we probably want some kind of "rust-gather" script to triggger properly ordered rebuilds, since Koji can't do it
18:06:27 <tibbs> I'm not suggesting it's something that can be fixed with packaging guidelines anyway.  I honestly don't know if the ocaml dependencies actually enforce rebilds or if they just facilitate some other mechanism which does it.
18:06:43 <Pharaoh_Atem> afaik, rwmjones just gathers them and does it
18:07:03 <Pharaoh_Atem> I think the ghc guys do something similar
18:07:29 <Rathann> hm how about requiring all rust libraries to provide %{name}-static, too, because that's what they are right now, static libs
18:07:31 <Rathann> ?
18:07:31 <tibbs> Would be nice if we could find some generic method that can be used to standardize.
18:08:08 <Rathann> ah maybe not
18:08:12 <limburgher> Pharaoh_Atem: Sadly rwmjones, though awesome, only scales so far. :)
18:08:14 <ignatenkobrain> Rathann: well, those are sources.. I remember that we do it that way with headers.. but I never understood it.
18:08:25 <Rathann> I just noticed that devel subpackages are noarch
18:08:33 <Pharaoh_Atem> limburgher: I know, it's why I keep begging for some OBS-like auto-rebuilding power in the Fedora buildsystem
18:09:02 <Pharaoh_Atem> just updating the compiler triggers a targeted rebuild, fixing everything :)
18:09:19 <ignatenkobrain> tibbs: in modularity Fedora, this will not be a problem, everything will be rebuilt automatically btw
18:09:29 <Pharaoh_Atem> ignatenkobrain: I don't have high hopes for that
18:09:31 <ignatenkobrain> but that's unrelated ;)
18:09:34 <Rathann> still, I'd like to see a note somewhere that there's not support for dylibs for now and the libraries must be treated as header-only static libs
18:09:59 <ignatenkobrain> Pharaoh_Atem: ^ could you make a note about this
18:10:04 <Pharaoh_Atem> sure
18:10:05 <ignatenkobrain> though I was mentioning this one day :D
18:10:48 <limburgher> Rathann: YES
18:11:23 <tibbs> Anyway, I think what's there is certainly reasonable.
18:11:33 <Rathann> hm why are some BuildRequires: under # [dependencies] and some under # [build-dependencies] ?
18:12:04 <Rathann> aren't they all build dependencies?
18:12:23 <ignatenkobrain> Rathann: #[dependencies] is something what used to build package, #[build-dependencies] is something what used to do "pre-build" steps
18:12:30 <Rathann> and # [dev-dependencies]
18:12:46 <ignatenkobrain> and dev-deps is just test deps
18:12:53 <Pharaoh_Atem> Rathann: it's all poorly named in Cargo
18:12:57 <Rathann> ok
18:13:01 <Pharaoh_Atem> basically, they all map to BuildRequires
18:13:06 <ignatenkobrain> http://doc.crates.io/specifying-dependencies.html
18:13:09 <tibbs> The terminology is basically something that won't make much sense once they have actual runtime dependencies.
18:13:12 <Rathann> I see
18:13:15 <Pharaoh_Atem> ignatenkobrain: notes added
18:13:17 <tibbs> But, well, that's their mistake.
18:13:37 <Pharaoh_Atem> yep
18:13:41 <Pharaoh_Atem> nothing we can do about it for now
18:13:49 <Pharaoh_Atem> and one of the reasons I'm loathed to have our own parser for this
18:14:00 <Pharaoh_Atem> I think they'll wind up significantly reworking this in the future
18:14:07 <Rathann> ok, I'm +1 to the current version
18:14:25 <tibbs> +1
18:14:41 <limburgher> +1
18:14:48 <geppetto> +1
18:14:52 <Pharaoh_Atem> :D
18:15:01 <orionp> +1
18:15:03 <Rathann> one thing I slightly dislike is the use of %{summary} as %description of subpackages
18:15:11 <limburgher> #petpeeve
18:15:19 <limburgher> Usually %{summary}. :)
18:15:40 <ignatenkobrain> Rathann: probably I have to explicitly mention one thing here ;) `with` is new richop which are currently banned in fedora due to rel-eng tools are not supporting those. But I'm pushing hard and offering any help to rel-eng to start supporting them. And looks like it is going to be ready within F27 timeline.
18:15:40 <Pharaoh_Atem> I personally don't like it either, but afaik, long descriptions aren't a thing in Cargo
18:15:56 <ignatenkobrain> Pharaoh_Atem: Cargo has only long description ;)
18:16:03 <ignatenkobrain> so it doesn't have summary
18:16:18 <limburgher> Implement %{tldr}
18:16:33 <ignatenkobrain> Rathann: I usually put `%{summary}.` if description is same as summary
18:16:43 <ignatenkobrain> otherwise description has more info than summary
18:16:46 <Rathann> ok
18:17:09 <ignatenkobrain> e.g. check "Binary" section
18:17:15 <geppetto> ignatenkobrain: How bad is it if with is changed to and?
18:17:35 <Pharaoh_Atem> geppetto: see ML link I posted earlier :)
18:17:39 <ignatenkobrain> geppetto: it will just pull random packages into buildroot ;)
18:17:46 <Pharaoh_Atem> ^
18:17:50 <geppetto> ahh
18:18:01 <ignatenkobrain> that's the whole point of new richop we were working on ;)
18:18:07 * geppetto nods
18:18:20 <geppetto> just wondered if it was a corner case thing, or a nothing works thing
18:18:28 <Pharaoh_Atem> it's a nothing works thing
18:18:40 <ignatenkobrain> geppetto: it's not corner case, but very very common ;)
18:18:53 <Pharaoh_Atem> other people have hit it (nodejs, ruby, php, etc.)
18:18:58 <Pharaoh_Atem> but we hit it *all* the time
18:19:01 <ignatenkobrain> maintainers of every ecosystem were reporting bugs on this ;)
18:19:09 <geppetto> ok
18:19:21 <ignatenkobrain> actually, we were talking about this one day with Rathann here about it =)
18:19:56 <geppetto> mbooth: I think you're the only one that hasn't voted
18:20:06 <mbooth> geppetto: +1 as well
18:20:33 <geppetto> #action Rust Packaging Guidelines (+1:6, 0:0, -1:0)
18:20:37 <ignatenkobrain> so the only note from me here is how are we going to handle allowance of rich deps ;)
18:20:55 <geppetto> #topic Open Floor
18:21:11 <geppetto> Ok, we are over time by 20mins … so anyone have anything they need to talk about today?
18:21:18 <ignatenkobrain> not really =)
18:21:39 <limburgher> Not I said the duck.
18:21:43 <Rathann> I had something but I forgot what it was
18:21:53 * geppetto hands the duck a comma
18:21:58 <Rathann> something I wanted to mention to orionp specifically
18:22:01 <Rathann> ... :(
18:22:39 <ignatenkobrain> have to run.. thank you a lot for feedback!
18:22:40 * limburgher is grateful
18:22:42 <orionp> I'm around a few more hours if it comes to you...
18:23:02 <ignatenkobrain> (and obviously for your time spent)
18:23:17 <geppetto> ignatenkobrain: No problem
18:23:25 <Pharaoh_Atem> I've got to go myself
18:23:33 <geppetto> Ok, I'm going to close anyway
18:23:42 <Pharaoh_Atem> but thanks for looking it over
18:23:42 <Rathann> thanks everyone
18:23:43 <geppetto> Thanks for the work on the guidelines
18:23:46 <limburgher> Thanks all!
18:24:12 <geppetto> #endmeeting