15:31:26 <jwf> #startmeeting Fedora CommOps (2017-11-27)
15:31:26 <zodbot> Meeting started Mon Nov 27 15:31:26 2017 UTC.  The chair is jwf. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:31:26 <zodbot> The meeting name has been set to 'fedora_commops_(2017-11-27)'
15:31:40 <jwf> #meetingname commops
15:31:40 <zodbot> The meeting name has been set to 'commops'
15:31:42 <jwf> #nick commops
15:31:44 <jwf> #topic Agenda
15:31:48 <jwf> #link https://infinote.fedoraproject.org/cgit/infinote/tree/meeting-templates/fedora-commops-meeting-next
15:31:57 <jwf> /me needs to update ^
15:32:01 <jwf> #info (1) Roll call / Q&A
15:32:03 <jwf> #info (2) Announcements
15:32:09 <jwf> #info (3) Action items from last meeting
15:32:11 <jwf> #info (4) Tickets
15:32:13 <jwf> #info (5) Open floor
15:32:15 <jwf> #topic Roll call / Q&A
15:32:23 <jwf> #info Name; Timezone; Sub-projects/Interest Areas
15:32:25 <jwf> #action commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
15:32:28 <jwf> If this is your first time at a CommOps meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
15:32:45 <bt0> #info Alberto Rodriguez S; UTC-6;CommOps (Metrics, Community engagement), DotNet (Testing), Infrastructure(Apprentice), Markerting (Contributor)
15:32:46 <jwf> #info Justin W. Flory; UTC-5; CommOps, Diversity, Ambassador, sysadmin-badges
15:32:52 * jwf waves to bt0
15:32:54 <jwf> #chair bt0
15:32:54 <zodbot> Current chairs: bt0 jwf
15:33:10 * bt0 waves back to jwf
15:33:16 <jwf> I'm AFK for a couple more minutes – let's see if anyone else is around too.
15:33:26 <bt0> it's ok
15:38:45 <jwf> Okay, back.
15:38:55 <jwf> #topic Announcements
15:39:06 <jwf> Anything to share?
15:40:41 <jwf> It was mostly a quiet week from my POV.
15:40:59 <bt0> no, very quiet
15:40:59 <dhanesh95> #info Dhanesh B. Sabane, UTC+5:30, CommOps, Packaging, Python
15:41:21 <DiscordBridge> <Rhea> hai
15:41:31 <jwf> #info === "Fedora 25 End Of Life" ===
15:41:33 <dhanesh95> Whoops. I was too late on that one
15:41:38 <jwf> #link https://fedoramagazine.org/fedora-25-end-life/
15:41:43 <jwf> dhanesh95: No worries, welcome :)
15:41:45 <DiscordBridge> <Rhea> I have something to share for announcements too o.o
15:41:57 <jwf> #info === "Kernel 4.14 Test Day 2017-11-30" ===
15:42:04 <jwf> #link https://communityblog.fedoraproject.org/kernel-4-14-test-day-2017-11-30/
15:42:17 <jwf> @Rhea: Go for it :)
15:42:39 <DiscordBridge> <Rhea> Given the holiday on Thursday, i'd like to thank y'all for being awesome.
15:42:54 <DiscordBridge> <Rhea> 'ts all.
15:43:26 <jwf> .thank Rhea
15:43:27 <zodbot> jwf thinks Rhea is awesome and is happy they are helping! (Please don't forget to Rhea++ also)
15:43:38 <jwf> Right back at you!
15:43:41 <dhanesh95> .thank Rhea
15:43:42 <jwf> Anything else?
15:43:42 <zodbot> dhanesh95 thinks Rhea is awesome and is happy they are helping! (Please don't forget to Rhea++ also)
15:43:57 <dhanesh95> Rhea++
15:43:57 <zodbot> dhanesh95: Karma for rhea changed to 3 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:44:09 * bt0 thinks Rhea is amazing too
15:46:08 <jwf> #topic Action items from last meeting
15:46:16 <jwf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2017-11-20/commops.2017-11-20-15.31.html
15:46:32 <jwf> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action if needed. If no status, we'll try to get a quick update and move forward.
15:47:05 <jwf> #info === [INCOMPLETE] "jwf Follow up with Pingou about an old patch to support Fedora Badges with Mailman3 / Hyperkitty" ===
15:47:17 <jwf> #action jwf Follow up with Pingou about an old patch to support Fedora Badges with Mailman3 / Hyperkitty
15:47:21 <x3mboy> .fas x3mboy
15:47:23 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
15:47:24 <x3mboy> Sorry
15:47:33 <jwf> #info === "bt0 bt0 work on Issue #48 and break the information into smaller actions for Marketing team, file tickets and/or contact Marketing team about it" ===
15:47:33 <x3mboy> I'm a litte late
15:47:44 <jwf> Hey x3mboy! No worries.
15:47:53 <jwf> #chair dhanesh95 x3mboy Rhea
15:47:53 <zodbot> Current chairs: Rhea bt0 dhanesh95 jwf x3mboy
15:48:43 <bt0> ohh, thats is mine, complete :P
15:48:44 <jwf> bt0: Any updates?
15:48:52 <jwf> Awesome!
15:49:15 <jwf> #info ^ Completed this past week
15:49:25 <jwf> #info === "jwf Document process in upcoming internal docs writing" ===
15:49:34 <jwf> #action jwf Document process in upcoming internal docs writing
15:49:54 <jwf> #info === [IN PROGRESS] "jwf With FAD proposal, create a proposal draft and come up with new sub-tasks to divide and conquer among team members" ===
15:50:22 <jwf> I have a draft in the existing template, but haven't gone much further than that.
15:50:36 <jwf> #action jwf With FAD proposal, finish proposal draft and come up with new sub-tasks to divide and conquer among team members
15:51:10 <jwf> #info === [COMPLETE] "jwf Announce Mindshare nomination call on mailing list, remove ticket from meeting agenda, choose final candidate and confirm with robyduck on Monday, Dec. 4" ===
15:51:32 <jwf> #link https://lists.fedoraproject.org/archives/list/commops@lists.fedoraproject.org/thread/CZVZEHS5XCZQ3YN5N5GMBSYULQY2IIHT/
15:51:47 <jwf> #info === [INCOMPLETE] "jwf Produce the planning flowchart from FPL's template, use for dividing tasks and planning the rest of the FAD (due: 2017-11-27)" ===
15:51:59 <jwf> #action jwf Produce the planning flowchart from FPL's template, use for dividing tasks and planning the rest of the FAD
15:52:27 <jwf> I underestimated some of my time with the holiday last week. I'm going to be working on these more consistently this week.
15:53:04 <jwf> That's all the action items – to the tickets.
15:53:05 <jwf> #topic Tickets
15:53:11 <jwf> #link https://pagure.io/fedora-commops/issues?tags=meeting
15:53:34 <jwf> #info === Ticket #114: "Use metrics dashboard to visualize fedmsg data" ===
15:53:39 <jwf> #link https://pagure.io/fedora-commops/issue/114
15:55:36 <jwf> I'm due for the Grafana / Grimoire comparison. I know skamath was looking into the Perceval plugin if we used Grimoire.
15:56:16 <jwf> I was wondering if it would be helpful to plan out some of the types of metrics we want to show in an example dashboard.
15:57:08 <jwf> Knowing what kind of stories we want to show is something that I think is helpful for pre-planning too, and maybe a little more exciting than the technical research.
15:58:14 <jwf> We could do some brainstorming for that now, to make use of our time together in the meeting since the research isn't ready yet.
15:58:26 <DiscordBridge> <Rhea> jwf need help with FAD proposal?
15:58:29 <bt0> we have a collection of metric tools that can serve as a reference
15:58:44 <jwf> @Rhea: Yeah, definitely. I was going to bring that up in the next ticket. :)
15:59:00 <DiscordBridge> <Rhea> is waiting
15:59:06 <DiscordBridge> <Rhea> i'll be more patient
15:59:41 <jwf> bt0: Hmm, I was thinking less about the tools and more about the data visualizations we want to show. Other than pulling raw fedmsg data, are there trends we want to map? Or would be interesting to see?
15:59:51 <jwf> @Rhea: I appreciate your enthusiasm nonetheless :D
16:00:37 <jwf> For example, putting two different data sets together on one graph or chart to make comparisons.
16:01:04 <jwf> I was trying to think of things in fedmsg that would be helpful to group together like that.
16:01:45 <bt0> active contributors by group/country/last_seen
16:02:22 <jwf> For example, the size of the Ambassadors FAS group and the number of badges earned over a period of time (looking at whether more badges means more events, since there are so many event badges).
16:02:31 <bt0> cross core contributors (members of multiple groups and also core members of that groups)
16:02:39 <jwf> bt0: Yeah, exactly – things like this. :)
16:02:58 <jwf> #idea Active contributors by: FAS group, country, last_seen
16:03:35 <jwf> #idea Ambassadors FAS group membership mapped over time to number of badges (to ask, if there is correlation)
16:04:04 <jwf> #idea Cross core contributors: Users who are core members of multiple FAS groups
16:04:39 <jwf> I'm trying to think of questions or problems we want to solve too.
16:04:48 <bt0> that sounds a little tricky , by example, jwflory was a top badger this week and also member of Ambys but none of that badges is about events
16:04:51 <dhanesh95> Can we also visualize meeting data through fedmsg?
16:04:59 <jwf> I wonder if bexelbie is around for this one, I think he's been interested in this before.
16:05:52 <bt0> +1 for dhanesh95 idea (and dhanesh95++ )
16:05:52 <zodbot> bt0: Karma for dhanesh95 changed to 1 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:05:55 <jwf> bt0: Yeah, maybe filtered down to badges with the 'event' tag. It was kind of a stretch, but I was trying to give an idea of what I was talking about.
16:06:13 <jwf> dhanesh95: Hmm, what kind of meeting data? Generally, yes!
16:06:35 <jwf> If you peek in #fedora-commops, we can take all of those types of hooks firing off now.
16:06:45 * bexelbie reads
16:06:49 <bt0> cool, number of attendees , scheduled vs runned, etc
16:07:00 <dhanesh95> So maybe we can map the frequency of meetings and the number of active contributors. Maybe there's a correlation there?
16:07:47 <jwf> bexelbie: tl;dr – we're brainstorming ideas for visualization stories we want to show in the metrics dashboard while we're blocking on some technical research. Curious on your ideas for problems where data visualizations might be helpful.
16:08:26 <bexelbie> Average time between earning the starter/new series of badges and earning a "contribution" badge
16:08:33 <DiscordBridge> <Rhea> Meetings as data is kinda meh...
16:08:44 <jwf> dhanesh95: Active contributors in a FAS group by their meeting activity? Or do you mean all meetings and all contributors?
16:08:47 <DiscordBridge> <Rhea> So far in ... half a year? I've been to one ambassadors meeting.
16:08:52 <bt0> Rhea: lol :P
16:08:55 <DiscordBridge> <Rhea> The meeting time is "meh" for me.
16:09:05 <bexelbie> Ideas about who is active in what areas and across areas - not concerned with the people but are we isolated groups or a large mass that cross-polinates
16:09:14 <DiscordBridge> <Rhea> If I don't need anything from the meeting, I won't attend...
16:09:18 <bexelbie> Average time for response on an email list
16:09:43 <bexelbie> don't look for visualizations, in my opinion
16:09:49 <dhanesh95> jwf: I mean active contributors in a FAS group by their meeting activity. Maybe that can help us understand if it has any effect on contributors giving up and becoming inactive.
16:09:50 <bexelbie> we don't need pretty charts, we need answers to real questions
16:09:52 <bexelbie> imho
16:09:52 <dhanesh95> Just a thought
16:10:21 <bexelbie> dhanesh95, I'd be interested in average time a contributor stays active first
16:10:29 <DiscordBridge> <Rhea> Anyway that was supposed to be a me-example on how meeting times don't exactly capture every active contributor. I'm actieve as ambassador at conferences all over europe, I just don't attend meetings, I never ask for ambassador funding, etc... x_x
16:10:36 <bexelbie> is there a pattern of activity that predicts further activity versus inactivity?
16:10:41 <jwf> #idea Measure of time between earning "beginner" badges and an authentic "contribution" badge
16:11:12 <bexelbie> this would go toward "where do we need to stage an intervention"
16:11:16 <bt0> that idea is awesome
16:11:18 <bexelbie> i.e. if we see this pattern - send an email
16:11:27 <dhanesh95> bexelbie: I love that idea.
16:11:38 <jwf> #idea Measuring the "distance" between FAS groups: Are contributors active in different FAS groups? Are our sub-projects isolated groups or large mass that cross-polinates?
16:11:50 <jwf> #idea Average time for response on mailing list
16:12:11 <bexelbie> What groups go from new contributor to contribution the fastest and slowest
16:12:36 <bt0> Rhea " Anyway that was supposed to be a me-example on how meeting times don't exactly capture every active contributor. I'm actieve as ambassador at conferences all over europe, I just don't attend meetings, I never ask for ambassador funding, etc... " tha is my idea of being a great ambassador
16:12:49 <bexelbie> map specific event badges to patterns of activity and inactivity amongst recipients (where should we go for engagement)
16:13:09 <jwf> @Rhea: Right – this is why building these profiles is helpful since not every group or sub-project has the same trends or patterns.
16:14:09 <DiscordBridge> <Rhea> bt0 😄
16:14:12 <jwf> bexelbie: The last I knew of the pattern of activity was in the three-month lifecycle of a Fedora contributor that bee2502 discovered.
16:14:59 <jwf> #link https://jflory7.fedorapeople.org/pub/flock/2016/i-contributed-now-what/i-contributed-now-what-slides.pdf
16:15:59 <jwf> #idea How long it takes a new / beginner contributor to become a core contributor the fastest or slowest (compared against different FAS groups)
16:16:19 <DiscordBridge> <Rhea> hum...
16:16:53 <jwf> bexelbie++ ooohh, that one is nice, about event badges
16:17:01 <x3mboy> Well, for me, it depends on what a "core contributor" means?
16:17:37 <jwf> #idea "Do we go back or not?": Measuring users who get an event badge against activity in the project (are people we engage with getting into our community after the event?)
16:17:37 <DiscordBridge> <Rhea> What do you consider a core contributor?
16:17:38 <x3mboy> For example, I don't call myself a "core contributor", I don't develop or package anything, I just write a lot and love the terminal
16:18:17 <x3mboy> For me a core contributor is one that contribute to make the distro great and better
16:18:28 <jwf> x3mboy, @Rhea: This is something that would be specific for each FAS group, I think. Some groups may not have a way to effectively measure a core contributor or not (for example, I think of Marketing).
16:18:39 <x3mboy> Is spreading the word considered a core task to a distro?
16:18:57 <jwf> It's one idea that may fit well for some profiles, but not for others.
16:19:19 <DiscordBridge> <Rhea> Seeing how active you are, I'd say you are well within the core 😄
16:20:01 <jwf> Do either of you have ideas on how to measure a core contributor for a group? figuring that out would be helpful too, even if it's specific to only one or two groups.
16:20:49 <jwf> @Rhea: Heh, ask me about that after December… exams and traveling take a lot of my time
16:20:52 <bexelbie> Core Contributor is defined in mattdm's talks as the top 10% of contributors in a category
16:20:58 <bexelbie> without regard to type of contribution
16:21:14 <bexelbie> let's use the definition mattdm uses to avoid confusion
16:21:41 <jwf> Okay, fair.
16:21:51 <DiscordBridge> <Rhea> I do not think that we can figure out the exact measurement that would apply to everyone (even if we take the 10% - who is the 10% and how do you measure it?)
16:22:00 <DiscordBridge> <Rhea> We can come up with rough generic guidelines at best..
16:22:20 <jwf> #info Core contributors: Top 10% of contributors in a category (https://mattdm.org/fedora/2017flock/2017-State-of-Fedora.pdf)
16:24:14 <jwf> I guess defining the category is the next thing to wrangle. But I think this gives us a fair start to ideas on the dashboard. I'll get these organized and add a comment after the meeting.
16:24:26 <jwf> Anything else someone wants to throw out before going to the next ticket?
16:24:45 <jwf> Going once…
16:24:55 <jwf> Going twice…
16:25:00 <jwf> Going thrice…
16:25:07 <jwf> #info === Ticket #125: "[TRACKER TICKET] Organize a CommOps FAD" ===
16:25:11 <DiscordBridge> <Rhea> \o/
16:25:12 <jwf> #link https://pagure.io/fedora-commops/issue/125
16:26:17 <jwf> So, I obviously didn't get much work done on this over the last week, but it's something that has a finite time to complete. I think it would be helpful if we figured out some of the tasks we wanted to split up now.
16:26:53 <jwf> I'm still working through the things I actioned to myself earlier, but I think there's some things we could start doing independently
16:27:03 <DiscordBridge> <Rhea> Hmm... sorry just a one more question to previous... is the dashboard supposed to just display the data, or also come to some conclusions?
16:27:17 <DiscordBridge> <Rhea> Since we were talking about core contributors, did we drift off topic?
16:27:19 <jwf> Like the logistical planning of location, estimating travel costs / budget, etc.
16:27:35 <DiscordBridge> <Rhea> If we're just displaying the data, we don't care about who's the core contributor, that would be more of a use-case for the dashboard.
16:27:37 <dhanesh95> jwf: Is #108 still on the table??
16:28:01 <jwf> @Rhea: Hmmm… at a minimum, display the data. But if we do it well, come to conclusions too. :)
16:28:43 <DiscordBridge> <Rhea> Then we should note that it should be easily extended per-fas-group, so every fas group should be able to better define their core contributor "requirements"
16:29:00 <DiscordBridge> <Rhea> Or something along those lines?
16:29:03 <jwf> dhanesh95: Hmmm, we haven't looked at it in a while. If you're interested, we could cover it quickly next.
16:29:11 <DiscordBridge> <Rhea> Maybe not fas group but... category was the term used?
16:29:33 <dhanesh95> jwf: I was thinking maybe we can include it in our FAD.
16:29:37 <bexelbie> we need to build something that can easily answer questions
16:29:41 <jwf> @Rhea: That sounds right to me. That's what I had in mind too.
16:29:44 <bexelbie> don't lock us in
16:29:51 <bexelbie> we don't know the questions we will have in many cases
16:30:10 <jwf> dhanesh95: Oh, yeah. If we could integrate the Magazine and the CommBlog into FAS, that would be legendary
16:30:26 <DiscordBridge> <Rhea> +1
16:30:47 <jwf> dhanesh95: It would probably take a little bit of research into PHP and WordPress plugins, but if someone felt confident in it, we can make it a target ticket
16:31:14 <jwf> Actually, yeah, even identifying the tickets we want to focus on is something we can do independent of the other action items
16:31:21 <dhanesh95> jwf: When you say integration of Magazine and CommBlog into FAS, what exactly do you mean by that?
16:31:41 <DiscordBridge> <Rhea> FAD, not FAS I believe typo
16:32:38 <DiscordBridge> <Rhea> And if it wasn't typo then I'm confused 😛
16:32:47 <jwf> dhanesh95: fedmsg events for when new articles published, including their authors, any other accounts that edited the article, its category, and any tags; when an article is edited and by whom; when an article receives a certain number of views (if possible)
16:33:24 <jwf> Wait, d'oh
16:33:29 <jwf> I said FAS… but meant fedmsg
16:33:39 * jwf sighs
16:33:43 <DiscordBridge> <Rhea> hee hee
16:33:47 <dhanesh95> jwf: Me and skamath had a chat long time ago and he mentioned that we'll be needing Python for this. I think WordPress already has a REST API documentation.
16:33:56 <dhanesh95> #link https://developer.wordpress.org/rest-api/
16:34:07 <jwf> dhanesh95: Yeah, actually, that's right! For a few versions now. So probably even with Python then.
16:34:14 <jwf> I think this would be a good candidate ticket.
16:34:32 <DiscordBridge> <Rhea> (the #link is not quite in the right topic...err... ticket)
16:34:36 <dhanesh95> jwf: fedmsg integration would really be legendary
16:34:44 <jwf> #idea Ticket #108: Metrics for CommBlog / Fedora Magazine; integrating WordPress sites into fedmsg bus (events for when new articles published, including their authors, any other accounts that edited the article, its category, and any tags; when an article is edited and by whom; when an article receives a certain number of views)
16:35:03 * dhanesh95 was about to hit undo when jwf posted the idea
16:35:23 <jwf> I think it's relevant, I'll snag it and put it into the ticket as a reference later
16:37:25 <jwf> For location and dates, I thought after DevConf / before FOSDEM in Brno would be the best option for the FAD. Dates being anywhere from Jan. 29 — Feb. 1.
16:37:52 <jwf> For the Diversity FAD, it was held in the Red Hat office in Brno, a short distance from the DevConf venue
16:38:59 <jwf> It was cost-affordable and saved us money for bringing more people together.
16:39:20 <DiscordBridge> <Rhea> Start on Sunday 28 maybe?
16:39:42 <DiscordBridge> <Rhea> Like afternoon when devconf is kinda sorta over...
16:39:53 <jwf> One of the tasks we can start now is researching the dates and location to estimate a budget
16:39:56 <DiscordBridge> <Rhea> Actually I'll need to know asap about the dates.
16:40:02 <DiscordBridge> <Rhea> So I can book a room
16:40:09 <DiscordBridge> <Rhea> The time around devconf is always busy as hell
16:40:56 <bexelbie> we got luck last year with rooms - we may need to look at an offsite location this year
16:41:18 * jwf nods
16:42:31 <jwf> #help Research for logistical planning (location, travel, budget, dates, etc.) needed
16:43:29 <DiscordBridge> <Rhea> Yeah I can take care of it either way, on-or-off site
16:43:49 <DiscordBridge> <Rhea> Just gib a "GO!" :]
16:44:29 <jwf> :) We'll try to start earlier than later on that.
16:44:34 <jwf> Anyone else have anything to throw out here?
16:45:00 <DiscordBridge> <Rhea> bexelbie but last year we had one whole building less 😉 😉 😄
16:46:33 <bexelbie> yes, but there are some new meetings this year :)
16:46:37 <jwf> Heheh, I forgot there's a new one now too
16:46:39 <jwf> #topic Open floor
16:46:49 <bexelbie> and given the huge number of internal meetings, limited places an external meeting can be held
16:46:54 <bexelbie> how many people are we talking?
16:46:58 <bexelbie> 5, 10, 15?
16:47:12 <DiscordBridge> <Rhea> Not more than 10 for sure...
16:47:19 <DiscordBridge> <Rhea> We would fit into the smallest rooms
16:47:24 <jwf> bexelbie: It would be between 5-10
16:48:52 <jwf> Anyone have anything to share during open floor?
16:49:07 <jwf> Otherwise, we can wrap up a few minutes early.
16:49:10 <DiscordBridge> <Rhea> Nothing worth sharing to share o.o
16:49:11 <bt0> not this time
16:49:54 <x3mboy> Well, not from me
16:50:05 <x3mboy> I will work on the Hacking session to take some ticket
16:50:10 <x3mboy> But for now, nothin
16:50:13 <jwf> Alrighty, then I think we're good to close up. As always, thanks everyone for coming!
16:50:15 <x3mboy> Nothing*
16:50:17 <jwf> Oh, yes, the hack session
16:50:47 <jwf> I will be around 30 minutes late again because of a commute I have to do for two more weeks right before the hack session
16:50:52 <jwf> But I'll be there. :)
16:51:03 <jwf> Happy Monday to you all!
16:51:04 <jwf> #endmeeting