18:01:32 <geppetto> #startmeeting fpc
18:01:32 <zodbot> Meeting started Wed Feb  7 18:01:32 2018 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:32 <zodbot> The meeting name has been set to 'fpc'
18:01:32 <geppetto> #meetingname fpc
18:01:32 <geppetto> #topic Roll Call
18:01:32 <zodbot> The meeting name has been set to 'fpc'
18:01:39 <ignatenkobrain> hello ;)
18:01:47 <geppetto> #chair tibbs
18:01:47 <zodbot> Current chairs: geppetto tibbs
18:01:49 <geppetto> #chair Rathann
18:01:49 <zodbot> Current chairs: Rathann geppetto tibbs
18:01:55 <geppetto> #chair mbooth
18:01:55 <zodbot> Current chairs: Rathann geppetto mbooth tibbs
18:01:59 <geppetto> #chair orionp
18:01:59 <zodbot> Current chairs: Rathann geppetto mbooth orionp tibbs
18:02:16 <geppetto> Well, I'm obviously organized today … trying to have the meeting in $fedora-devel :)
18:04:14 <Rathann> no worries
18:04:17 * limburgher here-ish
18:04:17 <tibbs> I'm trying not to get the flu today.
18:04:33 * Rathann trying not to fall asleep
18:05:14 <geppetto> #chair limburgher
18:05:14 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp tibbs
18:05:22 <mbooth> 6 :-o
18:05:37 <geppetto> #topic Schedule
18:05:38 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/NJL2IBBF6HN622BZ5AVI4E5TDZC7SZ5A/
18:05:52 <geppetto> #topic #743 Add link to C/C++ build flag docs. in redhat-rpm-config
18:05:52 <geppetto> .fpc 743
18:05:56 <zodbot> geppetto: Issue #743: Add link to C/C++ build flag documentation in redhat-rpm-config - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/743
18:06:24 <Rathann> this seems reasonable
18:06:55 <geppetto> I'm tempted to say "yes, please do a draft" :)
18:06:59 <limburgher> LOL
18:08:26 <geppetto> I suspect florian is super busy … I guess if we just add the link somewhere, we can probably hack it in "now"
18:08:39 <tibbs> I swear I had commented in that ticket.
18:09:07 <Rathann> in this section: https://fedoraproject.org/wiki/Packaging:Guidelines#Compiler_flags
18:09:30 <tibbs> Well.... one interesting question is whether we're comfortable with the document we're linking to basically being about the current state of rawhide.
18:10:02 <geppetto> I thought that'd gone everywhere now
18:10:05 <tibbs> And also, at what point does content in a linked document stray into guidelines territory.
18:10:41 <geppetto> ignatenkobrain: is the new redhat-rpm-config config. in all releases or just rawhide?
18:11:04 <tibbs> Well, the point is that it links straight into git.
18:11:05 <Rathann> I propose adding something like "Current (rawhide) compiler and linker flags are documented here: [link] or even turn "system rpm configuration" into a link.
18:11:14 <tibbs> It's not pointing at a file that's on end user systems.
18:11:22 * geppetto nods … yeh
18:11:36 <tibbs> Note that Florian wrote that document basically because modifying the packaging guidelines is too difficult.
18:11:40 <ignatenkobrain> just rawhide I suppose
18:11:55 <tibbs> Really that document _is_ a packaging guideline.
18:12:13 <ignatenkobrain> better to ask fweimer if he wants to backport it to older releases... but I guess he doesn't want
18:12:26 <tibbs> I do think there's a case to be made for just importing it, but then modifications have to go through bureaucracy.
18:12:27 <geppetto> yeh, damit ... I first thought it was just a macro file with comments
18:13:00 <tibbs> No, it's a really nice guideline drafts.
18:13:21 <tibbs> And it does say that "you must" do things.
18:13:32 <geppetto> yeh, scimming the text it seems fine … but we can't just point to that, sigh.
18:13:50 <tibbs> I think that's really the fundamental question.
18:15:33 <tibbs> Personally I think it's a well-written document that we could certainly just import wholesale.
18:15:39 <Rathann> hm you may be right
18:16:18 <geppetto> Any idea what to call it?
18:16:31 <mbooth> Like replacing the whole c/c++ page with this doc, and removing the compiler flags section from the main guidelines?
18:17:34 <mbooth> Probably makes sense to also rename the page to "Packaging:C, C++ and Fortran" in that case
18:17:39 <tibbs> There's probably a little bit more in the c/c++ page which we'd want to keep, but yeah.
18:18:57 <geppetto> ok, so we really need a draft then … to see where this is going and what it is replacing
18:19:19 <geppetto> anyone want to volunteer to help florian?
18:20:04 <mbooth> geppetto: Assign it to me and I'll hopefully have some time
18:20:49 <geppetto> #action mboddu Will help florian get a real draft we can vote on, probably merging that docs. into the C/C++ page.
18:21:06 <geppetto> #topic #749 Add note about disabling BRP scripts to guidelines
18:21:08 <Rathann> by the way, I'm wondering why our C and C++ guidelines seem to suggest clang is an equal alternative to gcc?
18:21:13 <geppetto> .fpc 749
18:21:19 <mbooth> geppetto: Damn overloaded username prefixes ;-)
18:21:22 <zodbot> geppetto: Issue #749: Add note about disabling BRP scripts to guidelines - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/749
18:21:36 <geppetto> Gah
18:21:55 <mbooth> Rathann: Because is the main guideline it says you can use clang if your package does not compile with gcc, for example
18:22:26 <Rathann> they do, but the C and C++ page doesn't seem to prefer gcc over clang
18:23:09 <mbooth> #749 was something I wrote following the last meeting -- instead of various pages explaining how to disable burp scripts, I thought it could be in one place and referenced
18:23:51 <geppetto> Is there a good way to get a list of all the current brp scripts?
18:24:21 <mbooth> geppetto: https://src.fedoraproject.org/rpms/redhat-rpm-config/blob/master/f/macros#_137
18:26:48 <tibbs> geppetto: rpm --showrc, look for __os_install_post
18:27:09 <tibbs> That was the subject of my comment in 749.
18:27:16 <Rathann> $ rpm --eval '%__os_install_post'
18:27:57 <geppetto> Those are the expanded macros though
18:29:00 <tibbs> RIght, --eval isn't what you want.  --showrc is the best thing  (besides just looking in the macro files).
18:30:37 <geppetto> even showrc is after the macro's are expanded
18:30:54 <tibbs> Not on F27 and rawhide, at least.
18:31:21 <geppetto> What does: rpm --showrc | fgrep brp say?
18:31:35 <tibbs> Or at least, not in the way that matters for the question at hand.
18:32:33 <geppetto> Well I want something we can show packagers which is "you need to undefine foo" and to get a list of foo run XYZ
18:32:40 <Rathann> right
18:32:55 <tibbs> If that's what we want then we will have to maintain that list by hand.
18:33:23 <tibbs> On rawhide, __os_install_post just tells you things like "%{?__brp_ldconfig}".
18:33:58 <tibbs> The list shown there is all that will be called as far as I'm aware (and of course some of those are also conditional on __debug_package.
18:34:18 <Rathann> this seems to be the right file /usr/lib/rpm/redhat/macros
18:34:26 <geppetto> Yeh, was was just wondering if that file mbooth linked to is available somewhere you can fgrep _brp_ on
18:34:44 <geppetto> But I don't think it is … looks like it's compiled into rpm magically
18:34:55 <mbooth> geppetto: Is this not enough? https://paste.fedoraproject.org/paste/08IeB8hOvosoZmpR11AFCg
18:35:22 <Rathann> or /usr/lib/rpm/platform/%{_arch}-linux/macros
18:35:28 <tibbs> Please note that what you get on rawhide is significantly different than what you get on F27.
18:35:47 <mbooth> Yeah, I mean the guideline I wrote says F28+
18:36:09 <geppetto> mbooth: I get '' for that on F27
18:36:42 <geppetto> If that's the way to see it going forward I'm happy to point to that fgrep … just that it doesn't do anything here.
18:37:27 <tibbs> F27 doesn't have any uniform method of disabling brp scripts.
18:38:05 <tibbs> Which is presumably why the proposal says that it's F28+ only.
18:38:50 * geppetto nods … looking at rawhide now
18:40:43 <geppetto> Cool, rawhide repo. is broke on F27
18:41:18 <geppetto> upgrading to rawhide rpm didn't show anything
18:41:48 <geppetto> upgrading to reawhide redhat-rpm-config ftw
18:42:34 <tibbs> It's all in /ur/lib/rpm/redhat/macros.
18:42:35 <ignatenkobrain> since I need to leave, I probably want to ask you to fix https://fedoraproject.org/wiki/Packaging:Scriptlets#Shared_Libraries page... it should use `libs` instead of `-n libs`, `%license` instead of `license` and `[…]` instead of `[,,,]`
18:43:32 <tibbs> Did I get that that wrong?  The lack of uniformity where you use -n and where you don't in RPM is really annoying.
18:44:20 <tibbs> But wait, you do use %post -n foo.
18:44:28 <tibbs> So why not %ldconfig_scriptlets -n foo?
18:44:49 <tibbs> That's the way I intended the macro to work.
18:44:49 <geppetto> So this is probably what we want to put in: fgrep '%__brp_' /usr/lib/rpm/redhat/macros
18:45:17 <tibbs> ignatenkobrain: I fixed the missing % in %license.
18:45:29 <tibbs> I don't see what else you wanted to be changed.
18:46:10 <geppetto> Adding the fgrep line in, I'm +1 on the change for brp stuff.
18:46:52 <tibbs> geppetto: There's no guarantee that every mention of __brp_ is going to show a script that actually gets called by default.
18:47:05 <tibbs> Looking at __os_install_post is really the only reasonable way.
18:47:23 <Rathann> tibbs: s/-n libs/libs/
18:47:32 <tibbs> Rathann: I disagree with that, though.
18:47:52 <Rathann> uh why?
18:47:59 <geppetto> That's technically true … but I hope they'd keep the same naming convention, so it would work … and this way we can say "run this command" instead of "hunt through this source file"
18:47:59 <Rathann> %files -n libs is surely wrong?
18:48:00 <tibbs> -n libs works fine and mirrors all of the other scriptlets.
18:48:19 <tibbs> So which -n libs are you talking about, then?
18:48:32 <Rathann> the one next to %files
18:48:53 <tibbs> So the libs subpackage doesn't have any files?
18:49:13 <tibbs> I mean, if there's a libs package at all, it has to have a %files section.
18:49:27 <Rathann> exactly
18:49:38 <tibbs> And it will start with %files -n libs, won't it?
18:49:43 <Rathann> but %files -n libs is for a package name 'libs', not 'foo-libs'
18:50:09 <ignatenkobrain> Rathann: yep
18:50:21 <tibbs> So you're asking for libs to be changed to example-libs or whatever?
18:50:42 <Rathann> no, I'm asking for s/%files -n libs/%files libs/
18:50:43 <ignatenkobrain> or just drop `-n` in there
18:51:35 <ignatenkobrain> and s/[,,,]/[...]/ also
18:51:36 <tibbs> So I guess 749 got derailed completely, sorry.
18:51:48 <tibbs> Rathann: You know you can edit that page....
18:51:55 <mbooth> :-)
18:52:05 <geppetto> I thought the idea of "libs" there was meant to imply "the package which provides the libraries" not necessarily "foo-libs"
18:52:28 <geppetto> So I don't think it's wrong … but maybe it's better without the -n
18:52:34 * geppetto ¯\_(ツ)_/¯
18:52:44 <Rathann> heh
18:53:10 <geppetto> There are certainly examples of subpackages which aren't just %{name}-libs
18:55:36 <tibbs> Sadly we're still not getting through enough stuff.
18:56:30 <geppetto> Having a meeting is a start, wanting to decide on what to do for more than one ticket is just optimism
18:57:02 <geppetto> Anyway I think people mostly agree with 749
18:57:11 <tibbs> Yes.
18:57:16 <Rathann> I voted already
18:57:42 <geppetto> So that's +3
18:57:54 <mbooth> I updated it to include your suggestions
18:57:56 <geppetto> I'd like a list command, but if you'd prefer not to … then I'm +1 anyway
18:58:05 <geppetto> So that's +4
18:58:06 <tibbs> I'm +1 to any of the three proposed variants (the original, mine that mentions os_install_post, and one that gives more detailed info on how to find out what will be called.
18:58:20 <geppetto> orionp: limburgher: Vote?
18:58:35 <mbooth> i.e. mention _os_install_post so packagers can go digging AND mention the fgrep command to list them on F28+
18:58:44 <mbooth> Hopefully that pleases all :-)
18:59:34 <orionp> sure, +1
18:59:40 <limburgher> Sorry, was AFK. . .reading. . .
18:59:57 <limburgher> +1
19:00:01 <geppetto> Ok, that's +5
19:00:24 <geppetto> #action Add note about disabling BRP scripts to guidelines (+1:5, 0:0, -1:0)
19:00:35 <geppetto> So … done, two tickets dealt with (kinda)
19:00:44 <geppetto> #topic Open Floor
19:01:05 <geppetto> Anything anybody wants to talk about in the -0 seconds we have left ?:)
19:01:47 <Rathann> nope
19:02:20 <geppetto> #endmeeting