17:20:29 <Kellin> #startmeeting RELENG (2018-02-08)
17:20:29 <zodbot> Meeting started Thu Feb  8 17:20:29 2018 UTC.  The chair is Kellin. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:20:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:20:29 <zodbot> The meeting name has been set to 'releng_(2018-02-08)'
17:20:35 <Kellin> #meetingname releng
17:20:35 <zodbot> The meeting name has been set to 'releng'
17:20:42 <Kellin> #chair dgilmore nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu Kellin
17:20:42 <zodbot> Current chairs: Kellin dgilmore masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
17:20:56 <nirik> morning
17:22:28 <Kellin> morning
17:22:31 <Kellin> #topic Create another new tag for Modularity
17:22:37 <Kellin> #link https://pagure.io/releng/issue/6663
17:23:05 <Kellin> is this still a relevant thing?
17:29:47 <nirik> no idea, ask in bug, close if no answer?
17:31:46 <Kellin> #info Pinging Ralph Bean in https://pagure.io/releng/issue/6663 to see if this is still needed
17:32:25 <Kellin> #topic f26 mass branching followups
17:32:30 <Kellin> #link https://pagure.io/releng/issue/6676
17:32:39 <Kellin> this is likely relevant since F28 branching is just around the corner
17:32:47 <Kellin> if any of this is still apropos
17:32:59 <nirik> yeah, it's going to be very different... no pkgdb
17:33:14 <puiterwijk> Also, I thought we weren't going to actually branch?
17:33:17 <Kellin> was pkgdb here for F27?
17:33:34 <Kellin> no branch?  are we going to just work out of rawhide?
17:34:06 <puiterwijk> I think the plan was to just use Git as Git. i.e., use the stream branching and allow people to create an f28 braanch if they so desire
17:34:13 <nirik> puiterwijk: there's some proposals around that, but not public until now. ;)
17:34:23 <puiterwijk> nirik: oh.
17:34:42 <nirik> but yeah, anything like that should get discussed well in advance of mass branching...
17:34:49 <puiterwijk> Right.
17:35:06 <puiterwijk> Kellin: but to answer your original question: during f27 branch we still had pkgdb I think
17:35:28 <nirik> yeah, we did for f27 I think...
17:35:52 <nirik> anyhow, I'd propose we just table this for a few weeks and see if any proposals change things before we go updating a bunch of stuff.
17:36:33 <puiterwijk> agreed
17:36:33 <Kellin> I'm not sure tabling it is a good idea - we should ping the folks who are making suggestions and at the very least get the discussion activated.  It's not something to leave to the last second, yah?
17:38:12 <Kellin> mass branching would be 12 days from today
17:38:18 <Kellin> if we keep on the schedule
17:38:44 <nirik> I think they intend to... was talk at devconf/etc around it...
17:39:11 <puiterwijk> Yeah, I talked with Pierre about it last week, and he said he'd bring it up then.
17:39:29 <puiterwijk> Anyway, let's give them a few more days and ping people
17:40:09 <puiterwijk> Kellin: if we go ahead with mass branching, those same people would have to write the code for that anyway (if that's not yet done). If it is done, there's not much we'd need to do upfront
17:40:26 <Kellin> puiterwijk: so low risk of causing a delay is what I'm hearing?
17:40:43 <puiterwijk> Of the tabling proposal: yes.
17:41:26 <puiterwijk> The branching itself - nobody knows yet. WE haven't tried it yet
17:43:18 <Kellin> so...table changes for now, wait for contributors who were discussing it at devconf to come forward, ping them in a few days if they don't
17:43:26 <Kellin> is that a fair summary of the proposal?
17:43:33 <Kellin> *table change discussion
17:44:57 <nirik> sure.
17:45:13 <Kellin> #info tabling discussion of change request to wait for contributors discussing it at DevConf to put forward their ideas.
17:45:36 <Kellin> #action Kellin and puiterwijk will discuss again in a few days to determine if we should ping people.
17:47:55 <Kellin> #topic F26 Alpha image paths and CHECKSUM files changed partially from underscore to dash
17:48:00 <Kellin> #link https://pagure.io/releng/issue/6739
17:48:18 <Kellin> so this looks like nothing to do, not sure why it's tagged meeting?
17:49:41 <Kellin> I would assume this is a scripting issue and should be moved to Taiga to ensure this is documented as part of our deliverables
17:49:46 <nirik> dunno... except as a reminder not to mess with image filenames because it messes up websites and others.
17:51:58 <Kellin> seems to me the information belongs in https://docs.pagure.org/releng/sop_composing_fedora.html - we agree that's the right place?
17:55:09 <nirik> seems plausable
17:55:16 <Kellin> going with that then
17:55:42 <Kellin> #info The information needs transcribed into release engineering's SOP for composes.
17:56:08 <Kellin> #action Kellin to update the Composing Fedora SOP
17:56:58 <Kellin> We are 4 minutes to the end of meeting, do we have any need for Open Floor today or do one more ticket?
17:59:23 <Kellin> #topic Open Floor
17:59:31 <Kellin> nirik: puiterwijk any pressing matters?
18:00:00 <puiterwijk> Let's go with "no"
18:00:13 <Kellin> okay, well it's the end of our hour, thanks all
18:00:17 <Kellin> #endmeeting