14:04:49 <otaylor> #startmeeting Fedora Atomic Workstation
14:04:49 <zodbot> Meeting started Mon Mar  5 14:04:49 2018 UTC.  The chair is otaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:49 <zodbot> The meeting name has been set to 'fedora_atomic_workstation'
14:04:59 <jlebon> .hello jlebon
14:05:00 <zodbot> jlebon: jlebon 'None' <jlebon@redhat.com>
14:05:03 <lorbus> .hello2
14:05:04 <zodbot> lorbus: lorbus 'Christian Glombek' <c@petersen-glombek.de>
14:05:08 <walters1> .hello walters
14:05:09 <zodbot> walters1: walters 'Colin Walters' <walters@redhat.com>
14:05:20 <miabbott> .hello miabbott
14:05:21 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
14:05:30 <sanja> .hello2
14:05:31 <zodbot> sanja: sanja 'Sanja Bonic' <sanja@redhat.com>
14:05:55 <otaylor> .hello otaylor
14:05:56 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
14:06:43 <dustymabe> .hello2
14:06:44 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
14:07:02 <otaylor> We don't have a well-assembled agenda today. I thought we'd start by going back to the topic of F28 release goals - then have an open floor for anything else people want to discuss
14:07:17 <otaylor> #topic F28 release goals for Fedora Atomic Workstation
14:07:33 <kalev> .hello kalev
14:07:34 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
14:07:37 <sanja> sounds good
14:07:47 <walters> my topic is perhaps related to that
14:08:03 <sanja> Agenda: https://fedoraproject.org/wiki/Workstation/AtomicWorkstation/SIG/Agenda
14:08:04 <walters> so i know not many people follow PRs on the repo
14:08:14 <walters> but I had one more I wanted to do today: https://paste.fedoraproject.org/paste/Rq42tH16KQFa0UQyZW4QbA
14:08:35 <walters> big picture goals: slim down the base, but include newer container tech (podman/buildah)
14:08:54 <walters> dropping the virt stack by default feels perhaps aggressive but I think it's the right long term move; if you want it you can install it, but virt-in-container is sane too
14:09:06 <otaylor> walters: sounds good, we'll get to that next - maybe we can discuss the base/main split then.
14:09:38 <walters> I found out `origin-clients` is now "just" 40MB instead of 270MB
14:09:38 <otaylor> sanja: Thanks - looks like we also have the bootloader spec questoin
14:10:08 <otaylor> OK - on f28 release gaols - it seems like we should have a "works" goal to start with
14:10:41 <kalev> I guess a question here is how much we want to differ from a regular Workstation install -- I believe an original goal was to have Workstation and Atomic Workstation as close in the package set as possible
14:10:43 <otaylor> I think that means installs, runs, updates - on F28 release day
14:11:13 <otaylor> kalev: that's the next topic, I think :-)
14:11:15 * kalev nods.
14:11:50 <otaylor> Do we think we "work" by that definition now - are there things to fix before f28?
14:12:22 <walters> kalev: there's lots of aspects to that, such as whether FW installs container tools by default
14:12:46 <walters> to me though it's not FAW if you have e.g. `fpaste` on your root filesystem by default
14:12:56 <walters> you're not doing FAW if you're not living in containers 😃
14:13:44 <otaylor> Should we move on to that topic then? :-)
14:13:56 <kalev> sure :)
14:14:04 <walters> otaylor: i think there's a ton of stuff to fix but no...blockers?
14:14:05 <otaylor> #topic Package set composition
14:14:50 <otaylor> walters: let's tag anything that looks like a F28 blocker as such on the FAW pagure
14:16:11 <kalev> I think I'd prefer a slightly larger default package set (similar to regular Workstation) until we have a working app install in gnome-software
14:16:13 <otaylor> I'm definitely of the opinion that the default set for FAW and FW should be *very* similar. I would expect differences for update-tooling - no PackageKit on FAW or whatever, and for things that you specifically need do differently... but I don't think FAW should be more stripped down from the user point of view.
14:16:19 <walters> SGTM
14:16:30 <kalev> right now we don't support layered packages in gnome-software, and we don't have flatpaks in fedora infrastructure, so we can't show them in gnome-software either
14:16:37 <walters> #link https://pagure.io/workstation-ostree-config/pull-requests?status=0
14:17:01 <walters> otaylor: is that arguing for stripping down FW too or you disagree with the PRs so far?
14:17:04 <kalev> I would be happy to reconsider this once we have working app install in FAW gnome-software
14:17:36 <otaylor> walters: I think I've voiced objections once or twice on the PR's, but I haven't had time to do full reviews :-(
14:17:56 <otaylor> I definitely strongly objected in one of them to the idea of removing graphical applications
14:17:57 <walters> i think there's a much bigger question to answer around how much we promote this
14:18:31 <walters> i was originally closer to where you feel, but now I live in containers a lot more
14:18:58 <jlebon> is the eventual goal that we replace FW with FAW?
14:19:02 <otaylor> I don't mind *minor* stripping down of FW if there are things that seem just spurious ... and as we get a better container based devel story.
14:19:58 <otaylor> jlebon: yes, but only when we don't feel like we're alienating significant amounts of users that way. I don't want it to be a "our way or the highway" situation
14:20:24 <walters> let me outline a simple vision: FAW is like https://blog.lessonslearned.org/building-a-more-secure-development-chromebook/ but with container tools on the host by default, and the ability to install packages where you want it and flatpak for non-web-apps
14:20:27 <jlebon> otaylor: right, that makes sense
14:21:05 <walters> (and you have full control over the system implicitly, not just what google signs)
14:21:45 <jlebon> so then, we need to figure out which workflows that we have right now on FW we want to transparently port to newer technologie
14:22:26 <jlebon> and which ones we're comfortable with expecting users to learn
14:23:30 <otaylor> My feeling is that from a non-developer end-user point of view, FW and FAW should feel pretty similar. I don't think we have resources to maintain two things long term.
14:23:46 <walters> another thread running through this is my expectation is people who want anything beyond the "chromebook experience" should be comfortable with the command line and learning new things
14:24:33 <walters> i'm not sure that e.g. "gnome boxes installed by default vs not" is a huge maintenance burden compared to e.g. PackageKit vs not
14:24:38 <otaylor> walters: I certainly don't think that we're trying to provide the *same* developer experience - that doesn't really make sense.
14:25:06 <jlebon> otaylor: yeah, i think that's probably the right barometer to adhere to
14:25:18 <miabbott> i think an out-of-the-box 'chromebook experience' is a reasonable goal for FAW
14:25:27 <kalev> I would be perfectly fine with dropping gnome-boxes from the default FW install and FAW install both, but I think I'd like to have the same decision across the two products right now
14:25:27 <jlebon> same non-developer workflows, vastly different developer workflows
14:25:34 <otaylor> walters: to me, the question is partly simply whether the FAW SIG wants to be deciding about Simple Scan or whatever separately from the FW working group - I think not.
14:26:04 <dustymabe> +1
14:26:08 <dustymabe> less burden
14:26:42 <walters> so on that topic the starting point for my PR series was scripting keeping comps in sync
14:27:10 <walters> so by default then we'll pick up FW (comps) changes
14:27:13 <walters> but on top of that we now have a "blacklist"
14:28:00 <walters> i think though in general baking apps in by default conflicts with flatpak and sends the wrong long term message
14:28:03 <otaylor> Yeah-  I agre ewith that, but I disagree with about half the contents of the blacklist
14:28:20 <otaylor> Things are a lot more baked in if they are in people's layer list...
14:28:44 <walters> (of course this intersects rather strongly with the "what if we preloaded flatpaks" thread)
14:28:54 <walters> hmm, why do you say that?
14:29:14 <walters> in that the package names are like an ABI?
14:29:55 <dustymabe> :) - we lost him
14:30:19 <walters> this thread may be better as a mailing list thread?
14:30:50 <otaylor> (sorry, chat client crashed)
14:31:21 <otaylor> I think it's good here ... though actually I'm going to have to run very soon - I managed to double book myself. :-(
14:31:31 <walters> i was just saying this may be better as a mailing list discussion
14:31:44 <otaylor> walters: we can continue it there, yes.
14:32:34 <kalev> what's the mailing list for Atomic Workstation? desktop@ list, same as for regular Workstation?
14:32:37 <otaylor> Can someone take over chairing the meeting?
14:32:52 <otaylor> kalev: yes
14:33:10 <otaylor> quick question - should I send meeting reminders to the fedora atomic list as well?
14:33:33 <dustymabe> otaylor: atomic-devel@projectatomic.io should be good
14:33:33 <sanja> yes please
14:33:44 <jlebon> that'd be nice
14:33:47 <lorbus> otaylor: yes please
14:35:19 <walters> #action walters to start a thread on desktop@ about these PRs
14:36:17 <jlebon> hmm, i think only otaylor is chair right now
14:38:16 <walters> ok, anyone have any other topics?
14:39:26 <miabbott> the agenda has a question of switching to the bootloader spec and its implications for FAW
14:42:50 <walters> i'd need to learn more about that, it'll probably mostly be for me to sort out wrt ostree/grubby
14:42:56 <walters> offhand i think it'll improve the install-inside-existing flow
14:44:29 <sanja> ok then let's be done with the meeting for today - in 2 weeks we might know more after discussions on the list if we do them and more information on other fronts
14:44:41 <kalev> good plan
14:45:16 <jlebon> sgtm
14:45:31 <sanja> if otaylor is gone, can we eve end the meeting
14:45:35 <miabbott> ¯\_(ツ)_/¯
14:45:39 <sanja> s/eve/even/
14:46:22 <sanja> well then, thanks for being here everyone and have a nice week
14:46:58 <lorbus> thanks everyone! :)
14:47:08 <otaylor> #endmeeting