16:59:25 <mboddu> #startmeeting RELENG (2018-03-15)
16:59:25 <zodbot> Meeting started Thu Mar 15 16:59:25 2018 UTC.  The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:59:25 <zodbot> The meeting name has been set to 'releng_(2018-03-15)'
16:59:25 <mboddu> #meetingname releng
16:59:25 <zodbot> The meeting name has been set to 'releng'
16:59:26 <mboddu> #chair dgilmore nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu Kellin
16:59:26 <mboddu> #topic init process
16:59:26 <zodbot> Current chairs: Kellin dgilmore masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
17:00:10 <masta> howdy
17:01:59 <dgilmore> hi
17:02:49 <Kellin> .hello kellin
17:02:50 <zodbot> Kellin: kellin 'Kellin' <kellin@retromud.org>
17:03:32 <mboddu> masta: FYI, https://www.reddit.com/r/Fedora/comments/837zi3/fedora_media_writer/ we replied to his comment and he understood the problem
17:03:47 * masta looks
17:04:18 <nirik> morning
17:05:35 <masta> mboddu, thx for the update
17:05:58 <mboddu> masta: sure
17:06:06 <mboddu> Lets start
17:06:25 <mboddu> #topic [RFE] Add new repositories for modular[-updates[-testing]]
17:06:32 <mboddu> #link https://pagure.io/releng/issue/7227
17:06:40 <mboddu> Just wanted to get the status on this one
17:06:52 <mboddu> Seems like we got the compose working the way we want today
17:07:12 <mboddu> Bodhi is still WIP
17:07:23 <Kellin> is that for permanent, or still a temporary thing until we turn it back to the way it was?  how did that land?
17:07:56 <mboddu> Kellin: Which one are you talking about? FMW or ...?
17:08:02 <nirik> Kellin: pungi is finally doing what we want I think? so, it should be perm...
17:08:38 <Kellin> ...the modular topic we're on, not FMW
17:08:54 <Kellin> I was under the impression that we split it out for now, but modularity WG wants to go back to unified in a month or two
17:09:00 <Kellin> but it was 'in the air'
17:09:17 <Kellin> so I'm asking if that's landed or if we need to keep that on the radar to know if/when that change request will show up
17:09:25 <mboddu> Kellin: Okay, we got what we want from pungi, modular is part of the pungi compose as a variant
17:10:01 <mboddu> We are doing hybrid composes, which has all the things we used to do before with Modular as a new variant
17:10:05 <nirik> perhaps we could ask in this ticket if this is the final desired state?
17:10:12 <nirik> I thought it was... but could be wrong.
17:10:41 <mboddu> nirik: Its a good idea, rather than assuming what we think is right
17:11:11 <mboddu> #action mboddu will update the ticket with what we got from the pungi compose and ask if it is what they want
17:11:26 <mboddu> #undo
17:11:26 <zodbot> Removing item from minutes: ACTION by mboddu at 17:11:11 : mboddu will update the ticket with what we got from the pungi compose and ask if it is what they want
17:11:30 <mboddu> #action mboddu will update the ticket with what we got from the pungi compose and ask if it is what they wanted
17:12:36 <mboddu> nirik: Any other tools, processes that you know of to update or WIP?
17:12:39 <mboddu> other than Bodhi
17:13:36 <nirik> bodhi... and mbs I think needs more work.
17:13:38 <puiterwijk> Note that I sent emails to infra and devel list with some info for what people need to watch out for.  (NVR vs NSVC)
17:14:06 <puiterwijk> nirik: I think the mbs work is for multi-platform (multi-stream expansion), the basics should be fine as far as I know
17:14:43 <nirik> well, we still cannot build for rawhide/f29? or was that just a pdc issue now?
17:14:55 <puiterwijk> That's just the fact that there's no platform entry in PDC
17:14:58 <dgilmore> nirik: pdc
17:15:03 <puiterwijk> pdc content
17:15:27 <nirik> ok. so needs a '29' there? or rawhide? or both?
17:15:48 <dgilmore> possibly both
17:15:55 <puiterwijk> mbs uses "29"
17:15:59 <dgilmore> probaly needs to be looked at
17:16:07 <dgilmore> but rawhide should eb called rawhide
17:16:11 <dgilmore> not 29
17:16:14 <puiterwijk> We should ask for SOP docs
17:16:17 <nirik> well, I can probibly add it, but we need to add that info to the branching SOP
17:16:19 <mboddu> Kellin: So, for f28 we want modular and Everything to be separate but for F29 it might change, we dont know how its going to look https://pagure.io/pungi/issue/862#comment-497664
17:16:20 <dgilmore> puiterwijk: indeed
17:16:39 <dgilmore> puiterwijk: and if MBS requires 29 a RFE should be filed to fix it
17:16:51 <nirik> well, we have pdc SOP... there's a command line tool to add/edit things
17:17:02 <puiterwijk> nirik: sure. But this would need to happen anytime we branch
17:17:14 <nirik> yes, it needs to be in that SOP for sure.
17:17:46 <dgilmore> I do not think any of the sops have been updated for pkgdb being removed, or for supporting modules
17:18:25 <mboddu> dgilmore: we just updated branching SOP to consider pdc and pagure over dist-git, but not for modules
17:18:35 <dgilmore> mboddu: okay
17:18:49 <mboddu> just = during f28 branching
17:18:59 <Kellin> mboddu: so that's what I have an eye on, because we got hit super late in the F28 cycle with changes required for modularity, we need to be on guard to avoid the same in F29 cycle
17:19:11 <dgilmore> was everything actually covered?
17:19:57 <mboddu> dgilmore: in the SOP? yes, I followed what pingou was doing and added it to SOP
17:20:06 <dgilmore> mboddu: okay
17:21:38 <nirik> should I make the f29 release in pdc? or wait until threebean is around to make sure it's correct?
17:22:04 <mboddu> nirik: If I am not wrong I created the release
17:22:06 * mboddu checks
17:22:17 <nirik> there is a fedora-29-updates
17:22:21 <nirik> but no fedora-29
17:23:36 <mboddu> nirik: Yup, which I haven't created afaik
17:24:40 <nirik> yeah, modules are not buildable until that exists. (not sure what other effects it has)
17:25:26 <mboddu> nirik: Sorry, I created product version 28 - https://pdc.fedoraproject.org/rest_api/v1/product-versions/?version=28
17:25:38 <nirik> right, we need a 29 too. :)
17:26:02 <mboddu> But we have a product version called rawhide, so ...
17:26:31 <nirik> ok, well, we can sort it outside of the meeting...
17:26:38 <mboddu> nirik: Okay
17:27:20 <mboddu> #info We think pungi work is done, bodhi, pdc, mbs might still need some updates
17:27:56 <puiterwijk> bodhi should be about done now hopefully. At least very soon
17:29:02 <mboddu> #info Bodhi work is almost done and hopefully deployed very soon
17:29:22 <mboddu> Okay, moving on
17:29:42 <mboddu> #topic #7113 proposal to run bodhi updates pungi composes with `--no-label`
17:29:49 <mboddu> #link https://pagure.io/releng/issue/7113
17:30:02 <mboddu> puiterwijk: Can you give us a quick as you recently worked on this one
17:30:04 <mboddu> ?
17:30:05 * puiterwijk wonders why that's back on the meeting agenda...
17:30:35 <mboddu> puiterwijk: Just an update, thats all
17:30:35 <puiterwijk> mboddu: they want some tests to happen as part of the bodhi compose. We need a patch and FBR for that.
17:30:39 <masta> It's easy to apply a label after pungi compose, just edit the composeinfo.json
17:30:52 <puiterwijk> masta: the subject is no longer applicable
17:31:14 <masta> puiterwijk, oh my bad
17:31:19 <puiterwijk> The bug title is entirely wrong now, and we need to change one thing in the bodhi pungi configs and they want to add image creation to it.
17:31:40 <puiterwijk> I have just not had time to look at this due to the other bodhi work. It's on the todo list
17:31:47 <mboddu> puiterwijk: Okay, thanks for the update
17:32:13 * puiterwijk thinks it should be untagged from meeting. There's not really anything to discuss about it at this stage
17:32:36 <dgilmore> indeed
17:32:53 <mboddu> puiterwijk: Okay
17:33:41 <mboddu> #topic #7398 Make Rawhide repository handling more suitable for automated processing
17:33:48 <mboddu> #link https://pagure.io/releng/issue/7398
17:34:19 <mboddu> I haven't gone through it fully yet, but looks a big change
17:34:53 <mboddu> It just got filed 15 min back
17:34:55 <mboddu> Do you guys want to do this now or punt it for next week?
17:35:24 <nirik> lets look at it next week... I actually think a lot of it is already done in mm...
17:36:05 <mboddu> nirik: Okay
17:36:15 <masta> I'd like to study it
17:36:47 <mboddu> #info Punting it for the next week
17:38:40 <mboddu> #topic #7344 Please generate static deltas for FAW27
17:38:48 <mboddu> #link https://pagure.io/releng/issue/7344
17:39:01 <mboddu> So, generating static deltas for FAW
17:39:24 <masta> does pungi even support that yet?
17:39:31 * masta thinks no
17:39:49 <mboddu> masta: Seems like it https://pagure.io/releng/issue/7344#comment-495606
17:40:13 <mboddu> Not sure if got an updated pungi with that patch in it
17:40:56 <masta> we can do it manually
17:42:45 <mboddu> masta: Sure, but I think its better to automate it from start
17:44:04 <mboddu> Anyway, my idea is to run it after we push batched updates and then if a security bug or something fixed, then they can file a ticket against releng and we will do it manually
17:45:29 <masta> sounds reasonable.
17:46:55 <masta> side question, does anybody know if we prune static deltas?
17:47:32 <Kellin> not in all cases iirc - it's on the roadmap
17:48:42 <masta> cool
17:48:53 <mboddu> masta: not sure, but I think we prune old composes https://pagure.io/releng/blob/master/f/scripts/push-two-week-atomic.py#_603
17:50:02 <mboddu> Any +1's or -1s on the idea when to generate the static deltas?
17:52:01 <mboddu> If not, we can punt the decision to next week
17:52:11 <masta> mboddu, i'm +1 on the batch updates.
17:52:22 <mboddu> masta: Thanks
17:53:15 <masta> or, static deltas should be avoided on a daily basis
17:55:01 <mboddu> #info Current plan is to generate the static deltas for FAW after we push batched updates and also generate them manual as on necessity basis
17:55:05 <mboddu> Okay, lets move on
17:55:09 <mboddu> #topic Open Floor
17:55:16 <mboddu> Anybody got anything?
17:56:09 <puiterwijk> Also for releng, it might be useful to read my email on devel/infra lists on NVRs/NSVs
17:56:32 <puiterwijk> (actually, I'd say "especially for releng", since there's likely a bunch of scripts and tools parsing NVRs)
17:57:14 <masta> hehe... yeah
17:57:24 <mboddu> puiterwijk: Sure, I am going to
17:57:49 <masta> will do puiterwijk
17:59:21 <mboddu> puiterwijk: I just opened it and Context in NVSC caught my eye
17:59:26 * mboddu will read more about it
17:59:36 <mboddu> Anyway, I think this is it for today
17:59:42 <mboddu> Thank you all for joining
17:59:52 <masta> thx mboddu for hosting
18:00:00 <mboddu> #endmeeting