17:00:02 <mboddu> #startmeeting RELENG (2018-05-17)
17:00:02 <zodbot> Meeting started Thu May 17 17:00:02 2018 UTC.
17:00:02 <zodbot> This meeting is logged and archived in a public location.
17:00:02 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:02 <zodbot> The meeting name has been set to 'releng_(2018-05-17)'
17:00:03 <mboddu> #meetingname releng
17:00:03 <zodbot> The meeting name has been set to 'releng'
17:00:03 <mboddu> #chair nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu Kellin dustymabe
17:00:03 <zodbot> Current chairs: Kellin dustymabe masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
17:00:03 <mboddu> #topic init process
17:00:14 <nirik> morning
17:00:32 <mboddu> nirik: How goes? Thanks for looking into sssd and refiring rawhide
17:00:56 <masta> hey gang
17:01:08 <mboddu> masta: Hello
17:01:20 * masta waves hello
17:02:37 <nirik> no problem... lucikly it wasn't a long fix.
17:02:37 <mboddu> I have only 2 topics today
17:03:11 <mboddu> nirik: :)
17:03:39 <mboddu> Okay, lets start
17:03:51 <mboddu> #topic #7501 Fedora 28 debuginfo path inconsistency
17:03:58 <mboddu> #link https://pagure.io/releng/issue/7501
17:04:14 <mboddu> So, the problem here is inconsistency between updates and updates-testing repos
17:04:24 <mboddu> http://mirrors.syringanetworks.net/fedora/linux/updates/28/Modular/x86_64/debug/
17:04:25 <mboddu> and
17:04:31 <mboddu> https://mirror.steadfast.net/fedora/updates/testing/28/Modular/x86_64/debug/
17:05:08 <nirik> see also https://bugzilla.redhat.com/show_bug.cgi?id=1578301
17:05:30 <mboddu> Yes
17:05:50 <nirik> we need to snip the tree. :)
17:06:35 <masta> I concur
17:06:53 <masta> whack tree
17:07:03 <mboddu> nirik: Oh, there was an inconsistency with where the repos are generated (which seems to be fixed now)
17:07:12 <mboddu> So, yeah, I will updates the fedora-repos package
17:07:23 <mboddu> I have big git stash waiting in my repo :)
17:07:46 <nirik> yeah, we should make sure and pick up all the pending changes...
17:07:53 <nirik> ie, check tickets/bugs
17:07:56 <mboddu> #action mboddu will work on updating the url's in fedora-repos package and send it as an update
17:08:01 <mboddu> nirik: Yup
17:08:26 <mboddu> nirik: I will create the PR today and please review it when you get a chance
17:08:40 <nirik> I wonder if we shouldn't update/add a f30 key now too... to save us from having to late.
17:08:42 <nirik> later.
17:09:10 <masta> good idea
17:09:51 <mboddu> nirik: I am having hard time parsing that statement, you want to add f30 key now or later?
17:10:08 <nirik> I want to generate it and add it now.
17:10:21 <nirik> even tho we aren't going to be using it until branching
17:10:25 <masta> the earlier the better
17:10:51 <mboddu> nirik: Oh okay, true and I agree, "if we shouldn't update/add a f30 key now" confused me :)
17:11:13 <mboddu> masta: Hehe :)
17:11:37 <mboddu> nirik: Do you wanna add it to f26 as well? Generally we dont generate the key this advance, so ?
17:12:16 <nirik> well, what ones are we updating?
17:12:48 <nirik> I guess just f28 for the debug/tree thing?
17:12:49 <mboddu> nirik: Only the current releases - non EOL'ed releases
17:13:19 <mboddu> nirik: Oh, f28 and f29 for debug/tree thing and "adding to f26" is about f30 key
17:13:48 <nirik> ah, no need to update f26 for that I don't think... no one should try f26 -> f30 upgrades... only 2 is supported
17:14:29 <mboddu> nirik: Okay :)
17:14:46 <mboddu> #info nirik will generate the f30 key and add it to fedora-repos
17:14:55 <mboddu> Okay, moving on
17:15:02 <nirik> I guess there's the entire rawhide or 29 ticket that could also change repos... but not sure when we want to change for that
17:15:29 <mboddu> Yeah, we will get to it when we get there
17:15:35 <mboddu> #topic #7498 Support on-the-fly tarball generation in Koji
17:15:41 <mboddu> #link https://pagure.io/releng/issue/7498
17:16:31 <mboddu> So, this has been a hot topic in the last couple of days
17:17:04 * mboddu is a bit confused about what the ticket is all about based on the comments
17:18:54 <mboddu> So, what if "on the fly" it generates the tar ball and uploads the tar to our lookaside cache and store the checksum in out dist-git and then does a build from it?
17:19:00 <mboddu> Is that what they are asking?
17:19:10 * masta reads the ticket
17:20:16 <mboddu> If it is, then we have to support tons of version control systems as there are still a lot on SVN
17:20:18 <nirik> I very much dislike depending on 3rd party infra over the net to do builds.
17:20:36 <mboddu> Good point
17:21:15 * mboddu heard of bazaar after a long time :)
17:22:39 <nirik> I guess I'd say we let the discussion continue... I am not seeing great advantages so far.
17:23:04 <masta> I don't like this so far, but I am afraid I've not fully digested the topic
17:23:09 <nirik> The one I can think of is it will help maintainers with slow upload... they won't have to upload source anymore
17:23:48 <masta> yeah, it would reduce the steps
17:25:05 <mboddu> nirik: True
17:25:09 <mboddu> Okay, lets punt it
17:25:41 <mboddu> #info Punting it for now and let the discussion continue on releng ticket
17:26:19 <mboddu> #topic Alternative Architectures updates
17:26:34 <mboddu> sharkcz: Are you around?
17:26:43 <nirik> when is f26's end?
17:26:57 <mboddu> nirik: May 29th
17:27:16 <nirik> cool.
17:28:03 <mboddu> nirik: You can bring the s390x koji instance after that :)
17:28:09 <mboddu> bring down the*
17:28:33 <nirik> yeah... well, we can ask for those secondary ones to be added to our primary ones.
17:28:45 <mboddu> Hehe, which is what I was about to type :)
17:29:18 <mboddu> Anyway, lets move on as Dan is probably not around
17:29:31 <mboddu> #topic Open Floor
17:30:25 <nirik> I moved the armv7 builders mostly back to fedora 27... to avoid that bug with f28
17:30:35 <nirik> Hopefully it will get tracked down soon.
17:30:55 <mboddu> #info nirik downgraded arm builders to F27 due to an issue - https://bugzilla.redhat.com/show_bug.cgi?id=1576593
17:31:12 <nirik> and composers are up on 28 now along with all the other builders.
17:31:54 <mboddu> #info nirik upgraded composers to F28 and all other builders (non armv7) are running on F28 as well
17:32:26 <mboddu> Anybody got anything else?
17:32:43 <nirik> not off hand
17:33:32 <mboddu> Okay, this is a quick meeting
17:33:36 <mboddu> Thank you all for joining
17:33:49 <mboddu> Oh, I think I missed one thing
17:34:35 <mboddu> #topic #6676 f26 mass branching followups
17:34:41 <mboddu> #link https://pagure.io/releng/issue/6676
17:34:59 <mboddu> Kellin wanted to ask something about this ticket, but he is not around
17:35:09 <nirik> I guess someone needs to script something to figure out what those missing ones are...
17:36:00 <mboddu> nirik: I think Pierre made the changes that are required for pdc and pagure over dist-git
17:37:05 <nirik> ah, I thought this was a different ticket.
17:37:11 <nirik> is this all done then?
17:38:11 <mboddu> nirik: The only thing that I can think off is containers in OSBS
17:38:33 <mboddu> container namespace in dist-git is working
17:38:42 <mboddu> I am not sure if there are any changes required in OSBS
17:42:56 <nirik> dunno. I guess really someone should go thru the ticket, make sure everything is addressed and those things that aren't file new tickets wherever they should be fixed.
17:43:35 <mboddu> nirik: Okay, I will look into it then and talk to cverna if needed
17:43:53 <nirik> thanks mboddu
17:43:57 * cverna is around if needed
17:44:19 <mboddu> #info mboddu will go through the ticket to check if everything is done or not, if not, he will file tickets accordingly
17:44:23 <mboddu> cverna: Hehe :)
17:44:41 <mboddu> cverna: So, quick question, do we need to do anything on OSBS side when we branch?
17:45:16 <mboddu> container namespace in dist-git is handled, not sure if any changes are required on OSBS side
17:45:44 <cverna> nothing that I can think of like that. I pretty sure there is nothing needed to be done on OSBS itself
17:46:08 <mboddu> cverna: Okay, thanks for the info
17:46:16 <cverna> np
17:46:18 <mboddu> Okay, thats all I got
17:46:25 <mboddu> Thanks guys for joining
17:46:31 <mboddu> #endmeeting