13:01:27 <mclasen> #startmeeting Team Silverblue
13:01:27 <zodbot> Meeting started Mon Jun 11 13:01:27 2018 UTC.
13:01:27 <zodbot> This meeting is logged and archived in a public location.
13:01:27 <zodbot> The chair is mclasen. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:27 <zodbot> The meeting name has been set to 'team_silverblue'
13:01:53 <mclasen> I'm not sure we will have quorum today for a meeting - Sanja can't make it and Kalev is on vacation
13:02:08 <mclasen> #topic Roll call
13:02:10 <linuxmodder> what is team silverblue?
13:02:33 <mclasen> the fedora atomic workstation sig
13:02:46 <linuxmodder> ah
13:02:51 <linuxmodder> .hello linuxmodder
13:02:52 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@gmail.com>
13:03:09 <linuxmodder> all these name changes :)
13:03:09 <notkhris> .hello kthebyrd
13:03:10 <zodbot> notkhris: kthebyrd 'Khristian Byrd' <contact@khris.io>
13:03:37 <K_REY_C[m]> Are you basically looking to make subgraph for Fedora workstation?
13:03:53 <miabbott> .hello miabbott
13:03:54 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
13:04:20 <mclasen> K_REY_C[m]: I don't know subgraph, so I can't give you a detailed comparison
13:05:48 <mclasen> you may have better luck asking #atomic how it compares
13:05:55 <K_REY_C[m]> Container OS, basically. https://subgraph.com/ I'd read something about that on your site for Fedora 30.
13:06:11 <K_REY_C[m]> Understood. Thanks!
13:07:13 <mclasen> do we have items for the agenda ?
13:07:40 <mclasen> i would like to get an update on flatpak builds, but owen is not here
13:09:14 <mclasen> another item we could talk about is next steps for the docs on teamsilverblue.org
13:09:40 <notkhris> yeah I’m not sure anyone with actions is actually here.
13:12:01 <mclasen> I can give some status update on a few things, before we talk about docs
13:12:37 * dustymabe waves
13:12:48 <mclasen> hi dustymabe
13:13:00 <notkhris> hey dustymabe
13:13:02 <jlebon> .hello jlebon
13:13:02 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
13:13:07 <mclasen> #topic Matthias' updates
13:13:11 <dustymabe> .hello2
13:13:12 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
13:13:26 <mclasen> so, things I've achieved since we last met:
13:13:49 <mclasen> I got Silverblue added to osinfo-db, so it will show up nicely in gnome-boxes install dialog soon
13:14:31 <mclasen> and I got a talk about Silverblue accepted at GNOME.asia
13:15:38 <jlebon> cool!
13:15:43 <dustymabe> mclasen: any chance we can coordinate talks submitted for flock over here: https://pagure.io/atomic-wg/issue/502
13:16:09 <mclasen> sure
13:16:22 <mclasen> lets talk about that
13:16:58 <mclasen> I have heard that misc may be willing to do a silverblue talk at flock
13:17:23 <mclasen> misc: ?
13:18:11 <otaylor> .hello otaylor
13:18:12 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
13:18:49 <mclasen> I haven't submitted a flock talk myself because i'll only be there for part of it
13:19:04 <mclasen> anybody else want to talk about atomic or workstation topics at flock ?
13:19:32 <mclasen> otaylor: you are going too, right ?
13:20:31 <misc> mclasen: yes
13:20:33 <dustymabe> I think misc said he was going to
13:20:35 <otaylor> mclasen: yes  will be there, likely will submit another talk about flatpaks on fedora, in hopes that people will actually be able to build them and it won't be still more future pie
13:21:07 <misc> i was hoping to do a "2 month on silver blue" talk, upon well, me using silverblue since 2 months, the workflow, etc, etc
13:21:10 <otaylor> Don't think I'd submit anything on silverblue specifically unless there was a big gap that we needed to fill
13:21:36 <mclasen> otaylor: sounds fine
13:21:50 <misc> (so tell people when/what to use flatpak, what is missing, the whole pet container stuff, etc, etc). I have some ideas in my head, but not redacted yet
13:22:24 <mclasen> dustymabe: are there atomic talks ? the ticket doesn't list any...
13:24:29 <mclasen> I think it makes sense to collect silverblue and flatpak talks on that same ticket ?
13:25:03 <dustymabe> mclasen: yeah we just haven't submitted them yet
13:25:12 <dustymabe> first CFP deadline closes this week
13:25:15 <mclasen> #info add your silverblue and flatpak flock talks to https://pagure.io/atomic-wg/issue/502
13:25:22 <dustymabe> mclasen: please do add other talks to that ticket :)
13:25:34 <mclasen> sure
13:26:12 <mclasen> #topic status update on flatpak building
13:26:23 <mclasen> otaylor: anything to report ?
13:27:37 <otaylor> I jumped through some hoops to get test data all set up on fedora staging, and things should be all set to start pushing test through builds with cverna and seeing how they work. Hopefully over the next few days. I started some work on bodhi support - so hopefully we can have that out of the box as soon as we can start building flatpaks - it's needed to get them to registry.fedoraproject.org
13:28:35 <otaylor> We decided to scale back registry-indexing from a full blown service (written last fall, never deployed) to a simpler script to output a static index triggered off of bodhi pushes - that seemed much more doable for f29.
13:29:19 <otaylor> I think that's about all. Progress, but definitely incremental.
13:29:35 <mclasen> that sounds encouraging, though!
13:29:58 <mclasen> I'm looking forward to install the first flatpak coming out of this
13:30:50 <mclasen> thanks for the update owen
13:31:53 <mclasen> dustymabe: shall we talk briefly about the issue you filed ?
13:32:02 <dustymabe> mclasen: +1
13:32:10 <mclasen> #topic https://pagure.io/teamsilverblue/issue/20 - rebranding
13:32:47 <mclasen> the ticket lists a number of places where the name change could or should have an effect
13:33:25 <mclasen> for some of them, I have no idea what they are or what the effect is
13:33:47 <dustymabe> yep. a lot of "releng" implications
13:33:55 <dustymabe> know anybody with skills on that front?
13:34:39 * dustymabe notes that this work is why he was kinda like "What's wrong with the existing name" during the rebranding :)
13:37:38 <mclasen> whats the downside to keeping the current name in all the releng-relevant places, and just update UI strings ?
13:37:44 <mclasen> confusing ?
13:38:03 <dustymabe> yeah i mean that's a big part of it
13:38:33 <dustymabe> kind of like going to a restaurant named Bob's and all the glasses and menus on the inside say "Jim's"
13:39:01 * mclasen always goes to Joes
13:39:06 <dustymabe> :)
13:39:28 <dustymabe> it's work that's going to need to be done at some point
13:39:38 <mclasen> yes, I agree
13:39:45 <dustymabe> i'm just calling it out and saying that we need to plan it if you want it to happen for f29
13:39:59 <dustymabe> otherwise you'll try  to shove the changes in late and everyone will be upset with you
13:40:05 <dustymabe> believe me, i've been there before
13:40:07 <mclasen> lets briefly go through these, then
13:41:06 <mclasen> /etc/os-release is one that I believe mattdm was looking at. one of the strings does show up in the UI
13:41:46 <dustymabe> k
13:42:02 <mclasen> anaconda install media - does this mean the UI ?
13:42:41 <dustymabe> right. I think it says "Workstation" now in the UI
13:43:02 <mclasen> no idea where anaconda takes that string from. do you know ?
13:43:25 <dustymabe> fedora-logos packages
13:43:26 <mclasen> maybe it comes from lorax templates ?
13:43:42 <dustymabe> it's a Picture file that gets displayed
13:44:00 <dustymabe> for Atomic Workstation I think we just left it as "Workstation"
13:44:09 <dustymabe> for Atomic Host it says "Atomic"
13:44:16 <mclasen> I'll file an anaconda ticket and we can track it down there
13:44:48 <dustymabe> it might be good to create a highlevel ticket for each of these in the silverblue tracker
13:45:10 <mclasen> I'll do it that after the meeting
13:45:24 <mclasen> #action matthias will file individual tickets for the rebanding tasks
13:45:58 <mclasen> next, what refs does the user pull - thats branch names in the ostree repository ?
13:46:18 <dustymabe> right
13:46:35 <dustymabe> right now it's fedora/28/x86_64/atomic-workstation
13:46:35 <mclasen> are those specified in the json manifest that we feed to rpm-ostree ?
13:46:54 <dustymabe> that is one place it's specified, yes
13:47:12 <mclasen> I guess it is in the lorax templates as well
13:47:13 <dustymabe> but there are many places that use that string
13:47:45 <dustymabe> actually for the lorax templates we're good. but we will need to update the pungi configs to pass updated arguments to the lorax templates
13:47:47 <dustymabe> :)
13:47:52 <dustymabe> it's a can of worms
13:48:01 <mclasen> and docs, of course
13:48:22 <mclasen> where do the pungi configs live ?
13:48:35 <dustymabe> pagure.io/pungi-fedora
13:49:09 <mclasen> thanks
13:49:26 <mclasen> next, anaconda install class - whats that ? I have no idea
13:50:29 <dustymabe> that's basically the small amount of anaconda configuration that specifies like default partitioning and stuff like that
13:50:44 <dustymabe> for now we've just been re-using workstation configs
13:51:07 <mclasen> I see. that seems fine to keep doing ?
13:52:47 <mclasen> next one, media name
13:53:02 <dustymabe> right. but we'll probably want to make an explicit install class and inherit from the workstation one
13:53:12 <mclasen> ok, thats another anaconda issue to file
13:53:30 <dustymabe> media name, yep. we'll need to rename the variant from atomic workstation to silverblue
13:53:37 <dustymabe> that should give us the right media name
13:53:52 <mclasen> media name gets decided... let me guess - in pungi configs ?
13:54:22 <dustymabe> yeah, in and around pungi-fedora
13:54:26 <mclasen> ok
13:54:27 <dustymabe> also might need some changes to comps
13:54:57 <mclasen> is there some matching with comps group names ?
13:55:12 <dustymabe> i honestly can't remember
13:55:14 <dustymabe> :(
13:56:05 <mclasen> alright, we will keep an eye on composes as these changes happen
13:56:21 <mclasen> last list item: variants in pungi configs. Again, I'm clueless
13:58:59 <dustymabe> ahh yeah that was part of what we discussed before :)
13:59:06 <dustymabe> so we already talked about it
13:59:10 * dustymabe brb
13:59:17 <dustymabe> thanks mclasen for going through the list
13:59:31 <dustymabe> i'm just trying to give you all enough information to be successful
13:59:32 <mclasen> alright
13:59:37 <mclasen> out of time for this week
13:59:43 <mclasen> one minute for open floor
13:59:46 <mclasen> #topic open floor
13:59:58 <mclasen> speak now, or I'll close the meeting
14:02:31 <mclasen> #endmeeting