16:01:28 <mboddu> #startmeeting RELENG (2019-05-02)
16:01:28 <zodbot> Meeting started Wed May  1 16:01:28 2019 UTC.
16:01:28 <zodbot> This meeting is logged and archived in a public location.
16:01:28 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:28 <zodbot> The meeting name has been set to 'releng_(2019-05-02)'
16:01:28 <mboddu> #meetingname releng
16:01:28 <zodbot> The meeting name has been set to 'releng'
16:01:28 <mboddu> #chair nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu dustymabe ksinny jednorozec
16:01:28 <zodbot> Current chairs: dustymabe jednorozec ksinny masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
16:01:28 <mboddu> #topic init process
16:01:36 <nirik> morning
16:01:58 <mboddu> nirik: Morning
16:02:28 <mboddu> Happy F30 release
16:02:51 <mboddu> nirik: I am hearing a lot of good things about F30 release
16:02:58 <nirik> cool
16:03:04 <mboddu> Esp on reddit
16:05:16 <mboddu> Okay, lets get started
16:05:29 <mboddu> #topic
16:05:29 <mboddu> #8307 Fedora 31 change impact: Set skip_if_unavailable default to false
16:05:37 <mboddu> #undo
16:05:37 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f7e673434d0>
16:05:45 <mboddu> #topic #8307 Fedora 31 change impact: Set skip_if_unavailable default to false
16:05:55 <mboddu> #link https://pagure.io/releng/issue/8307
16:06:10 <nirik> I don't think this will affect us any... but I've not given it too much thought...
16:06:36 <mboddu> nirik: Yeah, afaik it wont break anything, but I just want to bring it up and see
16:07:22 <mboddu> nirik: I will close the ticket and see if it breaks anything at that point then or if anyone remembers anything they can reopen it and add the info
16:07:24 <nirik> nothing I can think of
16:07:40 <nirik> do we have that set in the h264 repo?
16:08:12 <nirik> yeah, it's set to false anyhow there.
16:08:39 <nirik> I can't think of any impact here.
16:09:21 <mboddu> nirik: It is set to true - https://src.fedoraproject.org/rpms/fedora-repos/blob/master/f/fedora-cisco-openh264.repo#_11
16:09:37 <mboddu> But I dont think it will affect it, since it is explicitly set
16:10:55 <nirik> right
16:11:32 <mboddu> #info This change might not break anything in infra and releng.
16:12:35 <mboddu> #topic #8294 coreos-pool and coreos-release koji tags request for FCOS
16:12:40 <mboddu> #link https://pagure.io/releng/issue/8294
16:13:03 <mboddu> nirik: This requires koji hub policy changes, I am waiting on infra freeze lift
16:13:09 <mboddu> But mizdebsk is on vacation
16:13:17 <mboddu> Can we do it together?
16:13:31 <nirik> freeze is lifted.
16:13:39 <nirik> sure, we can try.
16:13:48 <mboddu> Sorry, I was waiting*
16:14:10 <nirik> you want to whip up a patch and I can review? or we can both look at it later today?
16:14:23 <mboddu> Cool, I can make the changes and will send the patch to infra list
16:14:33 <mboddu> Or the 2nd option
16:14:38 <mboddu> Up to you
16:16:17 <nirik> sure, thats fine.
16:17:16 <mboddu> nirik: Cool, once reviewed I need your help to push the changes
16:17:44 <mboddu> #action nirik and mboddu will work on this ticket later today
16:19:13 <dustymabe> +1 thanks y'all
16:19:24 <dustymabe> this will help us get unblocked so we can release FCOS soonish
16:19:42 <mboddu> dustymabe: Since you are here, have time for couple of quick questions?
16:19:53 <dustymabe> sure - i just got back so haven't read scrollback
16:20:02 <dustymabe> but I can try to answer questions :)
16:20:06 <mboddu> Not entirely related to the ticket
16:20:17 <dustymabe> kk
16:20:45 <mboddu> 1. Is there anything else needed from infra or releng (other than release part) as part of setup for FCOS release?
16:20:58 <mboddu> 2. When do you think we will be ready for the release?
16:21:37 <dustymabe> 1. not sure yet - but we'll need to figure out signing - don't worry we'll reach out to you when we've brainstormed on it and have questions or a proposal
16:21:50 <dustymabe> 2. probably late june or early july
16:22:21 <dustymabe> btw thanks for joining us a few weeks ago for a brainstorm session - that was really helpful I think
16:22:34 <nirik> oh, and I have one... f30 updates/updates-testing has been failing in ostree... any ideas why? what are we making there, just silverblue (since we aren't doing atomic for 30 right?)?
16:23:14 <mboddu> dustymabe: Cool, I might have to do some traveling in June, but I will try to help/join as much as I can
16:23:22 <dustymabe> nirik: yes, no atomic for f30 - just silverblue
16:23:42 <nirik> 2019-05-01 00:35:30 [ERROR   ] [FAIL] Ostree (variant Everything, arch x86_64) failed, but going on anyway.
16:23:42 <nirik> 2019-05-01 00:35:30 [ERROR   ] 'ascii' codec can't decode byte 0xc2 in position 5644: ordinal not in range(128)
16:23:49 <nirik> https://kojipkgs.fedoraproject.org/compose/updates/Fedora-30-updates-20190501.0/logs/global/pungi.global.log
16:24:02 <dustymabe> nirik: I haven't caught up on emails/notifications so haven't looked at the failed compose tracker
16:24:17 <dustymabe> ahh that problem is an old one and one we've never quite tracked down I don't think
16:24:20 <nirik> yeah, the failed compose tracker stopped filing. ;(
16:24:24 <dustymabe> really?
16:24:31 <nirik> I figure your listener died?
16:24:41 <dustymabe> how long ago was that ?
16:24:47 <mboddu> dustymabe: Yes, it was about a month ago
16:25:05 <dustymabe> oh no! that's the worst time considering the impending f30 release
16:25:08 <mboddu> dustymabe: I tried to find the source code in github, pagure, but I couldn't find it
16:25:09 <nirik> yeah, 2019-03-27
16:25:21 <dustymabe> OMG that's the day we had our baby
16:25:33 <mboddu> dustymabe: Well, we were able to get it out on time
16:25:35 <dustymabe> guys you should have told me!
16:25:35 <nirik> we could/should put it somewhere more official and run the listener in infra?
16:25:48 <nirik> no great biggie, we dealt with things.
16:26:01 <mboddu> dustymabe: Thats fine, we were able to cope up with it
16:26:23 <mboddu> nirik: +1 to officilize (if thats a word) it
16:26:37 <mboddu> It is a word and I got the spelling wrong
16:26:44 <dustymabe> yes +1 for moving it to something more official - I can help you when you've got some time set aside for it
16:26:45 <nirik> ha.
16:27:05 <mboddu> dustymabe: Are you back now? Or still on PTO?
16:27:26 <nirik> sure, sounds good. If you can send me pointers to the code you used that would be great. I guess just a fedmsg-trigger? or fedmsg-hub with config?
16:27:35 <dustymabe> mboddu: back but will be taking a few PTO days here and there
16:27:39 <dustymabe> will send out emails for those
16:27:49 <mboddu> dustymabe: Okay
16:27:57 <mboddu> I want to move it to https://pagure.io/projects/releng/%2A
16:28:07 <dustymabe> mboddu: +1
16:28:08 <mboddu> And, run it in infra
16:28:12 <nirik> sure, +1
16:28:24 <nirik> we could possibly just add it to loopabull.
16:28:34 <mboddu> nirik: Yeah, we can do that as well
16:28:58 <mboddu> Can I schedule a meeting to talk about it?
16:29:23 <mboddu> Or we can do it over irc/email?
16:29:35 <nirik> how about lets make a ticket for it and discuss in that and if/when we need more bw we do a meeting?
16:29:38 <dustymabe> I've got it set up to run in openshift already
16:29:52 <mboddu> nirik: Sure
16:29:52 <nirik> yeah, thats an option too then
16:29:52 <dustymabe> so probably easiest to leave it running in openshift
16:30:11 <mboddu> dustymabe: Which openshift instance?
16:30:16 <dustymabe> my personal one
16:30:37 <nirik> it would be also perhaps nice if we could file ones for spins/other parts of composes and cc maintainers
16:30:37 <mboddu> Then better to move it to infra maintained instance
16:30:50 <nirik> but thats getting fancy
16:31:08 <mboddu> nirik: We can add *stuff* later on :)
16:31:08 <dustymabe> nirik +1
16:31:11 <nirik> sure
16:31:28 <dustymabe> it's definitely basic right now - but has been useful even in its premature form
16:31:38 <mboddu> dustymabe: Agreed
16:32:17 <nirik> yep
16:33:04 <mboddu> #info mboddu will create a ticket to track moving of dustymabe-failed-composes to officially maintained one
16:33:20 <mboddu> nirik: Probably taiga is a good place to track this, wdyt?
16:33:41 <nirik> I was thinking an infra ticket...
16:33:52 <nirik> but things are in a bit of flux so whatever works
16:34:29 <mboddu> nirik: I will create a ticket in fedora-infrastructure
16:34:35 <nirik> ok
16:35:04 <dustymabe> nirik: FYI: https://pagure.io/dusty/failed-composes/issue/1642
16:35:10 <dustymabe> this isn't new it doesn't look like
16:35:33 <nirik> yeah, it's been forever, I just was hoping we could fix it.
16:36:03 <dustymabe> does it happen for both updates and updates-testing?
16:36:16 <nirik> ostree has a non breakable utf8 space in output? thats weird
16:36:18 <nirik> yeah
16:37:17 <mboddu> Also looking at https://infrastructure.fedoraproject.org/cgit/ansible.git/tree/roles/bodhi2/backend/templates/pungi.rpm.conf.j2#n212
16:37:30 <mboddu> Dont we have to disable imagebuild for <F30
16:38:05 <mboddu> Only AH image build
16:38:16 <nirik> yeah, I would think so
16:39:14 <mboddu> nirik: Also the ostree_installer phase
16:39:23 <mboddu> https://infrastructure.fedoraproject.org/cgit/ansible.git/tree/roles/bodhi2/backend/templates/pungi.rpm.conf.j2#n274
16:39:25 <dustymabe> umm
16:39:43 <dustymabe> no - we are still creating atomic host artifacts and releases for f29
16:40:02 <dustymabe> so we still need the ostrees and images for f29AH from bodhi updates runs
16:40:14 <nirik> ah yeah, thats a 29 block, so fine
16:40:55 <mboddu> dustymabe: Ah, right, sorry, my bad
16:41:05 * nirik needs more coffe, back in a min
16:41:22 <dustymabe> mas cafe por favor
16:41:59 <mboddu> More coffee, please :)
16:42:22 * mboddu should pick up his spanish lessons from where I left off
16:44:05 <mboddu> I dont have anything else on this topic
16:44:07 <mboddu> So...
16:44:11 <mboddu> #topic Open Floor
16:44:24 <mboddu> #info Happy Fedora 30 release
16:44:36 <mboddu> Its a hatrick :D
16:44:46 * mboddu is sooooooooo happyyyyyyyyyy
16:45:43 <dustymabe> \o/ woot!
16:45:56 <dustymabe> thank you so much for all the work you do nirik and mboddu
16:46:14 <nirik> back
16:46:26 <nirik> yeah, f30 seems to have gone pretty smoothly...
16:46:55 <mboddu> Yup
16:48:40 <mboddu> Anything else?
16:49:26 <nirik> oh, how many things are still in the taiga backlog?
16:49:43 <nirik> should we try and process through them sometime soon? how far did you get the other day?
16:49:58 <mboddu> smooge and I started going through them and we got side tracked with EPEL stuff :D
16:50:16 <mboddu> Sure, we can go through them
16:51:05 <nirik> yeah, would be good to finish up with that this week sometime.
16:51:09 <mboddu> nirik: Just let me know when you have some free time, I am almost free now that the release is out
16:51:40 <nirik> ok. possibly tomorrow morning after meetings... or perhaps later today, but I have a pile of stuff I wanted to do.
16:52:10 <mboddu> nirik: Can we do tomorrow morning, so that Tomas might be able to join as well
16:54:15 <nirik> I should be available after infra meeting... so, 16utc?
16:54:44 <mboddu> nirik: 16UTC wont work for me :(
16:55:11 * mboddu checks his time/math again
16:55:29 <nirik> I could try and get up eariler I guess... before the infra meeting...
16:55:37 <mboddu> Yeah, unfortunately 16UTC wont work for me :(
16:56:10 <mboddu> nirik: I dont want to push you, either at 17UTC or Friday morning
16:56:34 <nirik> 17 would work fine for me, would tomas be available then? or too late?
16:56:49 <mboddu> I am not sure, but I can check
16:57:02 <nirik> ok.
16:57:16 <mboddu> Anyway, that is it for today
16:57:20 <mboddu> Thanks everyone for joining
16:57:27 <nirik> thanks mboddu!
16:57:31 <mboddu> #endmeeting