16:06:08 <mboddu> #startmeeting RELENG (2019-06-20)
16:06:08 <zodbot> Meeting started Wed Jun 19 16:06:08 2019 UTC.
16:06:08 <zodbot> This meeting is logged and archived in a public location.
16:06:08 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:06:08 <zodbot> The meeting name has been set to 'releng_(2019-06-20)'
16:06:08 <mboddu> #meetingname releng
16:06:08 <zodbot> The meeting name has been set to 'releng'
16:06:08 <mboddu> #chair nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu dustymabe ksinny jednorozec
16:06:08 <mboddu> #topic init process
16:06:08 <zodbot> Current chairs: dustymabe jednorozec ksinny masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
16:06:59 <dustymabe> .hello2
16:07:00 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:07:10 * dustymabe waves at mboddu
16:07:14 <mboddu> Hello dustymabe
16:07:49 <dustymabe> mboddu: i don't have anything for today - just saying hey
16:08:26 * sharkcz is here to say hello at least :-)
16:08:32 <bcotton> .hello2
16:08:33 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:09:18 <mboddu> Since sharkcz is here, lets check on alt arches
16:09:23 * nirik had this down later or something...
16:09:24 <nirik> morning
16:09:28 <mboddu> #topic Alternate Architecture Updates
16:10:10 <mboddu> #info nirik is still blocked on s390x moving to KVM
16:10:13 <sharkcz> things should be looking pretty good, but we still wait on the builder migration under kvm
16:10:19 <mboddu> sharkcz: ^ anythign else other than that?
16:10:26 <sharkcz> nope
16:10:31 <mboddu> Thanks sharkcz
16:10:47 <mboddu> #info Everything is looking good other than kvm migration
16:11:49 <mboddu> #topic #8080 rsync temporaries under /alt/risc-v
16:11:55 <mboddu> #link https://pagure.io/releng/issue/8080
16:12:12 <mboddu> nirik: ^ I know you were working on it? Can you share some light on what it is?
16:12:31 * mboddu has no clue about it
16:12:48 <nirik> I have no idea... thats the risc-v secondary arch folks syncing their data...
16:12:53 <nirik> we have to ask them how they do it.
16:13:21 <nirik> I guess ask if anyone has seen it still, or if it's solved?
16:13:42 <mboddu> nirik: Okay, I will ping in the ticket
16:14:09 <mboddu> #action mboddu will ping in the ticket to ask if its been resolved and also document the process
16:16:25 <mboddu> #topic #8421 allow coreos team to regen coreos distrepos
16:16:30 <mboddu> #link https://pagure.io/releng/issue/8421
16:16:49 <nirik> we need to fix dist-repo generation.
16:17:01 <mboddu> Now that tag2distrepo is part of koji plugin, they lost the repo generation ability
16:17:14 <nirik> I think puiterwijk was going to add this to kojira... but I am not sure what the status is.
16:17:32 <puiterwijk> No, I think mizdebsk was going to take that to upstream.
16:17:41 <nirik> ah, ok.
16:17:42 <puiterwijk> I talked about it with him, and he said he'd be happy to look at it
16:17:45 * mboddu waves at puiterwijk
16:17:52 * puiterwijk waves back
16:17:59 <mboddu> Thanks puiterwijk
16:18:00 <nirik> so, we are waiting for that, but perhaps we put the cron back until it's there?
16:18:21 <puiterwijk> Yeah
16:18:32 <mboddu> #info mizdebsk is working on fixing the dist repo generation (probably adding it to kojira)
16:18:35 <mboddu> nirik: +1
16:19:15 <mboddu> #info For the mean time, we will renable cron job that generates the dist repos
16:19:25 <mboddu> nirik: ^ Is that okay?
16:20:23 <nirik> well, sure, thats what I suggest.
16:20:32 <nirik> there's a infra ticket on this too
16:20:55 <mboddu> nirik: Okay, just confirming before I put it in the ticket :)
16:21:19 <nirik> hum.... hang on.
16:22:29 <nirik> I guess this needs to be fedmsg based... so wonder if it's worth the effort. I guess it depends on how long until kojira handles it.
16:23:20 <nirik> and how often they change repos.
16:24:25 <mboddu> nirik: Hmmm, are there any consequences if we enable the message listener?
16:25:14 <nirik> what message listener? tag2distrepo?
16:25:20 <mboddu> nirik: Yes
16:25:42 <nirik> well, yeah, it could fight with the koji plugin
16:26:00 <nirik> or generate many more repo regens
16:26:36 <mboddu> nirik: Well, until kojira supports the repo regen, there wont be multiple repo regens
16:26:48 <mboddu> But I am not sure if anything else gets affected
16:27:04 <mboddu> Or, we could create a cron job, which runs every 30 mins or so
16:29:06 <nirik> I'm confused...
16:29:50 <nirik> puiterwijk: what exactly does the koji plugin do... sees tags and requests a dist-repo? if so, what do we need kojira for?
16:30:15 <puiterwijk> nirik: yep.
16:30:28 <puiterwijk> nirik: the problem is that we do *not* want kojira to interfere.
16:30:31 <puiterwijk> Which it does right now
16:30:50 <puiterwijk> Basically, right now, kojira sees any "repo" equally, whether they're buildroot repos or dist repos. And it will clean them up after a timeout
16:31:00 <puiterwijk> (which I think is a day or something)
16:31:03 <nirik> ah, so the 1 week timeout issue?
16:31:05 <puiterwijk> Yes
16:31:08 <nirik> (it's a week by default)
16:31:14 <puiterwijk> Right. It's some huge number
16:31:51 <nirik> ok, that makes sense. in that case lets just gen them every monday and friday or something until kojira can leave them alone
16:32:01 <nirik> or... up it to 6 months or something
16:32:03 <puiterwijk> Yeah, that works.
16:32:12 <puiterwijk> nirik: I don't think we want 6 months
16:32:19 <puiterwijk> Actually, never mind that remark.
16:32:39 * puiterwijk forgot for a second that buildroot repos are just repodata with pointers for a second there.
16:32:57 <puiterwijk> Although I'm not entirely sure about distrepos. Those might be full copies of the signed RPMs
16:33:42 <mboddu> Cant we separate them? Like having x days for buildroot repos and y days for dist repos?
16:33:46 <nirik> they are seperate
16:33:47 <mboddu> I thought thats what mizdebsk is fixing
16:33:49 <puiterwijk> yes, that is what we need
16:33:52 <nirik> kojira has seperate config for each
16:33:54 <puiterwijk> correct
16:34:07 <nirik> we just want the dist-repo one to be infinity
16:34:11 <puiterwijk> nirik: huh, it does? When I checked the code, it didn't
16:34:21 <puiterwijk> nirik: well, the non-latest repos should be nuked
16:34:30 <nirik> ;how soon (in seconds) to clean up expired repositories. 1 week default
16:34:30 <nirik> ;deleted_repo_lifetime = 604800
16:34:30 <nirik> ;how soon (in seconds) to clean up dist repositories. 1 week default here too
16:34:30 <nirik> ;dist_repo_lifetime = 604800
16:34:37 <puiterwijk> ah, okay
16:34:46 <mboddu> nirik++
16:34:58 <puiterwijk> But we do only want to retain the "latest" one for that long. I think that upping that would also delay removing the others
16:35:11 <puiterwijk> Though given the number of pcakages we have i nthose tags, it might not be that big a deal
16:35:34 <puiterwijk> So sure. Let's just up dist_repo_lifetime to 6 months for now, and see if those become too big
16:35:43 <nirik> yeah, it looks like it has no understanding of latest currently
16:35:50 <nirik> it just does the timeout
16:35:54 <puiterwijk> Yeah.
16:36:01 <puiterwijk> And for that, it considers every repo identically
16:36:21 <mboddu> So, iirc, the fix is, upping ;dist_repo_lifetime and then divide non-latest vs latest and add different values for each, latest for long time and non-latest for shorter time
16:36:23 <puiterwijk> Anyway, as said, it might not be that big a deal. Let's just up it to 6 months
16:36:32 <mboddu> s/iirc/iiuc/
16:36:38 <puiterwijk> mboddu: we'd want "latest" to be "indefinite" :)
16:36:48 <puiterwijk> I think that that would be the kojira change we should submit upstream.
16:37:06 <puiterwijk> (since "dist repos" sound like "repos for distribution", so I'd say you always want those available)
16:37:20 <nirik> so perhaps up to 6 months and also file a ticket on koji so we don't forget and hit it in 6 months. ;)
16:37:21 <mboddu> Okay, long time = indefinite :D
16:37:37 <puiterwijk> nirik: if we up it to 6 months, we will probably never hit it anymore :)
16:37:59 <puiterwijk> Because most of our active tags will see at least 1 tag in those 6 months, a new repo is generated, which again is around for 6 months
16:38:20 <nirik> true. ok.
16:38:24 <nirik> sold. lets up it.
16:38:46 * mboddu will be back in 5 min
16:39:19 <puiterwijk> mboddu: no, 6 months :P
16:39:30 <nirik> har
16:41:18 * mboddu is back
16:41:45 <mboddu> puiterwijk: I ordered oneplus 7 pro and it got delivered now, need to sign for the package delivery
16:42:17 <nirik> nice
16:42:28 <nirik> did you get one for everyone? :)
16:42:29 <mboddu> nirik: ^ Oh, you must be interested as well :)
16:42:59 <mboddu> nirik: This is not as cheap as the samsung tizen phone I got for you, or else I would have :)
16:43:08 <mboddu> So, let me summarize it
16:43:15 <mboddu> Well, dist-repo thing
16:43:24 * nirik was just pushing the change
16:45:00 <mboddu> #info We will be increasing the dist_repo_litetime to 6 months and then koji ticket will be filed to keep the latest rpm generated dist-repos indefinitely and non-latest rpm generated dist-repos to have shorter time which will be set in the config
16:45:07 <mboddu> nirik: ^ Have I got it right?
16:45:48 <mboddu> nirik, puiterwijk: Now I read about the ticket, I think its about permissions rather than retention - https://pagure.io/releng/issue/8421
16:46:13 <nirik> well, we don't likely need the ticket anymore... we could do it I guess tho
16:46:15 <puiterwijk> That ticket is permissions, yes.
16:46:17 <mboddu> But I guess if event based, that shouldn't be a problem
16:46:33 <puiterwijk> mboddu: but the last comment is about the timeout issue
16:46:41 <nirik> they shouldn't need those perms?
16:46:56 <puiterwijk> right
16:46:59 <puiterwijk> they shouldn't
16:47:15 <nirik> so, close -> we fixed this so it shouldn't happen again
16:47:30 <puiterwijk> mboddu: this ticket is now done with the timeout. "Today we had an issue where the distrepo yum repos for our coreos tags went away" - this was the timeout
16:47:45 <puiterwijk> they wanted another solution, which is to get permission to regen themselves. But if we keep it for 6 months, they don't need that
16:47:49 <mboddu> nirik: I guess, its more like, if the repo is generated when you tag a build, then why do you need permissions
16:48:08 <nirik> right, they should not...
16:48:16 <mboddu> puiterwijk: ack
16:48:29 * nirik closed https://pagure.io/fedora-infrastructure/issue/7872 which was the infra version of that same issue
16:48:37 <puiterwijk> thanks
16:51:37 * mboddu also closed releng the ticket
16:51:46 * mboddu really cant type
16:51:51 <mboddu> I closed the releng ticket :D
16:53:39 <mboddu> But "releng the ticket" phrase is sounding funny, now I need to find a situation where I can use it :D
16:54:23 <nirik> thats like 'do the needfull'
16:55:05 <mboddu> haha :)
16:55:11 <mboddu> #topic Open Floor
16:55:21 <mboddu> Anyone got anything to share?
16:56:02 <nirik> rawhide status?
16:56:11 <mboddu> Right
16:57:01 <mboddu> #info Oz finally moved to python3 and we moved everything to python3 which broke some stuff and we fixed all them, thanks to nirik
16:57:03 <mboddu> nirik++
16:57:22 <nirik> So, things have been broken a while. Initially it was due to moving everything to python3. I worked through those bugs as best I could and they were fixed this weekend/early this week. Now we are dealing with things that broke whiile composes were out... kde broken deps (fixed), and now a aarch64/ppc64le cloud bug in rpm/python/dnf/something
16:57:29 <nirik> yep
16:57:35 <nirik> I should mail the list too
16:58:04 <nirik> of course I need to actually finish reading my email and not being in meetings for that. :)
16:58:14 <mboddu> #info After moving to python3, we faced issues with KDE broken deps, rdieter fixed them for us
16:58:34 <mboddu> #info Now, we have facing aarch64 cloud bug, pwhalen is looking into it
16:59:00 <mboddu> nirik: Hehe, I wish we have clones like puiterwijk does :P
16:59:23 <mboddu> nirik: FYI, I will be going to India after FLOCK and will be on vacation for a week and then work from India for couple of weeks later and then return to the States
16:59:39 <nirik> ok
17:00:18 <mboddu> nirik: I will be working on F31 beta freeze from India
17:00:40 <mboddu> nirik: Also, mass branching is right after flock, so I will be working from Brno with Tomas on mass branching
17:01:25 <nirik> ok
17:01:32 <nirik> oh look, my next meeting.
17:01:37 <mboddu> puiterwijk: ^ This reminded me, we need to fix the creation of dist-git branches during mass branching
17:01:47 <mboddu> Thanks nirik for joining
17:01:57 * mboddu is done with meetings today, knocks the wood
17:02:17 <mboddu> puiterwijk: It seems like repospanner wont work with the existing script we got
17:02:26 <mboddu> Anyhoo
17:02:30 <mboddu> Thanks everyone for joining
17:02:31 <puiterwijk> Correct. Not hard to fix.
17:02:48 <mboddu> puiterwijk: Awesome, we can work on it later, thanks again :)
17:02:50 <puiterwijk> It's just that right now, the script is trying to bypass everything and inject stuff on the filesystem
17:02:52 <mboddu> #endmeeting