16:00:30 <mboddu> #startmeeting RELENG (2019-09-26)
16:00:30 <zodbot> Meeting started Wed Sep 25 16:00:30 2019 UTC.
16:00:30 <zodbot> This meeting is logged and archived in a public location.
16:00:30 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:30 <zodbot> The meeting name has been set to 'releng_(2019-09-26)'
16:00:30 <mboddu> #meetingname releng
16:00:30 <zodbot> The meeting name has been set to 'releng'
16:00:30 <mboddu> #chair nirik sharkcz pbrobinson pingou mboddu dustymabe ksinny jednorozec
16:00:30 <zodbot> Current chairs: dustymabe jednorozec ksinny mboddu nirik pbrobinson pingou sharkcz
16:00:30 <mboddu> #topic init process
16:01:30 <nirik> morning
16:04:01 <mboddu> nirik: Morning, how goes?
16:04:21 <nirik> I can't complain, but sometimes I still do. ;)
16:04:49 <mboddu> Lol :)
16:04:57 <mboddu> Anyway, lets get started
16:05:12 <mboddu> #topic #7553 Arch-Specific Runtime Dependencies in sub-packages
16:05:21 <mboddu> #link https://pagure.io/releng/issue/7553
16:06:18 <mboddu> Well, I picked up a wrong ticket, but we can discuss this as well
16:06:23 <nirik> I would suggest this should be a upstream koji ask.
16:06:31 <nirik> and/or mock
16:06:43 <nirik> but we already heard from mock developer
16:08:06 <mboddu> I guess "2) ask RPM team to implement some new tag. E.g., "ExcludeInstallArch" which will be ignored during build time and just put into RPM header and rel-eng can parse it and act accordingly." is the best way to do this
16:09:38 <mboddu> #action mohanboddu will file a koji ticket for this
16:09:43 <nirik> yeah
16:09:52 <nirik> well, I'd say rpm upstream ticket?
16:10:02 <nirik> or ask the reporter(s) to?
16:10:52 <mboddu> #undo
16:10:52 <zodbot> Removing item from minutes: ACTION by mboddu at 16:09:38 : mohanboddu will file a koji ticket for this
16:11:18 <mboddu> #action mohanboddu will file a koji ticket and rpm ticket
16:11:26 <mboddu> whichever gets us there first
16:11:36 <mboddu> May be koji can do this without rpm changes
16:11:48 <nirik> perhaps.
16:12:04 <mboddu> #topic #8737 Please workaround koji bug 789
16:12:12 <mboddu> #link https://pagure.io/releng/issue/8737
16:12:40 <mboddu> So, I had a little chat with Dennis Gregorovic
16:12:46 <mboddu> about this ticket
16:13:04 <nirik> ok, cool.
16:13:08 <mboddu> He said, he will get back to us with some timeline for solving this issue
16:13:37 <nirik> ah ha. cool!
16:13:46 <mboddu> nirik: So, do you still want to try and split the builders? Or should we just wait?
16:14:08 <nirik> I'd really rather not split the builders. ;) So waiting is just fine with me.
16:14:38 * mboddu agrees
16:15:08 <nirik> but obviously it's a pain for those affected, so a solution would be good.
16:15:17 <mboddu> #info mohanboddu had a little chat with koji folks and they are going to give us some timeline on when they can fix this issue
16:15:32 <mboddu> Yeah, totally agreed
16:15:58 <mboddu> #topic #6967 new mock and systemd-nspawn
16:16:04 <mboddu> #link https://pagure.io/releng/issue/6967
16:16:10 <mboddu> nirik: Your favorite :P
16:16:22 * mboddu hides
16:19:07 <nirik> yeah, I saw this update...
16:19:18 <nirik> basically we just need to have the time to really test stuff...
16:19:51 <nirik> good that old-chroot is here to staytho
16:19:56 <mboddu> nirik: DC move time? :D
16:20:02 * mboddu now runs :)
16:20:47 <mboddu> Yeah, having old-chroot will help us a lot in switching things back
16:21:54 <nirik> I wonder...
16:22:25 <nirik> I was thinking we could switch all the normal packages first and keep images and kernel on old-chroot...
16:22:31 <nirik> but we can only set it per tag.
16:23:05 <mboddu> May be we could try it on F29, after F31 GA?
16:23:54 <mboddu> F29 will be only available for a month after F31 GA, less traffic and less attention
16:24:40 <nirik> well, but most of the builds on it will be security issues, etc.
16:24:54 <nirik> probibly easier to try on rawhide first
16:25:24 <nirik> or...
16:25:40 <nirik> we could ask people who request side tags if they would be willing to try it
16:26:14 <mboddu> Thats not a bad idea, we could try that on rawhide side tags
16:26:50 <nirik> would at least tell us if some packages build fine.
16:27:00 <mboddu> Yup
16:27:01 <nirik> I would expect most normal packages would be fine
16:27:12 <nirik> kernel builds and images/runroot will be the challenge
16:28:27 <mboddu> #info We will ask the side tag requestors if they are okay with having systemd-nspawn in the side tag which will help us in testing the switch
16:30:59 <mboddu> #topic #7520 Provide stable names for images
16:31:41 <mboddu> #link https://pagure.io/releng/issue/7520
16:31:49 <dustymabe> mboddu: nirik sorry I was doing something else
16:32:36 <mboddu> nirik: Last time we discussed about having spins/labs maintainers able to build and release their images, this is sorta related to that
16:32:42 * mboddu waves at dustymabe
16:33:22 <mboddu> I think that initiative is being called as "Fedora Independent Artifacts" (for now)
16:33:24 <nirik> hey dustymabe
16:33:41 <dustymabe> mboddu: nirik ping me when it gets to open floor if you don't mind
16:33:47 <nirik> mboddu: yeah, I suppose it could. I think we could do it with hardlinks looking at it.
16:33:48 <mboddu> dustymabe: Will do
16:34:02 <mboddu> nirik: Yes
16:34:10 <mboddu> So, my quick question here is
16:34:51 <mboddu> While building the images, we will provide GA repo + updates repo + updates-testing repo(if they want to)
16:35:21 <mboddu> The install tree will be coming from GA itself, as we dont compose it everyday in updates and we can only provide 1 install tree as an option
16:35:27 <mboddu> Does that affect the image build?
16:35:36 <mboddu> nirik: ^ Do you know by any chance?
16:36:01 <nirik> well, live images only? or ?
16:36:08 <nirik> for lives I think that will work fine.
16:36:14 <nirik> netinstalls need a tree.
16:36:21 <nirik> dvd's need a tree
16:36:39 <nirik> I think appliances don't
16:37:03 <mboddu> All the labs/spins are live images, so I think they should be fine
16:37:50 <nirik> yeah, if the scope is just them thats fine.
16:38:12 <mboddu> We can provide the tree from GA compose, even for netinstalls or dvd's
16:38:48 <mboddu> But having the install tree from GA and the repo is from GA+updates+updates-testing, will it create any issue?
16:39:40 <nirik> I really don't think netinstalls/dvd's will work unless pungi builds a new compose tree for them... I guess it could work partly by accident, but would blow up if the package set changed much
16:40:10 <mboddu> Okay, thats what I am looking for
16:40:41 <nirik> but I don't think we want those things on a seperate release schedule anyhow, do we?
16:40:51 <nirik> and if we do, why not make a new tree...
16:41:03 <mboddu> So, we need to scope it for just live images
16:41:18 <nirik> I think that makes the most sense.
16:41:22 <nirik> at least at first
16:41:47 <mboddu> nirik: The current scope is for labs/spins, I am not sure if council will want to expand it later as it was not clear when I talked to mattdm
16:43:35 <mboddu> I will add this info to open floor as its not directly related
16:43:43 <mboddu> #topic Open Floor
16:44:29 <nirik> I have one thing
16:44:41 <mboddu> #info Fedora Independent Artifacts will be only scoped for live images as they dont require the install tree, if the scope changes, we might need to ask pungi to create the tree for making netinstalls and dvd's
16:45:12 <mboddu> #info devconf.cz CFP is open now, please send your proposals
16:45:23 <nirik> chromium builds are taking more than our timeout on aarch64. There's discussions on how to fix that, but in the mean time they would like us to increase the limit a little bit...
16:45:26 <nirik> https://pagure.io/fedora-infrastructure/issue/8232#comment-600333
16:45:29 <mboddu> And I will be working from SFO, CA next week
16:45:39 <nirik> nice. sunny!
16:47:16 <mboddu> nirik: AFAIK, we have set a different time limit for one other package as well, right?
16:47:19 * mboddu checks
16:47:33 <nirik> oh? I didn't think it was per package setable
16:49:17 <mboddu> nirik: If I am not wrong, it is texlive
16:49:37 <mboddu> Or, we set a different timeout on signing of texlive builds
16:49:41 * mboddu is confused now
16:50:26 <nirik> we set a proxytimeout larger for texlive (because it's uploading takes so long)
16:50:35 <nirik> (thats set to 3 hours now)
16:50:49 <nirik> but this is the rpmbuild_timeout...
16:51:08 <nirik> I'd like to propose bumping it from 48h to 54h
16:51:39 <nirik> (and hopefully something else will make it take less time moving forward, but this is a good stopgap)
16:51:49 <mboddu> nirik: Right and agreed
16:52:47 <mboddu> #info nirik will bump the rpmbuild timeout from 48h to 56h which will unblock chromium builds timing out on aarch64
16:52:58 <mboddu> dustymabe: You are up
16:54:03 <dustymabe> mboddu: hiya
16:54:13 <dustymabe> let me see what is int my docket for today
16:54:55 <dustymabe> one sec let me find the link
16:55:20 <dustymabe> https://github.com/coreos/fedora-coreos-tracker/blob/master/Fedora-Requests.md#existing-requests-for-fedora-releng
16:55:34 <dustymabe> how are we looking on the distrepos issue?
16:55:59 <nirik> I think we can solve it now (as mboddu pointed out we can add it as a new perm)
16:56:09 <dustymabe> perfect
16:56:27 <dustymabe> i would like the tag2distrepo think fixed at some point but that's not really on you guys
16:56:35 <dustymabe> for copying ostree content
16:56:46 <dustymabe> https://pagure.io/releng/issue/8811#comment-598901
16:56:50 <dustymabe> let's try to do this in stage
16:58:37 <nirik> so, back to the dist-repo thing... I can grant you that perm for now, but we also wanted it to work for the group perm?
16:58:51 <nirik> so, we need koji to add policy for that I think.
16:59:27 <dustymabe> yeah we want it for the group so that I can have our bot request distrepos
16:59:34 <dustymabe> so that we can workaround the race condition
16:59:38 <mboddu> nirik: I think we tried that, but for some reason we didn't have it in our koji, so you thought its just a db change or something...
17:00:06 <nirik> that was for the koji permission.
17:00:18 <nirik> to allow a group it needs to be policy... ie, in the hub policy file.
17:00:27 <nirik> but there's no dist-repo policy that I can tell.
17:02:28 <nirik> proposal: grant dustymabe the permission for now, file another koji upstream ticket to add policy around dist-repos, close ticket and wait for koji upstream to implement, then fix our policy
17:02:33 <mboddu> I thought I have seen the dist-repo policy in the docs somewhere
17:02:45 <dustymabe> k
17:02:46 <mboddu> ack
17:03:26 <nirik> mboddu: I could have missed it, we can both re-look after meeting?
17:03:40 <mboddu> nirik: Sure, but I am okay with your proposal
17:04:46 <mboddu> nirik: May be you are right, https://docs.pagure.org/koji/permissions/#tasks it is part of the user level policy
17:04:57 <mboddu> user/task level
17:05:10 <mboddu> #info grant dustymabe the permission for now, file another koji upstream ticket to add policy around dist-repos, close ticket and wait for koji upstream to implement, then fix our policy
17:05:19 <nirik> dustymabe: added you and jlebon in prod... please test
17:05:29 <dustymabe> nirik: will do after other meeting
17:05:43 <nirik> no hurry, just whenever and let us know if it doesn't work
17:06:05 <mboddu> #info mohanboddu can file the ticket in upstream koji for the dist-repo policy
17:06:33 <nirik> hum, but perhaps it should work in policy... the docs are confusing me again. ;)
17:06:38 <nirik> but I think I tried in stg
17:07:18 <mboddu> Haha, now I am not sure whether I am right in first place or not, well, file the ticket and see what they have to say
17:07:35 <mboddu> Anything else guys before I close the shop?
17:09:13 <mboddu> Okay, thanks for joining
17:09:19 <mboddu> #endmeeting