17:15:39 <cmurf> #startmeeting Workstation WG (2021-08-24)
17:15:39 <zodbot> Meeting started Tue Aug 24 17:15:39 2021 UTC.
17:15:39 <zodbot> This meeting is logged and archived in a public location.
17:15:39 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:15:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:15:39 <zodbot> The meeting name has been set to 'workstation_wg_(2021-08-24)'
17:15:41 <cmurf> #meetingname workstation
17:15:41 <zodbot> The meeting name has been set to 'workstation'
17:15:43 <cmurf> #chair: Neal
17:15:43 <zodbot> Current chairs: : Neal cmurf
17:15:55 <cmurf> #topic Rollcall
17:15:57 <cmurf> #info present:  Michael, Chris, Allan, Jens, Kalev, Matthias, Neal, Owen, Tomas
17:15:59 <cmurf> #info regrets: Langdon
17:16:01 <cmurf> #info present guests: Zac
17:16:03 <cmurf> #topic Approval of August 17 minutes https://meetbot.fedoraproject.org/teams/workstation/workstation.2021-08-18-03.18.html
17:16:05 <cmurf> #agreed Approved
17:16:07 <cmurf> #topic Announcements, follow-ups, status reports
17:16:09 <cmurf> #info beta freeze about to start. GNOME 41 packages should be up to date soon (gnome-terminal excluded). Some issues with it already, such as gnome-initial-setup
17:16:11 <cmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=1996901
17:16:13 <cmurf> #info Allan reviewing open WG tickets, pushing back milestones where F35 no longer seems possible
17:16:15 <cmurf> #topic Make use of malcontent in the default install?
17:16:17 <cmurf> #link https://pagure.io/fedora-workstation/issue/186
17:16:19 <cmurf> - Allan concerned about malcontent
17:16:21 <cmurf> - Neal says there is a dependency problem with malcontent. gnome-control-center doesn't properly depend on malcontent. Fallback UI is not in good shape.
17:16:23 <cmurf> - gnome-initial-setup malcontent integration is not enabled.
17:16:25 <cmurf> - Chris points out a package that's not yet stable will be left out of beta without a freeze exception
17:16:27 <cmurf> - flatpak's malcontent support is broken, triggers selinux violations
17:16:29 <cmurf> - gnome-software's malcontent support is also not enabled
17:16:31 <cmurf> #action Kalev to enable malcontent in relevant places, create a freeze break request?
17:16:33 <cmurf> #info Michael suggests it's pretty late to enable this. Neal notes it's already sort of enabled. WG discusses scheduling. We basically forgot to test this.
17:16:35 <cmurf> #topic More announcements, follow-ups, status reports
17:16:37 <cmurf> #info Neal requests review of https://gitlab.gnome.org/GNOME/gnome-settings-daemon/-/merge_requests/257
17:16:39 <cmurf> #action Michael to review the MR and poke relevant maintainers
17:16:41 <cmurf> #info Allan is planning WG organisation work. Proposes that we don't change the working group name (https://pagure.io/fedora-workstation/issue/226). He plans to port our documentation from the Fedora wiki to docs.fedoraproject.org (https://pagure.io/fedora-workstation/issue/225).
17:16:43 <cmurf> #topic Automatically install the OpenH264 codecs
17:16:45 <cmurf> #link https://pagure.io/fedora-workstation/issue/84
17:16:47 <cmurf> - Kalev suggests doing this in anaconda
17:16:49 <cmurf> - Matthias, Michael suggest using anaconda or gnome-initial-setup is not good enough. It should work later if internet is not available during installation.
17:16:51 <cmurf> - Kalev suggests using the new software page in gnome-initial-setup
17:16:53 <cmurf> - Neal suggests using fedora-third-party? Owen thinks this would be strange.
17:16:55 <cmurf> - Kalev mentions plan to use a one-shot systemd service to both install openh264. This should be untangled from uninstalling anaconda. We can use an anaconda postinstall script to remove anaconda and treat that as separately from systemd.
17:16:57 <cmurf> #action Kalev to handle systemd unit for openh264, but not anaconda.
17:16:59 <cmurf> - Michael requests some care to ensure it retries until the network is ready. Neal suggests this is possible using systemd conditions. Also don't want to run the unit if openh264 is already installed.
17:17:01 <cmurf> #action Neal to create a WG ticket for removing anaconda.
17:17:03 <cmurf> #topic Make adobe-source-code-pro-fonts optional in @gnome
17:17:05 <cmurf> #link https://pagure.io/fedora-workstation/issue/236
17:17:07 <cmurf> - Jens: Originally this was just a proposal to unify the default GTK and Fontconfig monospace fonts. But the -scope of the ticket has expanded a lot.
17:17:09 <cmurf> - Neal thinks Noto fonts look better in KDE than in GNOME.
17:17:11 <cmurf> - Some technical discussion of current default font settings in GNOME
17:17:13 <cmurf> - Matthias suggests GNOME font defaults should just defer to Fontconfig?
17:17:15 <cmurf> - Kalev proposes changing Fontconfig defaults from DejaVu to Noto, considering this separately from any GNOME/GTK-level changes.
17:17:17 <cmurf> - Matthias isn't fond of Noto. It's a zoo of a huge number of different fonts. Breaks scalability assumptions. Allan shares this complaint.
17:17:19 <cmurf> - Jens says Akira Tagoh is planning to unify the various Noto fonts so they're no longer split into so many separate fonts.
17:17:21 <cmurf> #info WG discusses fonts!
17:17:23 <cmurf> - Owen doesn't like Noto Sans Mono. It seems "funky." Monospace font is important for developer workstation. International coverage may not be so important for monospace.
17:17:25 <cmurf> Neal suggests we could keep Source Code Pro in the GNOME settings but use Noto for Fontconfig settings. Neal doesn't want us to fall back to DejaVu.
17:17:27 <cmurf> - Jens: how many Noto fonts do we include? Need to develop a more complete proposal.
17:17:29 <cmurf> #topic Re-revisit Fedora Workstation minimums
17:17:31 <cmurf> #link https://pagure.io/fedora-workstation/issue/241
17:17:33 <cmurf> #info Deferred to next week
17:17:35 <cmurf> #topic Open Floor
17:17:37 <cmurf> #info Matthias asks Allan about monospace font size. Allan is worried that the next largest size is too large.
17:17:39 <cmurf> #link https://pagure.io/fedora-workstation/issue/134
17:17:41 <cmurf> #agreed meeting adjourned
17:18:04 <cmurf> #endmeeting