15:02:25 <coremodule> #startmeeting Fedora ARM Working Group Meeting
15:02:25 <zodbot> Meeting started Tue Aug 15 15:02:25 2023 UTC.
15:02:25 <zodbot> This meeting is logged and archived in a public location.
15:02:25 <zodbot> The chair is coremodule. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:02:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:25 <zodbot> The meeting name has been set to 'fedora_arm_working_group_meeting'
15:02:25 <coremodule> #chair pwhalen pbrobinson jlinton jforbes coremodule
15:02:25 <zodbot> Current chairs: coremodule jforbes jlinton pbrobinson pwhalen
15:02:25 <coremodule> #topic roll call
15:02:35 <coremodule> Sorry for the late start, who is around today?
15:02:40 * pwhalen is here
15:02:57 <coremodule> hey pwhalen, how are you?
15:03:38 * jlinton waves
15:03:56 <jforbes> I am here
15:05:20 <coremodule> hi all, let's get started
15:05:28 <coremodule> #topic 1) ==== Stable Releases ====
15:05:28 <coremodule> #info Fedora-Cloud-38-20230711.0
15:05:29 <coremodule> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=38&build=Fedora-Cloud-38-20230815.0&groupid=5
15:06:26 <coremodule> looks good to me...
15:07:24 <jlinton> Stable or F39? The first problem with the x13s and related QC machines is that this PR hasn't been merged yet: https://github.com/rhboot/grub2/pull/101
15:08:36 <coremodule> this is stable, jlinton does this affect f39 kernels?
15:08:45 <jlinton> With that its possible to get signs of life with F38/etc.
15:08:51 <jlinton> its a grub problem.
15:09:00 <coremodule> ah, okay
15:09:44 <jforbes> Do we have a bz or pull request to get this patch into fedora grub?
15:10:44 <pwhalen> doing well, coremodule. Hope all is well with you (sorry for the late reply)
15:10:46 <jlinton> I don't think there is a bz, but I can open one and link it to that PR, which wasn't initially for the x13s/etc. As can be seen from the initial messagers.
15:13:18 <jlinton> There is: https://github.com/rhboot/grub2/pull/101
15:13:44 <jlinton> whops bad paste again: the BZ is 2149020
15:13:50 <jforbes> I meant maybe a pull against the package itself with the patch added so we don't have to wait for upstream merge
15:14:03 <jlinton> but I can open a more specific one.
15:14:13 <jforbes> Which I don't think would do much more than prod an upstream merge
15:16:22 <coremodule> thanks for bringing this up jlinton
15:17:20 <coremodule> anything else here?
15:17:56 <jlinton> I will open a PR against the fedora grub.
15:19:02 <coremodule> thanks jlinton
15:20:29 <coremodule> #action jlinton to open PR against Fedora grub regarding failure to boot on the x13s.
15:20:44 <coremodule> #topic 2) ==== Kernel Status ====
15:20:44 <coremodule> #info F38 kernel-6.4.10-200.fc38
15:20:44 <coremodule> #info https://koji.fedoraproject.org/koji/buildinfo?buildID=2272534
15:20:45 <coremodule> #info Branched kernel-6.5.0-0.rc6.43.fc39
15:20:45 <coremodule> #link https://koji.fedoraproject.org/koji/buildinfo?buildID=2273908
15:20:46 <coremodule> #info Rawhide kernel-6.5.0-0.rc6.43.fc40
15:20:47 <coremodule> #link https://koji.fedoraproject.org/koji/buildinfo?buildID=2273783
15:21:08 <coremodule> jforbes, anything to know about the most recent kernels?
15:21:14 <jforbes> Some things of note.  6.5 will be the shipping kernel for F39
15:21:32 <jforbes> The armv7 bits have been ripped out of the spec and configs for 6.5
15:21:44 <pwhalen> no issues with 6.4 for me, will upgrade a few to 6.5 rc6 today
15:22:11 <jforbes> aarch64 16k bits have been added to the spec and configs for 6.5.  We will not be building it by default just yet, but it is on the way.
15:22:40 * pwhalen pours some coffee out for armv7
15:23:59 <jlinton> Hmmm, I have the 16k and a "hacked" 4k on the M1pro I have access to, and frankly i'm sorta on the side of just fixing the 4k page support (via bounce buffers/iommu overallocation/etc) to just work with the 4k kernel.
15:24:29 <jforbes> jlinton: I thought that wasn't going to be possible for graphics stuff, etc.
15:24:56 <jlinton> The graphics at the moment are rust, so its sorta off the table without down stream patches for the time being anyway, right?
15:25:14 <jforbes> For now, yes.
15:25:43 <jforbes> Asahi is doing their own kernel for the Fedora Asahi spin. We just want to keep as much of it as is upstream actually ready
15:26:17 <jlinton> My M1 is far from a perfect device, but at the moment with just a few minor hacks the 4k and 16k kernels are functionally the same from what I can tell.
15:26:35 <jforbes> thunderbolt and such working with 4k?
15:27:12 <jlinton> so, yah it might be less secure.. (well the pcie, i've not tested thunderbolt, the PCIe was just removing the explicit limitation).
15:28:14 <jforbes> Well, either way.  you can build a 16k kernel now with the spec in rawhide, we just don't build it by default
15:30:24 <coremodule> jforbes, unrelated, and perhaps elementary, but if I use grubby to edit kernel parameters, do you know if that remains persistent through different kernel installs?
15:30:59 <jforbes> I think it does
15:31:36 <coremodule> okay, thanks
15:32:11 <coremodule> let's move on
15:32:13 <coremodule> #topic 3) ==== Bootloader Status ====
15:32:13 <coremodule> #info uboot-tools-2023.07-2.fc39
15:32:13 <coremodule> #link https://koji.fedoraproject.org/koji/buildinfo?buildID=2257668
15:33:10 <coremodule> I don't have anything here
15:35:37 <coremodule> #topic 4) ==== Fedora 39 status ===
15:35:37 <coremodule> #info OpenQA Testing Fedora-39-20230815.n.0
15:35:37 <coremodule> #info https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=39&build=Fedora-39-20230815.n.0&groupid=5
15:36:35 <coremodule> I'
15:36:50 <coremodule> I'll test this base service manipulation test, don't know why that would be failing
15:39:11 <coremodule> #topic 5) ==== Open Floor ====
15:39:25 <coremodule> I have one thing for the open floor:
15:40:07 <coremodule> lruzicka did a good talk on OpenQA at flock this year, it does focus more on setting up tests, but there is some good info about how the system works and how to interpret the data that openQA gives out.
15:40:11 <coremodule> #link https://youtu.be/GkYURkrIzx0?list=PL0x39xti0_64OcXEGLCtoI4nouADqaTcT&t=24747
15:40:17 <coremodule> in case anyone is interested
15:41:43 <coremodule> alright everyone, thanks for attending
15:41:48 <coremodule> #endmeeting