15:00:00 <nils> #startmeeting modularity_wg
15:00:00 <zodbot> Meeting started Tue Sep 13 15:00:00 2016 UTC. The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:00 <zodbot> The meeting name has been set to 'modularity_wg'
15:00:00 <nils> #meetingtopic Weekly meeting of Modularity WG
15:00:00 <nils> #chair dgilmore jkurik langdon tflink
15:00:00 <zodbot> Current chairs: dgilmore jkurik langdon nils tflink
15:00:13 <nils> #topic Roll Call
15:00:15 <jkurik> .hello jkurik
15:00:16 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:00:18 <nils> .hello nphilipp
15:00:19 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:00:23 <tflink> .hello tflink
15:00:24 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:00:24 <moto-timo> .hello ttorling
15:00:26 <nils> Hello everbody :)
15:00:27 <zodbot> moto-timo: ttorling 'None' <TicoTimo@gmail.com>
15:00:27 <langdon> .hello langdon
15:00:30 <contyk> .hello psabata
15:00:33 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:00:36 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:54 <sgallagh> .hello sgallagh
15:00:56 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:01:43 <nils> #topic Agenda
15:01:43 <nils> #info Demos
15:01:43 <nils> #info UX work on user visible terminology (mclarke)
15:01:43 <nils> #info Badges
15:01:43 <nils> #info Base Runtime
15:02:00 <nils> Does anybody have something to add to this?
15:02:39 <nils> Doesn't seem like it.
15:03:45 <nils> langdon: I see "Demos" there, but Adam is on vacation, what do we do?
15:03:50 <bconoboy> also perhaps schedule for next week
15:03:58 <langdon> nils, ohh noes.. :)
15:04:10 <langdon> nils, did he update the agenda etherpad?
15:04:47 <nils> langdon: I have no idea, the topic was there but I don't know who added it. Etherpad seems to have a leaky memory.
15:04:59 <contyk> nils: says it was you :)
15:05:08 <langdon> nils, ha.. but the punch list isn't there.. we can just give the yt playlist
15:05:17 <nils> yeah.
15:05:21 <langdon> bconoboy, schedule?
15:05:37 <langdon> like we should probably cancel this? or just not have some of us here?
15:06:05 <contyk> the whole meeting or just this topic?
15:06:09 <nils> contyk: possible, but I seem to recall not adding that last week because Adam wanted to add it, doesn't matter
15:06:23 <bconoboy> langdon: yeah, pretty much
15:06:58 <langdon> contyk, the meeting next week as bconoboy, sct, me, contyk probably some others wont be able to make it (likely)
15:07:21 <contyk> oh right
15:07:36 <contyk> next week
15:07:52 <nils> bconoboy: I'll add that as a topic then
15:08:00 <nils> #info Schedule next week
15:08:15 <nils> ok
15:08:23 <nils> #topic Demos
15:08:55 <langdon> nils, you gonna do this one?
15:09:03 <nils> yeah, just grabbing the URL
15:09:24 <langdon> cool
15:09:35 <nils> #link https://www.youtube.com/watch?v=StsQTZDyuh0&list=PLcwHJG45BmANw_bj5jTnO_xlq0GkXc1Ln Demos for sprint #12
15:09:47 <nils> nothing more to say I guess :)
15:10:13 <langdon> watch the demos!
15:10:15 <langdon> :)
15:10:20 <contyk> now let's wait until everyone finishes watching it--
15:10:26 <nils> contyk: haha
15:10:29 <nils> #topic UX work on user visible terminology (mclarke)
15:10:32 <nils> contyk: NO
15:10:42 <contyk> ;(
15:10:44 <nils> maryc: this is yours :)
15:10:51 <maryc> nils: yep
15:10:59 <nils> #chair maryx
15:10:59 <zodbot> Current chairs: dgilmore jkurik langdon maryx nils tflink
15:11:04 <nils> #undo
15:11:04 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1f8d9990>
15:11:06 <nils> #chair maryc
15:11:06 <zodbot> Current chairs: dgilmore jkurik langdon maryc maryx nils tflink
15:11:14 <nils> gah
15:11:14 <maryc> I just wanted to let everyone in this meeting know that discussions are started around user visible terminology
15:11:15 <langdon> nils, you lost your topic
15:11:20 <nils> maryc: hold on
15:11:31 <nils> #topic UX work on user visible terminology (mclarke)
15:11:45 <nils> maryc: please continue, sorry for messing it up
15:11:53 <maryc> nils: np
15:12:00 <maryc> discussions are started :)
15:12:09 <maryc> around user visible terminology
15:12:29 <maryc> I have started a document to capture input and decisions
15:12:32 <langdon> maryc, you may want to elaborate on what "user visible terminology" means :)
15:12:54 <maryc> langdon: ok...I thought it was obvious :)
15:13:13 <langdon> well.. kinda.. but i think some context would help..
15:13:22 <maryc> user visible terminology can involve any terms/verbs that the user might use to interact with functionality within a CLI or in a GUI
15:13:42 <langdon> righto.. and in this case.. it kinda informs how people think about modules..
15:13:51 <contyk> so it affects module developers as well
15:13:54 <langdon> so .. thats why we want to spend some "real" time on thinkgin about it
15:13:57 <langdon> contyk, point
15:14:15 <maryc> langdon and contyk: right
15:14:43 <langdon> maryc did you send a note to the fedora mailing list on this? or did i make that up?
15:14:51 <maryc> we want to make sure we don't inadvertently change the terms we use for the same functions
15:14:51 <contyk> so I was thinking `select' would make a great verb to enable/install modules ;)
15:15:10 <maryc> I have not done that yet langdon
15:15:13 <moto-timo> echoes of Gentoo
15:15:32 <maryc> I am planning too, but I wanted to have it posted on the modularity wiki page first
15:15:32 <langdon> moto-timo, contyk is that what gentoo uses for slots or something?
15:15:45 <maryc> I am working with Stephen Gilson on that
15:15:47 <langdon> maryc +1 .. just confusing myself :)
15:15:56 <contyk> langdon: not exactly but close
15:16:43 <maryc> so, today is to make sure everyone on this meeting is aware that discussions have started and to highlight that there will be some items documented soon
15:16:47 <langdon> contyk, i kinda like it too.. we should add that to the idea list :)
15:17:11 <maryc> langdon, contyk: I'll add that
15:17:15 <contyk> hah
15:17:17 <maryc> any other ideas to add?
15:17:23 <sgallagh> maryc: Perhaps we should discuss *how* to have this conversation?
15:17:31 <moto-timo> +1
15:17:33 <contyk> +1
15:17:44 <maryc> I am open to any ideas sgallagh
15:17:44 <sgallagh> It's going to be extremely easy for such a discussion to end up deadlocked in opposing bikesheds
15:18:18 <sgallagh> I see three phases of the problem:
15:18:24 <langdon> sgallagh, why? the obvious bikeshed color is green!
15:19:03 <sgallagh> 1) Determine what terminology needs disambiguating. Some things will just be obvious, others contentious.
15:19:23 <sgallagh> 2) Have a limited time period to suggest (and defend) options for the terminology to use.
15:19:43 <sgallagh> 3) Have a formalized vote that everyone understands going in will be definitive.
15:20:41 <sgallagh> Those are the broad strokes, at any rate.
15:21:10 <maryc> sgallagh: what is the best format to provide to all involved the 'document' or place to suggest/defend
15:21:58 <sgallagh> I think the easiest answer is to just use the mailing list and archives. We only really need to document the final result and maybe pointers to the threads where the alternatives were discussed.
15:22:21 <sgallagh> I don't think we want to go as far as formal proposal documents
15:23:06 <maryc> does that work for everybody?
15:23:10 <sgallagh> Also keeping it on the mailing list helps ensure transparency and inclusion in the discussion
15:23:45 <langdon> +1
15:23:51 <moto-timo> +1
15:24:23 <maryc> ok, look for something on the mailing list soon
15:24:28 <sgallagh> Someone should probably be tasked with following the thread(s) and keeping a side-document of the proposals and a short summary of them, in the interest of later voting.
15:24:34 * contyk can already see those endless threads about this topic
15:24:48 <moto-timo> side-document => wiki?
15:24:51 <sgallagh> contyk: Precisely why I said "limited time"
15:24:52 <nils> contyk: haha
15:24:55 <sgallagh> moto-timo: Most likely, yes
15:25:06 <maryc> sgallagh: I will do that
15:25:20 <sgallagh> maryc++
15:25:30 <nils> so, something to #info, #action?
15:25:40 <moto-timo> limited time --- especially for those contentious flame war addicts out there
15:27:03 <nils> "next Saturday, between 3:00 and 3:05 AM" ;)
15:27:17 <sgallagh> nils: What time zone? ;-)
15:27:24 <langdon> maryc, sgallagh #info? or should nils or i add one?
15:27:31 <langdon> sgallagh, mars
15:27:53 <nils> sgallagh: any time zone that doesn't harbor known flamers? :D
15:28:06 <maryc> langdon: I am going to plead ignorance here...
15:28:07 <sgallagh> nils: Alpha centauri, then
15:28:47 <langdon> maryc, so.. to make the log of this meeting meaningful we pick out important bits and lead it with #info then zodbot highlights it in the minutes
15:28:56 <langdon> sgallagh or nils, care to take a stab?
15:29:04 <sgallagh> /me isn't chaired
15:29:11 <nils> #chair sgallagh
15:29:11 <zodbot> Current chairs: dgilmore jkurik langdon maryc maryx nils sgallagh tflink
15:29:18 <nils> #unchair maryx
15:29:18 <zodbot> Current chairs: dgilmore jkurik langdon maryc nils sgallagh tflink
15:29:20 <langdon> fixed that! :)
15:29:31 <sgallagh> OK, one moment while I phrase it.
15:29:35 <nils> even fixed my bumble from before :)
15:31:40 <sgallagh> #info We will have a three-phase approach to dealing with user-visible terminology.
15:31:40 <sgallagh> #info Phase 1: Generate a list of concepts that need consistent names.
15:31:40 <sgallagh> #info Phase 2: State a limited (less than two weeks) period to propose, justify and discuss those names on the fedora-devel mailing list
15:31:40 <sgallagh> #info Phase 3: Hold a binding vote to select the terminology that will be used.
15:32:02 <sgallagh> maryc: Do you want to take a #action to kick this off?
15:32:07 <langdon> sgallagh, who can vote?
15:32:22 <nils> langdon: +1 good question
15:32:23 <sgallagh> langdon: I was assuming Modularity WG seats
15:32:29 <contyk> hrm
15:32:33 <sgallagh> But yeah, I shouldn't assume
15:32:38 <langdon> maryc, #action is what it sounds like.. again in the meeting minutes it will be captured as "mary agreed to do this"
15:33:03 <sgallagh> Anyone can propose an option, but it should really be a small group empowered to make the final decision
15:33:06 <langdon> re: voting) im kinda inclined to say anyone who has a fas account can vote.. why not?
15:33:31 <nils> maryc: yeah, a line starting with "#action maryc ..." will record this as an action item for you
15:33:33 <sgallagh> langdon: There are Politics involved there.
15:33:45 <langdon> sad
15:33:49 <maryc> #action maryc will lead the phases by kicking off the discussion in the fedora devel mailing list and documenting responses on the wiki
15:33:58 <langdon> ok.. lets say modularity wg .. with lazy consensus
15:34:10 <nils> maryc: 👍
15:34:26 <sgallagh> I think that's totally reasonable. The modularity WG is ultimately the ones implementing it
15:34:47 <sgallagh> And I doubt anyone here would vote wildly against a general consensus if one arose anyway
15:34:52 <langdon> maryc, when you get to the "voting step" i can help you word it ...
15:35:03 <maryc> langdon: sounds good
15:35:06 <moto-timo> or feel offended if their preferred was not chosen
15:35:56 <sgallagh> moto-timo++
15:36:30 <nils> ok, are we good here?
15:36:42 <langdon> i think so
15:36:50 <nils> #topic Badges
15:37:12 <langdon> ok.. i guess i get this one
15:37:18 <nils> yup :)
15:37:24 <tflink> langdon: you did take the vote :)
15:37:32 <moto-timo> who can vote?
15:37:39 <langdon> i only got two votes.. but.. i didn't give people much time.. so i will ask for more votes here.. but then lets call it a day..
15:37:44 <nils> voting WG members
15:37:59 <langdon> but feel free to offer an opinion moto-timo
15:38:28 <moto-timo> FWIW, I like both of the last two... but the last one the green stroke is a bit too contrasty on the right side (the orange? lego)
15:39:33 <langdon> ok.. so i have a vote for https://fedorahosted.org/fedora-badges/ticket/466#comment:25 and a vote for ..
15:40:06 <langdon> https://fedorahosted.org/fedora-badges/attachment/ticket/466/ticket%20%23466_attempt%207.png
15:40:15 <langdon> any other voters here?
15:40:36 <langdon> i am inclined to vote for https://fedorahosted.org/fedora-badges/attachment/ticket/466/ticket%20%23466_attempt%207.png as well..
15:40:38 <nils> #link https://fedorahosted.org/fedora-badges/ticket/466 ticket with candidates
15:40:44 <langdon> nils, thanks
15:41:00 <moto-timo> +1 attempt 7
15:41:58 <langdon> dgilmore, haraldh, sct opinions on badge design?
15:43:20 <langdon> ok.. i say we move to the rest of the agenda and in the last 5 mins come back to this to see if we get any more votes
15:43:29 <nils> ok
15:43:45 <nils> #info voting at the end of the meeting
15:44:01 <nils> #topic Base Runtime
15:44:06 <contyk> ok, this is me
15:44:06 <nils> contyk: ?
15:44:10 <nils> #chair contyk
15:44:10 <zodbot> Current chairs: contyk dgilmore jkurik langdon maryc nils sgallagh tflink
15:44:13 <contyk> right
15:44:33 <contyk> so I just wanted to say we kicked off the first sprint last week
15:44:52 <contyk> we're going to work in short, one week sprints for now
15:45:08 <contyk> the public kanban board is still fairly empty
15:45:11 <sgallagh> No rest for the wicked
15:45:22 <contyk> #link https://taiga.fedorainfracloud.org/project/base-runtime/kanban base runtime kanban board
15:45:33 <contyk> (is it how you do it?)
15:45:43 <sgallagh> yes
15:45:57 <contyk> I also created an empty landing wiki page just before the meeting
15:46:14 * contyk looks for the link
15:46:26 <nils> contyk: perfect
15:47:05 <contyk> #link https://fedoraproject.org/wiki/BaseRuntime base runtime wiki page
15:47:34 <contyk> basically this is a sister project of modularity, focusing on the low level modular content -- the application runtime environment and hardware enablement layer
15:47:50 <contyk> so far it's been sgallagh and I working on it
15:48:18 <contyk> we're still figuring out what we're trying to achieve, so don't expect too much too soon
15:48:50 <contyk> the first deliverable will be a self hosted module that we could as a starting point for further development
15:49:08 <contyk> the goal is to bootstrap the modularity stg infrastructure with whatever we come up with
15:49:49 <contyk> that should happen, hopefully, by next week
15:49:54 <contyk> sgallagh: anything to add?
15:50:31 <sgallagh> Not really. As contyk said, we're still deep into the "research" side of R&D
15:51:35 <contyk> that's probably it for today then
15:51:46 <nils> ok
15:51:57 <nils> #topic Schedule next week
15:52:04 <nils> bconoboy, langdon?
15:52:39 <langdon> well.. nils i would say it is kinda up to you.. do you want to host the meeting with those people missing?
15:53:02 <contyk> it could be one of those five minute meetings we had in the past
15:53:09 <nils> I can host the meeting, sure.
15:53:21 <contyk> where I came ten minutes late and the meeting was over already
15:53:34 <langdon> contyk, we were just hiding from you
15:53:38 <sgallagh> /me thinks those are the best kind, honestly
15:53:54 <nils> #info Meeting next week will take place as scheduled
15:53:59 <nils> ok
15:54:09 <langdon> we use this meeting for a lot of status reporting.. cause we aren't good at doing it using other methods
15:54:19 <moto-timo> +1
15:54:37 <nils> #topic Badge #2, the Vote™
15:55:00 <langdon> lol
15:55:13 <langdon> 3rd vote: https://fedorahosted.org/fedora-badges/ticket/466#comment:31
15:55:21 <langdon> 4th i suppose
15:55:31 <langdon> ok.. going once
15:55:47 <langdon> twice
15:55:58 <langdon> and three times
15:56:03 <tflink> what is the vote?
15:56:11 <tflink> or are you just asking if there are more votes?
15:56:14 <langdon> for the badge.. you already votes
15:56:16 <langdon> *voted
15:56:24 <langdon> yeah
15:56:33 <langdon> from the other voters who didn't hit me on email
15:56:46 <langdon> but are, in theory, on irc :)
15:58:07 <langdon> ok so, 1 for attempt #6, 2 for attempt #7
15:58:12 <langdon> i think that is it
15:58:30 <langdon> so.. attempt #7 it is, right?
15:58:44 <langdon> https://fedorahosted.org/fedora-badges/attachment/ticket/466/ticket%20%23466_attempt%207.png
15:59:03 <nils> langdon: you said you had one for #6 before, is that jkurik's?
15:59:18 <jkurik> nils: yes
15:59:35 <nils> ahh ok
15:59:39 <langdon> nils, one vote for #6 was from a non-voting member
15:59:43 * contyk voted for #6 via mail
15:59:43 <nils> aah
15:59:51 <contyk> :)
16:00:00 <langdon> so .. in the interest of this not being a tie.. i discounted contyk's vote :/
16:00:11 <nils> contyk: I hope it wasn't an Austrian ballot envelope ;)
16:00:14 <contyk> that's fine
16:00:18 <nils> yeah
16:00:23 <langdon> ok.. finally
16:00:43 <langdon> #agreed https://fedorahosted.org/fedora-badges/attachment/ticket/466/ticket%20%23466_attempt%207.png is the winning badge design
16:00:56 <langdon> ^^ talk about things that were way more effort than required :)
16:01:17 <nils> oh yeah
16:01:26 <langdon> nils, open floor?
16:01:30 <nils> yup
16:01:31 <langdon> or did we have something else?
16:01:34 <contyk> next we should discuss how long we're going to discuss the ux thing
16:01:38 <langdon> #action langdon updating badge ticket
16:01:46 <nils> langdon: not on the agenda
16:01:52 <nils> #topic Open Floor
16:03:03 <nils> so, how long should we discuss the UX thing? :)
16:03:13 <contyk> let's start a thread about it
16:03:21 <langdon> nils, i was praying that was a joke
16:03:28 <contyk> ;)
16:04:26 <nils> it was :)
16:04:31 <contyk> so, anybody got anything?
16:04:34 <langdon> ok.. so.. any "real" topics?
16:04:39 <langdon> what he said :)
16:05:14 <nils> *crickets*
16:05:29 <nils> good
16:05:44 <nils> Thanks everybody!
16:05:45 <nils> #endmeeting