15:01:58 <langdon> #startmeeting modularity_wg
15:01:58 <zodbot> Meeting started Tue Nov 15 15:01:58 2016 UTC.  The chair is langdon. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:58 <zodbot> The meeting name has been set to 'modularity_wg'
15:02:47 <langdon> #chair cydrobolt dgilmore haraldh langdon mikedep333 sct tflink
15:02:47 <zodbot> Current chairs: cydrobolt dgilmore haraldh langdon mikedep333 sct tflink
15:03:08 <langdon> #topic Roll Call
15:03:11 <langdon> .hello langdon
15:03:12 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:03:13 <asamalik> .hello asamalik
15:03:13 <sct> .hello sct
15:03:15 <contyk> .hello psabata
15:03:15 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:03:18 <zodbot> sct: sct 'Stephen Tweedie' <sct@redhat.com>
15:03:21 <zodbot> contyk: psabata 'Petr Ĺ abata' <psabata@redhat.com>
15:03:43 <karsten> .hello karsten
15:03:44 <zodbot> karsten: karsten 'Karsten Hopp' <karsten@redhat.com>
15:04:08 <langdon> #topic agenda
15:04:20 <langdon> #link http://piratepad.net/modularity-wg-agendas agenda
15:04:24 <langdon> anyone got anything?
15:05:15 <contyk> langdon: you could provide an overall update :)
15:05:23 <langdon> ok..
15:05:24 <contyk> langdon: we haven't heard from you in a while :)
15:05:37 <langdon> i thought people might like that
15:05:46 <langdon> ;)
15:05:55 <langdon> ok.. ill do a bit of an update
15:05:59 <langdon> anyone got anything else?
15:06:33 <langdon> ohh.. actually, asamalik can you give a demo update?
15:06:41 <langdon> someone asked about them in #f-m
15:07:33 <langdon> ok... let's start then?
15:07:40 <asamalik> langdon: I can, yes
15:07:43 <langdon> #topic modularity general update
15:08:27 <langdon> ok.. hmm.. i don't have much prepared.. so ask qs and/or my typing may be slow
15:08:52 <langdon> first off.. we have moved most of the modularity infrastructure work in to the factory 2 team under threebean
15:09:08 <langdon> so.. still pretty tightly integrated but one less thing for me to worry about
15:09:26 <langdon> as you know, most of the gen-core/base runtime work is being led up by contyk now too
15:09:39 <langdon> so modularity kinda core team is focusing on starting to ship content
15:09:57 <langdon> specifically, we are working on how to ship content as containers as well as rpms
15:10:12 <langdon> and we are focused on the content that the server wg is looking for
15:10:48 * langdon digs for link
15:11:14 <contyk> packaging modules is not an easy task; which team is going to create some helper tools?
15:11:45 <contyk> also, I was asked today -- is there going to be some catalog with available modules and their APIs?
15:11:49 <langdon> contyk, client-side? i think "me" .. as in modularity team
15:11:49 <moto-timo> .hello ttorling
15:11:50 <zodbot> moto-timo: ttorling 'Tim Orling' <ticotimo@gmail.com>
15:11:54 <contyk> so a module author can browse and see what to base their module on
15:11:58 <moto-timo> this time change thing :/
15:12:06 <contyk> moto-timo: hey
15:12:13 <langdon> contyk, i think that is something we need to put in to the queue for factory-2
15:12:35 <langdon> i can't find the link to the server wg logic model quickly
15:12:56 <langdon> so.. I would like to improve our module-creation tools (i.e. make some :) )
15:13:14 <langdon> and also make sure modulemd can be really simple but the details get generated
15:13:21 <langdon> contyk, does that make sense?
15:13:53 <contyk> langdon: I have some first hand experience with creating modules now and it's not very pleasant
15:13:57 <langdon> ha
15:14:11 <contyk> langdon: I don't know what could make it easier
15:14:12 <langdon> maybe you could write up your ideas?
15:14:16 <contyk> but I hope there are ways :)
15:14:18 <langdon> ahh..
15:14:38 <contyk> jkaluza's mock backend (a new feature of the MBS) is surely going to help a great deal
15:14:49 <langdon> modularity team has been a bit disjointed while splitting work out.. i think we are getting back on track
15:15:46 <langdon> re: module browser, i would like to feed requirements to threebean about that..
15:16:01 <langdon> more comments? questions?
15:16:40 * contyk thinks
15:17:12 <langdon> more demos are planned for devconf and fosdem (assuming talks get accepted)
15:17:19 <contyk> any specific goals for the upcoming two weeks?
15:17:30 <langdon> asamalik, also proposed a "getting started with making a module" for devconf
15:17:50 <langdon> we hope to build some early containers this sprint.. based on modules
15:18:04 <asamalik> yeah! it will be a workshop for people to try to build their first module
15:18:15 <langdon> but we haven't focused on the client tooling yet.. so it will just be like docker pull
15:19:00 <contyk> what will you use as the base image?
15:19:12 <langdon> contyk, magic?
15:19:18 <langdon> you will have one for us, right?!?!??
15:19:29 <langdon> nah.. probably just fedora, i should think
15:19:30 <contyk> langdon: you know I don't :)
15:19:43 <langdon> btw, server wg logic model: https://kolinahr.fedorainfracloud.org/edit/57ff81347b76717eefcbc44b
15:20:05 <contyk> langdon: one of your goals is to work with the base runtime team and define the gen-core api ;)
15:20:16 <langdon> anything we should #info?
15:20:19 <langdon> ohh right..
15:20:44 <langdon> contyk, yes.. collaborate with base runtime team to make an early gen-core
15:20:52 <contyk> +1
15:21:05 <moto-timo> sounds like an action :)
15:21:10 <langdon> well.. really, i expect it will be "base runtime proposes gen-core" .. modularity adds a few missing bits
15:21:13 <langdon> moto-timo, ha
15:21:42 <langdon> #chair asamalik
15:21:42 <zodbot> Current chairs: asamalik cydrobolt dgilmore haraldh langdon mikedep333 sct tflink
15:21:56 <langdon> should we move to talk about demos?
15:22:01 <langdon> or what is in the yt channel?
15:22:14 <asamalik> langdon: let's do it
15:22:27 <langdon> like i said, we have spent the past few weeks sorting out some team dynamics.. so less productive than i would have hoped
15:22:42 <langdon> #topic modularity demos update
15:22:52 <langdon> asamalik, all yours.. and ill brb
15:22:57 <asamalik> but we still have something
15:23:18 <asamalik> there are not much of the "traditional demo" videos
15:23:39 <asamalik> but we are preparing an overview demo that would explain how do we build modules and containers
15:24:26 <langdon> im back
15:24:35 <asamalik> and I guess we would like to be more focused on some kind of higher level overview than just plain sprint reports, right?
15:24:58 <langdon> yeah.. i thought the demo overview videos were pretty good
15:25:08 <moto-timo> +1
15:25:19 <langdon> unfortunately the person who asked about the demos isn't here..
15:25:32 <langdon> but.. i would like to know.. what would you like to see more of?
15:25:37 <langdon> sprint demos? emails?
15:25:40 <langdon> blog posts?
15:25:53 <langdon> like how do we better communicate what is going on?
15:27:01 * asamalik is not sure if that question is to him or to others
15:27:13 <langdon> both :)
15:27:40 <moto-timo> well... I like the blog posts and the video demos. plus the howto wikis
15:27:52 <langdon> ok.. cool
15:28:03 <asamalik> I guess I would like to have a project page with high level overview that would explain what we do and why we are do it? something easier to start with than the wiki
15:28:29 <moto-timo> make sure your svg animations hit that page
15:28:30 <langdon> #topic ideas for communication
15:28:51 <langdon> ahh yes.. we do need that.. do we have an outline or anything that people could contribute too?
15:28:57 <asamalik> moto-timo: right :)
15:29:38 <langdon> asamalik, iirc we thought you could spend a bit of time each week on working a "website"
15:29:39 <asamalik> langdon: I guess I can start something.. just need to agree on a place and url/domain
15:29:48 <asamalik> langdon: yeah!
15:29:58 <langdon> contyk, would you want to put base runtime stuff in there too?
15:30:01 <asamalik> langdon: that's what I meant by project page....
15:30:16 <langdon> asamalik, how about www.fed-mod.org?
15:30:21 <asamalik> langdon: +1
15:30:30 <contyk> I don't have much
15:30:42 <contyk> we're still struggling with the build of the initial prototype
15:30:53 <moto-timo> dependency hell?
15:30:57 <langdon> contyk, yeah.. but your png you have been floating around for gen-core might be good
15:31:00 <dgilmore> hi
15:31:05 <contyk> the latest news is we ran into package build failures (as opposed to factory2 failures) which we will focus on resolving in the upocoming few weeks
15:31:11 <contyk> moto-timo: indeed
15:31:23 * langdon waves to dgilmore
15:31:31 <contyk> langdon: I posted that picture last time :)
15:31:40 <contyk> langdon: you're not paying attention!
15:31:45 <langdon> but asamalik is gonna make a FANCY website..
15:31:46 * moto-timo was in bed sick last time
15:31:49 <langdon> i meant in there.. not here
15:32:07 <contyk> aha!
15:32:13 * contyk wasn't paying attention
15:32:51 <langdon> contyk, ha.. at least i am not the only one :)
15:33:19 <langdon> asamalik, can we add an action that next wg meeting you will have some website "plan" or something?
15:33:20 <contyk> we can make some new pictures, too
15:33:29 <contyk> prettier
15:33:37 <contyk> with more useful info
15:33:46 * langdon guesses the existing ones aren't svg..
15:33:49 <asamalik> langdon:  yeah, let's do it
15:33:57 <moto-timo> svg all the things
15:34:03 <langdon> asamalik, wording?
15:34:09 <langdon> like what do you want to commit too?
15:34:12 <asamalik> I can work with contyk on base runtime content etc
15:34:21 <contyk> +1
15:34:34 <asamalik> langdon: I guess I can create a prototype
15:34:45 <langdon> ok.. that was more than i was hoping :)
15:34:47 * moto-timo can be guinea pig
15:34:59 <langdon> #action asamalik to create "modularity website" prototype
15:35:12 <asamalik> langdon: so we can se all the info and if we decide it's fine, I'll make it final and ship it to the cloud!
15:35:19 <langdon> lol
15:35:28 <moto-timo> www.skynet.org
15:35:37 <langdon> moto-timo, thats for LATER
15:35:56 <langdon> it was a secret!
15:36:02 <langdon> ok.. what else we got?
15:36:05 * moto-timo looks sheepish
15:36:39 * langdon notes he is disappointed with what is actually hosted at skynet.org
15:37:05 <langdon> #topic open floor
15:37:13 <langdon> we got anything for open floor?
15:37:50 <moto-timo> contyk, langdon: did you need anything from me regarding containers?
15:38:09 <langdon> moto-timo, i think i owe you follow ups
15:38:13 <contyk> moto-timo: we haven't made much progress on the content side of things
15:38:24 <moto-timo> yeah, I have that problem too
15:38:37 * langdon notes skynet.horse *is* available though
15:38:41 <moto-timo> I can tell you 10,000 ways to break eclipse though
15:38:44 <langdon> ha
15:38:50 <langdon> when you only need one!
15:39:05 <langdon> ok.. im gonna start the countdown
15:39:09 <langdon> going once
15:39:26 <langdon> going twice
15:39:31 <contyk> :)
15:39:38 <langdon> three times has it! :)
15:39:44 * moto-timo waves
15:39:45 <langdon> #endmeeting