15:00:00 <nils> #startmeeting modularity_wg
15:00:00 <zodbot> Meeting started Tue Dec 18 15:00:00 2018 UTC.
15:00:00 <zodbot> This meeting is logged and archived in a public location.
15:00:00 <zodbot> The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:00 <zodbot> The meeting name has been set to 'modularity_wg'
15:00:01 <nils> #meetingtopic Weekly Meeting of the Modularity Working Group
15:00:07 <contyk> o/
15:00:12 <nils> #topic Roll Call
15:00:14 <contyk> .hello psabata
15:00:15 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:17 <nils> .hello nphilipp
15:00:18 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:01:39 <nils> Hmm, since we got rid of the "voting members" notion, should I #chair the usual suspects anyway?
15:01:58 <nils> So far this has worked nicely as a veiled ping :)
15:02:20 <contyk> doesn't make much sense to me
15:02:48 <contyk> most of the chairs don't attend regularly anyway and people who do are not listed :)
15:02:52 <contyk> so not sure how useful that is
15:03:30 <Son_Goku> .hello ngompa
15:03:31 <zodbot> Son_Goku: ngompa 'Neal Gompa' <ngompa13@gmail.com>
15:03:32 <nils> I meant, chair the usual suspects who participate instead of chairing the intersection of "voting member" and "present"?
15:03:59 <contyk> if you have a way to determine who that is...
15:04:09 <nils> Heh, fair enough :)
15:04:13 <nils> Anyway, here's what wasn't concluded last week:
15:04:31 <nils> ah no
15:04:34 <nils> first things first
15:04:37 <nils> #topic Agenda
15:04:49 <nils> #info #112 Discussion: Module lifecycles
15:04:58 <nils> #info #115 Discussion: Stream branch ownership for packages & modules
15:05:09 <nils> #info #119 Modularity WG Charter (contd.)
15:05:21 <nils> now
15:05:29 <nils> #topic #112 Discussion: Module lifecycles
15:05:40 <contyk> so I opened a FESCo ticket for this
15:05:41 <nils> #link https://pagure.io/modularity/issue/112
15:05:46 <contyk> just a couple of days ago
15:05:55 <contyk> we can expect feedback after the holidays
15:06:11 <nils> yeah, I've seen it, should we keep our ticket open for tracking/revisiting next year?
15:06:21 <contyk> yes
15:07:03 <nils> #link https://pagure.io/fesco/issue/2027 corresponding FESCo ticket
15:07:19 <nils> #topic #115 Discussion: Stream branch ownership for packages & modules
15:07:25 <contyk> same here
15:07:27 <nils> I assume the same
15:07:57 <nils> #link https://pagure.io/fesco/issue/2028 corresponding FESCo ticket
15:08:19 <nils> #topic #119 Modularity WG Charter (contd.)
15:08:32 <nils> #link https://pagure.io/modularity/issue/119
15:09:29 <nils> I filed this one because last time we only decided about our mode of voting but langdon wrote a full proposal for an updated charter which we didn't get to so far.
15:10:01 <nils> I've updated it to reflect the changes we agreed on re voting.
15:10:59 <contyk> does the Council need to approve these things?
15:11:45 <nils> Maybe not. It was in the original proposal and seemed to work even with the agreed upon changes in effect, so I left it in.
15:11:56 <contyk> also with my Council hat on, we would like to simplify/unify labels groups use, like "working group" here
15:12:04 <nils> Until we decide on it, nothing's set in stone :).
15:12:19 <contyk> so maybe we will be renaming this group to "team" later but we'll see
15:12:42 <contyk> so we voted on the "making decisions" bit, you'd like to vote on the "membership" part now?
15:12:43 <nils> Sounds good to me, saves me from a lot of typing :)
15:13:52 <nils> No, I think we implicitly decided last week that there is no "voting membership" anymore, making membership de facto, i.e. who participates is in.
15:14:37 <contyk> I think we also voted on how we're going to vote :)
15:14:42 <contyk> so what part of the charter do you want to vote on?
15:15:10 <nils> I've outlined the changes at the top of the ticket, so that's what I proposed for voting :)
15:15:45 <nils> The last bullet point is just putting last week's decision into the charter, so I don't think it needs to be voted on, again.
15:15:53 <contyk> ah, I thought the text in the ticket was your proposal
15:16:41 <nils> It was Langdon's proposal with my updates reflecting the voting changes from last week.
15:17:00 <langdon> .hello2
15:17:01 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:17:06 <langdon> sorry.. notifications failing me today
15:17:12 <contyk> ok
15:17:27 * contyk still feels like we've already agreed to both of those things but is happy to vote again
15:17:55 <nils> Well, we'd need to get three +1s in the ticket now because the proposal isn't a week old yet :)
15:18:26 <contyk> ah
15:18:26 <langdon> fyi... we do not need council approval to change the WG rules
15:18:30 <contyk> why is it on the agenda then? :P
15:18:47 <nils> Maybe to get these three votes? :D
15:18:51 <langdon> contyk: it is?
15:19:01 <contyk> langdon: we're talking about it here, now
15:19:03 <contyk> so yeah :)
15:19:03 <nils> Also to get the discussion rolling.
15:19:18 <langdon> what does us talking about it have to do with council approval?
15:19:32 <contyk> langdon: nothing :)
15:19:34 <nils> langdon, contyk was replying to me
15:19:43 <nils> text chats are wonderful
15:19:51 <langdon> ohh.. much less confused now
15:19:52 <contyk> oh yeah, I see it now
15:20:20 <contyk> ok, I'll comment on the ticket
15:21:33 <langdon> me too.. and hopefully we can get it approved by next meeting
15:21:38 <nils> So let me make this short detour, here's my take: I don't understand anything in the voting process to say you can't bring it up in the meeting before the week has passed. Starting or continuing the discussion is good use of WG meeting time, this is not merely a voting event. Agree/disagree?
15:21:55 <nils> (informally)
15:22:15 <langdon> generally, i agree .... the only thing is anything worthy of #info should probably also land in the ticket
15:22:25 <nils> yep
15:22:32 <langdon> or #anything really
15:23:16 <langdon> or.. we could just, as a policy, link the meeting minutes in to the ticket comments whenever that ticket was on the agenda and discussed
15:23:48 <nils> We'd have to put in a meeting command to be able to link properly, i.e. #info, #agreed, ...
15:23:51 <contyk> the fewer policies the better :)
15:24:02 <nils> Not every line in the log is hot-linkable, unfortunately.
15:24:28 <langdon> linking the meeting minutes (in total i meant) is  a lot simpler that re-transcribing any # events from the meeting
15:24:32 <contyk> when I update tickets post meeting, it's either the agreed line or something human readable, depending on the ticket/context
15:24:38 <langdon> s/that/than
15:25:04 <langdon> contyk: that assumes a decision was made.. i was talking about nils' example of just a discussion
15:25:07 <contyk> it's simpler for you to do, it's more cumbersome for others to read as they need to follow a link
15:25:13 <nils> langdon, agreed but I'd say hot-linking the pertinent part is even more useful
15:25:29 <langdon> yeah.. either way..
15:26:05 <contyk> just think of the people for whom you're posting the update :)
15:26:12 <nils> I think we can put on record that involving the Council isn't necessary, so I'll update the proposal to that effect.
15:26:27 <contyk> normally I wouldn't care about a link to some discussion I'm supposed to go through, I'd want a summary I can just read in email
15:26:37 <nils> yea
15:26:39 <langdon> nils: the way it is phrased as a "notice" isn't a bad idea i don't think
15:26:50 <langdon> contyk: +1 .. but who writes the summary???
15:27:01 <contyk> normally it's the meeting chair
15:27:10 <langdon> nils: "After initial ratification, any substantive changes can be approved by a formal vote and sent to the Fedora Council for acceptance."
15:27:12 <nils> langdon, any #info or #agreed serves as a summary
15:27:19 <nils> it's put in the minutes and can be hot-linked
15:27:22 <langdon> ok.. im down w/ that..
15:28:03 <nils> langdon, WDYM "phrased as 'notice'"?
15:28:17 <nils> I don't know what you're referring to
15:28:42 <nils> Right now, "acceptance" implies a final call on the Council's behalf
15:29:41 <langdon> so " sent to the Fedora Council for acceptance" normally means (in my head at least) in orgs that the group sends "hey council we updated some stuff". .. technically, the council can veto it.. but unless they proactively do something it is assumed approved..  that was the intent i was going for (i think i wrote it.. it is certainly how i read it)
15:30:30 <contyk> I understood it as "we will open a Council ticket and wait for an explicit approval"
15:30:40 <langdon> ahh .. no..
15:30:44 <nils> In my head, "notice" would more be s.th. like "... formal vote of which the Fedora Council is informed."
15:30:50 <langdon> that wasn't the intent or the way i read it
15:31:04 <langdon> ok.. so let's change it
15:31:13 <nils> Just to be crystal clear these things don't have to wait for a decision by the Council.
15:31:29 <nils> If they want to veto things, they can do so on their own initiative.
15:31:33 <langdon> words are hard™
15:31:37 <nils> oh yes
15:31:51 <nils> even more so if a pedant like me is around :)
15:33:22 <nils> So, I'll update to the effect of us informing the Council of the charter and subsequent changes?
15:33:41 <langdon> +1
15:34:04 <nils> contyk?
15:34:24 <contyk> sure, +1
15:34:34 <contyk> although I don't think the Council cares ;)
15:34:54 <nils> I can also remove it, fine with me.
15:35:17 <nils> It was in the original proposal, so I didn't want to nix it on my own :)
15:35:20 <contyk> no, it's fine
15:35:25 <langdon> nils: i think the heads up is important in terms of buy in .. personally
15:35:32 <nils> good!
15:35:58 <contyk> I don't see any other groups announcing such changes; FESCo certainly doesn't
15:36:20 <contyk> to the Council, I mean
15:36:25 <langdon> contyk: really? we should probably mention that to council and tell them to require it :)
15:36:35 <contyk> langdon: why?
15:36:36 <nils> #action nils updates #119, clarifying that the Council is informed of this charter and substantial changes
15:36:48 <nils> contyk, because we'll run out of red tape otherwise :D
15:36:55 <nils> (I kid, I kid.)
15:37:29 <nils> Okay, I think we're through the agenda.
15:37:31 <langdon> contyk: mostly to keep what has happened in the past from happening... no one has any idea what all thr groups are ..
15:38:10 <contyk> langdon: you can bring it up at the Council meeting ;)
15:38:24 <contyk> but I think we strive for less micromanagement and let people do what they want, not the opposite
15:38:30 <nils> Just FYI, there are some tickets opened by praiskup in the issue tracker but he doesn't seem to be on today so I didn't put them on the agenda.
15:38:48 <contyk> they're also all fairly new
15:38:55 <contyk> I'll go through the queue later
15:39:23 <nils> At least one seemed to need input from Adam who's out over the holidays, too.
15:39:25 <contyk> nils: the point of that week-long window is to minimize the number of items we need to discuss in sync
15:40:33 <nils> Ah okay :)
15:41:21 <nils> Anything for Open Floor?
15:42:08 <contyk> not here
15:42:49 <nils> alright
15:42:54 <nils> Thanks everybody!
15:42:59 <nils> #endmeeting