00:02:47 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:02:47 <zodbot> Meeting started Thu Aug 27 00:02:47 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:54 <Sparks> #topic Roll Call
00:02:55 * Sparks 
00:03:38 * rudi is here
00:03:56 * itbegins here
00:05:18 * Sparks wonders where everyone is today
00:06:24 * laubersm is here
00:07:05 <Sparks> Okay, lets get started...
00:07:11 <Sparks> #topic Last week's action items
00:07:23 <Sparks> Sparks to create BZ component Deployment Guide --Third alarm
00:07:31 <Sparks> Finally done.
00:07:43 <Sparks> Sparks to write up CVE checking/validation procedures in the wiki --third alarm
00:07:48 <Sparks> Still in progress
00:07:56 <Sparks> #action Sparks to write up CVE checking/validation procedures in the wiki
00:08:08 <Sparks> quaid to follow up with Mizmo on the Zikula theme
00:08:13 <Sparks> quaid: You around?
00:08:42 <Sparks> I know Mo has been working on the Zikula theme.  I'm sure this is in progress.
00:08:56 <Sparks> rudi to follow up with Jeff about changing the license information in Publican 0.44 and 1.0
00:09:10 <Sparks> rudi: Got an update?
00:09:21 <rudi> We're still a few steps away from that
00:09:26 * ianweller rolls in
00:09:45 <itbegins> I can report a little on the theme, depending on what you want to knwo
00:10:04 <Sparks> rudi: Okay, I'll put it down for next week so we can talk about it again.
00:10:11 <rudi> Yep
00:10:14 <Sparks> #action rudi to follow up with Jeff about changing the license information in Publican 0.44 and 1.0
00:10:18 <Sparks> ianweller: Go
00:10:40 <ianweller> about my part of it? the writing up of the announcement?
00:11:32 <ianweller> Sparks: hi?
00:11:42 <Sparks> the theme
00:11:48 <ianweller> oh for zikula
00:12:05 <ianweller> hmm i'm not sure what i need to say, other than taht school is eating me alive
00:12:14 * ianweller wasn't sure he had anything assigned for zikula right now
00:12:37 <itbegins> Sparks: You mean me?
00:12:39 <Sparks> ianweller: Opps..  sorry
00:12:46 <Sparks> itbegins: Yeah, I meant you.  sorry
00:12:49 <quaid> quaid: yep, zikula theme is all rolling for FI
00:12:55 * Sparks is not doing a good job of multitasking tonight
00:13:05 * quaid either
00:13:07 <itbegins> mizmo is in progress on the theme: http://publictest6.fedoraproject.org/zikula/
00:13:17 <itbegins> and Zikula is getting rolled out to staging
00:13:35 <quaid> and things are prepared in the repo (ideally) so she can have related Docs theme in there to make a Docs-specific RPM of the theme (AIUI)
00:13:44 <quaid> or I'm confused and it's all going to run from one instance, one theme
00:14:06 <itbegins> quaid: One filesystem instance, mutliple databases -> multiple themes
00:14:21 <quaid> I think I'm confused; that was my old idea, but Paul said we'll likely all be on the same instance
00:14:36 <itbegins> i.e turning on docs.fedoraproject.org Zikula is a case of installing a few new packages and updating the config file
00:14:50 <quaid> ok
00:15:34 <Sparks> Okay, we'll come back to Zikula in a little bit for a more indepth discussion.
00:15:45 <Sparks> quaid to follow up with Richard about the use of the CC logo on the wiki.
00:15:50 <Sparks> quaid: Got an update on this?
00:17:16 <danielsmw> ;/me sneaks in late...
00:17:26 <Sparks> quaid: hello?
00:18:48 <Sparks> Okay, quaid must have rushed off...
00:18:59 <Sparks> Any more old business?
00:19:06 <Sparks> #action quaid to follow up with Richard about the use of the CC logo on the wiki.
00:19:29 <Sparks> #topic Status on CMS (Zikula)
00:19:44 <Sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:19:58 <Sparks> itbegins: So what is the status on rolling out Zikula for docs.fp.o?
00:20:24 <itbegins> Sparks: well, we're still waiting on those modules held up with license problems I think
00:20:43 <itbegins> Sparks: but marketing have kindly packaged a couple of modules we can use for the docs instance too.
00:20:50 <itbegins> Sadly not the blockers for the docs instance
00:21:14 <Sparks> I think we both need at least one editor to go with Scribite.
00:21:28 * Sparks hasn't had any time to even look at packaging one of those.
00:21:37 <itbegins> yes,that's true
00:22:16 <quaid> Sparks: sorry, phone call
00:22:23 <quaid> do you want to hear about the CC logos?
00:22:53 <Sparks> quaid: That will be the next topic
00:23:02 <Sparks> itbegins: Okay so we are close but not there
00:23:17 <Sparks> itbegins: Does marketing have everything they need to roll out their instance?
00:24:21 <itbegins> apart from a visual editor, probably
00:24:24 <quaid> after a last minute scramble with chitlesh++, bobjensen++, toshio++ getting a few last minute packages done last night/today
00:24:26 <itbegins> though things may still come up
00:24:34 <quaid> oh! no visual editor? heh heh
00:25:24 <Sparks> So we need one of the editors packaged
00:25:32 <Sparks> anyone want to stand up to take that task?
00:26:52 * danielsmw can try if no body else will, but he's never successfully packaged anything...
00:27:25 <Sparks> danielsmw: Well, this would be a good time to start being successful...  there are templates for the SPEC and everything
00:27:25 <danielsmw> Also I haven't been involved in this process at all so far
00:27:40 <danielsmw> Sparks: Alright, well...
00:27:48 <danielsmw> I suppose I can give it a shot and report back next week.
00:28:19 <Sparks> danielsmw: I'm sure ianweller or someone will be around to help
00:28:35 <Sparks> #action danielsmw to package an editor for Scribite
00:28:46 <Sparks> Okay, anything else on Zikula?
00:29:04 * quaid notes Beacon was accepted for F10/F11
00:29:13 <quaid> but I guess it's not integrated?
00:29:18 <itbegins> danielsmw: Try pinging Toshio, he is involved with Zikula packaging
00:29:20 * danielsmw really likes beacon, btw.
00:29:22 <Sparks> quaid: And Beacon is the DocBook editor?
00:29:24 <danielsmw> itbegins: Will do
00:29:27 <quaid> Sparks: yep
00:29:45 <quaid> Sparks: well, it's a web wysiwyg editor that now has upstream code to read/write docbook :)
00:29:48 <Sparks> Yeah, we need to get that integrated
00:30:17 <quaid> satya has it running on a publictest instance, we can look at how to use it plain, too
00:30:22 * quaid is wandering topics now
00:31:02 <Sparks> Okay, let's move on.  Lots of work to be done on Zikula but things are starting to come together
00:31:14 <Sparks> #topic Status on CC license rollout.
00:31:22 <Sparks> quaid: So what's the skinny on the CC logos?
00:31:53 <quaid> ok
00:31:59 <quaid> I read and read that page
00:32:03 <quaid> http://www.redhat.com/archives/fedora-docs-list/2009-August/msg00075.html
00:32:16 <quaid> and it's clear that the ball is in Richard's court with folks from Creative Commons
00:32:36 <Sparks> And we haven't heard back from him on this, yet.
00:32:37 <quaid> it only having been a few weeks ... and he being a proactive and busy guy ... I think we have our clear answer for now
00:32:44 <quaid> and will hear when there is something more
00:33:10 <Sparks> ianweller: Do you have the text for the wiki?
00:33:28 <quaid> I would put this on the back-burner; don't forget about it, but revisit if a month goes by, then prod for a status.
00:33:44 <quaid> so ... a few more weeks at least, then see if we can kindly get a status. :)
00:33:54 <Sparks> Well, we can go ahead with the change over, use the text version of the license, and change later as necessary
00:33:58 * danielsmw has to go, sorry for the short visit.
00:33:59 <quaid> yes
00:34:02 <quaid> ciao danielsmw
00:34:06 <danielsmw> au revoir.
00:34:07 <Sparks> danielsmw: Have a good day!
00:34:11 <danielsmw> Sparks: Thanks!
00:34:41 <Sparks> #action ianweller to bring to the list the text for the CC license for the wiki so it can be approved
00:35:03 <Sparks> #link https://fedoraproject.org/wiki/License_changeover_schedule
00:35:17 <Sparks> ^^^  That is the timeline if anyone would like to take a peek at it.
00:35:56 <Sparks> I guess we are still waiting on the text being approved and then we can move on to step 4.
00:36:27 <Sparks> rudi: So what needs to happen to get the license changed in Publican for step 6?
00:37:19 <rudi> The people involved in doc publishing could do it at any time by hacking their Publican 0 installs
00:38:12 <Sparks> rudi: Yeah, but I want to push it to everyone.  That way there is 1) no confusion, 2) no differences, 3) and everyone does it.
00:38:44 <rudi> I think it's unlikely that any more changes are forthcoming to brand packages for 0
00:38:52 <rudi> since 1 handles brands so differently.
00:39:28 <rudi> (And we're not quite up to testing brands in 1)
00:40:02 <Sparks> Well, that's a problem.
00:40:17 <Sparks> If 1 isn't out then 0 still needs to be supported
00:40:19 <quaid> um, hmm
00:40:26 <rudi> Not really; there are very few people actually publishing
00:40:36 <quaid> is there any technical reason not to change brand pkg for 0?
00:40:49 <quaid> it's just text strings, right?
00:41:05 <rudi> and I'm quite happy to wrap those notices up in the package that I've got parked on my Fedora people page.
00:41:10 <rudi> quaid -- correct.
00:41:18 <rudi> No technical reason
00:41:22 <Sparks> Well if we get new people in we should be able to say "install publican" not "install publican and then do all these changes before you can use it"
00:41:29 <quaid> rudi: is CS waiting to rebuild RHEL guides with the new license until 1.x handles brands?
00:41:32 * ianweller notes his action item and makes a sticky note
00:41:39 <Sparks> ianweller: Thank you
00:41:56 <Sparks> rudi: Can you adopt the brand and just make the changes there?
00:42:04 <Sparks> rudi: Or one of us?
00:42:25 <rudi> Sparks - I can check into that.
00:42:28 <quaid> does publican need a co-maintainer for the package?
00:42:38 * Sparks thinks 1.x should be released as publican-devel
00:42:53 <quaid> -devel has a specific meaning, though
00:43:10 <quaid> or was that a joke!
00:43:23 <Sparks> rudi: I'm not saying anything bad about Jeff... I know he's busy and he has this new tool he's putting a lot of effort into.  But we still need the old tool to work for now.
00:43:25 <quaid> because if it was, very funny! just don't tell it to jfearn if you are on the same continent.
00:43:46 <Sparks> quaid: I thougth -devel was for the development version of a package... a beta
00:43:51 <quaid> nope
00:43:57 <ianweller> Sparks: -devel is development headers
00:44:00 <quaid> yep
00:44:03 <ianweller> in C, those would be the .h files
00:44:06 <rudi> Sparks -- yeah, but "work" for about three people :)
00:44:22 <quaid> Sparks: and Publican was originally proposed as 'docs-devel', with much arguing about why that wasn't OK and such
00:44:58 <quaid> rudi: sorry, where is the approv text for the license page? or proposed-and-under-review?
00:45:00 <Sparks> Well...  I don't know.  I'd like it to be in the repos...  :)
00:45:28 <quaid> rudi: it's not the people count, it's the F12 release
00:45:35 <quaid> we have a dependency on a workingn tool for the F12 release
00:45:43 <rudi> quaid -- proposed and review version is here : http://rlandmann.fedorapeople.org/license/
00:45:54 <quaid> we've had a rocky time for three releases with Publican feature status
00:46:06 <rudi> The source is in the Publican repo already
00:46:20 <quaid> and I thought with RHEL content upstream out here using Publican, it would work for Fedora :)
00:48:06 <quaid> Sparks: well, there is no moving backward for now, so if Publican upstream isn't going to issue an update we can use, we'll have to do manual process around it again.
00:48:47 * Sparks thinks hijacking the package is an option... :)
00:48:50 <Sparks> quaid: Yeah
00:48:52 <rudi> (Fedora *is* the Publican upstream)
00:49:13 <Sparks> Okay, anything else on the license changeover?
00:49:25 <quaid> what is the reason for not pushing the brand update?
00:51:30 * quaid wonders if he has bad breath?
00:51:49 <Sparks> rudi: ^^^
00:52:31 <quaid> sorry, I haven't been reading publican-list; you can tell me to read the archives, if that's it
00:52:39 <rudi> Basically that energies are elsewhere at the moment
00:53:09 <quaid> can we have a packager apply to be co-maintainer?
00:53:19 <quaid> we can get some help to do the work, if that's the block.
00:53:43 <rudi> I'll ask :)
00:53:47 <quaid> https://fedorahosted.org/publican/browser/branches/0.45/publican-fedora/en-US/Legal_Notice.xml is the old stuff
00:54:22 <quaid> sparks, stickster, ke4qqq, or ianweller would all be good choices
00:54:53 <rudi> Yes, because the new is here: https://fedorahosted.org/publican/browser/trunk/publican-fedora/en-US/Legal_Notice.xml
00:55:36 <quaid> what's the bz for this?
00:56:34 <rudi> For what?
00:57:12 <quaid> the bz for publican-fedora requesting the license update
00:57:42 <rudi> I don't know that there is one
00:57:44 <Sparks> Might not be
00:57:54 <quaid> heh, ok
00:58:05 <quaid> rudi: thanks, that XML was helpful; I'm building a book I want to be clearly under the CC
00:58:19 <rudi> NP
00:58:50 <quaid> rudi: and many thanks for working on the update of the content
00:58:51 <rudi> If it's your own book, you might want to include the CC logo too ;)
00:59:09 * quaid is doing a Red Hat branded book, so knows the answer to that already
00:59:10 <rudi> I know I would :)
00:59:14 <rudi> Ah OK :)
00:59:49 <Sparks> NO CC LOGO IN PRINT!!!  :)
01:00:33 <Sparks> Okay...  anything else on this topic?
01:01:04 <rudi> Action -- rudi to investigate getting a co-maintainer for 0
01:01:16 <quaid> #Action -- rudi to investigate getting a co-maintainer for 0
01:01:20 * quaid thinks he can do that?
01:01:49 <rudi> Let me test the waters first :)
01:02:30 <Sparks> Okay, lets move on to the last few topics so we can wrap things up for the day
01:02:39 <Sparks> #topic Guide needs?
01:02:48 <Sparks> Does anyone need anything for their guide?
01:03:14 <Sparks> #topic New Guides
01:03:22 <Sparks> How about new guides?  Any of them?
01:04:22 <Sparks> Okay, there is a new guide in the works...
01:05:12 <Sparks> there will be an Amateur Radio Guide coming out discussing the various pieces of software in Fedora for hams
01:05:24 <Sparks> Any others?
01:05:51 <Sparks> #topic All other business
01:06:01 * laubersm is available for proofreading
01:06:06 <Sparks> Okay, anything else for the meeting?
01:06:09 <laubersm> I have lots of little sturts of time
01:06:15 <laubersm> I have very little predictable time
01:06:29 <laubersm> But ping me and I am happy to review materials...
01:06:30 <Sparks> laubersm: Yeah...  understood
01:06:33 <Sparks> Thanks!
01:06:35 <laubersm> I know RN is coming up fast
01:06:47 <laubersm> and IG and UG for example
01:07:23 <rudi> Thanks laubersm -- I'll be needing you :)
01:07:33 <quaid> are the guides using Trac for one-task-per-chapter?
01:07:46 <quaid> there is a workflow we can impose there, with writer owning then passing to an open editor
01:07:51 <quaid> it's manual ...
01:08:36 <Sparks> Each chapter would be in its own file
01:08:53 <Sparks> The AR Guide will be in git
01:10:08 <Sparks> Anything else?
01:11:24 <Sparks> Okay, thanks everyone for coming tonight!
01:11:27 <Sparks> #endmeeting