00:03:02 <jjmcd> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:03:02 <zodbot_> Meeting started Thu Sep 10 00:03:02 2009 UTC.  The chair is jjmcd. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:03:02 <zodbot_> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:03:11 <jjmcd> two minutes - he's not gonna show
00:03:23 <jjmcd> #topic Roll Call
00:03:28 * danielsmw 
00:03:29 * jjmcd is here
00:03:31 * bcotton is here
00:03:34 * rudi is here
00:03:57 * jjmcd needs more windows to do this
00:04:07 <jjmcd> #topic Last week's action items
00:04:29 <jjmcd> danielsmw to package an editor for Scribite  - where are we?
00:04:46 <danielsmw> jjmcd: I surveyed what would work with scribite and what had what features and such
00:04:52 <danielsmw> And I've decided on TinyMCE
00:04:58 * perspectival is here
00:05:05 <danielsmw> the problem I've run into is the lack of guidelines on javascript library packaging
00:05:17 <danielsmw> And especially js built with ant
00:05:26 <danielsmw> (which I didn't actually know was possible, who knew).
00:05:48 <danielsmw> As a new packager, I don't think I can handle that sort of task by myself.
00:05:55 <danielsmw> It's not a time thing, just a knowledge thing.
00:06:07 <jjmcd> Well, somebody has to be able to help with js, but ant? You may be on your own
00:06:11 <danielsmw> So I can still do it, but I'd really appreciate if someone would be willing to sit down iwth me one day and do it.
00:06:28 <danielsmw> There are actually pretty okay ant guidelines under Packaging/Java
00:06:36 <danielsmw> It's the mixture of the two that I don't understand.
00:06:55 <jjmcd> Oh, OK.  What about whoever wrote those guidelines?
00:07:21 <danielsmw> I suppose I could ask them. The JS guidelines are still in draft, though. I'm not sure that there really even are guidelines, officially.
00:07:32 <danielsmw> Personally,  it doesn't make sense to package javascript libraries.
00:07:38 <jjmcd> Perhaps having the background of writing the guidelines they will have the perspective to be able to guide you
00:07:44 <danielsmw> But I don't understand the going ons of Zikula
00:07:46 <danielsmw> and such.
00:07:57 <danielsmw> That's probably at least a start, you're right.
00:08:08 <jjmcd> Well, Zikula isn't sooo different from other web apps
00:08:10 <danielsmw> Okay, then I'll do that this week and hopefully get somewhere by the weekend.
00:08:24 <jjmcd> OK, I'll try to be around to offer what little I can
00:08:30 <danielsmw> Thanks, jjmcd
00:08:32 <jjmcd> Maybe mostly moral support
00:08:36 <danielsmw> :-)
00:08:57 <jjmcd> The other items are Sparks, quaid and ianweller, none of whom are here
00:09:22 <jjmcd> ANything else on action items?
00:09:52 <jjmcd> #topic Release notes format changes
00:10:01 <jjmcd> OK, here I need some help
00:10:22 <danielsmw> I can offer moral support. :-)
00:10:25 <jjmcd> We talked about having all changes in tables, and only a little in the way of prose
00:10:48 <jjmcd> But there are a lot of apps that cross beats, and not all apps are covered by beats
00:11:11 <jjmcd> And oh yeah, Alpha was really lame, only about 20% of packages, so we don't really know what we have
00:11:30 <jjmcd> I am proposing to move the tables to the end, and organize them by rpm_group
00:11:50 <jjmcd> With an alphabetical index, people can find anything fairly easily
00:12:13 <jjmcd> Trouble is, it is big, but we don't really know for sure how big
00:12:31 <jjmcd> Any thoughts on that approach?
00:12:46 * danielsmw likes alphabetical indexes.
00:13:13 <danielsmw> Does it matter if it's too big, really?
00:13:18 <danielsmw> besides losing some style points?
00:13:42 <danielsmw> that might be a dumb question, I'm not familiar with RN so much
00:13:43 <jjmcd> I don't think so.  We don't add a lot to translate
00:13:48 <danielsmw> okay.
00:14:11 <rudi> The other intrinsic problem is that the rpm groups don't always make much sense
00:14:51 <jjmcd> rudi, you got that right, but if I turn my head sideways, I can generally see how someone could imagine they belong the way they are
00:14:57 <danielsmw> that's true. lots of things belong in more than one category in reality, so the groups are occasionally confusing.
00:15:01 <jjmcd> Which leads me to believe that no grouping is perfect
00:15:14 <rudi> Indeed
00:15:27 <jjmcd> Example tables/index in http://jjmcd.fedorapeople.org/Download/f12alpha
00:15:40 <danielsmw> Although grouping it my rpm may encourage packagers to more carefully consider the groups they use.
00:15:53 <jjmcd> I was kind of thinking that, too
00:16:11 <jjmcd> With the index you can find what you are looking for
00:16:13 <rudi> Yeah -- it will be good if we can somehow apply some pressure in that direction
00:16:14 <ryanlerch> and not create new groups
00:16:29 <ryanlerch> or sub groups
00:16:37 <jjmcd> Some are just stupid, like Applications/Games vs games
00:16:48 <jjmcd> Why do you need both, pick one or the other
00:17:02 <ryanlerch> from memory, the networking one was a bit crazy too
00:17:46 <jjmcd> The list on fedorapeople is against rawhide.  I expect F12 will be smaller than that, but we don't have a feel for how much smaller because alpha was so limited
00:18:23 <jjmcd> Yes, there are amateur radio apps in networking that have nothing to do with networking
00:19:02 <jjmcd> Also, there are some beats with a few minor changes, I think we need to drop them rather than adding fluff
00:20:15 <jjmcd> And I think we need to move embedded development out of development to the specialized group.  It really goes with FEL
00:20:34 <jjmcd> even tho it has the word development.  It doesn't fit with the rest
00:21:20 <jjmcd> rudi, are you pretty much there on installer?
00:21:41 <rudi> Well, I haven't got anything new :)
00:22:08 <jjmcd> I think I may have put some placeholders in there but not turned it into real prose
00:22:21 <rudi> I'll take another look
00:22:35 <jjmcd> I did go through the feature pages and tried to spatter stuff through the beats
00:23:13 <jjmcd> We were supposed to have the 'big' pots out yesterday
00:24:27 <jjmcd> So I intend to do what I can tomorrow and Saturday and then try to make pots saturday or sunday.  The beats are nowhere near where I'd like, but L10N is waiting on us
00:25:02 <rudi> I'll pitch in to help with that
00:25:11 <jjmcd> I appreciate that rudi
00:25:19 <jjmcd> I'll be out of town Friday
00:25:23 <rudi> NP
00:25:45 <jjmcd> But except for a few interruptions, I'll be around otherwise
00:26:07 <jjmcd> The good news is we don't have to do all that po madness from 11 so it should be a little easier
00:26:23 <jjmcd> although I should check with glezos on that
00:26:45 <rudi> Yeah -- check. I'm assuming that we *will* have to do the po madness
00:26:45 <jjmcd> #action jjmcd to check with glezos on po's
00:27:21 <jjmcd> OK, anything else on release notes?
00:28:06 <jjmcd> I'm surprised noriko didn't come over
00:28:30 <jjmcd> We have no ke4qqq for Zikula so ....
00:28:45 <jjmcd> #topic Status on CC license rollout
00:28:51 <jjmcd> ANything new to report?
00:29:47 <jjmcd> hearing nothing
00:29:58 <jjmcd> #topic Guide needs?
00:30:08 <danielsmw> I haz guide needs
00:30:19 <jjmcd> Ahhhh, whatcha got?
00:30:26 <rudi> I know -- I'm the blocker there
00:30:33 <danielsmw> rudi: :-)
00:30:39 <danielsmw> a little, rudi, but I can still write content
00:30:46 <rudi> Yeppa
00:31:04 <danielsmw> rudi: Did I send you an email about what sections I wanted to cover for F11?
00:31:10 <danielsmw> I think I wrote it and may not have sent it
00:31:18 <danielsmw> doesn't matter, anyway, the point is
00:31:29 <rudi> I saw a link in IRC
00:31:37 <danielsmw> okay, good
00:31:41 <rudi> But you were offline by the time I read it -- I bookmarked it
00:31:52 <danielsmw> do you still have the link by chance?
00:32:16 <danielsmw> never mind, I got it
00:32:19 <danielsmw> https://fedoraproject.org/wiki/User:Danielsmw/Desktop_Guide_tasks
00:32:41 <danielsmw> anyway, my proposal is just to work up through the first 5 chapters for F12 release.
00:32:48 <jjmcd> There is a lot of detail in the desktop beat that I wonder whether it belongs in the desktop guide
00:33:02 <danielsmw> jjmcd: I will take a look and see if perhaps it does
00:33:07 <jjmcd> thanks
00:33:28 <danielsmw> anyway, if anyone has any comment on what I've chosen to be ready for F12, now's your chance I suppose.
00:34:27 <danielsmw> Okay, well, I'll put something out to the list, but that's all I have to say.
00:35:03 <danielsmw> except, rudi: I really don't want to pressure you at all, because it isn't a big deal, but do you have an estimate on when you'll be ready?
00:35:09 <danielsmw> with the Xml skeleton?
00:35:30 <jjmcd> Looks to me like a good triage
00:35:32 <rudi> Still "RSN" -- next couple of days
00:35:39 <danielsmw> okay, that's fine.
00:35:42 <rudi> (although I know I said that two days ago!!) :)
00:35:47 <danielsmw> :)
00:36:00 * danielsmw is done with his guide needs.
00:36:14 <jjmcd> OK, anything else on guide?
00:36:31 <jjmcd> s/?/s?
00:36:42 <danielsmw> ??
00:37:09 <jjmcd> <---- old PDP guy
00:37:14 * bcotton needs to actually work on the RPM guide, but doesnt require any external assistance at the moment (except maybe a cattle prod)
00:37:37 <danielsmw> jjmcd: yeah, i always get confused when regexs aren't closed on the end
00:37:47 <jjmcd> hehe - I think we all have that "the hurrier I go the behinder I get" syndrome
00:38:10 <jjmcd> danielsmw, I'm pretty ancient, esp. as this business is concerned.
00:38:35 <jjmcd> By the way, today is Dennis Ritchie's birthday, seems to me there should have been a lot more press about it
00:38:57 <jjmcd> #topic All other business
00:39:08 <jjmcd> Anything else for the good of the order?
00:39:40 <rudi> Anyone else here able to sponsor new package maintainers?
00:39:40 <jjmcd> 5
00:39:45 <rudi> (I think ianweller can)
00:40:00 <danielsmw> I need one, I'll have to ask ianweller.
00:40:09 <jjmcd> lets all gang up on the missing ianweller
00:40:12 <rudi> lolz
00:40:43 <rudi> We need to get some new packagers sponsored who are going to look after Publican dependencies
00:41:03 <jjmcd> Yes, I need to get my badge as well
00:41:04 <rudi> That's a current blocker for Publican 1.0 and the new Fedora brand package for 0.44
00:41:43 <jjmcd> rudi, how can we find out about that sort of thing?
00:42:12 <rudi> I raise it in a meeting? :)
00:42:40 <jjmcd> Hey - I just got an email from mister K&R himself!
00:42:45 <jjmcd> I suspected as much
00:43:06 <jjmcd> It would be nice to be able to identify those things before they become painful
00:43:18 <rudi> It only *just* became a blocker
00:43:37 <jjmcd> K
00:43:40 <rudi> (within the last couple of days)
00:44:26 <rudi> But I didn't want to rush the sponsorship process either
00:44:33 <rudi> It's important that we do things right.
00:45:04 <rudi> But yeah, it's been a few days without any activity yet, so now I'm making noise :)
00:45:23 <jjmcd> Yes, I agree.  Seems like there are things we could predict, though.  After all, it isn't like we don't have computers and stuff.
00:45:58 <jjmcd> OK, anything else?
00:46:21 <jjmcd> 5
00:46:30 <jjmcd> 4
00:46:40 <jjmcd> 3
00:46:50 <jjmcd> 2
00:47:00 <jjmcd> 1
00:47:09 <jjmcd> #endmeeting