00:01:39 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:01:39 <zodbot> Meeting started Thu Oct  1 00:01:39 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:01:45 <Sparks> #topic Roll Call!
00:01:47 * Sparks 
00:02:04 * jjmcd est ici ou la
00:02:36 * ke4qqq is here - believe it or not
00:03:09 * rudi is here
00:03:15 * Sparks just updated the agenda... :)
00:03:18 * quaid esta aqui
00:04:39 * ianweller is here but not watching, mention me if a response is needed...
00:05:08 <Sparks> Okay, let's get started.
00:05:15 <Sparks> #topic Release notes format changes
00:05:22 <jjmcd> Couple things on RNs
00:05:31 <jjmcd> We are building every night for L10N
00:05:32 <Sparks> jjmcd: Remind me, again, what this is and do we need to keep it on the agenda
00:05:54 <jjmcd> Most mornings I have been posting  errors to trans list
00:06:15 <rudi> Props to jjmcd -- this is *excellent*
00:06:16 <jjmcd> I notice yesterday juhp and rudi had q1uite a chat about the tables
00:06:21 <jjmcd> as did I
00:06:47 <jjmcd> Result, really no changes.  juhp thought comps might be a better source than primary.sqlite, but it is very incomplete
00:07:00 <jjmcd> And now, Sparks, I think you can remove this from the list
00:07:08 <jjmcd> Thanks rudi, but purely selfish
00:07:19 <Sparks> jjmcd: This is awesome work!
00:07:22 <jjmcd> We get a lot of hard errors fixed by someone else
00:07:23 <Sparks> jjmcd++
00:07:33 <jjmcd> <<--- lazy
00:07:47 <rudi> It relocates the work where it really should be?
00:07:47 <jjmcd> If I can get someone else to do the work !!  ;-))
00:08:03 <rudi> :)
00:08:07 <jjmcd> ANd some of the translators are really digging in
00:08:13 <Sparks> So...  is the plan still to post everything to docs.fp.o and to provide a link in the HELP menu and not the document itself?
00:08:37 <jjmcd> I thought we were going to figure out the KDE alternative for yelp
00:08:48 <Sparks> I don't know
00:08:49 <jjmcd> or just do yelp
00:08:56 <jjmcd> I think that was the result
00:09:08 <Sparks> I know we had discussed a few different ways of doing it
00:09:23 <jjmcd> I did intend to go back through the logs -- yeah, we talked about a half-doze approaches
00:09:34 <jjmcd> but I had this nagging feeling I had to much with KDE
00:09:34 <Sparks> I'm concerned about the translations and the RPMs
00:09:48 <jjmcd> If we make the rpm like F11 no prob
00:10:14 <Sparks> one BIG one or multiple RPMs for different languages?
00:10:30 <jjmcd> one big one, like we always have, except not as many formats
00:10:40 <jjmcd> Soyou get your lang automatically
00:10:49 <Sparks> Okay
00:11:02 <jjmcd> Won't be a shock to anyone that way
00:11:07 <Sparks> yeah
00:11:21 <Sparks> okay, any other questions?
00:12:08 <Sparks> #topic Status on CMS (Zikula)
00:12:18 <Sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:12:23 <Sparks> Any update on this?
00:12:47 <ke4qqq> none to speak of
00:12:59 <ke4qqq> at least not from me
00:13:06 <Sparks> someone was working on packaging the editor we needed.
00:13:06 <ke4qqq> mchua|away: and gang are making progress
00:13:19 <quaid> danielsmw was working the editor iirc
00:13:55 <Sparks> ianweller: Were you going to review the editor package?
00:14:25 <ianweller> was i?
00:14:38 <ianweller> i don't really remember.
00:14:48 <Sparks> ianweller: I think danielsmw was supposed to get with you to work out the errors he was getting...
00:14:58 <ianweller> i never heard from him.
00:15:00 <Sparks> ...and possibly get you to review the package
00:15:01 <Sparks> Okay
00:15:29 <jjmcd> I think it was last week Friday that I expected danielsmw to ask for help, never saw him, but I thought ianweller was going to review
00:15:53 <ianweller> i'll happily help out when needed :)
00:15:54 <Sparks> okay
00:16:06 <Sparks> can one of you follow up with him this week, please?
00:16:32 <jjmcd> I'll keep an eye out for him, but haven't seen much lately
00:16:50 <Sparks> ke4qqq: Isn't danielsmw down there with you?
00:17:01 <ke4qqq> he recently started back to college and he's on the 3 year plan - so things are probably a tad busy
00:17:11 <Sparks> I would think so
00:17:11 <ke4qqq> I'll call him this week and see what's up
00:17:15 <Sparks> ke4qqq: Thanks
00:17:31 <Sparks> #action ke4qqq to follow up with danielsmw on the editor package for Zikula
00:17:39 <Sparks> Okay, anything else on this topic?
00:18:32 <Sparks> #topic Status on CC license rollout.
00:18:40 <Sparks> #link https://fedoraproject.org/wiki/License_changeover_schedule
00:19:29 <Sparks> ianweller: Are we ready to make the internal announcement?
00:20:00 <Sparks> quaid: Have you done the follow up with the RPM guide?
00:20:39 <quaid> hrm
00:20:47 <quaid> ok, here's the two bits.
00:21:09 <quaid> 1. I need to contact Eric Foster-Johnson about relicensing RPM Guide .. he didn't do a CLA, for example.
00:21:44 <Sparks> quaid: Where is the RPM Guide?  I don't remember what that is, exactly.
00:21:48 <quaid> 2. We have some issues to work through still with the Max RPM content; there is a contributor who doesn't want to have their content relicensed nor have attribution.
00:21:57 <quaid> we have it in cvs or git or something
00:22:24 <Sparks> We were going to add more development and include the Max RPM content?
00:22:38 <quaid> yeah, the idea was to have both to meld in to one, new, shiny RPM Guide.
00:22:55 <Sparks> What are the current licenses?
00:23:31 <ianweller> Sparks: hi
00:23:42 <ianweller> sorry
00:23:55 <quaid> OPL clean for RPM Guide, OPL + non-free clauses for Max RPM
00:24:11 <Sparks> Well that's a problem.
00:24:32 <quaid> not if they are relicensed to the same CC BY SA :)
00:24:45 <ianweller> someone (Sparks) tell me if we're ready and i will make the announcement on docs-list devel-announce advisory-board etc
00:25:03 <Sparks> quaid: Yeah...  IF
00:25:30 <Sparks> Okay...  so here's the deal.  I want the license change over done within the next two weeks.  Is that feasible?
00:26:01 <Sparks> We can change the license and then reject the RPM guides if they don't want to play ball, imo.
00:26:16 <Sparks> rudi: Can you have publican updated within a week or two?
00:26:18 <quaid> oh, yeah
00:26:20 <ianweller> do we have to relicense them?
00:26:26 <quaid> RPM stuff is totally non-critical path
00:26:32 <rudi> Yep -- I'm just waiting for someone to pull the trigger
00:26:42 <quaid> move ahead with relicensing without worrying about RPM content
00:26:50 <Sparks> Okay.
00:27:02 <ianweller> #action ianweller to figure out how to change the license on the wiki
00:27:03 <ianweller> :)
00:27:05 <Sparks> ianweller: Go ahead and put the word out internally
00:27:05 <quaid> that was all a courtesy/interest; that's RPM.org stuff, people here just said, "I'd like to help," so I took on that relicensing too :)
00:27:12 <ianweller> Sparks: ok
00:27:34 <ianweller> will do that in a couple of hours
00:27:38 <Sparks> This license change will NOT affect stuff in git... etc.
00:27:42 <Sparks> ianweller: Thanks
00:27:47 <ianweller> Sparks: is that on the announcement draft?
00:27:49 <ianweller> let's go over that.
00:27:54 <ianweller> cuz that's what i'm gonna copy/paste.
00:28:02 <Sparks> The license change will affect stuff on the wiki and stuff we publish
00:28:05 <ianweller> that requires i find it
00:28:22 <Sparks> ianweller: Doh!  I didn't link to it anywhere!
00:28:49 <Sparks> #action rudi to change the license information in the publican brands for Fedora
00:29:11 <rudi> Sparks -- so is that a green light now?
00:29:20 * ianweller hunts in his email box
00:29:24 <Sparks> rudi: Yes
00:29:27 <rudi> OK
00:29:40 <ianweller> https://fedoraproject.org/wiki/User:Ianweller/Creative_Commons_press_release -- the bottom one.
00:29:47 <ianweller> let's discuss that.
00:30:02 <Sparks> rudi: I'm going to shoot a message to the list to make sure that all guide owners are aware of the upcoming change.  Just reply to that when you get it all straight, please.
00:30:13 <rudi> Will do
00:31:25 <Sparks> ianweller: Looks good.  Should we make a wiki page that says why we are doing this and maybe some FAQs and post that link in that announcement?
00:31:38 <ianweller> Sparks: that would be pretty awesome.
00:31:52 <ianweller> i'm working on an english project right now so if somebody could do that tonight i will buy them a drink
00:32:10 <Sparks> Of course we'd need some folks to ask questions so we'd know what is a FAQ
00:32:19 <ianweller> "what's CC"
00:32:25 <ianweller> "why is the OPL bad"
00:32:30 <ianweller> "why is CC better"
00:32:30 <Sparks> "why is it better than OPL"
00:32:32 <ianweller> "what's the scope of this change"
00:32:38 <quaid> uh, did't I write all that?
00:32:45 <ianweller> you did yeah.
00:32:52 <quaid> but not as a FAQ!
00:32:53 <ianweller> i think.
00:32:53 <Sparks> quaid: Where?
00:32:59 <ianweller> Sparks: on the announcement
00:33:03 <quaid> FAQe (pronounced "fake")
00:33:06 <quaid> one sec
00:33:07 <ianweller> lole
00:33:24 <Sparks> quaid: Yeah, you did.
00:33:26 <quaid> http://fedoraproject.org/wiki/Relicensing_OPL_to_CC_BY_SA
00:33:29 <quaid> #link http://fedoraproject.org/wiki/Relicensing_OPL_to_CC_BY_SA
00:33:32 <ianweller> well HEY
00:33:48 <quaid> some of those links don't look right ...
00:33:53 <quaid> maybe I left stubs for more?
00:33:57 <ianweller> whoa.
00:34:04 <Sparks> Ummm
00:34:17 <Sparks> I don't think we are relicensing Fedora Hosted... are we?
00:34:24 <quaid> no, see
00:34:24 <quaid> stubs
00:34:25 <Sparks> I could see some potential problems.
00:34:28 <Sparks> Oh
00:34:29 <quaid> for all of the guides we have there
00:34:38 <quaid> just fill in whatever
00:34:54 <ianweller> but yeah i still need somebody awesome to turn that page into an FAQ perhaps
00:34:58 <quaid> yeah, last history is 'interim save' meaning I never got it to deserving a full comment block
00:35:11 <ianweller> quaid: hah
00:35:14 <Sparks> quaid: Can I use your blog text on the page?
00:35:57 <quaid> Sparks: natch!
00:36:14 <quaid> I hereby license it under CC BY SA, with attribution being a link back to the original post
00:36:43 * quaid dual licenses it under OPL for the time being
00:36:50 <quaid> so it can be put on the page until he license change :D
00:36:56 <quaid> isn't copyright fun!
00:37:04 <Sparks> quaid: I'm going to need that in writing, please.  :)
00:37:18 <ianweller> that isn't writing? ;)
00:37:59 <Sparks> I need a paper
00:38:20 <Sparks> On advice from my attorney-in-training...
00:38:25 <quaid> nope, IRC log is good enough
00:38:31 <quaid> on advice from my monkey council
00:38:46 <Sparks> :)
00:39:10 * Sparks really didn't ask her as she's currently writing a motion for her case and I'd hate to become a part of that case
00:39:40 * ianweller makes a motion
00:39:43 * ianweller dances on the floor
00:39:56 <ianweller> quaid: ok so i'm volunteering you to faqize that faqe
00:40:25 <quaid> ha
00:40:29 <quaid> good luck with that
00:40:36 <ianweller> ;)
00:40:46 <quaid> hey, you know what would help here?
00:40:51 <ianweller> a drink?
00:40:54 <quaid> can we get a quick list of the guides in f'hosted?
00:40:56 <quaid> yeh, that too
00:41:00 <quaid> that we want to switch?
00:42:00 * quaid edits the page to put them in
00:42:08 <Sparks> Okay, I just pasted that into the wiki page but it's ugly... I'll be fixing that later.
00:42:12 <quaid> um, if it's done for now?
00:42:13 <quaid> ok
00:42:26 * quaid is adding in the fhosted list so will fix some formatting now
00:42:49 <Sparks> quaid: Do we want to selectively list the guides we are relicensing or just say "all guides"?
00:44:02 <quaid> hmm
00:44:13 <quaid> I have it as a task to email *all* contributors, past and present
00:44:14 <quaid> as a courtesy
00:44:21 <quaid> so it would help if we had a definitive list
00:44:24 <quaid> I think ...
00:44:53 <Sparks> Is that even possible?
00:45:17 <quaid> theoretically
00:45:29 <quaid> I could get a good list of names with a few hours in cvs and f'hosted
00:45:44 <Sparks> I know the security guide has been in so many different formats and changed/modified that I don't know what kind of paper trail is even left.
00:45:48 <quaid> it's a courtesy move; if we cannot reach people, it's not a game stopper.
00:45:54 <quaid> ah
00:46:00 <quaid> yeah, well, I mayn't look for wiki stuff
00:46:01 <Sparks> the SG came from the wiki...
00:46:04 <quaid> just thinking Install guide, etc.
00:46:08 <quaid> yeah, I get that
00:46:11 <Sparks> and I mean MOIN wiki
00:46:16 <quaid> heh
00:46:23 * quaid can get his hands on that stuff, too
00:46:30 <quaid> ok ...
00:46:40 <quaid> well, it might be futile; and it's NOT on the critical path.
00:46:44 <Sparks> Not trying to discourage...  :)
00:46:47 <quaid> ok, back to the question at hand ...
00:46:49 <quaid> I have:
00:46:52 <quaid> Wiki
00:46:56 <quaid> Installation guide
00:46:59 <quaid> Release notes
00:47:04 <quaid> Security guide
00:47:07 <quaid> SELiux guide
00:47:11 <quaid> adding ...
00:47:14 <quaid> Deployment guide
00:47:56 <quaid> else?
00:48:04 <Sparks> Assessibility Guide
00:48:18 <quaid> is that fhosted.org/accessibility-guide?
00:48:48 <Sparks> I think so... I just put it there a few months ago.  It used to be in the RN up to F9 or F10
00:49:19 <quaid> /me looking for 'guide' on fh.o
00:49:30 <Sparks> That's a good start.  :)
00:50:56 <Sparks> quaid: You should see one in there for an Amateur Radio Guide but there's nothing there, yet, and should be jjmcd and I working on that so no worries there.
00:51:21 <quaid> http://svn.fedoraproject.org/svn/Deployment_Guide/ ?
00:51:37 <Sparks> What's the question?
00:51:48 <quaid> http://fedorahosted.org/deploymentguide
00:52:00 <quaid> it's weird for both to appear, first seems empty; old?
00:52:10 <rudi> New!
00:52:16 <quaid> ah, or that
00:52:27 <rudi> perspectival is working on that one
00:52:32 <rudi> Doesn't seem to be here right now
00:53:51 <Sparks> any others?
00:54:21 <rudi> Add Virtualization Guide
00:54:36 <quaid> yeah
00:54:41 <quaid> I'm rolling down the page
00:54:45 <quaid> about-fedora etc.
00:55:04 <quaid> what is http://git.fedoraproject.org/git/redhatsecurityguide.git
00:55:05 <quaid> v.
00:55:14 <quaid> https://fedorahosted.org/securityguide/
00:55:33 <Sparks> Don't know what the first one is... the second one should be the "fedora" sg
00:55:47 * quaid wishes we had all stuck with the "- is the space designator" for hosted project guide names
00:56:05 <quaid> some with, some without, and now a bunch of New_Style
00:56:09 <jjmcd> Publican works better with _
00:56:47 * quaid rolls his eyes and bites his tongue
00:56:57 <jjmcd> Yeah, well, I agree
00:57:00 <quaid> probably not worth changing the other names
00:57:17 * quaid *cough* you know, from the names similar to Fedora Packaging Standards
00:57:34 <quaid> ok, we don't have to kill the mtg with this
00:57:41 <quaid> I'll publish the updated page in a few.
00:57:48 <Sparks> Okay
00:57:53 <Sparks> anything else on this topic?
00:58:08 <quaid> #link https://fedorahosted.org/rpmguide/
00:58:13 <quaid> for the record
00:58:49 <Sparks> Okay...  lets cut down to the meat and potatoes...
00:58:55 <Sparks> #topic Guide needs?
00:59:01 * ianweller has to run
00:59:02 <Sparks> Any guides have any needs?
00:59:27 <Sparks> ianweller: See ya
00:59:33 <jjmcd> Sparks - use same image conventions as user guide?
00:59:42 <jjmcd> i.e. images/chapter
00:59:51 <Sparks> sure
01:00:52 <Sparks> #topic New Guides
01:00:56 <Sparks> Any new guides?
01:01:31 <Sparks> #topic All other business
01:01:39 <Sparks> Any other items that need to be discussed?
01:02:16 <Sparks> 5
01:02:20 <Sparks> 4
01:02:23 <Sparks> 3
01:02:25 <Sparks> 2
01:02:28 <Sparks> 1
01:02:35 <Sparks> Okay, thanks everyone for coming!
01:02:38 <Sparks> #endmeeting