15:00:19 <rjune__> #startmeeting
15:00:19 <zodbot> Meeting started Tue Oct  6 15:00:19 2009 UTC.  The chair is rjune__. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:30 <rjune__> #chair adamw tk009
15:00:30 <zodbot> Current chairs: adamw rjune__ tk009
15:00:40 <rjune__> #topic Opening
15:01:08 <rjune__> Good [morning | afternoon | evening ] welcome to the Oct 6 edition of Fedora's bugzapper meeting
15:01:19 <rjune__> /me if you're here please
15:01:21 * thomasj whistles
15:01:25 * arxs is here
15:01:28 * jeff_hann is here
15:01:30 * waltJ is here.
15:01:30 <adamw> morning
15:01:31 * Tech33 is here
15:01:43 <adamw> nice turnout :) welcome new members!
15:02:25 <rjune__> tk009 is unable to be here today.
15:02:44 <rjune__> #topic Improving Triage Day
15:02:46 * gtirloni here
15:03:11 <adamw> i believe that was tk009's topic, right?
15:03:18 <rjune__> tk009 wanted to talk about this, he had some ideas. he was unable to be here today
15:03:18 <jeff_hann> yes
15:03:25 <adamw> has anyone else had any brain waves in the mean time? :)
15:03:49 <cebbert> here too
15:03:56 <adamw> hi chuck
15:05:11 <adamw> i guess we'll punt the topic to next week then
15:05:14 <rjune__> yup.
15:05:20 <rjune__> #topic kernel triage update.
15:06:05 <rjune__> This one is me. I did a general search on kernel bugs, and I think I've found a few where I can be useful, I need to send and email off to linville and verify the information needed, but at least it's something
15:06:23 <adamw> still seems like a lot of effort for little return...
15:06:30 <adamw> i'm not sure we're justifying the full project yet
15:06:38 <rjune__> I have some free time, so I'm good with it.
15:06:52 <adamw> sure, just looking at the wider context of the whole kernel triage project
15:07:04 <rjune__> plus if I can simply correct a couple of the minor things and send in patches, then all the better.
15:07:40 <adamw> yup
15:07:54 <adamw> well thanks for the update
15:07:57 <rjune__> so please, let me actually attempt to do something before scrapping the notion. eh?
15:08:07 * mcepl is here
15:08:08 <adamw> oh i'm not
15:08:11 <adamw> hi mcepl
15:09:34 <rjune__> Is Johann here?
15:09:47 <adamw> for the benefit of newer guys - rjune is scoping out kernel triage for us
15:09:53 <adamw> we haven't been triaging kernel bugs for a while
15:09:58 <adamw> but we thought about starting again
15:10:07 <adamw> rjune is scouting out the territory before we jump in :)
15:10:16 <jeff_hann> adamw: I want to help on that
15:10:27 <adamw> rjune__: can you arrange that with jeff?
15:10:32 <rjune__> I can try.
15:10:43 <adamw> cool
15:10:44 <rjune__> I've not been terribly useful so far, but I'm happy to try as best I can.
15:10:57 <adamw> #action rjune and jeff_hann to co-ordinate on kernel triage
15:11:00 <jeff_hann> me too
15:11:11 <rjune__> jeff_hann: lets swap email after meeting, k
15:11:19 <jeff_hann> ok
15:11:51 <rjune__> #topic standardize bug information pages
15:12:00 <rjune__> Johann wanted to talk about standardizing the wiki  pages a bit.
15:12:14 <rjune__> adamw: I'm guessing you have some clue as to what's going on here, yes?
15:12:19 <jeff_hann> rjune__: not sure I can attend the whole meeting, better swap emails sooner
15:12:30 <adamw> well, you were CCed on all the emails, that's the thing in a nutshell
15:12:55 <jeff_hann> adamw: got that
15:13:15 <adamw> again for benefit of new members - johann gudmundsson on the lists is viking_ice on IRC, we had a list discussion about the wiki pages intended to help with debugging / providing sufficient information in bug reports for specific components
15:13:48 <adamw> the pages can be found linked from https://fedoraproject.org/wiki/BugsAndFeatureRequests#Tips_by_Type_of_Bug
15:14:22 <adamw> waiting for split to settle...
15:14:43 <rjune__> Man, somebody should do something about those netsplits. they suck in the middle of a meeting
15:14:50 <cebbert> that was fun
15:15:03 <cebbert> it was a planned restart of some ircds
15:15:04 <adamw> rjune__: is that the classic case where 'somebody' means 'somebody else'? :)
15:15:34 <rjune__> I have no control over irc servers. ergo, I can only complain about it
15:15:38 <adamw> alright, so, yeah, bug info pages are linked from https://fedoraproject.org/wiki/BugsAndFeatureRequests#Tips_by_Type_of_Bug
15:16:39 <adamw> johann's idea, i believe - once trimmed down from its typical johann-y Let's Build A Cyber-Pony over-ambitiousness :) - is to have a standard style for the pages, perhaps a standard template, and to try to write them consistently in a way that will be understandable by those with limited experience
15:17:03 * Sir_Limpsalot joined
15:17:09 <rjune__> a finer summation I have yet to hear.
15:17:19 <adamw> i think that's probably a sensible idea, and we could develop a template from one of the existing pages in a collaborative way as we've done for other pages
15:17:25 <adamw> Sir_Limpsalot: hiya
15:17:32 <rjune__> so we need somebody familiar enough with the wiki to help build the template or templates.
15:17:54 <rjune__> and convert a demo pages so that others have a reference point.
15:17:54 <adamw> probably me, johann or chris beland, i guess
15:18:00 <adamw> ...sigh
15:18:06 <rjune__> adamw: http://wiki.imagestream.com
15:18:08 <adamw> anyone have any input / ideas on the topic?
15:18:40 * Sir_Limpsalot plays catchup
15:18:56 <rjune__> Templates are a fantastic idea, can you link a couple of pages to be standardized
15:19:37 <rjune__> that way there's no mistaking what we're looking at / talking about.
15:19:38 <adamw> rjune__: well, most of the pages i wrote already use a consistent layout, but the others tend to be different
15:19:56 <adamw> rjune__: compare https://fedoraproject.org/wiki/How_to_debug_Dracut_problems and https://fedoraproject.org/wiki/How_to_debug_OpenOffice_problems for e.g.
15:20:08 <rjune__> new guys( and myself ) need examples.
15:20:23 <adamw> or, more extremely, https://fedoraproject.org/wiki/Anaconda/BugReporting
15:20:34 <rjune__> Also, I would suggest using categories to our advantage.
15:20:36 <adamw> which pre-dates most of the other pages and was built as part of a different process so looks pretty different
15:20:39 <Sir_Limpsalot> I'm formally known as viking_ice btw until my toe heals ( broke it on practice hence sir limpsalot )
15:20:45 <jeff_hann> sorry guys, gotta run
15:20:47 <rjune__> nevermind.
15:20:51 <adamw> Sir_Limpsalot: ahah, that's where you're hiding :)
15:20:56 <adamw> cya jeff, thanks for showing!
15:21:04 <rjune__> Sir_Limpsalot: we were just talking about you
15:21:07 <jeff_hann> talk later; take care :)
15:21:11 <rjune__> jeff_hann: happy to have the help
15:21:19 * adamw was saying nasty things about you behind your back :)
15:21:24 <jeff_hann> rjune__: happy to help
15:21:32 <rjune__> Sir_Limpsalot: and I was talking about your butt
15:21:34 <adamw> rjune__: the pages are all in the 'debugging' category already i believe
15:21:43 <rjune__> ok, so yeah, I see the differences, and yes, I missed the category
15:22:09 <adamw> there is a problem here in that we're sort of co-opting pages that may be actively maintained by other groups or by the component maintainers or whatever
15:22:24 <rjune__> well, we ask nice and there probably won't be a problem.
15:22:36 <adamw> so where that's the case we'll have to try and talk to them and see if they're happy to have them reformatted or we come up with a middle ground or something
15:22:38 <rjune__> aka, don't go off half cocked and change a bunch of stuff without saying anything
15:22:42 <adamw> just wanted to note it down
15:22:43 <adamw> yup
15:23:30 <rjune__> adamw: which of those two pages should be closer to canon?
15:24:09 <adamw> rjune__: openoffice and dracut pages are more likely to be close to what we end up with, or at least the direction bugzappers members have been going in so far
15:24:20 <adamw> but i don't want to pre-empt the process :)
15:26:06 <rjune__> ok.
15:26:23 <rjune__> that's what I wanted to find out.
15:26:24 <adamw> anyone have any suggestions here / want to get involved with writing these pages or the standardizing or anything?
15:27:34 <Sir_Limpsalot> I think we can settle on something like https://fedoraproject.org/wiki/How_to_debug_Dracut_problems
15:28:15 <Sir_Limpsalot> template wize
15:28:28 <adamw> surprisingly, i'd think we could settle on something like the openoffice page ;)_
15:28:38 <adamw> (look at the history pages to get the joke)
15:29:14 <rjune__> #action create a base template for how to debug pages.
15:29:19 <adamw> right
15:29:28 <adamw> we can move forward on the list, anyway, sinc everyone seems to agree with the idea
15:29:59 <rjune__> yeah, that leaves us with...
15:30:05 <rjune__> #topic open floor
15:30:20 <rjune__> Give me your gripes, complaints, kudos, and anything else you want to share.
15:31:20 <rjune__> Bueller?
15:31:58 <adamw> or is everyone super-happy? :)
15:32:32 <Sir_Limpsalot> So the template would have "Identifying your problem area" "Information to include in your report" and "Debugging <component>"
15:33:09 <Tech33> not super, just happy ... (wanted to let you know you're not alone)
15:33:15 <rjune__> Sir_Limpsalot: yes.
15:33:21 <rjune__> Sir_Limpsalot: will you be doing that action?
15:33:40 <Sir_Limpsalot> I can take an action item
15:33:52 <Sir_Limpsalot> :)
15:33:52 <rjune__> it was the creating a template.
15:33:53 <adamw> we've got an action item already
15:34:05 <rjune__> I was going to do it if nobody else did. but I wasn't about to own up to it publicly
15:34:19 <mcepl> or super-overloaded so we have head so much under water that we don't have even complains ;)
15:34:23 <adamw> it doesn't necessarily have to be an actual mediawiki template, an example page could work too...not sure which would be better.
15:34:34 <adamw> mcepl: that works for me!
15:34:36 <rjune__> I'm going on mediawiki template.
15:34:52 <rjune__> if we do that right, we can change the format if we need to.
15:35:07 <adamw> yeah.
15:35:10 <Sir_Limpsalot> well we have to do right from the start
15:35:23 * mcepl makes an action item for him to make Firefox/Thunderbird/other-Gecko-stuff page
15:35:46 <Sir_Limpsalot> or else change ever component debug page to the new template improve template
15:35:55 <rjune__> right.
15:36:07 <rjune__> so we do the template setup right from the get go. and we have less problems in the future.
15:36:33 <Sir_Limpsalot> yup..
15:36:52 <rjune__> glad to see that great minds think alike.
15:37:07 <adamw> mcepl: there already is one - https://fedoraproject.org/wiki/Bug_info_Firefox
15:37:33 <adamw> mcepl: could definitely do with some expanding
15:37:42 <mcepl> adamw: OK, that needs a lot of love (and it is obviously not in any template)
15:38:01 <adamw> yay collaboration!
15:38:24 <adamw> ok, so we can count on sir_limpsalot to come up with a template and maybe convert one page to use it as an example? (both in draft for now)
15:39:18 <Sir_Limpsalot> moving on from there should we start creating how_to_debug critical path components then head to the wast of other components ?
15:39:47 <adamw> that sounds like a reasonable priority for a single person creating pages for multiple components
15:39:54 <adamw> but at the same time we should take what we can get :)
15:40:03 <Sir_Limpsalot> ofcourse
15:42:30 <adamw> well i guess we're sorta done then...
15:43:05 <adamw> if any of our new members would like some help getting started with triaging, some of us will be around in #fedora-bugzappers after the meeting, please shout out
15:43:20 <Sir_Limpsalot> ok so you can continue to talk behind my back..
15:43:25 <Sir_Limpsalot> :)
15:43:58 <adamw> yup! ;)
15:44:14 <adamw> i hear sir_limpsalot has cooties
15:44:17 <adamw> he caught it from his cyber-pony
15:45:43 <rjune__> #endmeeting