00:01:03 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:01:03 <zodbot> Meeting started Thu Oct  8 00:01:03 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:01:09 <Sparks> #topic Roll Call
00:01:11 * Sparks 
00:01:23 * jjmcd is here
00:01:44 * bcotton is here (who is this guy anyway)
00:01:54 <jjmcd> And according to my watch, you were within a couple seconds, probably IRC lag
00:02:04 * danielsmw is here
00:02:27 * Sparks wants to shoot the guy who schedules a meeting in the middle of an amateur radio contest!
00:02:48 <jjmcd> There's always a contest
00:02:50 <ianweller> i wonder who that was
00:02:56 <Sparks> :)
00:03:10 <Sparks> 70cm is dead anyway
00:04:40 <Sparks> Okay, let's get started...
00:04:46 <Sparks> #topic Old Business
00:05:10 <Sparks> danielsmw: What the status on the editor for Zikula?
00:05:37 <danielsmw> Sparks: i've been working on it for the past hour
00:05:42 <Sparks> :)
00:05:45 <danielsmw> Sparks: rpmlint comes out clean now
00:05:53 <Sparks> danielsmw: Very cool!
00:05:55 <danielsmw> so I think i may go ahead and put it on bugzilla
00:06:25 <danielsmw> Yup.
00:06:30 <Sparks> Excellent.
00:06:48 <Sparks> Let us know if you need any support.
00:06:55 <Sparks> Thanks for packaging it!
00:07:01 <danielsmw> Sparks: Will do. I probably will later this evening
00:07:04 <danielsmw> No problem1
00:07:54 <Sparks> rudi: I see you changed the license info on the Fedora brand package for Publican
00:08:14 <rudi> Yep -- all done
00:08:41 <Sparks> rudi: Excellent
00:08:42 <jjmcd> rudi, does that also include the additional localization?
00:08:51 <rudi> jjmcd -- kinda
00:08:57 <Sparks> ianweller: Did you figure out how to change the license on the wiki?
00:09:02 <rudi> It includes the feedback file
00:09:08 <ianweller> Sparks: it's in localsettings.php
00:09:10 <ianweller> which is in puppet
00:09:17 <Sparks> ianweller: So you are good to go?
00:09:19 <rudi> But "Document Conventions" is part of the publican package
00:09:26 <rudi> not the Fedora brand package.
00:09:35 <ianweller> Sparks: sure i'll work on a patch sometime tonight and test it somewhere
00:09:37 <jjmcd> That seems odd
00:10:08 <rudi> (I also missed 4 languages in the package I released the other day, there's a corrected package in Bodhi now that should appear soon to fix that)
00:10:36 <jjmcd> All the langs except Chinese are now building
00:10:48 <rudi> Well, since "Document Conventions" documents how Publican renders various XML tags, this doesn't tend to change from brand to brand.
00:12:03 <rudi> If someone came up with a very heavily customized brand that *did* change how those tags were rendered, they could also create a new "Document Conventions" text to ship with that package
00:12:42 <rudi> Which would override the one in Common_Content/common
00:13:11 <rudi> Anyway, I'll see if I can package the extra "Document Conventions" translations into a new release of Publican 0.44 for us
00:13:33 <jjmcd> good deal
00:14:52 <Sparks> Okay...
00:15:01 <Sparks> #topic Status on CMS (Zikula)
00:15:15 <Sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:15:21 <Sparks> Can anyone provide an update?
00:16:36 <Sparks> Well, I know danielsmw will be submitting the editor for Zikula for review tonight.
00:16:44 <danielsmw> Yup.
00:17:13 <Sparks> Anyone else have an update?
00:17:36 <Sparks> Okay, moving on
00:17:42 <Sparks> #topic Status on CC license rollout.
00:17:50 <Sparks> *  #link https://fedoraproject.org/wiki/License_changeover_schedule
00:17:54 <Sparks> #link https://fedoraproject.org/wiki/License_changeover_schedule
00:18:19 <jjmcd> kudos to ianweller  for his announcement and notoriety
00:18:20 <Sparks> I think ianweller sent out the announcement on Monday.
00:18:29 <Sparks> ianweller: Have you received any feedback?
00:18:34 <ianweller> no
00:18:36 <jjmcd> Sparks, showed up in LWN
00:18:41 <Sparks> Cool
00:18:55 <ianweller> i am looking into the wiki crap at the moment if anybody's wondering
00:19:23 <jjmcd> Just reach into your bucket of magic pixie dust
00:19:31 <Sparks> I think quaid was working on contacting previous contributors
00:20:27 <Sparks> ianweller: do you have a link for that LWN article?
00:20:45 * ianweller looksies
00:21:02 <Sparks> I think the big thing is going to be #7... Make changes to the guides. Rebuild all current versions and push them to docs.fp.o and repos. (All)
00:21:04 <ianweller> http://lwn.net/Articles/355546/
00:21:15 <ianweller> they just copy/pasted my emai
00:21:17 <ianweller> email*
00:21:22 <Sparks> That means that all guides will need to be updated ASAP.
00:21:47 <Sparks> ianweller++
00:22:24 <Sparks> This will be coming up in the near future.
00:23:02 <rudi> I feel a world of CVS hurt a-comin :)
00:23:02 <Sparks> #action Sparks to send to the list an action request to all guide leaders for update status of the license
00:23:09 <Sparks> rudi: Yeah
00:23:17 * danielsmw is afk for a bit
00:23:35 <Sparks> Okay, anything else on this topic?
00:23:54 <rudi> Are we just republishing F11 docs?
00:23:59 <rudi> Or further back too?
00:24:31 <Sparks> rudi: I think just F11.
00:24:36 <rudi> +1 !!!!!!
00:24:44 <Sparks> F10 will be EOL soon anyway.
00:24:54 <Sparks> rudi: Unless you want to go back to the FC days.  :)
00:25:14 <rudi> Uh....
00:25:20 <rudi> NO
00:25:23 <rudi> :)
00:25:28 <Sparks> IMO if people are going to want to use some of our information they would probably want to get it from the latest source and not an old guide.
00:25:52 * Sparks thinks ianweller got off easy during this ordeal
00:26:07 <Sparks> Okay, moving on.
00:26:13 <Sparks> #topic Shared open-source style guide
00:26:21 <Sparks> #link https://www.redhat.com/archives/fedora-docs-list/2009-June/msg00163.html
00:26:28 <Sparks> Does anyone have an update on this?
00:26:58 <Sparks> Going...
00:27:01 <Sparks> going...
00:27:07 <Sparks> gone.
00:27:09 <rudi> Still blocked by the NotEnoughHoursInTheDay bug
00:27:17 <Sparks> rudi: Understood.
00:27:26 <rudi> Expect some traction after I finish on the Publican 1.0 User Guide :)
00:27:36 <Sparks> rudi: You might want to shoot ke4qqq an email on this as I think he wanted to work on it but probably has the same bug.
00:27:38 <rudi> (RSN)
00:27:52 <Sparks> #topic Guide needs?
00:27:58 * ianweller hsa to run
00:28:01 <Sparks> Okay, anyone have any guides that are in need?
00:28:10 <rudi> Sure -- my blocker is getting the content together that legal has agreed to release to the wider community
00:28:10 <Sparks> ianweller: Cya
00:28:21 <jjmcd> I sent a wuery to qrplinux-L looking for help
00:28:24 <jjmcd> no joy
00:28:38 <jjmcd> I think I will ping QRP-L, a much bigger list
00:28:39 <bcotton> the RPM guide might need a new owner, i am ashamed to admit that I havent done squat with it all summer :-/
00:28:40 <Sparks> jjmcd: On the Amateur Radio guide?
00:28:45 <jjmcd> affirm
00:28:59 <jjmcd> bcotton: same bug as rudi?
00:29:05 <Sparks> jjmcd: Okay.  I need to take a stab at some of it.
00:29:31 <bcotton> jjmcd: a combo of that and NotEnoughExperience
00:29:32 <Sparks> rudi: Which guide is this that you are having legal issues on?
00:29:34 <jjmcd> Sparks, it would be nice to have something fairly complete for F12
00:29:52 <Sparks> jjmcd: Might be too late in the game
00:30:12 <jjmcd> could be
00:30:15 <rudi> No guide -- I got left behind -- I was still talking about the Open Source Style Guide
00:30:25 <Sparks> rudi: Ahhh
00:30:26 <rudi> (and Red Hat's internal Style guidelines)
00:30:35 <Sparks> rudi: understood
00:30:53 <Sparks> bcotton: What do you need?  More help or more time or both?
00:31:39 <jjmcd> bcotton, you might be able to get some help from Florian.  He asked us to do it, probably could provide content guidance
00:31:57 <bcotton> Sparks: a bit of both.  i'm taking a new job later this month, which should give me a bit more time once i get settled.  i'll also get more experience with git and rpm building, and so forth
00:32:23 <Sparks> bcotton: Put the word out on the f-docs-l and see if there are any takers.
00:32:59 <bcotton> sparks: to help or to take?  i'd be okay with either.  i know the guide is rather dated, but i dont want to let it languish any more than it needs to
00:33:23 <Sparks> bcotton: Whichever you feel most comfortable.  You'd probably find helpers first, though.
00:33:35 <bcotton> (i'll also try to hang out in the IRC channel more, i've been fairly absent for a while)
00:33:44 <bcotton> sparks: can do!
00:33:44 <Sparks> Okay
00:33:51 <Sparks> jjmcd and rudi: How goes the RNs?
00:33:58 <jjmcd> Well,
00:34:14 <jjmcd> I need one small edit before I make the beta rpm
00:34:29 <jjmcd> Next move I guess is to update docs.fp.o
00:34:46 <rudi> jjmcd -- I've been doing that as langs hit 100%
00:34:57 <jjmcd> We have been building every night anf the L10N gang has been working hard
00:35:14 <Sparks> excellent
00:35:23 <rudi> A couple of thoughts:
00:35:57 <rudi> 1) this time, I think we should only move langs to d.fp.o if there's been L10N work in the current cycle
00:36:25 <rudi> 2) langs should remain "Drafts" until they hit 100%
00:37:04 <rudi> I think we're getting to the point where we should present readers with something a bit more polished
00:37:19 <rudi> Some of you may have seen the French L10N team take a firm stand on this recently ;)
00:37:35 <jjmcd> Last time there were a lot of langs at 80-90%, shouldn't we pull the trigger on those?  Or should we encourage the translators to move that last few percent.
00:37:37 <Sparks> I didn't
00:37:43 <Sparks> rudi: Can you elaborate?
00:37:56 <rudi> (They nuked the entire F12 RN fr.po file because they didn't want to see mishmashed docs published)
00:38:10 <rudi> (and don't have plans to translate the F12 RN)
00:38:39 <rudi> jjmcd -- I think we need to provide the encouragement to squeeze out that last 10%-20%
00:39:15 <Sparks> rudi: So let me get this straight...  There were French translations and they removed them all?
00:39:26 <rudi> Sparks -- yes
00:39:35 <rudi> French translations carried over from previous cycles
00:39:37 <Sparks> rudi: That's not going to sit well with me at all.
00:39:44 <rudi> For headings and stuff
00:39:52 <Sparks> rudi: Why did they do that?
00:40:00 <Sparks> What was the reasoning?
00:40:21 <rudi> Sparks -- because they saw us (docs) publishing half-complete work in the past and didn't want it to happen again
00:40:29 <jjmcd> Sounds so terribly French of them
00:40:30 <ryanlerch> rudi: what was the % translated when they nuked it?
00:40:33 <Sparks> so they aren't going to do them at all?
00:40:49 <rudi> Sparks -- they have no plans to for F12
00:40:57 <Sparks> I'm not good with that
00:41:43 <rudi> ryanlerch -- only about 10%–20%
00:41:47 <rudi> Reused strings.
00:42:08 <Sparks> Okay... anything else?
00:42:19 <rudi> It does mean, however, that if they decide that they want to do RN in French for (say) F13, they'll need to rebase the PO to F10
00:42:28 <rudi> (or start from scratch, as they choose)
00:42:49 <Sparks> That's just nuts
00:43:12 <rudi> True, but they probably didn't realise that they could just ask us not to publish the doc ;)
00:43:32 <Sparks> I'll keep my thoughts to myself at the moment.
00:43:34 <rudi> And, I sympathise with their desire not to publish half-finished work to the world
00:43:40 <Sparks> Okay, moving on.
00:43:47 <Sparks> Anything else in the guide department?
00:44:17 <Sparks> #topic New guides?
00:44:28 <Sparks> Any new guides to be discussed?
00:44:39 <jjmcd> You don't have enough?
00:44:56 <Sparks> I don't have enough time to work on the guides I want to work on!
00:44:58 <Sparks> :)
00:45:06 <Sparks> #topic Other business
00:45:09 <rudi> Just noting that the Virt Guide is up
00:45:14 <Sparks> Anyone have anything else they want to talk about?
00:45:18 <Sparks> rudi: +1
00:45:21 <rudi> On the F12 drafts page
00:45:23 <jjmcd> Sparks
00:45:24 <rudi> Check it out! :)
00:45:36 <jjmcd> You are aware that the beta meeting moved a week
00:45:46 <Sparks> jjmcd: Yes... Was going to mention that to you... :)
00:46:12 <jjmcd> :-)  Poelstra sent me a note, I wasn't sure it also went to you
00:46:41 <Sparks> jjmcd: I saw it on the logistics list.  Are you on that?
00:46:56 <jjmcd> Not sure, don't think so
00:47:05 <jjmcd> I already have too many lists
00:47:24 <Sparks> Okay, that list was created as a joint list kinda thing... mutual aid?
00:48:17 <Sparks> Okay, anything else?
00:48:21 <jjmcd> Yep, the note from JP was posted to logistics so I guess I am on it
00:48:38 <Sparks> I actually have something.
00:49:11 <Sparks> The first meeting after the F12 release I'll accept nominations for "leader" of the Docs Project.
00:49:27 <Sparks> We'll give that a week and then we'll have a poll setup to vote.
00:49:47 <Sparks> So be thinking of someone you'd like to see running this thing.
00:50:02 <Sparks> I think it is a good idea to do this every release or two...
00:50:12 <jjmcd> I don't know if you can get out of it that easy
00:50:15 <Sparks> just to keep the ideas new and the momentum moving.
00:50:23 <Sparks> jjmcd: One can try.
00:50:36 <Sparks> jjmcd: All I have to do is nominate you.  :)
00:50:43 * ryanlerch nominates zodbot, he is always in meetings...
00:50:55 <rudi> lolz@ryanlerch
00:50:56 <Sparks> ryanlerch: That's true.  And he does take really good notes.
00:50:59 * bcotton seconds ryanlerch's nomination
00:51:02 <jjmcd> I'll decline, but maybe I should nominate EvilBob, he is always at these meetngs, too
00:51:31 <bcotton> but here's a question: why can't zodbot be a she?
00:51:43 <EvilBob> that is what I get for having a good bouncer
00:51:45 <Sparks> bcotton: zodbot sounds too masculine
00:51:59 <jjmcd> what about Sonar_Gal?
00:52:26 <jjmcd> Always coming and going
00:52:41 <Sparks> :)
00:52:45 <Sparks> Okay, anything else?
00:53:12 <danielsmw> ls
00:53:16 * danielsmw apologizes
00:53:40 <Sparks> rm -Ir danielsmw
00:53:43 <jjmcd> better than firefox http://myfavepornsite &
00:54:26 <Sparks> 5
00:54:31 <Sparks> 4
00:54:35 <Sparks> 3
00:54:39 <Sparks> 2
00:54:44 <Sparks> 1
00:54:49 <Sparks> Thanks everyone for coming!
00:54:56 <Sparks> #endmeeting