17:00:16 <jds2001> #startmeeting FESCo meeting 20091009
17:00:16 <zodbot_> Meeting started Fri Oct  9 17:00:16 2009 UTC.  The chair is jds2001. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:16 <zodbot_> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:21 <jds2001> #chair dgilmore jwb notting nirik sharkcz jds2001 j-rod skvidal Kevin_Kofler
17:00:21 <zodbot_> Current chairs: Kevin_Kofler dgilmore j-rod jds2001 jwb nirik notting sharkcz skvidal
17:00:32 * j-rod here on time for once
17:00:32 * notting is here
17:00:34 * sharkcz is here
17:01:07 <jds2001> skvidal, nirik?
17:01:11 <skvidal> yes
17:01:25 <jds2001> coolio, lets get started
17:01:26 <Kevin_Kofler> Preseent.
17:01:34 <Kevin_Kofler> Present even. ;-)
17:01:36 <jds2001> #topic Revert Milestone adjustment
17:01:38 <jds2001> .fesco 255
17:01:39 <zodbot_> jds2001: #255 (Proposal: Revert "Milestone Adjustment Proposal") - FESCo - Trac - https://fedorahosted.org/fesco/ticket/255
17:01:39 * nirik is here.
17:01:49 <jds2001> -1, no signoff from rel-eng/QA
17:01:50 <notting> (note: i have a hard stop just before 2PM)
17:01:56 <j-rod> -1
17:01:56 <Kevin_Kofler> That one's my proposal. :-)
17:01:59 <Kevin_Kofler> Obviously +1 from me.
17:02:21 <sharkcz> -1
17:02:25 <Kevin_Kofler> Other projects also feature freeze at beta!
17:02:26 <nirik> -1 here. I'm sorry it caused confusion this cycle, but I think it will get better and we will be more aligned with industry/etc.
17:02:29 <Kevin_Kofler> http://techbase.kde.org/Schedules/KDE4/4.3_Release_Schedule
17:02:38 <Kevin_Kofler> Hard Feature Freeze is our feature freeze.
17:02:48 <Kevin_Kofler> Soft Feature Freeze is the equivalent of our feature submission deadline.
17:02:51 * notting is -1; having a milestone where nothing is actually due was becoming more and more pointless
17:02:54 <Kevin_Kofler> Hard Feature Freeze is at beta.
17:03:13 <Kevin_Kofler> So the claim that having feature freeze at beta is contrary to industry standards is blatantly false.
17:03:13 <jds2001> #agreed Milestone Adjustment will not be reverted
17:03:23 <jds2001> #topic yum-presto by default
17:03:26 <Kevin_Kofler> Ugh...
17:03:28 <jds2001> .fesco 256
17:03:29 <zodbot_> jds2001: #256 (yum-presto by default) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/256
17:03:33 <skvidal> hmm
17:03:38 <skvidal> sorry -  I was still typing
17:03:41 <skvidal> but nevermind :)
17:03:43 <Kevin_Kofler> Folks, do you actually listen to arguments rather than shooting down things just because they were proposed by me?
17:03:46 <jds2001> I'm ambilbant about this
17:03:52 <jds2001> Kevin_Kofler: we do.
17:04:14 <jds2001> Kevin_Kofler: however, rel-eng and QA needed to signoff on that, and they didn't.
17:04:16 <nirik> Kevin_Kofler: I do. I just don't agree with you in this case.
17:04:18 <Kevin_Kofler> This "more aligned with industry" bullsh*t which was the whole rationale for the original milestone adjustment is just flawed.
17:04:22 <Kevin_Kofler> See the KDE schedule.
17:04:30 <nirik> Kevin_Kofler: so kde == industry?
17:04:39 * skvidal wonders why he is typing so slowly this afternoon
17:04:57 <j-rod> I'm indifferent on presto
17:05:08 * jds2001 too.
17:05:16 <j-rod> I have local mirrors just about everywhere, so its actually slower for me
17:05:17 <jds2001> I think it could be harmful to say, netbook users
17:05:17 <Kevin_Kofler> +1 to the yum-presto by default proposal, if only to get it out of the desktop comps groups where it just doesn't belong!
17:05:40 <skvidal> jds2001: I'm glad you've come  around to my apathy :)
17:05:42 <j-rod> I can see the benefit for folks with slow links and decent speed boxes
17:05:44 <Kevin_Kofler> I'm not set on whether it should be default or not, but the current "solution" of having it snuck in through the back door sucks.
17:05:45 <nirik> I agree, but those spins can remove it, or if it is very bad we can remove it for f13
17:05:45 <j-rod> but meh
17:05:58 <skvidal> jds2001: presto and drpms seem to work fine but it alternately hurts/helps various people
17:05:58 <jds2001> skvidal: :)
17:06:11 <skvidal> depending on what they have
17:06:29 <Kevin_Kofler> But I do think the idea was always to make it default for F12, the only reason the original feature we voted didn't make it default was that it was too late and thus too risky for F11.
17:06:39 * jds2001 would disable it, because on my netbook i have high bandwidth, low processor power.
17:06:44 <j-rod> personally, its not useful, I'd rather people have to turn it on if they want it
17:07:19 <j-rod> but if it helps more people than it hurts, maybe it makes sense to enable by default
17:07:20 <jds2001> and on my home machines i have a local mirror
17:07:26 <nirik> I also agree that putting it in desktop comps group is bad. They could just add it to their ks files tho, right?
17:07:27 <notting> i don't use them personally. but i'm not the typical use case
17:07:35 <Kevin_Kofler> nirik: That's what KDE SIG does.
17:07:48 <Kevin_Kofler> GNOME has it added to their comps group.
17:07:57 <nirik> Kevin_Kofler: yeah, makes more sense to me. but I can always - it in the Xfce ks. ;)
17:07:59 * notting is +1 to making it the default and taking it out of the desktop comps groups
17:08:01 <jds2001> hmm, it needs to get out of there, has nothing to do with GNOME :)
17:08:05 <Kevin_Kofler> But this means that if you install from the DVD and select only KDE, you won't get Presto.
17:08:20 <nirik> yeah.
17:08:23 <Kevin_Kofler> Or if you install from the DVD without a desktop at all, for that matter.
17:08:40 <Kevin_Kofler> So live CD kickstarts are not an optimal place for it, nor are desktop comps groups (and it logically has nothing to do with desktops at all).
17:08:43 <nirik> I guess I am slightly +1 to making it default... if it turns out bad we can remove it in the next cycle from there.
17:09:03 * skvidal maintains his -/+ 0
17:09:04 <Kevin_Kofler> jds2001: Right, that's my point. :-)
17:09:15 <nirik> we should also add a big release note about it and how to disable it if you don't want it.
17:10:08 <jds2001> yeah, and blogs, carrier pigeons, etc :)
17:10:10 <sharkcz> with a visible release note I would be +1
17:10:22 <Kevin_Kofler> A release note is definitely needed.
17:10:34 <jds2001> +1 with wide publication
17:11:45 <j-rod> +1 somewhat begrudgingly, as long as its well publicized how to turn it off
17:12:02 <jds2001> #agreed yum-presto is accepted as default for F12
17:12:13 <jds2001> #topic FPC report
17:12:39 <jds2001> .fesco 257
17:12:40 <zodbot_> jds2001: #257 (Fedora Packaging Committee items for ratification (2009-10-07)) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/257
17:12:54 <jwb_> -1 to presto by default
17:12:58 * jwb_ is very very late
17:13:37 <skvidal> I'm sure mether will be happy to hear presto is now default.
17:13:49 * jwb_ shrugs
17:14:21 <jds2001> +1 to Rpath
17:14:27 * nirik hopes mether would also be willing to write the release notes. ;)
17:14:55 <Kevin_Kofler> +1 to the rpath changes, for internal libraries there's really no better solution.
17:15:11 <nirik> +1 to rpath, seems fine to me.
17:15:15 <Kevin_Kofler> And standard libdir in rpath is still banned, so that's fine.
17:15:15 <notting> +1 to rpath
17:15:16 <j-rod> +1 for rpath changes
17:15:17 <sharkcz> +1 to rpath
17:15:20 <skvidal> +1 to rpath
17:15:29 <Kevin_Kofler> (We don't want libdir in rpath because that'd break things like freetype-freeworld.)
17:15:47 <skvidal> +1 to dir ownership
17:16:26 <jds2001> +1 to dir ownership, seems sane
17:16:33 <sharkcz> +1 to dir ownership
17:16:38 <notting> +1 to dir ownership (admittedly, i'm biased)
17:16:40 <jds2001> #agreed rpath packaging draft is approved
17:16:47 <j-rod> +1 for dir ownership too
17:16:53 <Kevin_Kofler> +1 to dir ownership here too.
17:16:55 <jds2001> #agreed dir ownership packaging draft is approved
17:17:07 <jwb_> +1 to both
17:17:07 <Kevin_Kofler> Sounds really like my intuition for common sense. :-)
17:17:17 <jds2001> #topic incomplete features
17:17:20 <jds2001> .fesco 254
17:17:22 <zodbot_> jds2001: #254 (Incomplete features) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/254
17:17:26 <jwb_> grr.  phone + IRC + email == hard
17:17:34 <nirik> +1 on dir ownership. I should check and make sure one of my packages does the right thing.
17:17:44 * jds2001 just wanted to bring this up to say we accepted DisplayPort with reduced scope
17:17:58 * jds2001 saw no objections to that.
17:18:22 <nirik> yeah, that seems like a good solution to me. Advertise the done part, try later for the other parts.
17:18:24 <Kevin_Kofler> LowerProcessCapabilities is now at 100%, so that's fine, NFSv4Default was moved to F13, so that one's fine too.
17:18:29 * skvidal is sad about nfsv4 but I understand why it is not considered complete
17:18:39 <jds2001> #agreed DisplayPort feature was accepted with reduced scope (Intel only) via email
17:18:45 <Kevin_Kofler> That leaves DisplayPort and as I wrote in e-mail I agree with the proposed solution.
17:19:13 <jds2001> #topic open floor
17:19:21 <jds2001> anything else?
17:19:33 <jwb_> yes
17:19:41 <Kevin_Kofler> nirik: KDE is not the whole "industry", but it's part of it.
17:19:47 <jds2001> jwb_: go :)
17:19:57 <Kevin_Kofler> So if KDE doesn't do things the way you claim is an "industry standard", it might not be one. ;-)
17:20:03 <jwb_> there was recently an email that suggested we should be doing more proactive leading and interacting
17:20:06 <nirik> sure, agreed. I just don't think that workflow is very standard in industry.
17:20:12 <jwb_> does anyone feel differently?
17:20:30 <jds2001> nope, but sometimes just -ENOTIME
17:20:42 <notting> jwb_: in the thread-o-doom?
17:20:53 <nirik> it's hard to proactively herd cats. ;)
17:20:54 <jwb_> notting, no, last week i think
17:20:54 <Kevin_Kofler> jwb_: When should we do that "more proactive leading and interacting"?
17:21:06 <jwb_> Kevin_Kofler, now.  what else are we doing?
17:21:06 <nirik> I think we should lead by example, but not clear what else we can/should do.
17:21:30 <jwb_> i can come up with some things that need attention
17:21:36 <Kevin_Kofler> jwb_: Discussing meeting items. ;-) And then probably leave for lunch or dinner depending on timezone. ;-)
17:21:43 * nirik proposed we look at assiging a fesco person to each feature next cycle. That fesco person watches/helps/gets that feature owner stuff they need... not sure how practical it would be though.
17:21:55 <jwb_> like updates QA and infrastructure, auto-qa, etc
17:22:05 <jds2001> that actually sounds like a good plan nirik
17:22:17 <Kevin_Kofler> FWIW, I proactively fixed all the broken dependencies in F12 Rawhide recently.
17:22:23 <Oxf13> jwb_: my question with that is what will the attention accomplish?
17:22:27 <jwb_> nirik, i like that, but it's not exactly what i'm talking about
17:22:44 <j-rod> I'm finding that I simply don't have time for it, and its only going to get worse for me in the near-immediate future
17:22:47 <Oxf13> we have people actively working on those things, what added benefit does "attention" from FESCo give those people?
17:22:48 * nirik waits for jwb to clarify what he is talking about.
17:22:48 <jwb_> Oxf13, by attention, i mean "participate in fixing/testing/etc"
17:22:49 <Kevin_Kofler> (Except one ppc64 issue where a ppc64 package requires something which is ExcludeArch: ppc64, but normally the ppc package should satisfy the dep because nobody actually uses pure ppc64.)
17:23:11 <notting> Kevin_Kofler: thx for the fixes
17:23:13 <jwb_> you know, leading by example
17:23:19 <Oxf13> Kevin_Kofler: yes, thank you, that was helpful
17:23:28 <jwb_> or rather, leading just by participating
17:24:11 <nirik> jwb_: I think fesco folks already are pretty involved in the project and help where they can. I'm not sure how much more focused work is possible unless the board is interested in hiring everyone away from their current jobs to work only on fedora items. ;)
17:24:15 * jds2001 has the same problem as jwb_ - $DAYJOB getting increasingly demanding of my time in the immediate future.
17:24:58 <jds2001> it will be turning into $DAY_NIGHT_WEEKEND_JOB
17:25:00 <Kevin_Kofler> nirik: That's pretty much how I feel, too. :-)
17:25:14 <jwb_> ok, well i'm going to put my money where my mouth is.  i hereby resign from FESCo so i can go participate in the activities i think really need working and help
17:25:37 <j-rod> anything powerpc-related, by chance? :)
17:25:55 <jwb_> nah.  that's just for fun
17:26:01 <jwb_> going to start looking at updates QA
17:26:02 * j-rod *wants* to help with that too, but is just as lacking in spare time for that too
17:26:34 <jwb_> which will pretty much consume any time i carve out
17:26:41 * skvidal has on and off been helping with any the repo checking stuff he can for the autoqa process
17:26:42 <nirik> jwb_: thats your choice of course. If you feel you can do more good working on things than fesco items, more power to you. :)
17:26:56 <skvidal> more off than on, though
17:26:56 <jwb_> yeah.  i don't think anyone should be surprised here
17:26:57 * dgilmore arrives
17:27:10 <notting> jwb_: if that's your choice, thanks for your service up until now, and go kick butt on updates QA
17:27:34 <jwb_> thanks.  it's been a long strange trip and all that ;)
17:27:44 * jds2001 will initiate the succession process for the remainder of this term.
17:28:28 <jds2001> jwb_: we should put something in the minutes, but not sure what.  You wanna give it a try?
17:28:31 <jds2001> #chair jwb_
17:28:31 <zodbot_> Current chairs: Kevin_Kofler dgilmore j-rod jds2001 jwb jwb_ nirik notting sharkcz skvidal
17:29:14 <jwb_> #agreed jwb resigns from FESCo to focus on other Fedora issues.  jds2001 will initiate the succession process for the remainder of this term
17:29:22 <skvidal> :(
17:29:39 <jwb_> only so much time in the day skvidal.  no reason to be sad
17:29:51 <dgilmore> have we looked at starting the next election process yet?
17:29:55 <skvidal> jwb_: but I won't get to harass you in fesco meetings
17:30:03 <dgilmore> skvidal: we still can
17:30:16 * nirik notes dwmw2 would be next in line.
17:30:21 <jds2001> it's not like he's dead :)
17:30:31 <jds2001> yeah, i was gonna send him an email after the meeting
17:30:32 <jwb_> skvidal, like i'm not always in this channel...
17:30:42 <skvidal> jwb_: but it's not as much fun
17:30:56 <jwb_> true.  and on the flip side, now i get to be a heckler
17:31:00 <jwb_> phear me
17:31:11 <notting> jds2001: is the succession process documented on the wiki?
17:31:16 <jds2001> it is.
17:31:30 * j-rod is 99% likely to revert to heckler status once his time is up too
17:31:35 * jds2001 not sure it's ever had to be used before
17:31:56 <jwb_> awesome.  this will highlight if our process needs fixing or not
17:32:53 <jds2001> https://fedoraproject.org/wiki/FESCo_election_policy
17:33:17 <notting> ah, wasn't linked from the FESCo page
17:33:20 <jds2001> need some formatting fixes
17:33:51 <dgilmore> who are the 4 people up this cycle?
17:34:30 <j-rod> I'm pretty sure I am
17:34:43 * jds2001 is
17:34:47 * sharkcz is
17:35:10 <jds2001> and jwb_ i think
17:35:18 <jwb_> yeah, believe i was
17:35:34 <jds2001> ok, we have 4 :)
17:36:13 <dgilmore> jwb is the 4th
17:36:35 * Kevin_Kofler gets to sit for one more release, hoping he doesn't burn out before that. ;-)
17:36:55 <jds2001> Kevin_Kofler: it's hard work. :)
17:37:11 <nirik> oh, I suppose I have one more quick item...
17:37:20 <jds2001> I've somewhat decided that I will likely run for re-election, however, I think I'll abdicate the chair role
17:37:43 <jds2001> should I get re-elected.
17:38:10 <jds2001> nirik: shoot
17:38:34 <nirik> haven't plugged it lately, but another nice way to contribute is to teach a class on something in the irc classroom. I've basically been doing all of them recently, and it's a bit discouraging. If anyone would like to teach anything, see https://fedoraproject.org/wiki/Classroom and/or talk to me.
17:38:53 * jds2001 has taught a few
17:39:40 * nirik realizes he didn't update the page after the last one. Oops. Updating it now.
17:39:41 <jds2001> i think it's a great thing, but AFAIK there's no predictable schedule
17:39:43 <Kevin_Kofler> Well, do you have any idea for anything interesting (and Fedora-related) I could teach folks?
17:39:46 <jds2001> and I just forget.
17:39:55 <jds2001> Kevin_Kofler: you could teach about KDE :)
17:40:04 <jds2001> Kevin_Kofler: no one denies you're an expert there :)
17:40:21 <jds2001> and you dont even have to be an expert
17:40:27 <Kevin_Kofler> But it's a bit vague as a subject.
17:40:38 <jds2001> saying "i don't know" is perfectly acceptable.
17:40:54 <jds2001> Kevin_Kofler: take some of the basic questions that I asked when I was trying KDE
17:41:09 <dgilmore> Kevin_Kofler: probraming in pyqt4
17:41:11 <nirik> basically anything at all fedora related.
17:41:18 <jds2001> like getting the weather plasmoid working
17:41:24 <nirik> we have a lot of very new users who show up, so basic things are good.
17:41:24 <Kevin_Kofler> We've had one class on KDE, it was pretty chaotic, just answering 1 or 2 users' questions (and that was about the whole audience).
17:41:42 <jds2001> you could probably do a whole class on desktop widgets
17:42:18 <dgilmore> id go to a class on akonadi
17:42:24 <Kevin_Kofler> As for the schedule, there's no predictable schedule because there were not nearly enough classes to fill the 2 days/month anymore after the first few sessions.
17:42:33 * notting has to step away for a few, sorry
17:42:49 <dgilmore> notting: we gave all tasks to you :)
17:42:52 <Kevin_Kofler> So now they let the "teachers" decide the schedule.
17:43:14 <nirik> yes. Also, doing them 2 days a month leaves scheduling problems for most teachers.
17:43:23 <jds2001> notting: you get to teach a class.
17:43:36 <nirik> I'm happy to change things around to whatever works. Open to suggestions.
17:44:12 <nirik> anyhow, we can discuss that on the classroom list or channel... thats all. Just wanted to plug it again.
17:44:12 * jds2001 filled an hour with rsync last time, for example.
17:45:04 * skvidal wonders if this meeting is over or what?
17:45:18 <jds2001> #help teachers are needed for the Fedora classroom, please help!
17:45:32 <jds2001> well, if there's nothing else, yeah
17:46:14 * jds2001 ends the meeting
17:46:24 <jds2001> #endmeeting