21:03:18 <kanarip> #startmeeting Spins SIG
21:03:18 <zodbot> Meeting started Mon Oct 12 21:03:18 2009 UTC.  The chair is kanarip. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:03:31 <kanarip> #topic Who's who
21:03:33 <kanarip> who's here?
21:03:35 * kanarip is
21:03:40 <brunowolff> Bruno
21:03:52 * nirik is sorta here.
21:03:52 * maxamillion is here
21:03:57 * biertie is here
21:04:23 <kanarip> cool, what's our first topic?
21:04:43 <brunowolff> How about QA Test Day spin ready for SIG
21:04:57 <kanarip> nice one
21:05:08 <kanarip> #topic QA Test Day Spin
21:05:24 <brunowolff> I think the SIG looked at it before biertie reviewed it, but I wanted to see if everything is ready for F12.
21:06:01 <kanarip> i think it is, given that one comment that i made about a .desktop file I believe?
21:06:12 <kanarip> (it's been some time ago for me... pfew)
21:06:40 <brunowolff> That was OK. I was thinking more of the wiki page for it.
21:07:13 <kanarip> looking at it right now
21:07:27 <brunowolff> Since we won't be making an iso for it for the release the wiki page is a bit different and I wanted to make that was OK.
21:07:49 <kanarip> i think what it is missing at this point is; how this kickstart is supposed to be used by a given QA Test Day organizer
21:08:11 <kanarip> like poelcat once wanted, a very simple quick howto addressing the how more so then the why
21:08:12 <brunowolff> The QA guys have a web page that includes instructions for that.
21:08:29 <kanarip> has it or could it be updated to use the qa-test-spin.ke?
21:08:33 <kanarip> s/ke/ks/
21:08:37 <brunowolff> It is the one linked from the spin page.
21:09:09 <kanarip> ah, yes
21:09:17 <kanarip> i see, it has been updated very nicely
21:09:19 <kanarip> cool
21:09:30 <brunowolff> They install some stuff and then pull the kickstart repository from git. Adjust some things and build.
21:09:47 <kanarip> awesome
21:09:57 <kanarip> how broad has this been announced so far?
21:10:12 <kanarip> like, do all feature owners for F12 know about this?
21:10:17 <brunowolff> I thought it better to leave that stuff on their page rather than trying to keep a separate description in sync.
21:10:33 <kanarip> brunowolff, very true, very well done
21:10:43 <brunowolff> I don't know for sure who QA told about it.
21:11:05 <kanarip> it's like, 1{a,b,c,...} add your Feature to F-x, have it approved, do the work
21:11:21 <brunowolff> I'd like to think anyone comptemplating a test day would know about it.
21:11:30 <kanarip> 2) Organize a test day for your feature if desirable and use this test spin thing
21:11:54 <kanarip> brunowolff, do you think announcing it through the QA communication channels would help?
21:12:03 <kanarip> them or us, regardless? ;-)
21:12:44 <brunowolff> I could ask the person I was working with if they think any more announcements need to be made.
21:13:08 <brunowolff> It might have made FWN. If not it might be worth mentioning there.
21:13:10 <kanarip> cool
21:13:33 <kanarip> i would really like to prevent anyone wanting to do any QA to have to reinvent the wheel sorta speak
21:13:56 <brunowolff> I can certainly do a followup to make sure we at least tried to let interested people know.
21:14:11 <kanarip> that'd be great
21:14:45 <brunowolff> #action brunowolff will followup with his QA contact and FWN to make sure people had a chance to hear about the QA Test Day spin.
21:15:10 <kanarip> #action brunowolff to follow up with QA teams to make sure the qa-test-day.ks is sufficiently known within various groups and teams needing QA (on a Test Day)
21:15:14 <kanarip> ;-)
21:15:26 <kanarip> #topic Who are Spin pages for?
21:15:32 <kanarip> this is a broader topic
21:15:54 <kanarip> from where we've started, Spin pages serve two purposes
21:15:57 <brunowolff> biertie started talking about this with regard to the target for the QA Test Day spin page.
21:16:00 <maxamillion> I don't entirely understand, are we talking ... what audience are we trying to attract with the spins pages?
21:16:24 <kanarip> 1) tracking the process and providing those involved with the process with enough information to make an informed decision
21:16:30 <brunowolff> But also with the new pages being done by mizmo this is something we should address. If not now, for the F13 cycle.
21:16:42 <biertie> kanarip: what pages do you mean? like the wiki spin pages, or the spin pages that will be shown on the new website?
21:17:03 <kanarip> 2) presenting the spin to the broader fedora audience, including some details people may be looking for and having a more detailed description to introduce people to the spin
21:17:14 <maxamillion> kanarip: what "process"?
21:17:34 <kanarip> biertie, the Wiki Spin pages were supposed to have the contents for the final (new) Web pages
21:17:56 <kanarip> detailed description, slogan if appropriate (i'm not much of a slogan person myself), etc.
21:18:15 * sdziallas is late, reads backlog
21:18:18 <biertie> yeah, some :)
21:18:30 <biertie> not like that kickstart, or all the dependencies etc etc
21:18:40 <kanarip> maxamillion, ah, the "spin approval process" -including trademark approval
21:18:51 <maxamillion> kanarip: ah
21:19:31 <kanarip> well the Spin Wiki page is an aggregation of everything that needs to be communicated to 1) the Spins SIG Wrangler, 2) the Spins SIG, 3) the Board, 4) the audience
21:19:44 <kanarip> all of these groups are interested in different things, hopefully
21:20:37 <maxamillion> fair enough
21:21:16 <brunowolff> So are 1, 2 and 3 staying with the old pages with 4 going to the new ones or is something else happening?
21:21:27 <kanarip> so the descriptions and details and slogans we're looking for right now for the new web pages on spins.fp.o can actually just be in the Spins Wiki page, probably somewhere at == Description ==
21:21:48 <brunowolff> Is whatever is happening for F12 what we want to happen for future releases?
21:22:42 <kanarip> i'd think so, but i was just explaining how we had originally envisioned this would work
21:23:09 <kanarip> one Spins Wiki page with different details to be used in various places, that's what we had in mind originally
21:23:35 <kanarip> i remember addressing a few of you in private last release or so about updating the description attached to various Spins wiki pages
21:23:42 <kanarip> wasn't that you too, brunowolff?
21:24:14 <brunowolff> I know you had some comments on my description, but I thought it was more suggestions on spicing things up rather
21:24:22 <brunowolff> than a new way of doing things.
21:24:30 <kanarip> yeah, exactly
21:25:16 <maxamillion> I've been working on some verbage for the new xfce spin page, its awaiting peer review from mr. fenzi and mr. wickert
21:25:29 <nirik> the current pages don't have much of the content asked for for the new site do they?
21:25:30 <maxamillion> (just on the topic of descriptions)
21:25:40 * nirik still needs to find time to look at that.
21:26:07 <maxamillion> nirik: its only about 8-10 lines long (depending on the size of your browser window)
21:26:15 <maxamillion> nirik: but I couldn't think of anything else to add to it
21:26:20 <kanarip> ok, so what is the actual requirements for the new spins.fp.o pages then?
21:26:35 <nirik> yeah, I glanced at it... and it sounded a bit awkward to me, but not sure how to spice it up.
21:26:38 <brunowolff> FEL did some really neat stuff, but that is kind of beyond what I am good at.
21:26:42 * nirik is not a tech writer. ;(
21:26:49 <kanarip> maxamillion, a good description doesn't have it's own chapters and sections though if you know what i mean ;-)
21:27:02 <maxamillion> https://fedoraproject.org/wiki/Website_redesign_2009/Mockups/Spins.fpo#Fedora_Electronic_Lab_Spins_Mockups <--- I've been using this as a guideline
21:27:15 <brunowolff> I gave mizmo some more background on my spin and am hoping they can give me some suggestions.
21:27:33 <maxamillion> as far as amount of verbage and to break out highlighted packages away from the paragraph of info
21:27:37 <maxamillion> etc
21:27:56 <nirik> http://mairin.wordpress.com/2009/10/09/let-me-bling-your-spin/
21:28:00 <kanarip> brunowolff, other people good at that stuff include fedora-marketing and fedora-docs
21:28:20 <kanarip> i'm sure they'll be glad to help anyone with a little spicing up anything
21:29:20 <maxamillion> nirik: I had not seen that, I must have missed it ... thanks :)
21:30:13 <kanarip> what FEL has of course is beyond just the spin
21:30:50 <kanarip> i would take it as an example (for inspirational purposes) but not try and compete with it
21:31:01 <maxamillion> I do like at the bottom that Mo was nice enough to lay out what she needs from each spin ... definitely clears up a couple questions for me :)
21:31:22 <maxamillion> (bottom referring to --> http://mairin.wordpress.com/2009/10/09/let-me-bling-your-spin/ )
21:33:00 <kanarip> well, this should be entirely doable if you really wanted to, no?
21:33:27 <maxamillion> completely, the information she is asking of each spin is extremely managable imo
21:34:05 <kanarip> brunowolff, as you indicated you are not a slogan person, how about: Fedora Games: Like a snail on a turtle: "Weeeeeeeeeeeeee!!!"
21:34:23 <kanarip> anyone else with a slogan idea for the games spin? ;-)
21:34:37 <kanarip> Fedora Games: Innocent. Really.
21:34:53 <kanarip> Fedora Games: Keep outta reach of children under the age of X
21:34:56 <nirik> All Fun and Games!
21:35:15 <kanarip> Fedora Games: All work and no play.
21:35:16 <maxamillion> Kickin' Butt and Takin' Names
21:35:28 <kanarip> Fedora Games: All your Free are belong to us
21:35:32 <maxamillion> kanarip: yes!!!!
21:35:53 <brunowolff> I had a problem with xorg and/or my video driver.
21:35:56 <maxamillion> or 'All your fun are belong to us"
21:36:07 <maxamillion> errr ... without the mixing of quotes
21:36:11 <kanarip> ohw, brunowolff, that's something else then a slogan ;-)
21:36:46 <brunowolff> That's is a nice quote.
21:37:02 <kanarip> Fedora Games: Something else then a slogan
21:37:16 <biertie> Fedora Games: kicks the gamers ass!
21:38:00 <brunowolff> I'd not want to boast too much when 3D isn't that great on the spin.
21:38:17 <brunowolff> I don't know that it worked on any platforms for F11.
21:38:43 <biertie> :p
21:38:53 <brunowolff> For F12 it should mostly work on Intel and ATI. But as you just saw video isn't completely stable on F12 currently.
21:38:55 <kanarip> i'm curious how this relates to this other discussion within fedora
21:38:57 <biertie> Fedora Games: why gamers should buy a console!
21:39:25 <kanarip> where people say that "what ends up in rawhide is inherently going in to the next release no rolling back possible" has become a problem
21:39:36 <brunowolff> I added 3D graphics to the wish list for the What is Fedora thread on FAB.
21:40:25 <brunowolff> That would make the Games Spin much better for what I want it to be.
21:41:09 <brunowolff> I hope that someone can get the nouveau guys more resources. (ATI and Intel will probably be pretty good for F13 in any case.)
21:41:37 <kanarip> nvidia still has the lead outside of the Free* paradigm though
21:42:04 <nirik> maxamillion: I added another rougher draft re-write on that wiki page.
21:42:09 <brunowolff> All the more reason to get nouveau working. The nvidia drivers don't help the games spin.
21:42:12 <kanarip> either way, Fedora is a lot of different things to a lot of different people
21:42:37 <kanarip> brunowolff, would it help if you were not bound to rawhide becoming GA?
21:42:39 <brunowolff> I even tried making a custom spin with the drivers already in place and found it doesn't work because of the way the drivers are done.
21:43:09 <kanarip> e.g., not bound to the regular release process for Fedora Project as a whole?
21:43:24 <maxamillion> nirik: oh ok
21:43:48 <maxamillion> nirik: I also just posted a "first thing that came to my mind" slogan on the "discussion" tab
21:43:51 <brunowolff> Not really. I have my only local repos and know enough now that I can test stuff fairly easily on my hardware pulling
21:44:16 <kanarip> brunowolff, fair enough, but keep it in mind as an option
21:44:27 <brunowolff> from where needed. But when the tests are a fail, I don't have a lot of variety to test on so I can have problems.
21:44:39 <nirik> maxamillion: thats not bad. The upstream one is '...and everything goes faster' I think...
21:45:03 <kanarip> if the need arises for the games spin to break free from the general fedora release process (and it is in fact a solution to your problems/challenges) it should also be worth mentioning outside of this little group
21:45:11 <maxamillion> nirik: yeah, it is
21:45:25 <kanarip> brunowolff, maybe organize a test day? ;-)
21:45:38 <maxamillion> nirik: didn't know if we wanted to "borrow" theirs or not
21:46:21 <brunowolff> I might do that for F13 if I get my QA stuff done. There are a lot of games to be tested. But I'd also want to have 3D working
21:46:35 <brunowolff> fairly reliably somewhere.
21:46:40 <kanarip> get up a matrix somewhere on a publicly editable wiki page and announce a test day with a test spin. coordinate it with QA and with a little luck there's a dozen people probing all kinds of hardware at some point in rawhide territory
21:47:01 <kanarip> organize just the 3D test day, for example
21:47:10 <kanarip> all of the games might be a different thing to tackle
21:47:34 <brunowolff> I know I mentioned the games spin as a useful way to test 3D to someone who was saying that wasn't testable with the normal spins.
21:48:07 <kanarip> choose like three games; one that is not so dependent on 3D, one that is moderately dependent on 3D performance-wise, and one that cannot work without full 3D capabilities
21:48:30 <brunowolff> I think on an ongoing basis I would want test days. There are a lot of ways it helps. But I don't think I am ready for one yet.
21:48:50 <kanarip> that could be an entirely separate test day, as you can get enough bugs logged/feedback on existing bugs purely by that
21:49:33 <brunowolff> I bet a games spin test day would be pretty popular.
21:49:38 <kanarip> the estimated rate of failure does not make a test day more or less useful, right?
21:50:14 <brunowolff> I want to make sure I am able to give direction and that enough works that useful testing can be done.
21:50:20 <kanarip> a test day just could gain you a co-maintainer for the spin, if nothing else
21:51:00 <kanarip> if something fails, useful testing has been done, and it's about the collection of sufficient background details that QA can help with, probably
21:51:16 <kanarip> that's why i'm saying you could coordinate your test day with the QA team
21:51:20 <brunowolff> That is why I want to have at least sketched out QA tests for each game.
21:51:30 <kanarip> sure thing
21:51:40 <kanarip> so, back to the original topic
21:51:59 <brunowolff> Also I want to know what hardware has a reasonable chance of working so I don't waste people's time testing 3D games
21:52:11 <kanarip> does everyone agree on what the Spins Wiki pages are for?
21:52:15 <brunowolff> when 3D doesn't work at all.
21:52:31 <kanarip> they can collect details you can't if it doesn't work as anticipated
21:52:44 <biertie> euhm, we haven't really said something about the pages, I think? :p
21:52:48 <biertie> so, yeah ;)
21:52:52 <brunowolff> I am still not sure about stuff for the new pages being replicated back to the old ones?
21:53:01 <kanarip> biertie, we have, you weren't paying attention
21:53:13 <biertie> mhm
21:53:21 <brunowolff> Are we not going to do that, replicate it manually, use an include mechanism/
21:53:23 <maxamillion> biertie: it was discussed about 40 minutes ago
21:53:30 <kanarip> the old pages are supposed to have all the details for the new pages to be composed from
21:53:54 <brunowolff> OK that answers part fo my question.
21:54:01 <kanarip> ergo; the Spins wiki pages are to have a description, a screenshot, the help information (IRC channel, mailing list, if applicable)
21:54:20 <brunowolff> Is there a way we can have one definitive source so that we don't have two entries that get out of sync?
21:54:21 <kanarip> you can do that in bullet points in the == Detailed Description == area
21:54:27 <biertie> already forgot that :p
21:54:44 <kanarip> brunowolff, one definitive source == Spins Wiki page?
21:55:22 <brunowolff> I know there is some sort of include mechanism like we have for the spins wrangler. Is there going to be an attempt
21:55:28 <kanarip> you don't have to do the actual layout, you have to provide the content
21:55:51 <brunowolff> to do something like that for the new information or is that too hard/complicated to be worthwhile/
21:56:03 <kanarip> the include mechanism doesn't work for chunks of content that varies between pages where the include is being made
21:56:39 <kanarip> all you have to do is put up the new content on the old spins wiki page and point the design team to that wiki page
21:56:48 <brunowolff> OK. So it will be manual. Are we going to have any specific process to keep things in sync? Or just best effort using watches
21:56:54 <brunowolff> on the various pages?
21:57:04 <kanarip> dear design team, as you requested, fp.o/My_Spin, see == Detailed Description ==
21:57:14 <kanarip> Kind regards, My_Spin Maintainer
21:57:52 <kanarip> the spins.fp.o page will always be lagging behind the spins wiki page and there's no way around it but manual intervention
21:57:59 <brunowolff> So the design team is responsible for keeping the data in sync, but the spin owners need to notify them when things
21:58:02 <brunowolff> change?
21:58:47 <biertie> yes
21:58:52 <kanarip> remember the spins.fp.o page is the page for one given release whereas the spins wiki page is rolling along with rawhide, with specific versions of the page attached to a release
21:59:43 <kanarip> which then again are static given the nature of how revisions work
21:59:48 <brunowolff> So the spin template should get changed to indicate this. What else in our documentation should be updated?
22:00:06 <kanarip> maybe some details in the spins process
22:00:38 <kanarip> like we emphasize the usefulness of the Spins wiki page and what details should be on there exactly
22:00:57 <kanarip> we need to wrap this up pretty quickly, so let's assign some actionable items
22:01:18 <maxamillion> I have to run
22:01:19 <maxamillion> laters
22:01:20 <brunowolff> Probably it should be covered in recurring and discontinued spin processes.
22:01:42 <kanarip> biertie, can you edit the new spins page template to reflect the new requirements from  http://mairin.wordpress.com/2009/10/09/let-me-bling-your-spin/ section "Content Needed for Each Spin"?
22:02:07 <brunowolff> The recurring spin process link is empty right now. I don't know if that is a typo in the link or if the page never actaully
22:02:11 <brunowolff> got set up.
22:03:03 <kanarip> biertie, ping
22:03:09 <brunowolff> I'll do the discontinue process change since I wrote that page.
22:03:52 <biertie> kanarip: check
22:03:59 <brunowolff> I think that's just notify the design team that the affected spin won't be in the next release.
22:04:19 <kanarip> #action brunowolff to update Discontinued spins process to reflect new requirements to spins wiki page content
22:04:33 <kanarip> #action biertie to update https://fedoraproject.org/wiki/Spins_New_Spin_Page_Template to reflect new requirements to spins wiki page content
22:05:00 <kanarip> wow that was one button too much at the same time
22:05:13 <nirik> we should also ping all spin maintainers to update it after it's updated in the template.
22:05:23 <kanarip> #action kanarip to update recurring releases with the new spins wiki pages content requirements
22:06:10 <kanarip> #action biertie to ping spin maintainers after updating the new template possibly referring directly to the awesomeness at http://mairin.wordpress.com/2009/10/09/let-me-bling-your-spin/
22:06:28 <kanarip> biertie, i just assigned another action item to you if you don't mind ;-)
22:06:53 <biertie> I do mind :(
22:06:55 <biertie> :p
22:07:17 <kanarip> we should all pay attention to whether pages have been updated thursday evening, and make sure we come up with something decent enough for those pages that have not been updated
22:08:01 <kanarip> that's a wrap as far as i'm concerned guys
22:08:03 <kanarip> anyone else?
22:08:20 <kanarip> guess what time i have to get up tomorrow ;-)
22:08:20 * nirik has nothing. Hopefully the nightly composes are still useful
22:08:42 <biertie> so, I HAVE to change the template + ping the maintainers tomorw, and set their death line on thursday?
22:08:56 <kanarip> biertie, yes
22:09:03 <brunowolff> The QA test Spin will continue to be an odd case, but I'll try to fill in something appropriate even if it won't have a fancy page.
22:09:10 <biertie> I love my new cell phone
22:09:13 <kanarip> biertie, mention that if they're not going to play nice, we're going to play nice for them
22:09:25 <biertie> ok
22:09:57 <kanarip> biertie, you may quote me on that if you use an appropriate smiley ;-)
22:10:12 * kanarip closing the meeting in 2
22:10:42 <biertie> 1
22:10:54 <kanarip> not yet, don't jump the gun
22:11:12 * kanarip closing the meeting in 1
22:11:23 <biertie> lolz
22:11:36 <kanarip> #endmeeting