21:00:00 <nirik> #startmeeting EPEL Meeting - 2009-10-16
21:00:00 <zodbot> Meeting started Fri Oct 16 21:00:00 2009 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:05 <nirik> #topic Init process.
21:01:40 <nirik> who all is around for an epel meeting.
21:01:55 * derks is present for epel
21:02:05 * dgilmore is here
21:02:09 * stahnma is here
21:02:57 * Jeff_S here
21:03:21 <nirik> cool. I guess lets go ahead and get started.
21:03:45 <nirik> #topic Blocking packages already in RHEL
21:03:48 <nirik> smooge: you around?
21:03:57 <nirik> smooge posted a list to the list the other day.
21:04:40 <nirik> should we file bugs on the conflicts? or just go block them/mark them dead.package ourselves?
21:05:19 <derks> nirik: were there any packages that EPEL has newer versions than RHEL ported?
21:05:36 <smooge> hello
21:05:37 <nirik> There were in the 5.3 timeframe.
21:05:37 <smooge> sorry
21:05:41 <nirik> I'm not sure about 5.4.
21:05:44 <smooge> I had to go deal with something
21:05:53 <nirik> no worries.
21:06:23 <smooge> derks, I just looked for comparisons as in in RHEL && in EPEL
21:06:33 <smooge> not whether it was newer or not
21:06:35 <dgilmore> the 5.3 ones i worked to get resolved for 5.4
21:06:56 <nirik> dgilmore: cool.
21:07:04 <smooge> I have not put in any bugs. The comparisons I made were for 5.4 so I guess its new stuff
21:07:09 <dgilmore> nirik: we should just block mark them dead
21:07:30 <nirik> yeah, I think so too... as long as we don't misidentify any.
21:07:31 <Jeff_S> I think we dead.package them and if RHEL was dumb enough to use an older version of what was in EPEL... that's up to them to sort out should their customers have issues
21:08:02 <nirik> ok, does someone want to take this action item?
21:08:04 <Jeff_S> in the past, haven't they just branched from what was in EPEL?  or am I making that up?
21:08:21 <derks> Jeff_S I agree...  rhel should consider the fact that not using atleast the version epel has would be an issue
21:08:22 <nirik> they have, but sometimes without notifying the epel maintainer, who keeps updating.
21:08:30 <smooge> dgilmore, I have a list of all src.rpms that are in 5.4.. should we mark them dead in tree?
21:09:02 <dgilmore> smooge: we should
21:09:13 <nirik> smooge: can you do that?
21:09:16 <dgilmore> smooge: we cant block them until Centos has released 5.4
21:09:26 <dgilmore> but we can kill them in cvs now
21:09:41 <Jeff_S> dgilmore: that's pushing to mirrors now, so we're close
21:10:07 <Jeff_S> probably next week IMO
21:10:15 <nirik> or I guess I can try and do it sometime.
21:10:35 <smooge> ok.. let me know a step set and we could do this en-mass
21:11:37 <nirik> https://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life
21:11:50 <nirik> I guess we could just wait for centos to finish landing and do it all then.
21:13:08 <nirik> sound reasonable? anything else on this, or shall we move on?
21:13:38 <nirik> #topic Fuse for 5.4 status
21:13:43 <Jeff_S> nirik: any reason not to do CVS already (like dgilmore mentioned)?
21:13:44 <nirik> rayvd: you around?
21:13:51 <Jeff_S> sorry, I'm too slow
21:13:59 <nirik> Jeff_S: we could. I don't much care.
21:14:04 * Jeff_S either
21:14:25 <Jeff_S> waiting for centos sounds fine to me.  we already waited this long :)
21:14:34 <nirik> There have been some fuse packages already branched... so thats good...
21:14:42 <nirik> moving along...
21:14:55 <nirik> #topic QA Efforts
21:15:20 <nirik> is there anything we can do to push more qa efforts in epel?
21:15:47 <nirik> It's very hard to get karma on updates, but then it is in fedora as well...
21:15:58 <nirik> we also don't have any broken deps checker or anything.
21:15:58 <maxamillion> sorry I'm late
21:15:59 * maxamillion is here
21:16:06 <nirik> no worries. welcome maxamillion
21:16:18 <Jeff_S> hi maxamillion
21:16:20 <maxamillion> nirik: thanks :)
21:16:21 <maxamillion> Jeff_S: hi hi
21:16:43 <maxamillion> nirik: could we request fedora infrastructure (or whoever runs the deps checker) to run them against EPEL also?
21:16:58 <nirik> maxamillion: what fedora dep checker?
21:17:04 <Jeff_S> as far as testing packages... that's hard since it's best done by people actually using the package in question.
21:17:13 <Jeff_S> nirik: there's a script floating around somewhere
21:17:21 <Jeff_S> or it may even be in yum-utils now?
21:17:27 <nirik> yeah, and it's hard to let them know they can. ;(
21:17:42 <nirik> there are a lot of scripts, but nothing that is very official or working.
21:17:57 <nirik> we had one in infrastructure a while back, but I think it got disabled due to brokenness.
21:17:59 <Jeff_S> nirik: yep.  (on both counts)
21:18:08 <maxamillion> nirik: isn't there a "broken dependencies in Fedora-$foo" email that goes out every so often?
21:18:29 <nirik> mmcgrath: you know what every happened to the epel dep checker script? disabled? removed? sank into the swamp?
21:18:42 <nirik> maxamillion: yeah, thats run by mschwent...
21:18:43 <stahnma> I think it fell a long way
21:18:57 <Jeff_S> I think it was semi-broken and thus never got used :)
21:19:12 <maxamillion> nirik: could we beg/bribe him? :)
21:19:19 <nirik> yeah. We could ask mschwent to do epel runs... not sure if he will...
21:19:26 <nirik> maxamillion: you want to mail him and ask?
21:19:54 <Jeff_S> also we had issues with RHEL vs. centos IIRC
21:20:00 <stahnma> we had that
21:20:08 <nirik> yeah, and at least once it mailed out invalid ones. ;(
21:20:12 <Jeff_S> heh
21:20:12 <maxamillion> nirik: sure can
21:20:16 <stahnma> as well as some child channel issues, (or maybe i just thought we would ahve those eventually)
21:20:25 <stahnma> either way, it didn't go very well
21:20:33 <Jeff_S> that's about how I remember it too...
21:20:34 <nirik> #action maxamillion will mail out and see if the deps checker script can be run against epel.
21:20:54 <maxamillion> .fasinfo mschwent
21:20:55 <zodbot> maxamillion: User "mschwent" doesn't exist
21:21:01 <nirik> he may not have rhel around, so would run it against centos, not sure how big a problem that is tho.
21:21:01 <maxamillion> o.O;
21:21:11 <nirik> it does mean the ppc stuff wouldn't work tho.
21:21:21 <maxamillion> nirik: true
21:21:24 <nirik> sorry, it's mschwendt
21:21:35 <maxamillion> nirik: actually, if I can get my hands on the script I can just set it to run
21:21:45 <Jeff_S> maxamillion: check yum-utils (IIRC)
21:21:52 <nirik> well, it's not the most basic of scripts from what I recall. ;(
21:22:04 <Jeff_S> it will require some good lovin
21:22:04 <nirik> if we could get a weekly run of it that would be great tho.
21:22:32 * nirik nods.
21:22:46 <smooge> it was semi broken and needs a rebuild
21:22:46 <smooge> there was some work done by I think jds2001 but it was to make it work with plague.
21:22:46 <smooge> the new changes would be to make it work with koji-epel special sauce
21:23:06 <maxamillion> hrmmm
21:23:09 <stahnma> mmm special sauce
21:23:18 <stahnma> <--- contributes a lot today :)
21:23:31 <maxamillion> .fasinfo mschwendt
21:23:32 <zodbot> maxamillion: User: mschwendt, Name: Michael Schwendt, email: mschwendt@gmail.com, Creation: 2005-04-13, IRC Nick: mschwendt, Timezone: UTC, Locale: en, Extension: 5100044, GPG key ID: B8AF1C54, Status: active
21:23:34 <zodbot> maxamillion: Approved Groups: cla_done fedorabugs cvsfedora packager cla_fedora provenpackager
21:23:37 <zodbot> maxamillion: Unapproved Groups: None
21:23:38 <maxamillion> win
21:23:53 <maxamillion> ok, I'll shoot him an email as soon as we finish the meeting
21:23:54 <mmcgrath> nirik: it was never properly maintained so your guess is as good as mine.
21:23:56 <Jeff_S> stahnma: it's important to have a peanut gallery :)
21:24:05 <mmcgrath> if someone wants to write a script that works every time it's run I can certainly put it in a cron job :)
21:24:09 <nirik> ok, can anyone think of more qa we could/should/outta be doing?
21:24:15 <mmcgrath> sorry I was a bit late on that.
21:24:25 <nirik> mmcgrath: yeah, it just sort of sank into the swamp as I feared. ;(
21:24:38 <stahnma> we could fix bugs :)
21:24:42 <stahnma> http://tr.im/epelbugs
21:24:49 <nirik> yeah, bug fixing is always good...
21:24:50 <stahnma> I think we still have around 140 open
21:25:28 * nirik has 2 that he's slacked on fixing. ;(
21:25:32 <Jeff_S> mmcgrath: a script that works *every* time?  what do you think this is??? :)
21:25:49 <nirik> Jeff_S: perhaps we can define 'works' our own way. ;)
21:25:50 <mmcgrath> :)
21:25:57 <Jeff_S> lol
21:26:15 <nirik> 151 bugs.
21:26:18 <nirik> many in new. ;(
21:26:47 <derks> whens the next epel bug day? (other than every day!)
21:27:08 <nirik> not sure.
21:27:13 * stahnma hasn't planned one :)
21:27:14 <nirik> do we want to try and do another one?
21:27:42 <Jeff_S> with blackjack and booze?
21:27:45 <derks> any numbers on what the closed bug count was from the last one?
21:27:46 <stahnma> the first one was a bust
21:27:53 <stahnma> derks: 2
21:27:56 <stahnma> 2 bugs
21:28:01 <Jeff_S> lol
21:28:06 <derks> whaoh.
21:28:12 <nirik> we did hit on all the bugs tho I think... which at least was nice.
21:28:13 * Jeff_S shouldn't laugh since he was away that day
21:28:20 <stahnma> I don't really have the appetite to try it again
21:28:31 <nirik> when I say "we" I mean stahnma did. ;)
21:28:44 <smooge> yeah.. stahnma really went 200% on that.
21:28:47 <stahnma> I mean, i'd participate, but leading didn't get us very much headway
21:29:21 <nirik> perhaps we could try and do a FAD or something with a summt/fudcon for more in person work on things.
21:29:46 <Jeff_S> yeah
21:29:51 <nirik> anyhow, any more ideas on QA?
21:30:04 <Jeff_S> that could possibly even double our bug closures
21:30:38 <stahnma> ncie
21:30:38 <nirik> ha.
21:30:40 <stahnma> :)
21:30:43 <nirik> #topic Open Floor
21:30:49 <nirik> anyone have anything for open floor?
21:30:56 <maxamillion> I kind of do
21:31:03 <tibbs|h> Is there a page for EPEL-specific packaging guidelines?
21:31:09 <maxamillion> lessfs (www.lessfs.com)
21:31:18 <maxamillion> tibbs|h: there aren't we follow Fedora packaging iirc
21:31:32 <tibbs|h> EPEL is starting to diverge significantly from Fedora in a few places.
21:31:51 <tibbs|h> Simply because it can't really evolve due to being tied to RHEL.
21:32:13 <tibbs|h> For example, BuildRoot: is optional in Fedora, required for all existing EPEL, at least.
21:32:37 <nirik> tibbs|h: there isn't such a page, but we should have one I think.
21:32:38 <maxamillion> anyhoo, lessFS .... actually, nvm ... I'm going to get with upstream a bit before I bring this before the group
21:32:46 <nirik> but should it be in the Packaging namespace?
21:32:48 <derks> tibbslh, on top of the fedora packaging guidelines, there are these for epel: https://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies
21:33:34 <tibbs|h> The Fedora  packaging committee occasionally gets hung up on what  to do about EPEL divergence.
21:34:11 <tibbs|h> There are some things like "tex(latex)" that could be solved just by adding a package.
21:34:20 <nirik> tibbs|h: I'd be happy to help maintain such a page.
21:34:24 <tibbs|h> Some macros could come in with an EPEL-specific macro package.
21:34:31 <nirik> there is also the tick of no ppc rhel client
21:34:49 <tibbs|h> But some of us are starting to lose track of just what works in RHEL4.
21:35:22 <smooge> tibbs|h, nothing works in RHEL-4.. its why my previous place is still 90% at RHEL-3
21:35:26 <nirik> yeah, I don't see a problem with a epel specific page.
21:35:34 <stahnma> smooge: :)
21:35:39 <smooge> sorry there was supposed to be a :) on that
21:36:05 <tibbs|h> Anyway, it's something to think about.  At some point we might want to link out of the packaging guidelines to an EPEL-specific page instead of lengthening the guidelines to describe EPEL issues inline.
21:36:19 * nirik nods. Seems reasonable to me.
21:36:24 <stahnma> agreed
21:37:09 <tibbs|h> Thanks; FPC will almost certainly talk more about this in the near future.
21:37:26 <nirik> tibbs|h: feel free to let us know here or the epel-devel list if we can do anything further on it.
21:37:36 <tibbs|h> Sure.
21:38:04 <nirik> maxamillion: did you have something with lessfs? or ?
21:38:05 <smooge> tibbs|h, I agree also
21:39:19 <maxamillion> nirik: no, there's something I will bring up eventually
21:39:25 <maxamillion> nirik: its just a concept right now
21:39:31 <nirik> ok.
21:39:50 <nirik> anyone have anything further, or shall we walk down the street 6 blocks to the pub? ;)
21:40:43 <derks> nirik, i might have to walk further
21:41:01 <nirik> depends on how long the blocks are I guess.
21:41:15 <tibbs|h> It's always six blocks.
21:41:47 <nirik> thanks for coming everyone!
21:42:04 <nirik> #endmeeting