18:04:51 <Oxf13> #startmeeting Fedora Release Engineering
18:04:51 <zodbot> Meeting started Mon Nov  2 18:04:51 2009 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:04:57 <Oxf13> #meetingname fedora-releng
18:04:57 <zodbot> The meeting name has been set to 'fedora-releng'
18:05:02 <Oxf13> #topic roll call
18:05:33 <Oxf13> ping: notting jwb lmacken rdieter_work wwoods warren dgilmore spot poelcat
18:05:43 <warren> plong
18:05:51 <rdieter> here
18:05:54 <wwoods> flap flap flap flap bonk
18:06:00 * poelcat here
18:06:06 * dgilmore is present
18:07:59 * notting is here
18:09:15 <Oxf13> #topic Fedora 12
18:09:19 <Oxf13> It looms.
18:09:29 <Oxf13> Supposed to be in RC state on Wed
18:09:34 <Oxf13> lots of blockers still in the way
18:10:11 <Oxf13> I made a promise earlier to create /something/ on Wed/Thur for testing, be it an RC, or be it a "test compose"
18:10:51 <Oxf13> and I still need to setup all the tickets for the f12 final milestone
18:11:10 <wwoods> to be fair the blocker list is *mostly* MODIFIED (13/25 at last check), which indicates we probably have builds fixing them
18:11:12 <Oxf13> so that's all I have to say about that.
18:11:24 <wwoods> and a lot (all but ~5?) of the things in ASSIGNED actually need moved to MODIFIED
18:11:30 <wwoods> so don't let the blocker list scare you too much.
18:11:48 <rdieter> scared--
18:11:48 <wwoods> just, you know, some.
18:15:18 <notting> what's the bodhi plan?
18:16:03 <Oxf13> We previously talked about opening bodhi for submission when we enter RC phase
18:16:21 <Oxf13> as that's the point where we'd stop taking random crap and only take things that would block the release of F12
18:17:29 <Oxf13> so basically it's just head down, keep going as we get closer to release
18:17:31 <notting> so, wednesday? i mean, i'd also assume we wouldn't be taking too much random stuff if we're just waiting on one or two blockers, too
18:17:46 <Oxf13> notting: yeah, I suppose we can just pick a date now
18:18:29 <Oxf13> no lmacken though
18:18:44 <Oxf13> #action Oxf13 will ask lmacken to enable bodhi for F12 submissions as of Wed
18:18:58 * poelcat thinks we have that as #76
18:18:59 <poelcat> http://poelstra.fedorapeople.org/schedules/f-12/f-12-releng-tasks.html
18:19:49 <Oxf13> yep
18:22:35 * warren is here, just nothing useful to add.
18:22:46 <Oxf13> #topic open floor
18:22:57 <Oxf13> I got nothing else for this meeting.
18:23:10 <warren> well, I don't see a point to requiring non-spin packages to be day-0 updates past RC.
18:23:18 <warren> new packages and stuff that totally doesn't effect any spin
18:23:41 <Oxf13> warren: except that we could wind up with tagging things that never make it into the Everything tree
18:23:59 <Oxf13> warren: it's just easier to redirect that action over to bodhi, so that there is no confusion or lost builds
18:24:24 <warren> might be good to use Bodhi for tag requests in the next cycle
18:24:38 <Oxf13> warren: wow, that's such a great idea.  I wonder why I didn't think of that.
18:24:46 <poelcat> Oxf13: i posted to rel-eng list about the Fedora 13 schedule
18:24:50 <poelcat> i know you were planning to review
18:24:57 <Oxf13> poelcat: I saw that, it's flagged for me to read/review
18:25:16 <Oxf13> warren: at some point, you really should read the no frozen rawhide proposal that went through releng and fesco
18:27:40 <notting> poelcat: my concern is that we'd end up with an ever-rotating release date
18:28:05 <poelcat> notting: that's one question I'm asking
18:28:27 <poelcat> in the past we said it was important to have predicatable release dates twice each year
18:28:50 <poelcat> but I'm wondering how important it is and to who?
18:29:13 <poelcat> as a result we constantly short change our release cycle (at least the initial schedule)
18:29:16 <poelcat> until we slip
18:29:17 <dgilmore> poelcat: i think it was important to help users schedule there upgrades
18:31:34 <wwoods> It's important to ensure *something* gets released
18:31:38 <wwoods> and on a regular schedule
18:31:59 <Oxf13> it was also theorized that it would help upstreams plan their major releases, and publications plan their issues
18:32:04 <wwoods> the length and endpoints of the cycle were basically arbitrary
18:32:16 <Oxf13> in reality I'm not sure if that's happening, mostly because we haven't been accurate to our release dates
18:32:40 <wwoods> one could argue we might be better off with (e.g.) a 9-month cycle
18:34:34 <wwoods> but it'd take a *lot* to convince me that we'd be better off without a regular release cycle
18:34:48 <skvidal> a gestation period of 9 months - how very homosapien!
18:34:57 <Oxf13> combined with no frozen rawhide, a 9 month schedule that leaves more time for bugfixing before the release (not necessarily more time for feature development) might be more acceptable
18:35:39 <wwoods> but this is a Big Idea and it might be better suited to a different time or place
18:35:52 <Oxf13> I think what we want is more time to stabilize, bugfix, and polish, and the only way to do that with our 6 month schedule is to eat into the time to develop features, which is already very short
18:36:28 <wwoods> indeed, and I've definitely heard complaints from developers about that problem
18:36:42 <warren> that means 19 month life span for Fedora releases?
18:36:43 * poelcat doesn't think "more time" is the answer if there is no discipline around when change does or doesn't happen
18:37:09 <Oxf13> poelcat: I'm not sure we're suggesting that there wouldn't be discipline
18:37:21 <poelcat> i am :)
18:37:30 <poelcat> IOW things would need to be different from today
18:37:56 <Oxf13> poelcat: I'm all ears on how we can enforce our policies in any scalable way across the entire package set.
18:38:14 <Oxf13> I think we've done a pretty darn good job with the crit path packages this freeze cycle.
18:39:04 <Oxf13> and we're only going to get better with AutoQA coming online, which can be a fence between "package got built" and "package ends up in a published tree"
18:39:36 <Oxf13> there is not likely to be any magic bullet here
18:40:00 <Oxf13> it's going to have to be multiple solutions touching on different parts of the problem
18:40:31 <Oxf13> and one part of the problem, getting feature like changes late in the cycle, is very much a product of not having enough time to do the feature development within our short window
18:40:55 <warren> not to mention the features being untestable because rawhide is very hosed in the early cycle
18:41:17 <warren> late cycle this time, I didn't need to do emergency untags late at night to prevent rawhide from being hosed the next day
18:41:21 <warren> like I had in the past 3 cycles
18:42:16 <warren> early cycle rawhide being hosed for days/weeks straight seems to be a remaining problem
18:42:33 <Oxf13> anyway I agree with wwoods that this is a Big Picture item, one that's going to take more than just us to fix it, and at a more appropriate time than right now where we're all head down trying to get F12 out the door
18:42:54 <wwoods> yup. This is a FAD-worthy discussion.
18:43:00 <Oxf13> warren: I'm attempting to fix that by removing the ebb/flow of rawhide, and just turning it into a constant flow
18:43:08 <wwoods> not really something to wedge into the middle of a rel-eng meeting.
18:43:14 <Oxf13> warren: removing the build up of changes and wreakage
18:43:55 <Oxf13> #info lots of talk about F13 schedule and release schedules in general, to be talked about more later
18:43:57 <warren> Oxf13: if everyone is testing late distro before release and a ton of untested packages build up in rawhide with few testers, is that really better?
18:44:15 <Oxf13> warren: you assume "everyone" is testing the late distro
18:44:44 <Oxf13> when in reality I suspect that there will be a fair amount of people who want to move on to testing things for the next release, as they're "done" with the current one
18:45:39 <Oxf13> and a fair amount of people who will never look at anything /but/ rawhide
18:46:46 <wwoods> But anyway I think we said this should be talked about more Later
18:46:53 <Oxf13> yep.
18:47:04 <Oxf13> if there are any other topics, you got 4 minutes to bring them up
18:53:28 <notting> other than we have a few tickets waiting for more testing/tagging, i don't have any new business
18:54:33 <warren> I need to restart to test a few of the tag requests.
18:54:38 <warren> waiting for this meeting to be over
18:55:50 <Oxf13> #endmeeting